Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
enduromen
4 / 4 / 2
Регистрация: 26.08.2015
Сообщений: 59
#1

Изменения размера табличного документа - 1С

14.03.2017, 20:58. Просмотров 319. Ответов 3
Метки нет (Все метки)

Добрый день.
Коллеги программисты нужна помощь.
Есть задача:
Необходимо реализовать обработку по печати ярлыков номенклатуры,
при этом на форме обработки должны быть реквизиты высоты и ширины ярлыка.
Как реализовать изменение размера ярлыка?
за ранее благодарю!!!
http://www.cyberforum.ru/1c-custom/thread1249031.html
0
Лучшие ответы (1)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
14.03.2017, 20:58
Я подобрал для вас темы с готовыми решениями и ответами на вопрос Изменения размера табличного документа (1С):

Сохранение табличного документа в pdf
Добрый день! При сохранении табличного документа в pdf-файл слетает...

Сохранение табличного документа в файл
Ситуация какая то шаманская. База SQL крутится на сервере Есть процедура...

Удалить области табличного документа
Добрый вечер. Такая проблема: есть документ "прием специалиста", где пациенту...

Редактирование формата табличного документа
Всем привет. Дело вот в чём. Есть таблица, в которой есть лишние данные...

Активизировать поле табличного документа
проблема. сделал отчет с собственной расшифровкой, неограниченный уровень...

3
Dethmontt
Модератор
Эксперт 1С
2577 / 2384 / 391
Регистрация: 10.03.2011
Сообщений: 8,429
Записей в блоге: 1
Завершенные тесты: 1
15.03.2017, 01:28 #2
enduromen, Что значит изменение размера ярлыка???
0
enduromen
4 / 4 / 2
Регистрация: 26.08.2015
Сообщений: 59
15.03.2017, 07:51  [ТС] #3
Dethmontt, Есть обработка которая аналогично инвентаризации ОС собирает в коллекцию объекты ОС, за тем для каждого объекта ОС в табличный документ по заданному макету выводятся данные по ОС, т.е. формируется ярлык, который при инвентаризации можно наклеить на инвентарный объект. Необходимо сделать так, что бы в зависимости от значения высоты и ширины указанных на форме обработки формировался ярлык с заданной высотой и шириной. (К примеру, что бы на листе А4 умещались 2 или 3 ярлыка). Аналогичный механизм нашел в обработке "Печать этикеток" в УПП, но там показатели высоты и ширины перемножаются на какие то коэффициенты. Не совсем понятно как работает.
0
Dethmontt
Модератор
Эксперт 1С
2577 / 2384 / 391
Регистрация: 10.03.2011
Сообщений: 8,429
Записей в блоге: 1
Завершенные тесты: 1
15.03.2017, 09:45 #4
Лучший ответ Сообщение было отмечено enduromen как решение

Решение

enduromen, да забей на эти коэффициенты

1C
1
2
ВысотаЭтикетки = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глЗначениеПеременной("глТекущийПользователь"), "ПринтерЭтикетокВысота");
        ШиринаЭтикетки = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глЗначениеПеременной("глТекущийПользователь"), "ПринтерЭтикетокШирина");
Добавлено через 1 минуту
enduromen, и основным в этом алгоритме является не высота и ширина, а вот это

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
            Для Копий =1 По КоличествоКопий Цикл
                Если ТекКолонка>ВсегоКолонок Тогда //новая строка.
                    Если ВсегоСтрок<>1 Тогда //выведем разделитель.
                        Для Сч = 1 по ВсегоКолонок Цикл
                            Если Сч = 1 Тогда
                                Таб.Вывести(ОбластьНачалоГраницыСнизу);
                            Иначе
                                Таб.Присоединить(ОбластьНачалоГраницыСнизу);
                            КонецЕсли;
                            Таб.Присоединить(ОбластьГраницаСнизу);
                            Таб.Присоединить(ОбластьНизГраницыСправа);
                            Сч = Сч + 1;
                        КонецЦикла;
                        ТекСтрока = ТекСтрока + 1;
                    КонецЕсли;
                    Если ТекСтрока/ВсегоСтрок = Цел(ТекСтрока/ВсегоСтрок) Тогда
                        Таб.ВывестиГоризонтальныйРазделительСтраниц();
                    КонецЕсли;
                    ТекСтрока = ТекСтрока + 1;
                    ТекКолонка=1;
                КонецЕсли;
                Если ТекКолонка<>1 Тогда //выведем разделитель.
                    Таб.Присоединить(ОбластьГраницаСправа);
                    ТекКолонка = ТекКолонка + 1;
                    Таб.Присоединить(ЭтикеткаОбласть);
                    ТекКолонка = ТекКолонка + 1;
                Иначе
                    Таб.Вывести(ЭтикеткаОбласть);
                    //Таб.Показать();
                    ТекКолонка = ТекКолонка + 1;
                КонецЕсли;
 
                ВывелиХотяБыОдинШтрихКод = Истина;
            КонецЦикла;
1
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
15.03.2017, 09:45
Привет! Вот еще темы с решениями:

Запись в ячейку макета табличного документа
Добрый день. Формирую в цикле значения ячеек табличного документа, значение...

Вывод области табличного документа в цикле
Приветствую, господа форумчане. Не могу исправить кусочек кода, уже...

Вывод подписей на первой странице табличного документа
Всем привет! Делаю печатную форму. В ней шапка, табличная часть, итоги и...

Открыть форму и заполнить поле табличного документа
Привет, народ! подскажите, как открыть форму программно , сформировать макет...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru