Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.63/8: Рейтинг темы: голосов - 8, средняя оценка - 4.63
Vlad69ik
1 / 1 / 2
Регистрация: 15.09.2013
Сообщений: 52
1

Проверка баланса на мтс коммуникаторе

22.04.2017, 14:06. Просмотров 1677. Ответов 8
Метки нет (Все метки)

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
&НаСервере
Функция ПолучитьБалансАккаунтаSMS(ВыдаватьСообщенияОбОшибке = Истина) Экспорт
    
    Результат = Новый Структура("Баланс, Валюта", , "Недоступно");
    
    // Инициализируем данные
    Прокси = ПолучитьПроксиWSDL(ВыдаватьСообщенияОбОшибке);
    Если Прокси = Неопределено Тогда
        Возврат Результат;
    КонецЕсли;
    
    // Отправляем и получаем ответ от сервера
    СтруктураОтветаWSПрокси = Прокси.GetBalance(Пользователь, Пароль);
    
    // Разбираем структуру ответа
    Если РасшифровкаОтветаСервера(СтруктураОтветаWSПрокси.Result).Действие = 0 Тогда
        Результат.Баланс = СтруктураОтветаWSПрокси.GetBalanceResponse;
        Результат.Валюта = "Руб.";
    ИначеЕсли ВыдаватьСообщенияОбОшибке Тогда
        Сообщить(РасшифровкаОтветаСервера(СтруктураОтветаWSПрокси.GetBalanceResult).Текст);     
    КонецЕсли;
    
    Возврат Результат;
    
КонецФункции
Выбивает ошибку
{ВнешняяОбработка.ОбратоткаSMS.Форма.ОбычноеПриложениеФорма.Форма(92)}: Ошибка при вызове метода контекста (GetBalance)
Возврат WSСервис.GetBalance(Пользователь,Пароль);
по причине:
При вызове веб-сервиса произошла ошибка. Ошибка вызова операции сервиса: {http://mcommunicator.ru/M2M}:MTS_x0020_Communicator_x0020_M2M_x0020_XML_x0020_API:GetBalance()
по причине:
При вызове веб-сервиса произошла ошибка. Ошибка SOAP сервера: INCORRECT_PASSWORD
Код ошибки: Client
Техническая информация:
<detail xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<code xmlns="http://mcommunicator.ru/M2M/">103</code>
<description xmlns="http://mcommunicator.ru/M2M/">INCORRECT_PASSWOR



Логин и пароль ввожу верные . Возможно проблема из-за того ,что на аккаунте нет денег. Подскажите может кто сталкивался с таким.
0
Лучшие ответы (1)
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
22.04.2017, 14:06
Ответы с готовыми решениями:

Проверка баланса скобок
Здравствуйте! Помогите пожалуйста со следующей задачкой. Необходимо написать код с помощью...

Проверка баланса скобок
#include&lt;stdio.h&gt; #include&lt;string.h&gt; struct NODE { char info; NODE *next; }; struct...

Проверка баланса скобок
Как задать условие в проверке баланса скобок, что если скобки окажутся НЕ пустыми, тое сть внутри...

Строки: проверка баланса скобок
Проверить баланс скобок в выражении.

Проверка баланса активных мощностей
Добрый день. Интересует формула по которой можно проверить баланс мощностей - активных Такая...

8
GreenkA
Форумчанин
Эксперт 1С
3003 / 1923 / 520
Регистрация: 25.06.2009
Сообщений: 6,817
22.04.2017, 14:23 2
Цитата Сообщение от Vlad69ik Посмотреть сообщение
INCORRECT_PASSWORD
из вашей же ошибки и так все понятно...
0
Vlad69ik
1 / 1 / 2
Регистрация: 15.09.2013
Сообщений: 52
24.04.2017, 12:24  [ТС] 3
С тем разобрался появилось что-то новое
Ошибка при выполнении обработчика - 'ОбработкаПроведения'
по причине:
{ВнешняяОбработка.СервисMTSSMS.МодульОбъекта(32)}: Ошибка при вызове метода контекста (SendMessage)
СтруктураОтветаWSПрокси = Прокси.SendMessage(ТекстSMS,Пользователь,Пароль,ПолучательSMS.НомерТелефона,Подпись);
по причине:
При вызове веб-сервиса произошла ошибка. Ошибка вызова операции сервиса: {http://mcommunicator.ru/M2M}:MTS_x0020_Communicator_x0020_M2M_x0020_XML_x0020_API:SendMessage()
по причине:
При вызове веб-сервиса произошла ошибка. Ошибка SOAP сервера: MSID_FORMAT_ERROR
Код ошибки: Client
Источник ошибки: http://www.mcommunicator.ru/m2m/m2m_api.asmx
Техническая информация:
<detail xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<code xmlns="http://mcommunicator.ru/M2M/">506</code>
<description xmlns="http://mcommunicator.ru/M2M/">MSID_FORMAT_ERROR</description>
</detail>
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
Функция ОтправитьSMS(ТекстSMS, ПолучателиSMS, ВыдаватьСообщенияОбОшибке = Истина) Экспорт
    Результат = Ложь;
    
    // Инициализируем данные
    Прокси = ПолучитьПроксиWSDL(ВыдаватьСообщенияОбОшибке);
    Если Прокси = Неопределено Тогда
        Возврат Результат;
    КонецЕсли;
                                   
    Для Каждого ПолучательSMS Из ПолучателиSMS Цикл
        
        // Отправляем и получаем ответ от сервера
        СтруктураОтветаWSПрокси = Прокси.SendMessage(ТекстSMS,Пользователь,Пароль,ПолучательSMS.НомерТелефона,Подпись);
        
        // Разбираем структуру ответа
        Если РасшифровкаОтветаСервера(СтруктураОтветаWSПрокси.SendMessageResult).Действие = 0 Тогда
            ПолучательSMS.IDСообщения = СтрЗаменить(Строка(СтруктураОтветаWSПрокси.MessageID), "*", "");
            Результат = Истина;
        Иначе
            ПолучательSMS.СтатусСообщения = РасшифровкаОтветаСервера(СтруктураОтветаWSПрокси.SendMessageResult).Текст;
            ПолучательSMS.СтатусДействия  = РасшифровкаОтветаСервера(СтруктураОтветаWSПрокси.SendMessageResult).Действие;           
            Если ВыдаватьСообщенияОбОшибке Тогда
                Сообщить(РасшифровкаОтветаСервера(СтруктураОтветаWSПрокси.SendMessageResult).Текст);
            КонецЕсли;
        КонецЕсли;
        
    КонецЦикла;
    
    Возврат Результат;
КонецФункции
0
Dethmontt
Модератор
Эксперт 1С
2688 / 2455 / 429
Регистрация: 10.03.2011
Сообщений: 8,891
Записей в блоге: 1
Завершенные тесты: 1
24.04.2017, 12:58 4
Vlad69ik, формат сообщения не верный...

Добавлено через 2 минуты
Vlad69ik, что бы исключить запрещенные символы в тексте сообщения, попробуй просто отправлять слово "Привет"
0
24.04.2017, 12:58
Vlad69ik
1 / 1 / 2
Регистрация: 15.09.2013
Сообщений: 52
24.04.2017, 13:36  [ТС] 5
Разобрался чуть позже ,что не в том порядки данные оправлял т.е.
не так Прокси.SendMessage(ТекстSMS,Пользователь,Пароль,ПолучательSMS.НомерТелефона,Подпись);
а Прокси.SendMessage(ПолучательSMS.НомерТелефона,ТекстSMS,Подпись,Пользователь,Пароль);
И пришел к тому с чего начал опять говорит, что неправильный пароль . Хотя в лк я захожу спокойно под этими данными и из формы тоже спокойно отправляется сообщение. Ошибка в последнем коде хз где . Даже предположить не могу из-за чего.
0
Dethmontt
Модератор
Эксперт 1С
2688 / 2455 / 429
Регистрация: 10.03.2011
Сообщений: 8,891
Записей в блоге: 1
Завершенные тесты: 1
24.04.2017, 14:30 6
Vlad69ik, а ты зарегистрирован в коммуникаторе?

Если не ошибаюсь то эта услуга (отправлять смс через API мтс) платная

Добавлено через 7 минут
http://www.corp.mts.ru/resheniya_dly..._kommunikator/
0
Vlad69ik
1 / 1 / 2
Регистрация: 15.09.2013
Сообщений: 52
24.04.2017, 14:34  [ТС] 7
Да зарегистрирован . Конект по WSDL идет http://www.mcommunicator.ru/m2m/m2m_api.asmx?WSDL
0
Dethmontt
Модератор
Эксперт 1С
2688 / 2455 / 429
Регистрация: 10.03.2011
Сообщений: 8,891
Записей в блоге: 1
Завершенные тесты: 1
24.04.2017, 14:44 8
Лучший ответ Сообщение было отмечено Vlad69ik как решение

Решение

Vlad69ik, если услуга (ссылка выше) не подключена, то и доступа не будет (будет ошибка - INCORRECT_PASSWOR или INCORRECT_LOGIN)

Добавлено через 2 минуты
Vlad69ik, или пароль должен быть не открытый...

Добавлено через 1 минуту
Vlad69ik, и тут все уже реализовано. https://1c-programmer-blog.ru/progra...ator-i-1s.html

А так же весь код есть в БСП
1
Vlad69ik
1 / 1 / 2
Регистрация: 15.09.2013
Сообщений: 52
24.04.2017, 15:44  [ТС] 9
Да я пользовался этим методом с сайта что вы дали. У меня получилось отправлять из формы. Дело в том что там есть уже встроенные рассылки и под 1 из них мне надо подвести мтсовскую . А так лк работает в тестовом режиме и смс доходят до меня . Ну я еще поговорю с начальником конечно, а так спасибо за помощь.
0
24.04.2017, 15:44
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
24.04.2017, 15:44

[Программа] Проверка баланса (Ростелеком)
Начну с того, что бОльшая часть полезного кода (получение данных из &quot;нового личного кабинета&quot;) была...

SerialPort. Проверка баланса на занятом порту
Доброго времени суток, форум! Вопрос: Есть 2 модема, стоящие на суперважном объекте, они оба...

Проверка баланса кавычек четырех видов
Здравствуйте! Подскажите, как можно написать программу, которая в данной строке проверяет...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.