Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.69/13: Рейтинг темы: голосов - 13, средняя оценка - 4.69
sokol566535
0 / 0 / 0
Регистрация: 09.01.2017
Сообщений: 30
1

Процедура ПередЗаписью и Процедура ПередЗаписьюНаСервере

13.05.2017, 19:30. Просмотров 2378. Ответов 3
Метки нет (Все метки)

В документе после нажатия на кнопку Провести и закрыть надо запросить информацию у пользователя : «Количество оборудования введено верно?» и, если пользователь ответит утвердительно то документ проведен.

&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
Если Вопрос("Количество оборудования введено верно?", РежимДиалогаВопрос.ДаНет)=КодВозвратаДиалога.Да тогда
ПараметрыЗаписи.Вставить("Ответ","Да");
Иначе
ПараметрыЗаписи.Вставить("Ответ","Нет");
КонецЕсли;
КонецПроцедуры
&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
Если ПараметрыЗаписи.Ответ="Да" Тогда
Объект=Документы.ЗаказМонтажа.СоздатьДокумент();
Объект.Дата=ТекущаяДата();
Объект.Заполнить();
Объект.Записать();

КонецЕсли;
КонецПроцедуры



Ошибка:Нельзя изменять поле, содержащее объект данных формы
Помогите пожалуйста, я что то туплю(
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
13.05.2017, 19:30
Ответы с готовыми решениями:

ПередЗаписью и передЗаписьюНасервере
вопрос дурацкий, просто чета сейчас голова пухнет- не могу отследить. в чем разница между...

Внешняя процедура
Можно на примере показать как запустить внешнюю процедуру.. Напрмер в справочнике Сотрудники я...

Процедура Печати
Ребят помогите пожалуйста, прохожу практику на производстве где 1с 7, в технаре не проводилы курсы...

Процедура документа
Добрый вечер! Помогите пожалуйста переделать этот код на 8.2. с добавлением в него условия, что...

Что делает процедура?
Здравствуйте, помогите разобраться для чего данный код: Процедура...

3
Joker_vad
Эксперт 1С
475 / 413 / 92
Регистрация: 26.09.2012
Сообщений: 1,856
13.05.2017, 22:00 2
Да вообще тут все не так.
1C
1
Объект=Документы.ЗаказМонтажа.СоздатьДокумент();
Тут создается новый документ. Причем вы новый документ записываете в "Объект", что есть объект формы...
0
polax
1120 / 726 / 247
Регистрация: 16.01.2015
Сообщений: 2,797
13.05.2017, 22:15 3
sokol566535, Нельзя в коде для обозначения параметров, реквизитов и т.п., конструкций языка 1С. Программа не понимает, что вы хотите. Переименуйте в вашем коде Объект в, например, НашОбъект
0
Xomych
838 / 640 / 108
Регистрация: 01.11.2012
Сообщений: 2,356
14.05.2017, 10:20 4
Нельзя использовать "Объект" в качестве переменной, назовите её по-другому.

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
       ПараметрыЗаписи.Вставить("Ответ",Вопрос("Количество оборудования введено верно?", РежимДиалогаВопрос.ДаНет)=КодВозвратаДиалога.Да);
КонецПроцедуры
 
&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
   Если ПараметрыЗаписи.Ответ Тогда 
        Об=Документы.ЗаказМонтажа.СоздатьДокумент();
        Об.Дата=ТекущаяДата();
        Об.Заполнить();
        Об.Записать();
   КонецЕсли;
КонецПроцедуры
0
14.05.2017, 10:20
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
14.05.2017, 10:20

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Процедура не обнаружена (глУстановитьВидимостьКолонок)
Пишет ошибку глУстановитьВидимостьКолонок<<?>>(Контекст, ИдентификаторФормы, ПолныйСписокКолонок);...

Не вызывается процедура ОбработкаПроведения
здравствуйте. Отладчик не всплывает на процедуре ОбработкаПроведения. Пробывал ставить на...

Процедура сортировки дисконтников
Необходимо реализовать процедуру отброрки дисконтных клиентов магазина и выявить, кто из...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.