Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.91/11: Рейтинг темы: голосов - 11, средняя оценка - 4.91
sokol566535
0 / 0 / 0
Регистрация: 09.01.2017
Сообщений: 30
1

Перенос макета печатной формы из одного документа в другой.

16.05.2017, 15:33. Просмотров 2013. Ответов 14
Метки нет (Все метки)

Подскажите, реально ли перенести макет печатной формы из одного документа в другой?
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
16.05.2017, 15:33
Ответы с готовыми решениями:

Модуль менеджера для печатной формы. Вывод на печать данных одного документа.
Задача обстоит в том плане что при данном коде он на печать выводит абсолютно все документы. Хотя...

Перенос данных одного документа в другой
Добрый вечер. При создании нового документа "Путевой лист" необходимо заполнить реквизит "остаток...

Печать макета внешней печатной формы
добрый день, задача такая: имеетсявнешняя печатная форма схожая с обычной печатной формой, но...

Как в ячейке макета печатной формы сделать перенос строк
Подскажите, пожалуйста. Делаю макет печатной формы. Объединил ячейки. Задал высоту строки. Пытаюсь...

Перенос данных табличной части из одного документа в другой
Всем доброго времени суток. Такая проблема-есть документ АктПриемаСдачи. В этом документе допустим...

14
Tklwegsd
Эксперт 1С
767 / 560 / 190
Регистрация: 24.07.2013
Сообщений: 1,918
16.05.2017, 15:38 2
Скопировать/Вставить.
0
sokol566535
0 / 0 / 0
Регистрация: 09.01.2017
Сообщений: 30
16.05.2017, 15:40  [ТС] 3
Это я уже сделала, макет на печать не выводит
0
Tklwegsd
Эксперт 1С
767 / 560 / 190
Регистрация: 24.07.2013
Сообщений: 1,918
16.05.2017, 15:42 4
Еще нужен код по формированию печатной формы.
0
sokol566535
0 / 0 / 0
Регистрация: 09.01.2017
Сообщений: 30
16.05.2017, 15:44  [ТС] 5
Код перенесен тоже. Что нужно в коде исправить?
0
Tklwegsd
Эксперт 1С
767 / 560 / 190
Регистрация: 24.07.2013
Сообщений: 1,918
16.05.2017, 16:06 6
Цитата Сообщение от sokol566535 Посмотреть сообщение
Что нужно в коде исправить?
А что в нем не получается?
0
sokol566535
0 / 0 / 0
Регистрация: 09.01.2017
Сообщений: 30
16.05.2017, 16:13  [ТС] 7
Ну дак данные для печати из другого документа, я как поняла система их не видит
0
Tklwegsd
Эксперт 1С
767 / 560 / 190
Регистрация: 24.07.2013
Сообщений: 1,918
16.05.2017, 16:21 8
Код выкладывайте.
0
sokol566535
0 / 0 / 0
Регистрация: 09.01.2017
Сообщений: 30
16.05.2017, 16:29  [ТС] 9
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)

ТабДок = Новый ТабличныйДокумент;
Печать(ТабДок, ПараметрКоманды);
ТабДок.АвтоМасштаб=Истина;
ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Ложь;
ТабДок.ОтображатьЗаголовки = Ложь;
ТабДок.Показать();
КонецПроцедуры

&НаСервере
Процедура Печать(ТабДок, ПараметрКоманды)
Документы.ОплатаМонтажа.Печать(ТабДок, ПараметрКоманды);
КонецПроцедуры

Процедура Печать(ТабДок, Ссылка) Экспорт
Макет = Документы.ЗаказМонтажа.ПолучитьМакет("Печать");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЗаказМонтажа.Выполнено,
| ЗаказМонтажа.Дата,
| ЗаказМонтажа.Клиент,
| ЗаказМонтажа.Номер,
| ЗаказМонтажа.ОбщаяСтоимость,
| ЗаказМонтажа.Оплачено,
| ЗаказМонтажа.ОтветственныйЗаРаботу,
| ЗаказМонтажа.СрокВыполненияРабот,
| ЗаказМонтажа.Услуга,
| ЗаказМонтажа.РасходныеМатериалы.(
| НомерСтроки,
| Оборудование,
| Количество,
| ЦенаОборудования,
| СтоимостьОборудования,
| ЦенаЗаМонтаж,
| СтоимостьМонтажа
| )
|ИЗ
| Документ.ЗаказМонтажа КАК ЗаказМонтажа
|ГДЕ
| ЗаказМонтажа.Ссылка В (&Ссылка)";
Запрос.Параметры.Вставить("Ссылка", Ссылка);
Выборка = Запрос.Выполнить().Выбрать();

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
Шапка = Макет.ПолучитьОбласть("Шапка");
ОбластьРасходныеМатериалыШапка = Макет.ПолучитьОбласть("РасходныеМатериалыШапка");
ОбластьРасходныеМатериалы = Макет.ПолучитьОбласть("РасходныеМатериалы");
ОбластьИтог=Макет.ПолучитьОбласть("Всего");
Подвал = Макет.ПолучитьОбласть("Подвал");
ТабДок.Очистить();

ВставлятьРазделительСтраниц = Ложь;
Пока Выборка.Следующий() Цикл
Если ВставлятьРазделительСтраниц Тогда
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;
ОбластьЗаголовок.Параметры.Заполнить(Выборка);
ТабДок.Вывести(ОбластьЗаголовок);

Шапка.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Шапка, Выборка.Уровень());
ТабДок.Вывести(ОбластьРасходныеМатериалыШапка);
ВыборкаРасходныеМатериалы = Выборка.РасходныеМатериалы.Выбрать();
СуммаИтог=0;
СуммИтог=0;
Пока ВыборкаРасходныеМатериалы.Следующий() Цикл
Если ВыборкаРасходныеМатериалы.Количество > 0 Тогда
ОбластьРасходныеМатериалы.Параметры.Заполнить(ВыборкаРасходныеМатериалы);
ТабДок.Вывести(ОбластьРасходныеМатериалы, ВыборкаРасходныеМатериалы.Уровень());
СуммаИтог=СуммаИтог+ВыборкаРасходныеМатериалы.СтоимостьОборудования;
СуммИтог=СуммИтог+ВыборкаРасходныеМатериалы.СтоимостьМонтажа;
Иначе Продолжить;
КонецЕсли;
КонецЦикла;
ОбластьИтог.Параметры.ВсегоПоДокументу=СуммаИтог;
ОбластьИтог.Параметры.ВсегоПоДокумент=СуммИтог;
ТабДок.Вывести(ОбластьИтог);

Подвал.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Подвал);

ВставлятьРазделительСтраниц = Истина;
КонецЦикла;
КонецПроцедуры
0
Tklwegsd
Эксперт 1С
767 / 560 / 190
Регистрация: 24.07.2013
Сообщений: 1,918
16.05.2017, 16:40 10
Запрос нужно переделать, чтобы данные выбирались из другого документа.
0
sokol566535
0 / 0 / 0
Регистрация: 09.01.2017
Сообщений: 30
16.05.2017, 16:49  [ТС] 11
в этот и проблема
мне нужно чтоб в документе Оплата монтажа печатная форма была из документа Заказ монтажа
0
polax
902 / 588 / 196
Регистрация: 16.01.2015
Сообщений: 2,107
16.05.2017, 16:52 12
Вы из команды передаете управление в процедуру
1C
1
Печать(ТабДок, ПараметрКоманды);
И тут же отправляете непонятно в чей модуль менеджера ( а именно в документ ОплатаМонтажа)
1C
1
2
3
4
&НаСервере
Процедура Печать(ТабДок, ПараметрКоманды)
Документы.ОплатаМонтажа.Печать(ТабДок, ПараметрКоманды);
КонецПроцедуры
В вашу процедуру Печать (нужную процедуру) просто нет вообще захода. Уберите код выше из модуля

Добавлено через 3 минуты
sokol566535, Не успел прочитать предыдущее сообшение, опубликовали практически синхронно ))
1C
1
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
из какой формы вызывается?
0
Tklwegsd
Эксперт 1С
767 / 560 / 190
Регистрация: 24.07.2013
Сообщений: 1,918
16.05.2017, 17:22 13
Цитата Сообщение от sokol566535 Посмотреть сообщение
мне нужно чтоб в документе Оплата монтажа печатная форма была из документа Заказ монтажа
А данные какого документа нужны?
0
sokol566535
0 / 0 / 0
Регистрация: 09.01.2017
Сообщений: 30
16.05.2017, 18:08  [ТС] 14
данные документа заказ монтажа
0
polax
902 / 588 / 196
Регистрация: 16.01.2015
Сообщений: 2,107
16.05.2017, 18:26 15
Просто уберите
1C
1
2
3
4
&НаСервере
Процедура Печать(ТабДок, ПараметрКоманды)
Документы.ОплатаМонтажа.Печать(ТабДок, ПараметрКоманды);
КонецПроцедуры
из кода. Если Макет в документе Заказ монтажа соответсвует заявленным в коде областям и параметрам, должно работать

Добавлено через 2 минуты
Хотя вот это
Цитата Сообщение от sokol566535 Посмотреть сообщение
мне нужно чтоб в документе Оплата монтажа печатная форма была из документа Заказ монтажа
противоречит
Цитата Сообщение от sokol566535 Посмотреть сообщение
данные документа заказ монтажа
Еще раз. Вы хотите распечатать документ заказ монтажа из формы этого же документа? Если так, то пробуйте все как сказано выше
0
16.05.2017, 18:26
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
16.05.2017, 18:26

Создание макета печатной формы
Добрый вечер. Почти доделал макет. Осталось сделать подвал. Не соображу, как сделать так ячейки,...

Программное изменение печатной формы (макета)
Доброго времени суток! Подскажите, как программно вставить в макет строку, содержащую...

Закрытие формы документа из внешней печатной формы
Нужно после печати документа, закрыть его форму. Управляемое приложение. Никак не могу понять прошу...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
15
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru