Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/6: Рейтинг темы: голосов - 6, средняя оценка - 4.67
Chubaka101
9 / 9 / 4
Регистрация: 14.10.2015
Сообщений: 252
1

Как запретить проведение документа, если в табличной части в поле Цена значение меньше либо равно 0?

31.05.2017, 16:59. Просмотров 1145. Ответов 6
Метки нет (Все метки)

Как сделать так, чтобы документ не проводился, если Цена <= 0?

Вот мои попытки
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
&НаКлиенте
Функция ПередЗаписью(Отказ, ПараметрыЗаписи)
    Отказ=Ложь;
    Для Каждого ТекСтрокаЦена Из Объект.Товары.Цена
         Цикл
         Если ТекСтрокаЦена     <=0 Тогда
             Отказ=Истина;
             Возврат Отказ;
КонецЕсли;
     КонецЦикла;
 
 
КонецФункции
 
Функция ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
ТЧ = Элементы.Товары;
Отказ=Ложь;
    //Строка = Элементы.Товары.ТекущиеДанные;
    Для каждого Товар ИЗ ТЧ Цикл
    Если Товар.Цена <= 0 Тогда
    Отказ = Истина;
    Возврат Отказ=Истина;
    КонецЕсли;
 
КонецЦикла
 
КонецФункции
0
Миниатюры
Как запретить проведение документа, если в табличной части в поле Цена значение меньше либо равно 0?  
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
31.05.2017, 16:59
Ответы с готовыми решениями:

Как запретить проведение документа, если на складе нет товара?
У меня есть различные склады, на которые поступает товар, как сделать так, чтобы при реализации...

Заполнение табличной части одного документа при проведение другого
Подскажите пожалуйста, какой можно использовать синтаксис при такой ситуации. Добавлено через 31...

Значение строки табличной части получить в табличной части другого документа
Есть документ ПриходнаяНакладная (товар приходит от поставщика по его цене), с табличной частью...

Как из одного документа перенести значение из табличной части в реквизит другого документа?
Только начинаю осваивать 1С, учебная задача. Есть два документа &quot;Индивидуальный заказ&quot; и...

Как вывести поле из строки табличной части справочника в реквизит документа?
Есть справочник ФизЛица с таблчной частью образование и документ Учет с реквизитом-образование (не...

6
Tklwegsd
Эксперт 1С
762 / 556 / 189
Регистрация: 24.07.2013
Сообщений: 1,915
31.05.2017, 17:01 2
ОбработкаПроверкиЗаполнения
0
Chubaka101
9 / 9 / 4
Регистрация: 14.10.2015
Сообщений: 252
31.05.2017, 17:58  [ТС] 3
Цитата Сообщение от Tklwegsd Посмотреть сообщение
ОбработкаПроверкиЗаполнения
Чет не работает, ЧЯДНТ?
1C
1
2
3
4
5
6
7
8
9
10
11
Процедура ОбработкаПроверкиЗаполнения(Отказ, ПроверяемыеРеквизиты)
     пр=ПроверяемыеРеквизиты.Найти("Товары.Цена");
Для Каждого ТекСтрока Из Объект.Товары Цикл
  //Если пр <=0 Тогда
  Если пр<>Неопределено Тогда
      Отказ=Истина;
            // Возврат Отказ=Истина;
  Сообщить("Не задана цена!");
КонецЕсли;
КонецЦикла
КонецПроцедуры
0
Tklwegsd
Эксперт 1С
762 / 556 / 189
Регистрация: 24.07.2013
Сообщений: 1,915
31.05.2017, 18:19 4
Цитата Сообщение от Chubaka101 Посмотреть сообщение
пр=ПроверяемыеРеквизиты.Найти("Товары.Цена");
А это что? И зачем?
0
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,104
31.05.2017, 18:44 5
Chubaka101,
Код здесь вообще не нужен. В свойствах поля Цена поставьте галку Неотрицательное и свойство Проверка заполнения - Выдавать ошибку. Попытка ввести Цена < =0 отсечется на этапе записи
1
Chubaka101
9 / 9 / 4
Регистрация: 14.10.2015
Сообщений: 252
31.05.2017, 19:21  [ТС] 6
polax, благодарю, но все-же, программно как это можно реализовать?
0
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,104
31.05.2017, 19:25 7
Лучший ответ Сообщение было отмечено Chubaka101 как решение

Решение

Chubaka101, В модуле объекта
1C
1
2
3
4
5
6
7
8
9
10
Процедура ОбработкаПроверкиЗаполнения(Отказ, ПроверяемыеРеквизиты)
     
Для Каждого ТекСтрока Из Товары Цикл
  Если ТекСтрока.Цена <=0 Тогда
  Отказ=Истина;
  Сообщить("Не задана цена!");
  КонецЕсли;
КонецЦикла
 
КонецПроцедуры
1
31.05.2017, 19:25
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
31.05.2017, 19:25

Подставить в поле ввода документа, из справочника табличной части
Приветствую, есть Справочник транспортные компании в котом есть 2 табличные части Водители и...

Заполнение табличной части одного документа из табличной части этого же документа
Здравсвуйте. 1С 8.2. Есть документ в этом документе 2 табличные части В 1 табличной части...

Заполнение табличной части одного документа из табличной части другого документа
Здравсвуйте. 1С 8.2. Есть документ Приход и документ Расход. Оба документа имеют табличные части -...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru