Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.85/13: Рейтинг темы: голосов - 13, средняя оценка - 4.85
Vlad69ik
1 / 1 / 2
Регистрация: 15.09.2013
Сообщений: 52
1

Подстановка данных в Word и вывод на печать

01.06.2017, 12:23. Просмотров 2451. Ответов 7
Метки нет (Все метки)

Так и не могу понять ,как сделать подстановку данных в документ. Надо сделать через "двоичные данные". Создал макет ПФ_DOC_Документ(загрузил туда документ). Но в модуле менеджера так и не пойму , что точно надо сделать. Надо ли создавать
ПФ_XML_Документ или без него можно обойтись. Печать идет из справочника. Документ разбит на области.
0
Вложения
Тип файла: docx Приложение 1 - копия.docx (25.1 Кб, 10 просмотров)
Лучшие ответы (1)
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
01.06.2017, 12:23
Ответы с готовыми решениями:

Вывод на печать данных справочника
Добрый день, форумчане! У меня в ходе выполнения работы возник вопрос. Поясняю, в чем он...

Вывод данных на печать в готовую форму Excel
Здравствуйте! 1с "Управление торговлей" версия 10.3. Есть документ, в который добавлены...

Вывод данных в существующую таблицу Word
Всем привет. Что-то я запуталась с выводом таблиц в ворд. В шаблоне у меня есть готовая шапка,...

Вывод данных из формы в печать через Word
Имеется база данных "АЗС", суть которой заключается в поставке топлива на 3 заправки. На форме...

Код вывода данных из таблицы в word и excel на печать
вот собственно сам код procedure TfmOrder.bbtGoClick(Sender: TObject); begin if...

7
engel89
3 / 3 / 2
Регистрация: 23.12.2016
Сообщений: 27
01.06.2017, 13:52 2
я через vba делал, пример:
1C
1
2
3
Замена = Документ.Content.Find;
//Замена в документе
Замена.Execute("<NomerDogovora>", Ложь, Истина, Ложь, , , Истина, , Ложь, "" + Объект.Договор.Наименование + "");
0
GreenkA
Форумчанин
Эксперт 1С
2997 / 1928 / 520
Регистрация: 25.06.2009
Сообщений: 6,815
02.06.2017, 11:57 3
Лучший ответ Сообщение было отмечено Vlad69ik как решение

Решение

Vlad69ik, судя по шаблону, у вас заполнение данных будет через замену текста, обрамленного фигурными скобками.
Какая у вас конфигурация? Посмотрите типовые печати. В УТ точно реализована подобная печать с заменой текстовых фрагментов.
Пример оттуда:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
&НаКлиенте
Процедура Печать_КП_Продажа(Команда)
    /////>>>
    ТипМакета = "doc";
    
    ДвоичныеДанныеМакетов = ПолучитьМакетСервер(ИмяМакета);
                
    ПечатнаяФорма = УправлениеПечатьюКлиент.ИнициализироватьПечатнуюФорму(ТипМакета);
    Макет = УправлениеПечатьюКлиент.ИнициализироватьМакет(ДвоичныеДанныеМакетов, ТипМакета);
    
    ОбластьШапка = УправлениеПечатьюMSWordКлиент.ПолучитьОбластьМакетаMSWord(Макет, "ОбластьШапка", 1, 0);
    ВыведеннаяОбласть = УправлениеПечатьюMSWordКлиент.ПрисоединитьОбласть(ПечатнаяФорма, ОбластьШапка, Ложь);
    
    //УправлениеПечатьюКлиент.ЗаполнитьПараметры(ПечатнаяФорма, ДанныеОбъекта);
    ЗаменитьПараметр("{v8 Область.Заголовок}", <ТекстЗамены>, ВыведеннаяОбласть);
    
    /////<<<
КонецПроцедуры
 
&НаКлиенте
Процедура ЗаменитьПараметр(СтрокаПоиска, СтрокаЗамены,ВыведеннаяОбласть)
    Object = ВыведеннаяОбласть.Document.Content;
    Object.Select();
    Selection = Object.Application.Selection;
    
    FindObject = Selection.Find;
    FindObject.ClearFormatting();
    Пока FindObject.Execute(СтрокаПоиска) Цикл
        Если ПустаяСтрока(СтрокаЗамены) Тогда
            Selection.Delete();
        Иначе
            Selection.TypeText(СтрокаЗамены);
        КонецЕсли;
    КонецЦикла;
    Selection.Collapse();
КонецПроцедуры
1
Vlad69ik
1 / 1 / 2
Регистрация: 15.09.2013
Сообщений: 52
02.06.2017, 12:46  [ТС] 4
Цитата Сообщение от GreenkA Посмотреть сообщение
судя по шаблону, у вас заполнение данных будет через замену текста, обрамленного фигурными скобками.
Какая у вас конфигурация? Посмотрите типовые печати. В УТ точно реализована подобная печать с заменой текстовых фрагментов.
Пример оттуда:
Конфигурация УТ11. Да , я смотрел какие есть там реализации ,но так и не понял полностью.
Спасибо за помощь.
0
02.06.2017, 12:46
GreenkA
Форумчанин
Эксперт 1С
2997 / 1928 / 520
Регистрация: 25.06.2009
Сообщений: 6,815
02.06.2017, 12:55 5
Vlad69ik, из какого справочника будет печать? Номенклатура? А цены откуда?
В заголовке что? Номера договоров и т.п.
0
Vlad69ik
1 / 1 / 2
Регистрация: 15.09.2013
Сообщений: 52
02.06.2017, 13:06  [ТС] 6
Цитата Сообщение от GreenkA Посмотреть сообщение
из какого справочника будет печать? Номенклатура? А цены откуда?
В заголовке что? Номера договоров и т.п.
__________________
Печать идет из справочника СоглашениеСКлиентами. В заголовке номер,дата,НомерПред и ДатаПред документа берется из этого же справочника. Товар и цена берется из Документа УстановкаЦенНоменклатуры.
0
GreenkA
Форумчанин
Эксперт 1С
2997 / 1928 / 520
Регистрация: 25.06.2009
Сообщений: 6,815
02.06.2017, 13:44 7
Документа УстановкаЦенНоменклатуры
Vlad69ik, какого? последнего на дату? с выводом всех товаров?
0
Vlad69ik
1 / 1 / 2
Регистрация: 15.09.2013
Сообщений: 52
02.06.2017, 13:53  [ТС] 8
Цитата Сообщение от GreenkA Посмотреть сообщение
Vlad69ik, какого? последнего на дату? с выводом всех товаров?
Прости ошибся , в том же справочнике таблица Товары от туда
0
02.06.2017, 13:53
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
02.06.2017, 13:53

Печать данных в документ Word, находясь в рабочей книге Excel
Как напечатать в конкретный документ Word данные, находясь в открытой книге Excel? Печать...

Вывод табличных HTML-данных на печать
Есть ли какой-нибудь компонент (серверный - клиентский), который бы подготавливал табличные данные...

Вывод данных на печать из текстового поля
Всеv доброго времени суток.... У меня есть текстовое поле в WPF сделал его мультилайнт через...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
8
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru