Форум программистов, компьютерный форум, киберфорум
Наши страницы

1С: Собственные программы

Войти
Регистрация
Восстановить пароль
 
Миша Колесников
2 / 2 / 0
Регистрация: 16.12.2011
Сообщений: 35
#1

Програмно изменить обязательность заполнения реквизита - 1С/1C 8.x

12.09.2017, 15:46. Просмотров 243. Ответов 1
Метки нет (Все метки)

Здравствуйте.

Только начинаю программировать на 1с после 10ти летнего перерыва, поэтому прошу не кидать камнями.
Задача: сделать, чтобы в зависимости от выбора одного элемента на форме (реквизит), был доступен другой элемент (реквизит2). Причем если доступно поле реквизит2, оно обязательно для заполнения. В настройках конфигуратора у реквизита2 поставил свойство проверка заполнения=выдавать ошибку.
В модуле формы написал следующее:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
&НаКлиенте
Процедура Элемент1ПриИзменении(Элемент)
    Элемент1ПриИзмененииНаСервере();
    
    Если        Объект.Элемент1 = ПредопределенноеЗначение("Перечисление.ТипНоменклатуры.Значение1")
        Тогда       Элементы.Элемент2.Доступность=Истина   ;
        Иначе       Элементы.Элемент2.Доступность=Ложь   ;
    КонецЕсли;
КонецПроцедуры
 
&НаКлиенте
Процедура ПриОткрытии(Отказ)
    Элементы.Элемент2.Доступность=Ложь   ;
    
КонецПроцедуры
Как сделать так, чтобы не требовалось заполнять реквизит2, если Элемент1 содержит не значение Значение1
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
12.09.2017, 15:46
Я подобрал для вас темы с готовыми решениями и ответами на вопрос 1C 8.x Програмно изменить обязательность заполнения реквизита (1С):

1C 8.x Автоматическое заполнения реквизита - 1С
Добрый день! Столкнулся с такой проблемой. Есть некий документ, в нем два реквизита "группа" и "специальность". (СправочникСсылка.Группы и...

Изменить значение реквизита справочника - 1С
Парни подскажите! Хочу сменить вид номенклатуры с Продукции на Товар, в результате меняется наименование текущего Вида Номенклатуры, а...

Подсчет по реквизита - 1С
Помогите с кодом, нужно по коду акции менять цену товара

1C 8.x Формула реквизита - 1С
Подскажите где найти в 8.2 формулу на реквизит,как было в 7.7 в свойствах в 8 найти не могу

Повторное изменение реквизита - 1С
Нужно изменить реквизит Наименование, при вводе текста в другой реквизит (Фамилия) &НаКлиенте Процедура ФамилияПриИзменении(Элемент) ...

1C 8.x Получение реквизита справочника - 1С
в 1с только начинаю разбиратся по работе , так что сильно не пинайте ;-) Есть обработка котрая запускается из справочника контрагенты, из...

1
polax
615 / 389 / 123
Регистрация: 16.01.2015
Сообщений: 1,304
12.09.2017, 17:02 #2
Миша Колесников, Уберите в форме обязательность заполнения реквизита и используйте либо в ОбработкаПроверкиЗаполнения либо где-нибудь ПередЗаписью
1C
1
2
3
4
5
Если Объект.Элемент1 = ПредопределенноеЗначение("Перечисление.ТипНоменклатуры.Значение1") 
       И НЕ ЗначениеЗаполнено(Объект.Элемент2) ТОгда
Отказ = Истина;
Сообщить("бла бла бла");
КонецЕсли;
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
12.09.2017, 17:02
Привет! Вот еще темы с ответами:

1C 7.x Удаление реквизита из справочника - 1С
проблема элементарная, но чёто туплю.... Нужно в цикле пройтись по справочнику и отчистить один из реквизитов. Вот код (но он почемуто не...

Создание уникального реквизита - 1С
Изучение 1С только начинаю, поэтому ссори за, может быть глупый вопрос. Как создать уникальный реквизит, артикул товара, который,...

1C 8.x Локализация значений реквизита - 1С
Если кто сталкивался с локализацией 1С 8.2 8.1, просьба помочь. Проблема следующая: как можно локализовать реквизит "НаименованиеПолное"...

1C 8.x Поиск реквизита и его длины - 1С
Добрый день! 1с Отель. В конфигураторе все на английском. Необходимо изменить длину строкового реквизита "Наименование"...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru