Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Миша Колесников
2 / 2 / 0
Регистрация: 16.12.2011
Сообщений: 35
#1

Програмно изменить обязательность заполнения реквизита

12.09.2017, 15:46. Просмотров 293. Ответов 1
Метки нет (Все метки)

Здравствуйте.

Только начинаю программировать на 1с после 10ти летнего перерыва, поэтому прошу не кидать камнями.
Задача: сделать, чтобы в зависимости от выбора одного элемента на форме (реквизит), был доступен другой элемент (реквизит2). Причем если доступно поле реквизит2, оно обязательно для заполнения. В настройках конфигуратора у реквизита2 поставил свойство проверка заполнения=выдавать ошибку.
В модуле формы написал следующее:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
&НаКлиенте
Процедура Элемент1ПриИзменении(Элемент)
    Элемент1ПриИзмененииНаСервере();
    
    Если        Объект.Элемент1 = ПредопределенноеЗначение("Перечисление.ТипНоменклатуры.Значение1")
        Тогда       Элементы.Элемент2.Доступность=Истина   ;
        Иначе       Элементы.Элемент2.Доступность=Ложь   ;
    КонецЕсли;
КонецПроцедуры
 
&НаКлиенте
Процедура ПриОткрытии(Отказ)
    Элементы.Элемент2.Доступность=Ложь   ;
    
КонецПроцедуры
Как сделать так, чтобы не требовалось заполнять реквизит2, если Элемент1 содержит не значение Значение1
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
12.09.2017, 15:46
Ответы с готовыми решениями:

Не отображаются изменения на форме после заполнения табличной части реквизита
Пишу внешнюю обработку для заполнения табличной части документа Реализация...

Автоматическое заполнения реквизита
Добрый день! Столкнулся с такой проблемой. Есть некий документ, в нем два...

Изменить значение реквизита справочника
Парни подскажите! Хочу сменить вид номенклатуры с Продукции на Товар, в...

Как изменить значение реквизита ТЧ? Ошибка: значение не является значением объектного типа (табличная часть)
Здравствуйте, все неравнодушные) Ситуация такая у меня: В документе (приходная...

Изм реквизита
Люди помогите, есть необходимость поменять реквизит в расходной накл. "Место...

1
polax
667 / 412 / 133
Регистрация: 16.01.2015
Сообщений: 1,436
12.09.2017, 17:02 #2
Миша Колесников, Уберите в форме обязательность заполнения реквизита и используйте либо в ОбработкаПроверкиЗаполнения либо где-нибудь ПередЗаписью
1C
1
2
3
4
5
Если Объект.Элемент1 = ПредопределенноеЗначение("Перечисление.ТипНоменклатуры.Значение1") 
       И НЕ ЗначениеЗаполнено(Объект.Элемент2) ТОгда
Отказ = Истина;
Сообщить("бла бла бла");
КонецЕсли;
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
12.09.2017, 17:02

Видимость Реквизита В 8.3
Конфигурация 1С бухгалтерия 8.3 В документе РеализацияТоваровУслуг в табличной...

Формула реквизита
Подскажите где найти в 8.2 формулу на реквизит,как было в 7.7 в свойствах в 8...

Период Реквизита!
Как сделать параметры НачалоПериода и КонецПериода в регистре сведений...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru