Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
 
Рейтинг 4.60/5: Рейтинг темы: голосов - 5, средняя оценка - 4.60
Джавид-777
2 / 2 / 1
Регистрация: 17.09.2017
Сообщений: 57
1

Разработка интерфейса. Создание формы справочника

17.09.2017, 13:20. Просмотров 898. Ответов 30
Метки нет (Все метки)

Здравствуйте! Помогите, пожалуйста с формой справочника. Не получается реализовать такую задачу в форме при выборе из списка определенного реквизита, становится виден другой реквизит. Например, чтобы был виден РеквизитПрофиль при выборе РеквизитТипНедвижимости "Объект новостройка", "Объект(вторичка),Объект(отдельно стоящий". Так, как при выборе других значений (квартира, новостройка и т.д) этот реквизит не требуется.
0
Миниатюры
Разработка интерфейса. Создание формы справочника   Разработка интерфейса. Создание формы справочника  
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
17.09.2017, 13:20
Ответы с готовыми решениями:

Открытие формы документа с заполнением данных из формы справочника
Здравствуйте! Платформа 1с 8.3, пытаюсь создать базу пациентов.)) Есть Справочник с формой...

Стандартные формы справочника
При создании формы в 1С через графический интерфейс, система 1С создаёт форму заполненную кнопками...

Доступность элементов формы справочника
Здравствуйте, подскажите, я только начинаю и вот столкнулся с такой ситуацией, создаю списки ,и при...

Проблемы с редактированием формы справочника
Присоздание нового поля ввода и индификатора в справочнике "Товар" в конфигураторе все сохраняется...

Создание справочника
Добрый день! Писала на работе программу документооборота простенькую на Делфи, теперь просят тоже...

30
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,104
17.09.2017, 14:17 2
Джавид-777,

1C
1
2
3
4
5
6
7
8
&НаКлиенте
Процедура РеквизитТипНедвижимостиПриИзменении
Если Объект.РеквизитТипНедвижимости = Справочники.ОбъектыНедвижимости.НайтиПоНаименованию("Объект новостройка")
Или Объект.РеквизитТипНедвижимости = Справочники.ОбъектыНедвижимости.НайтиПоНаименованию("Объект(вторичка)")
Тогда Элементы.РеквизитПрофиль.Видимость = Истина;
Иначе Элементы.РеквизитПрофиль.Видимость = Ложь;
КонецЕсли;
КонецПроцедуры;
1
Джавид-777
2 / 2 / 1
Регистрация: 17.09.2017
Сообщений: 57
17.09.2017, 15:23  [ТС] 3
Что-то не получилось(
0
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,104
17.09.2017, 18:22 4
Джавид-777, Укажите событие формы ПриИзменении для реквизита (как на скрине)
И код (исходя из вашей базы):
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
&НаСервере
Процедура РеквизитТипНедвижимостиПриИзмененииНаСервере()
Если Объект.РеквизитТипНедвижимости = Справочники.ТипыНедвижимости.НайтиПоНаименованию("Объект новостройка")
Или Объект.РеквизитТипНедвижимости = Справочники.ТипыНедвижимости.НайтиПоНаименованию("Объект(вторичка)")
Тогда Элементы.РеквизитПрофиль.Видимость = Истина;
Иначе Элементы.РеквизитПрофиль.Видимость = Ложь;
КонецЕсли;
 
КонецПроцедуры
 
 
&НаКлиенте
Процедура РеквизитТипНедвижимостиПриИзменении(Элемент)
    РеквизитТипНедвижимостиПриИзмененииНаСервере();
КонецПроцедуры
1
Миниатюры
Разработка интерфейса. Создание формы справочника  
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,104
17.09.2017, 18:24 5
Плюс, уберите проверку обязательности заполнения реквизита Проект (раз уж он нужен не всегда)
0
Джавид-777
2 / 2 / 1
Регистрация: 17.09.2017
Сообщений: 57
17.09.2017, 18:52  [ТС] 6
{Справочник.СправочникБазаАренда.Форма.ФормаЭлемента.Форма(4)}: Поле объекта не обнаружено (ТипыНедвижимости)
Если Объект.РеквизитТипНедвижимости = Справочники.ТипыНедвижимости.НайтиПоНаименованию("Объект (новостройка)")

Вот выдало такое сообщение
0
Джавид-777
2 / 2 / 1
Регистрация: 17.09.2017
Сообщений: 57
17.09.2017, 18:57  [ТС] 7
И почему-то Наименование(Объект (новостройка) и другое не высвечивается как у вас зеленым цветом
0
Миниатюры
Разработка интерфейса. Создание формы справочника  
Джавид-777
2 / 2 / 1
Регистрация: 17.09.2017
Сообщений: 57
17.09.2017, 19:02  [ТС] 8
Вот еще конфигурация моя на всякий случай
0
Вложения
Тип файла: zip 1Cv8.zip (209.3 Кб, 8 просмотров)
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,104
17.09.2017, 19:08 9
Лучший ответ Сообщение было отмечено Джавид-777 как решение

Решение

Джавид-777, Ну е-мое. Посмотрите как у вас называются справочники
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
&НаСервере
Процедура РеквизитТипНедвижимостиПриИзмененииНаСервере()
Если Объект.РеквизитТипНедвижимости = Справочники.СправочникТипыНедвижимости.НайтиПоНаименованию("Объект новостройка")
Или Объект.РеквизитТипНедвижимости = Справочники.СправочникТипыНедвижимости.НайтиПоНаименованию("Объект(вторичка)")
Тогда Элементы.РеквизитПрофиль.Видимость = Истина;
Иначе Элементы.РеквизитПрофиль.Видимость = Ложь;
КонецЕсли;
 
КонецПроцедуры
 
 
&НаКлиенте
Процедура РеквизитТипНедвижимостиПриИзменении(Элемент)
    РеквизитТипНедвижимостиПриИзмененииНаСервере();
КонецПроцедуры
Добавлено через 2 минуты
Джавид-777, ))) Не должно быть зеленым цветом в модуле, все правильно у вас показывает - черным. Это тэг в форуме немного ошибается
1
Джавид-777
2 / 2 / 1
Регистрация: 17.09.2017
Сообщений: 57
17.09.2017, 19:12  [ТС] 10
А вы можете посмотреть на мою конфигурацию?) Я только начинаю изучать программу, и у нас в городе вообще ни одного программиста по 1С. Только готовыми решениями пользуются. Приходится учить по видео и книгам
0
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,104
17.09.2017, 19:14 11
А вопрос-то в чем? У вас там только Справочники
0
Джавид-777
2 / 2 / 1
Регистрация: 17.09.2017
Сообщений: 57
17.09.2017, 19:21  [ТС] 12
Всё, разобрался, спасибо большое))) Название справочника неправильно указал)
P.S. Проект нужен, только при выборе "Квартира (вторичка)" и "Объект (вторичка)". Думаю еще помучаться самому)))
0
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,104
17.09.2017, 19:33 13
Джавид-777, Небольшое замечание. Справочник нужен если у вас в нем хранится какая-то расширенная информация (типа вашего БазаАренда). Если же там только наименование (как справочник ТипНедвижимости), то используйте Перечисления плюс предопределенные значения перечисления - наиболее часто используемые) Тогда можно обращаться напрямую, без поиска в базе. Например Перечисления.ТипНедвижимости.ОбъектНовостройка (перечисления ТипНедвижимости вместо справочника, предопределенное значение ОбъектНовостройка ). Удачи в освоении ))
1
Джавид-777
2 / 2 / 1
Регистрация: 17.09.2017
Сообщений: 57
17.09.2017, 22:07  [ТС] 14
Спасибо! Учту в будущем!)

Добавлено через 1 час 51 минуту
polax, А можете посоветовать, как создать контакт с номерами телефонов и именем? Сложность в том, что не могу настроить так, чтобы потом поиск по номеру был по всем справочникам (например, у одного контакта может быть и квартира в аренду, и объект на продажу и т.п) Чтобы не вводить одно и то же недвижимость, и посмотреть, какая недвижимость есть у определенного контакта в БД

Добавлено через 15 минут
polax, Например
Есть владелец Николай, с телефонами 8912 222 22 22 и 8908 220 00 00
У него есть квартира (объект, вилла..) в аренду
У него есть новостройка (вторичка, частный дом...) на продажу
Как создать поиск по номеру телефона в интерфейсе? Чтобы выводилась информация о недвижимостях Николая
0
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,104
17.09.2017, 22:43 15
Цитата Сообщение от Джавид-777 Посмотреть сообщение
как создать контакт с номерами телефонов и именем
В справочник Контакты делаете таблицу КонтактнаяИнформация, куда и вносите все по контактам (посмотрите любую доступную типовую конфигурацию, справочник Контрагенты)
Цитата Сообщение от Джавид-777 Посмотреть сообщение
У него есть квартира (объект, вилла..) в аренду
У него есть новостройка (вторичка, частный дом...) на продажу
Как создать поиск по номеру телефона в интерфейсе?
Это где все хранится? По вашей конфигурации не понятно. Но общий принцип. По контактной информации (телефон) ищется Контрагент (Николай) из формы выбора справочника контрагенты и уже по контрагенту идет отбор в списке конкретного справочника (но одного). Если же у вас все это хранится в разных справочниках (что на мой взгляд неверно), то получать информацию можно уже отчетом а не поиском в списке А лучше создать какой-то регистр сведений, куда будут записываться все объекты недвижимости контрагента. Например Измерения: Контрагент и Вид Недвижимости а ресурсы Адрес, и др нужная инфа
1
Джавид-777
2 / 2 / 1
Регистрация: 17.09.2017
Сообщений: 57
17.09.2017, 23:32  [ТС] 16
polax, Да, к сожалению невозможно в данном случае создать только один справочник. Потому, что параметры у видов недвижимости (в данном случае Подсистемы) разные. Например, у земли не бывает комнат, этажей. у новостроек не бывает проекта. У частного дома есть площадь участка и т.д. Вот и сложность в том, что у одного человека может быть много недвижимости и в аренду, и в продажу

Добавлено через 39 минут
polax, Можете сказать, что для этого есть группы справочника, и можно всё в одном справочнике создать. Но:
-В аренду сдают всё, кроме земли
-Бывают объекты отдельно построенные, под новостройкой и вторички
-Эти объекты нужно отразить и в аренде, и в продаже объектов
-Аренда сдаётся на определённое время и обновляется после окончания договора аренды, а продажа одноразовая сделка и недвижимость после продажи удаляется
-у вторичек бывают проекты, у новостроек фирма-застройщик (проектов нет)
Это немного из нюансов) Поэтому решил разделить по справочникам и подсистемам
0
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,104
18.09.2017, 07:43 17
Джавид-777, Посмотрите типовую конфигурацию справочник Номенклатура. Вам , конечно, виднее по задаче, но мне кажется подойдет этот справочник. Вместо Номенклатура (но по образу и подобию) делаете справочник БазаНедвижимости. Есть категории номенклатуры - ваши новостройка, вторичка, аренда и т.п., есть контактная информация (таблица справочника) - адреса объектов, есть Поставщик номенклатуры (отдельный справочник - владелец недвижимости), есть Прикрепленные файлы - ваши планы помещения и т.д.
1
Джавид-777
2 / 2 / 1
Регистрация: 17.09.2017
Сообщений: 57
18.09.2017, 10:23  [ТС] 18
polax, А потом возможно будет по отдельности вывести на интерфейс группы, как на моей конфигурации (аренда, вторичка, новостройки и т.д)? Потому, что ещё многое добавлю (видимость, роли, история звонков, напоминания об освобождаемых квартирах и т.д)
0
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,104
18.09.2017, 19:37 19
Джавид-777, О каких формах речь?
0
Джавид-777
2 / 2 / 1
Регистрация: 17.09.2017
Сообщений: 57
18.09.2017, 20:41  [ТС] 20
Не совсем понял. Об управляемых. У меня версия 8.3.10

Добавлено через 58 секунд
polax, Добрый вечер. Об управляемых. У меня стоит версия 8.3.10
0
18.09.2017, 20:41
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
18.09.2017, 20:41

Создание справочника
Добрый день! Прошу о помощи! Мне нужно доработать конфигурацию под фирму. В уже созданном...

Разные Формы Объектов Одного Справочника
Здравствуйте! У меня есть два вида заяво - от клиента и в транспортную компанию. Я хочу для этих...

Диалоговые формы работы с данными справочника
Справочник у меня основные средства а как разработать эти диалоговые формы где они находяться не...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
20
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru