Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.60/5: Рейтинг темы: голосов - 5, средняя оценка - 4.60
Владислаучык
1 / 1 / 7
Регистрация: 21.03.2013
Сообщений: 483
1

Отчет СКД: отображение значений параметров на форме

18.09.2017, 11:13. Просмотров 892. Ответов 6
Метки нет (Все метки)

Добрый день, устанавливаю значения параметров при открытии, но на форме колонки эти пустые, как-будто ничего не установлено, как сделать, чтобы было видно?

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
    КомпоновщикНастроекСКД = Отчет.КомпоновщикНастроек;
    УчетнаяПолитикаПоЗарплате=ОбщегоНазначения.ПолучитьЗначениеУчетнойПолитикиПоЗарплате();
    Отчет.ДатаНач = НачалоГода(ТекущаяДата());
    Отчет.ДатаКон = КонецГода(ТекущаяДата());
    
    
    ПараметрВидыРасчета = КомпоновщикНастроекСКД.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("ВидыРасчета"));
    Если Не ЗначениеЗаполнено(ПараметрВидыРасчета.Значение) Тогда
        
        ПараметрВидыРасчета.Значение=УчетнаяПолитикаПоЗарплате.ОтпускМатериальнаяПомощь;
        ПараметрВидыРасчета.Использование=Истина;
        
    КонецЕсли;
    
    ПараметрВидыРасчетаДекрет=КомпоновщикНастроекСКД.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("спДекрет"));
    Если Не ЗначениеЗаполнено(ПараметрВидыРасчетаДекрет.Значение) Тогда
        
        ПараметрВидыРасчетаДекрет.Значение=УчетнаяПолитикаПоЗарплате.ВидРасчетаОтпускВСвязиСБеременностьюИРодами;
        ПараметрВидыРасчетаДекрет.Использование=Истина;
        
    КонецЕсли;
0
Лучшие ответы (1)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
18.09.2017, 11:13
Ответы с готовыми решениями:

Отчет СКД. Передать параметры, заданные на форме отчета
Добрый день! Формирую отчет на скд, где устанавливаю отбор по периоду. Эти...

Как в СКД сделать отображение в отчете нулевых значений?
Здравствуйте! Подскажите пожалуйста, как в СКД сделать отображение в отчете...

Обычные формы, отчет на СКД - вывод параметров на форму
Обычная форма, делаю отчет на СКД. Задаю параметры , на форме размещаю...

Отчет СКД. Вывод нескольких таблиц в отчет из разных запросов.
Привет, коллеги! Возникла необходимость в одном отчете видеть 2 таблички: одну...

Отображение параметров отбора на обычной форме отчета
Добрый день, во вложении скрин самописного внешнего отчета на скд. Пытаюсь...

6
GreenkA
Модератор
Эксперт 1С
2275 / 1682 / 501
Регистрация: 25.06.2009
Сообщений: 6,182
20.09.2017, 01:07 2
Владислаучык, какие колонки пустые? Речь о параметрах или реквизитах отчета ДатаНач и ДатаКон? Они хоть где-то в коде связаны с параметрами отчета СКД?
0
Владислаучык
1 / 1 / 7
Регистрация: 21.03.2013
Сообщений: 483
20.09.2017, 16:56  [ТС] 3
GreenkA, ПараметрВидыРасчета.Значение и ПараметрВидыРасчетаДекрет.Значение - Вот они пустые при открытии(имеется ввиду отображение их нету), но они заполняются, в них есть значение
0
GreenkA
Модератор
Эксперт 1С
2275 / 1682 / 501
Регистрация: 25.06.2009
Сообщений: 6,182
20.09.2017, 20:32 4
Лучший ответ Сообщение было отмечено Владислаучык как решение

Решение

Цитата Сообщение от Владислаучык Посмотреть сообщение
Вот они пустые при открытии(имеется ввиду отображение их нету), но они заполняются, в них есть значение
в смысле?

Добавлено через 14 минут
Владислаучык, все, поняла. Проблема в том, что у вас эти параметры являются пользовательскими настройками, так что меняем код:
1C
1
2
3
4
5
6
7
8
    ПараметрВидыРасчета = КомпоновщикНастроекСКД.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("ВидыРасчета"));
    ПараметрВидыРасчетаПольз = КомпоновщикНастроекСКД.ПользовательскиеНастройки.Элементы.Найти(ПараметрВидыРасчета.ИдентификаторПользовательскойНастройки);
    Если Не ЗначениеЗаполнено(ПараметрВидыРасчетаПольз.Значение) Тогда
        
        ПараметрВидыРасчетаПольз.Значение=УчетнаяПолитикаПоЗарплате.ОтпускМатериальнаяПомощь;
        ПараметрВидыРасчетаПольз.Использование=Истина;
        
    КонецЕсли;
Со вторым так же.
0
Yulunga
314 / 212 / 63
Регистрация: 22.04.2013
Сообщений: 1,414
Завершенные тесты: 1
20.09.2017, 20:34 5
Владислаучык,
наверно стоит ограничение доступности ( см. первый скрин. по умолчанию галка стоит ) . когда убираешь галку - на закладке настройки в параметрах появляется параметр ( второй скрин ).
выбираешь строку, нажимаешь на "2", открывается окно. ставишь галку "3", оставляешь "4". ок.
всё. теперь твой параметр на форме.

если это имелось в виду
0
Миниатюры
Отчет СКД: отображение значений параметров на форме   Отчет СКД: отображение значений параметров на форме  
Yulunga
314 / 212 / 63
Регистрация: 22.04.2013
Сообщений: 1,414
Завершенные тесты: 1
20.09.2017, 20:35 6
а, я наверно как всегда не о том ))
0
GreenkA
Модератор
Эксперт 1С
2275 / 1682 / 501
Регистрация: 25.06.2009
Сообщений: 6,182
20.09.2017, 20:35 7
Yulunga, да не, он хочет их заполнить нужными значениями при открытии формы отчета, чтобы руками ничего не выбирать)
0
20.09.2017, 20:35
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
20.09.2017, 20:35

Отчет СКД
Добрый день. Пытаюсь какой уже день, все мысли исчерпаны. Пытаюсь сделать...

Отчет в СКД
Здравствуйте! Помогите пожалуйста разобраться с отчетом в СКД! Нужно чтобы в...

Отчет в СКД
Добрый день. Делаю простенький отчет в системе компановки данных. За основу...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru