Форум программистов, компьютерный форум, киберфорум
Наши страницы

1С: Собственные программы

Войти
Регистрация
Восстановить пароль
 
Denn1211
0 / 0 / 0
Регистрация: 14.04.2017
Сообщений: 2
#1

1C 8.3 Удаление строк в таблице значений в которых нет значений - 1С

19.09.2017, 10:17. Просмотров 330. Ответов 2
Метки (Все метки)

Добрый день!
Нужно написать обработчик, которые удаляет все строки в которых нет значений из таблицы значений на 1С.8,3.
Помогите пожалуйста!
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
19.09.2017, 10:17
Я подобрал для вас темы с готовыми решениями и ответами на вопрос 1C 8.3 Удаление строк в таблице значений в которых нет значений (1С):

Произворльная раскраска ячеек JTable в зависимости от значений которых нет в видимой таблице - Java SE
Всем привет! Раскрасить ячейки в зависимости от данных имеющихся в этих ячейках не сложно. А как оптимально раскрасить их в...

SQL. Вывод значений из таблицы и подсчет количества этих значений в другой таблице - MySQL
Задание звучит так: Для таблиц user и phones, где соответствие записей определяется равенством user.id = phones.user_id привести 2 разных...

MS Access Удалить строки в которых комбинация значений отсутствует в другой таблице - Delphi БД
Есть таблица связей podk_sv с полями kat, podkat и таблица расходов rashods с полями kat, podkat. Нужно в таблице podk_sv удалить такие...

Отбор в таблице значений по условию четных и нечетных значений - 1С
Здравствуйте, учусь работать с таблицами значений, дали задачу, написать форму и что бы в одной тч выводились номера домов и сумма...

Вывести строки в которых нет значений - SQL Server
здравствуйте! есть запрос select ppc.Destination_PP_ID, pp.object_id, ZP = dbo.fn_Operation_Price(pp.Object_ID, oj2.Operation_ID,...

Выборка значений которых нет в одной и 2-х таблиц - MySQL
Есть две таблицы taxpay и cheta. Этим запросом я выбираю количество лиц, которые имею счета, а вот как вывести кол-во лиц, которые имеют...

2
polax
615 / 389 / 123
Регистрация: 16.01.2015
Сообщений: 1,304
19.09.2017, 14:58 #2
Denn1211,
1C
1
2
3
4
5
6
7
8
9
10
Высота = ТЗ.Количество();
Сч = 0;
Пока сч <= Высота-1 Цикл
Если НЕ ЗначениеЗаполнено(ТЗ[сч].Номенклатура) Тогда    
ТЗ.Удалить(ТЗ[сч]);
Высота= Высота-1;
Продолжить;
КонецЕсли;
сч = сч+1;
КонецЦикла;
0
Yulunga
289 / 192 / 48
Регистрация: 22.04.2013
Сообщений: 1,101
Завершенные тесты: 1
19.09.2017, 15:36 #3
1C
1
2
3
4
НайденныеСтроки = ОплатаФакт.НайтиСтроки(Новый Структура("нетзначений", "нетзначений"));
Для каждого СтрокаТЧ Из НайденныеСтроки Цикл
   ОплатаФакт.Удалить(СтрокаТЧ);
КонецЦикла;
1
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
19.09.2017, 15:36
Привет! Вот еще темы с ответами:

Последовательность значений, которых нет в некой последовательности - C#
суть представленного неполного кода в следующем берется последовательность чисел и мы получаем значения которых нет в последовательности...

Объединить несколько значений в таблице значений - 1С
Друзья, есть такая табличная часть: Время | Программа 09:00 | Мультики 09:15 | Кино 10:00 | Новости 10:30 | Сериал 11:00 |...

Подсчитать количество элементов,значений которых больше значений предыдущего элемента - Turbo Pascal
Подсчитать количество элементов,значений которых больше значений предыдущего элемента?Спасибо.

Запрос: Выборка записей значения которых по полю Х не содержат таких же значений имеющихся в другой таблице - MS Access
Суть: Есть две таблицы в каждой из которых есть коррелирующие поля, в таблице1 - 100 записей, в таблице2 - 10 (значения которых ранее были...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru