Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Denn1211
0 / 0 / 0
Регистрация: 14.04.2017
Сообщений: 2
1

1C 8.3 Удаление строк в таблице значений в которых нет значений

19.09.2017, 10:17. Просмотров 443. Ответов 2
Метки (Все метки)

Добрый день!
Нужно написать обработчик, которые удаляет все строки в которых нет значений из таблицы значений на 1С.8,3.
Помогите пожалуйста!
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
19.09.2017, 10:17
Ответы с готовыми решениями:

1C 8.3 Перенос строки из первой таблице значений в другую таблицу значений
Добрый день! Нужно написать обработчик, который переносил бы строку таблицы...

Отбор в таблице значений по условию четных и нечетных значений
Здравствуйте, учусь работать с таблицами значений, дали задачу, написать форму...

Объединить несколько значений в таблице значений
Друзья, есть такая табличная часть: Время | Программа 09:00 | Мультики 09:15...

Обращение к таблице значений
Есть документ, он состоит из 3-х таблиц значений. Как из другого документа или...

поискт по таблице значений
у меня при переборе строк ТЗ ищется соответствие в ТЗЦены. Если находится...

2
polax
700 / 441 / 140
Регистрация: 16.01.2015
Сообщений: 1,559
19.09.2017, 14:58 2
Denn1211,
1C
1
2
3
4
5
6
7
8
9
10
Высота = ТЗ.Количество();
Сч = 0;
Пока сч <= Высота-1 Цикл
Если НЕ ЗначениеЗаполнено(ТЗ[сч].Номенклатура) Тогда    
ТЗ.Удалить(ТЗ[сч]);
Высота= Высота-1;
Продолжить;
КонецЕсли;
сч = сч+1;
КонецЦикла;
0
Yulunga
314 / 212 / 63
Регистрация: 22.04.2013
Сообщений: 1,414
Завершенные тесты: 1
19.09.2017, 15:36 3
1C
1
2
3
4
НайденныеСтроки = ОплатаФакт.НайтиСтроки(Новый Структура("нетзначений", "нетзначений"));
Для каждого СтрокаТЧ Из НайденныеСтроки Цикл
   ОплатаФакт.Удалить(СтрокаТЧ);
КонецЦикла;
1
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
19.09.2017, 15:36

Поиск в Таблице значений (7.7)
Здравствуйте. Возник срочный вопрос по поиску в Таблице значений. Есть...

1c8 поиск значения в Таблице значений
Есть две таблицы значений ТЗ1 и ТЗ2. Обхожу в цикле Для каждого СТЗ из ТЗ1 -...

Добавление и изменение данных в таблице значений
Доброго времени суток,есть задача изменять и добавлять в таблице значений...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru