Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/3: Рейтинг темы: голосов - 3, средняя оценка - 4.67
Denn1211
0 / 0 / 0
Регистрация: 14.04.2017
Сообщений: 2
1

1C 8.3 Удаление строк в таблице значений в которых нет значений

19.09.2017, 10:17. Просмотров 569. Ответов 2
Метки (Все метки)

Добрый день!
Нужно написать обработчик, которые удаляет все строки в которых нет значений из таблицы значений на 1С.8,3.
Помогите пожалуйста!
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
19.09.2017, 10:17
Ответы с готовыми решениями:

1C 8.3 Перенос строки из первой таблице значений в другую таблицу значений
Добрый день! Нужно написать обработчик, который переносил бы строку таблицы значений в другую...

Отбор в таблице значений по условию четных и нечетных значений
Здравствуйте, учусь работать с таблицами значений, дали задачу, написать форму и что бы в одной тч...

Объединить несколько значений в таблице значений
Друзья, есть такая табличная часть: Время | Программа 09:00 | Мультики 09:15 | Кино 10:00 |...

Произворльная раскраска ячеек JTable в зависимости от значений которых нет в видимой таблице
Всем привет! Раскрасить ячейки в зависимости от данных имеющихся в этих ячейках не сложно. А...

SQL. Вывод значений из таблицы и подсчет количества этих значений в другой таблице
Задание звучит так: Для таблиц user и phones, где соответствие записей определяется равенством...

2
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,104
19.09.2017, 14:58 2
Denn1211,
1C
1
2
3
4
5
6
7
8
9
10
Высота = ТЗ.Количество();
Сч = 0;
Пока сч <= Высота-1 Цикл
Если НЕ ЗначениеЗаполнено(ТЗ[сч].Номенклатура) Тогда    
ТЗ.Удалить(ТЗ[сч]);
Высота= Высота-1;
Продолжить;
КонецЕсли;
сч = сч+1;
КонецЦикла;
0
Yulunga
372 / 266 / 69
Регистрация: 22.04.2013
Сообщений: 1,701
Записей в блоге: 1
Завершенные тесты: 1
19.09.2017, 15:36 3
1C
1
2
3
4
НайденныеСтроки = ОплатаФакт.НайтиСтроки(Новый Структура("нетзначений", "нетзначений"));
Для каждого СтрокаТЧ Из НайденныеСтроки Цикл
   ОплатаФакт.Удалить(СтрокаТЧ);
КонецЦикла;
1
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
19.09.2017, 15:36

Удалить строки в которых комбинация значений отсутствует в другой таблице
Есть таблица связей podk_sv с полями kat, podkat и таблица расходов rashods с полями kat, podkat....

Вывести строки в которых нет значений
здравствуйте! есть запрос select ppc.Destination_PP_ID, pp.object_id, ZP =...

Последовательность значений, которых нет в некой последовательности
суть представленного неполного кода в следующем берется последовательность чисел и мы получаем...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru