Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
frodoirbit
0 / 0 / 0
Регистрация: 27.12.2015
Сообщений: 8
#1

Передача значение констант в строку табличной части документа - 1С

20.09.2017, 09:24. Просмотров 205. Ответов 13
Метки нет (Все метки)

Добрый день!Только начинаю программировать в 1с поэтому прошу помощи более опытных людей. Управляемые формы. Имеется табличная часть в документе, хочется чтобы при выборе Грузополучателя (не входит в табличную часть документа) в табличную часть вставали данные из Константы, при каждом создании новой строки
0
Лучшие ответы (1)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
20.09.2017, 09:24
Я подобрал для вас темы с готовыми решениями и ответами на вопрос Передача значение констант в строку табличной части документа (1С):

Значение строки табличной части получить в табличной части другого документа
Есть документ ПриходнаяНакладная (товар приходит от поставщика по его цене), с...

Как запретить проведение документа, если в табличной части в поле Цена значение меньше либо равно 0?
Как сделать так, чтобы документ не проводился, если Цена <= 0? Вот мои...

Из одного документа получить данные табличной части другого документа
Добрый день. Сразу оговорюсь 1С только начал изучать, поэтому просьба...

Автоматическое заполнение табличной части документа при изменении реквизита этого документа
Здравствуйте. Делаю свою конфу на 1с 8.3.5. Добавил справочник "Сотрудники" и...

Автозаполнение табличной части документа
Здравствуйте помогите пожалуйста, есть документ Заказ в котором в табличной...

Заполнение Табличной части документа
Здравствуйте! Заполняю табличную часть документа из справочника Номенклатура....

13
GreenkA
(◉‿◉)
Эксперт 1С
1964 / 1509 / 474
Регистрация: 25.06.2009
Сообщений: 5,424
20.09.2017, 10:48 #2
frodoirbit, на событие табличной части ПриНачалеРедактирования() пропишите:
1C
1
2
3
4
5
6
7
8
9
10
11
&НаКлиенте
Процедура ИмяТабличнойЧастиПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
    Если НоваяСтрока Тогда
        Элемент.ТекущиеДанные[ИмяРеквизита] = ПолучитьЗначениеКонстантыНаСервере("Грузополучатель");        
    КонецЕсли;
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция ПолучитьЗначениеКонстантыНаСервере(ИмяКонстанты)
    Возврат Константы[ИмяКонстанты].Получить();
КонецФункции
Заменить:
ИмяТабличнойЧасти - на имя своей табличной части;
ИмяРеквизита - на имя заполняемого реквизита по значению константы;
ИмяКонстанты - в коде "Грузополучатель", изменить, если есть отличия в имени.
0
frodoirbit
0 / 0 / 0
Регистрация: 27.12.2015
Сообщений: 8
20.09.2017, 12:37  [ТС] #3
GreenkA, А сможете подсказать как вытаскивать данные из РегистраСведений в котором измерение Грузополучатель и 2 ресурса, пытался сначала таким образом создать на примере в курсе чистова, но при выборе грузополучателя в форме получал "значение не является значением объектного типа". Делал событие грузополучательприизменении, добавлял новую строку и вставлял результат функции.
0
GreenkA
(◉‿◉)
Эксперт 1С
1964 / 1509 / 474
Регистрация: 25.06.2009
Сообщений: 5,424
20.09.2017, 12:51 #4
frodoirbit, выложите ваш код, а лучше - конфигурацию. Регистр периодический?
0
frodoirbit
0 / 0 / 0
Регистрация: 27.12.2015
Сообщений: 8
20.09.2017, 13:02  [ТС] #5
GreenkA, Да переодический в пределах дня
0
Вложения
Тип файла: rar 1Cv8.rar (106.7 Кб, 4 просмотров)
frodoirbit
0 / 0 / 0
Регистрация: 27.12.2015
Сообщений: 8
20.09.2017, 13:06  [ТС] #6
GreenkA, Документ реализация
0
GreenkA
(◉‿◉)
Эксперт 1С
1964 / 1509 / 474
Регистрация: 25.06.2009
Сообщений: 5,424
20.09.2017, 13:42 #7
frodoirbit, а где в реализации вы пытаетесь получить данные из регистра БелокЖирПоМолокозаводу?) Или это пока просто вопрос?
Для периодического регистра сведений используйте метод - ПолучитьПоследнее() с указанием даты отбора и значениями всех измерений регистра. В вашем случае код на сервере:
1C
1
2
3
ЗначенияРесурсов = РегистрыСведений.БелокЖирПоМолокозаводу.ПолучитьПоследнее(ДатаОтбора, Новый Структура("Грузополучатель", Грузополучатель));
ЗначениеБелка = ЗначенияРесурсов.Белок;
ЗначениеЖира = ЗначенияРесурсов.Жир;
Дата отбора - видимо, будет дата документа, Грузополучатель - реквизит документа Реализация.
0
frodoirbit
0 / 0 / 0
Регистрация: 27.12.2015
Сообщений: 8
20.09.2017, 13:56  [ТС] #8
GreenkA, Вот пытался прописать в Общем модуле.ДокументРеализация но помоему неправильно получилось поэтому все удалил
0
GreenkA
(◉‿◉)
Эксперт 1С
1964 / 1509 / 474
Регистрация: 25.06.2009
Сообщений: 5,424
20.09.2017, 14:01 #9
frodoirbit, пробуйте еще раз и показывайте.
0
frodoirbit
0 / 0 / 0
Регистрация: 27.12.2015
Сообщений: 8
20.09.2017, 14:05  [ТС] #10
GreenkA, А в форму как эти данные передать подскажите пожалуйста

Добавлено через 1 минуту
у меня вот именно в передаче показывало ошибку "что значение не является значением объектного типа"
0
GreenkA
(◉‿◉)
Эксперт 1С
1964 / 1509 / 474
Регистрация: 25.06.2009
Сообщений: 5,424
20.09.2017, 14:05 #11
frodoirbit, в какой момент вы хотите получить эти данные? В форму документа Реализация?
0
frodoirbit
0 / 0 / 0
Регистрация: 27.12.2015
Сообщений: 8
20.09.2017, 14:13  [ТС] #12
GreenkA, При выборе Грузополучателя, Данные регистра получить именно этого грузополучателя
0
GreenkA
(◉‿◉)
Эксперт 1С
1964 / 1509 / 474
Регистрация: 25.06.2009
Сообщений: 5,424
20.09.2017, 14:40 #13
Лучший ответ Сообщение было отмечено GreenkA как решение

Решение

Цитата Сообщение от frodoirbit Посмотреть сообщение
При выборе Грузополучателя
зачем? может все-таки ПриНачалеРедактирования() табличной части? Или тогда при изменении грузополучателя сделайте сохранение этих значений в переменные, чтобы потом их всегда и использовать:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
&НаКлиенте
Процедура ТоварПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
    Если НоваяСтрока Тогда
        Элемент.ТекущиеДанные.Грузополучатель = Объект.Грузополучатель;
        ЗначенияРесурсов = ПолучитьЗначенияРесурсовНаСервере(Объект.Дата, Объект.Грузополучатель);
        ЗаполнитьЗначенияСвойств(Элемент.ТекущиеДанные, ЗначенияРесурсов);
    КонецЕсли;
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция ПолучитьЗначенияРесурсовНаСервере(ДатаОтбора, Грузополучатель)
    Возврат РегистрыСведений.БелокЖирПоМолокозаводу.ПолучитьПоследнее(ДатаОтбора, Новый Структура("Грузополучатель", Грузополучатель)); 
КонецФункции
0
frodoirbit
0 / 0 / 0
Регистрация: 27.12.2015
Сообщений: 8
20.09.2017, 15:01  [ТС] #14
GreenkA, Да Вы правы, спасибо Вам большое Ольга! Голову сломал на этом месте огромное спасибо.
0
20.09.2017, 15:01
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
20.09.2017, 15:01
Привет! Вот еще темы с решениями:

Запрос к табличной части документа
Здравствуйте, есть запрос: "ВЫБРАТЬ | Док.Работники.( | Работник,...

Автозаполнение табличной части документа
Есть форма, в нем есть поле со списком где можно выбрать группу, при выборе...

Ошибка в табличной части документа
Приветствую Вас многоуважаемые форумчане:drink: После долгого отсутствия мне...

Оформление табличной части документа
Доброго времени суток Нужно по условию изменить цвет полей на красный Для...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
14
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru