Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.57/7: Рейтинг темы: голосов - 7, средняя оценка - 4.57
Владислаучык
1 / 1 / 7
Регистрация: 21.03.2013
Сообщений: 503
1

Переполнение стека встроенного языка на сервере

21.09.2017, 17:00. Просмотров 1326. Ответов 6
Метки нет (Все метки)

Добрый день, вот такая ошибка
Переполнение стека встроенного языка на сервере


1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
    ЗначениеПараметраПодразделение = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("Подразделение"));
    Если ЗначениеПараметраПодразделение <> Неопределено Тогда
        ЗначениеПараметраПодразделение.Значение = Подразделение;
        ЗначениеПараметраПодразделение.Использование = Истина;
    КонецЕсли;
    
    //ТиповыеОтчеты.ОбновитьПараметрыПериодаПоФорме(КомпоновщикНастроек, ЭтаФорма);
    табДокумент = Новый ТабличныйДокумент;
    ЭтотОбъект.СкомпоноватьРезультат(табДокумент);
    
    МакетЗаголовокПодвал = ПолучитьМакет("Макет");
    ОбластьЗаголовок = МакетЗаголовокПодвал.ПолучитьОбласть("Заголовок");
    ОбластьЗаголовок.Параметры.Организация = Справочники.Организации.НайтиПоКоду("000000001");
    ОбластьЗаголовок.Параметры.Период = ПредставлениеПериода(НачалоПериода, КонецДня(КонецПериода));
    
    ОбластьПодразделение = МакетЗаголовокПодвал.ПолучитьОбласть("Подразделение");
    ОбластьПодразделение.Параметры.Подразделение = Подразделение;
    
        
    
    ДокументРезультат.Очистить();
    ДокументРезультат.АвтоМасштаб = Истина;
    ДокументРезультат.Вывести(ОбластьЗаголовок);
      Если ЗначениеЗаполнено(Подразделение) Тогда       
        ДокументРезультат.Вывести(ОбластьПодразделение);
    КонецЕсли;          
    
    ДокументРезультат.Вывести(табДокумент);
КонецПроцедуры
Подскажите плз, в чем проблема может быть?
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
21.09.2017, 17:00
Ответы с готовыми решениями:

Созданеи элементов справочника средствами встроенного языка. 1с 8.1
Как средствами языка создать элемент справочника и заполнить его? нагуглил вот...

Как Заполнить Таб. Часть В 1с 8 При Помощи Встроенного Языка
Здравствуйте. Очень надеюсь на вашу помощь. В общем задача состоит в...

Переполнение стека
Всем привет. Помогите, пожалуйста с решением одной проблемы. Мне нужно в...

переполнение стека
Здравствуйте. Пишу пару программ, они постепенно развивались, вместе с моими...

Переполнение стека
Program kriteriy; uses crt,math; const...

6
Tklwegsd
Эксперт 1С
747 / 545 / 185
Регистрация: 24.07.2013
Сообщений: 1,899
21.09.2017, 17:05 2
При вызове метода СкомпоноватьРезультат выполняется обработчик события ПриКомпоновкеРезультата. Получается бесконечная рекурсия.
0
Владислаучык
1 / 1 / 7
Регистрация: 21.03.2013
Сообщений: 503
21.09.2017, 17:26  [ТС] 3
Tklwegsd, Так а как это обойти?
0
Tklwegsd
Эксперт 1С
747 / 545 / 185
Регистрация: 24.07.2013
Сообщений: 1,899
21.09.2017, 17:29 4
Очень просто. Не надо вызывать метод СкомпоноватьРезультат() внутри обработчика события ПриКомпоновкеРезультата.
0
Владислаучык
1 / 1 / 7
Регистрация: 21.03.2013
Сообщений: 503
21.09.2017, 17:40  [ТС] 5
Tklwegsd, Вот убрал это, и просто ничего не выводится, одна оболочка таблицы

Добавлено через 36 секунд
Tklwegsd, Хотя должно, при тех-же данных в обычной форме все выводится

Добавлено через 9 минут
ДокументРезультат - Это как я понимаю, мой Результат, который на форме создался?
0
Phil
Эксперт 1С
404 / 281 / 86
Регистрация: 28.05.2014
Сообщений: 1,134
21.09.2017, 17:50 6
Документ Результат это реквизит отчета с типом Табличный Документ
0
Владислаучык
1 / 1 / 7
Регистрация: 21.03.2013
Сообщений: 503
21.09.2017, 17:53  [ТС] 7
Да, это у уточнял.
0
21.09.2017, 17:53
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
21.09.2017, 17:53

переполнение стека!
вот кодprocedure TForm1.CheckBox7Click(Sender: TObject); begin if...

переполнение стека
Помогите довести программу до ума. Все, что я могла с ней сделать - я уже...

Переполнение стека
почему возникает переполнение стека (при вводе любого больше 1 числа)? using...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru