Форум программистов, компьютерный форум, киберфорум
Наши страницы

1С: Собственные программы

Войти
Регистрация
Восстановить пароль
 
Владислаучык
0 / 0 / 3
Регистрация: 21.03.2013
Сообщений: 426
#1

Не выводится результат ПриКомпоновкеРезультата - 1С

22.09.2017, 11:45. Просмотров 192. Ответов 1
Метки нет (Все метки)

Добрый день, такая проблема, на обычной форме, при таких-же данных есть вывод, на управляемой-же только оболочка таблицы. Что тут не правильно, помогите плз? Отчет имеет 2 макета, один СКД, один ручной.


1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
#Если Не ТолстыйКлиентОбычноеПриложение Тогда
Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
    
    ЗначениеПараметраПодразделение = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("Подразделение"));
    Если ЗначениеПараметраПодразделение <> Неопределено Тогда
        ЗначениеПараметраПодразделение.Значение = Подразделение;
        ЗначениеПараметраПодразделение.Использование = Истина;
    КонецЕсли;
    
    Параметр = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("НачалоПериода");
    Если Параметр <> Неопределено Тогда
        Параметр.Значение = НачалоДня(ЭтотОбъект.НачалоПериода);
        Параметр.Использование = Истина;
        Сообщить(Параметр.Значение);
    КонецЕсли;
    Параметр = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("КонецПериода");
    Если Параметр <> Неопределено Тогда
        Параметр.Значение = КонецДня(ЭтотОбъект.КонецПериода);
        Сообщить(Параметр.Значение);
        Параметр.Использование = Истина;
    КонецЕсли;
 
    
    //ТиповыеОтчеты.ОбновитьПараметрыПериодаПоФорме(ЭтотОбъект.КомпоновщикНастроек, ЭтотОбъект.ПолучитьФорму("ФормаОтчетаУправляемая"));
    табДокумент = Новый ТабличныйДокумент;
    //ЭтотОбъект.СкомпоноватьРезультат(табДокумент);
    
    МакетЗаголовокПодвал = ПолучитьМакет("Макет");
    ОбластьЗаголовок = МакетЗаголовокПодвал.ПолучитьОбласть("Заголовок");
    ОбластьЗаголовок.Параметры.Организация = Справочники.Организации.НайтиПоКоду("000000001");
    Сообщить(ЭтотОбъект.НачалоПериода);
    Сообщить(ЭтотОбъект.КонецПериода);
    ОбластьЗаголовок.Параметры.Период = ПредставлениеПериода(ЭтотОбъект.НачалоПериода, КонецДня(ЭтотОбъект.КонецПериода));
    
    ОбластьПодразделение = МакетЗаголовокПодвал.ПолучитьОбласть("Подразделение");
    ОбластьПодразделение.Параметры.Подразделение = Подразделение;
    
        
    
    //ДокументРезультат.Очистить();
    ДокументРезультат.АвтоМасштаб = Истина;
    ДокументРезультат.Вывести(ОбластьЗаголовок);
      Если ЗначениеЗаполнено(Подразделение) Тогда       
        ДокументРезультат.Вывести(ОбластьПодразделение);
    КонецЕсли;          
КонецПроцедуры
#КонецЕсли
Добавлено через 9 минут
Есть еще один отчет, там такая-же проблема, только макет один скд
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
Процедура УстановитьСтандартныеПараметрыСКД()
    
    //// Периоды и представление в параметры компоновки
    //Параметр = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("Период");
    //Если Параметр <> Неопределено Тогда
    //  Параметр.Значение = КонецДня(ЭтотОбъект.Период);
    //  Параметр.Использование = Истина;
    //КонецЕсли;
    //Параметр = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("парамПредставлениеПериода");
    //Если Параметр <> Неопределено Тогда
    //  Параметр.Значение = "на "+Формат(Период, "ДФ='dd MMMM yyyy'")+" г.";
    //  Параметр.Использование = Истина;
    //КонецЕсли;
    //
    //// Представление отбора в параметр компоновки
    //// выводится только используемый быстрый отбор; если есть заменяется представлением отбора
    //СтрОтбор = "";
    //ПерваяСтрокаОтбора = Истина;
    //Для Каждого ЭлОтбора Из ЭтотОбъект.КомпоновщикНастроек.Настройки.Отбор.Элементы Цикл
    //  Если ЭлОтбора.РежимОтображения = РежимОтображенияЭлементаНастройкиКомпоновкиДанных.БыстрыйДоступ И
    //      ЭлОтбора.Использование = Истина Тогда
    //      Если Не ПерваяСтрокаОтбора Тогда
    //          СтрОтбор = СтрОтбор + Символы.ПС;
    //      КонецЕсли;
    //      Если СокрЛП(ЭлОтбора.Представление) = "" Тогда
    //          СтрОтбор = СтрОтбор + ЭлОтбора.ЛевоеЗначение;
    //          Если ЭлОтбора.ВидСравнения <> ВидСравненияКомпоновкиДанных.Равно Тогда
    //              СтрОтбор = СтрОтбор+" "+Нрег(ЭлОтбора.ВидСравнения)+" ";
    //          Иначе
    //              СтрОтбор = СтрОтбор+": ";
    //          КонецЕсли;
    //          СтрОтбор = СтрОтбор + ЭлОтбора.ПравоеЗначение;
    //      Иначе // представление заполнено
    //          СтрОтбор = СтрОтбор + ЭлОтбора.Представление;
    //      КонецЕсли;
    //      ПерваяСтрокаОтбора = Ложь;
    //  КонецЕсли;
    //КонецЦикла;
    //Параметр = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("парамПредставлениеОтбора");
    //Параметр.Значение = СтрОтбор;
    //Параметр.Использование = Истина;
    //
    //// Параметры заполняемые если не изменены в сохраненных настройках
    //глТекущийПользователь = ПараметрыСеанса.ТекущийПользователь;
    //Организация = УправлениеПользователямиУП.ПолучитьЗначениеПоУмолчанию(глТекущийПользователь, "ОсновнаяОрганизация");
    //ОтветственныеЛица = РегламентированнаяОтчетность.ОтветственныеЛицаОрганизаций(Организация, Период, глТекущийПользователь.ФизЛицо);
    //
    //Параметр = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("парамОрганизация");
    //Если Параметр <> Неопределено Тогда
    //  Если СокрЛП(Параметр.Значение) = "" Тогда
    //      Параметр.Значение = Организация.НаименованиеПолное;
    //      Параметр.Использование = Истина;
    //  КонецЕсли;
    //КонецЕсли;
    //Параметр = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("парамИсполнитель");
    //Если Параметр <> Неопределено Тогда
    //  Если СокрЛП(Параметр.Значение) = "" Тогда
    //      Параметр.Значение = ОтветственныеЛица.Исполнитель;
    //      Параметр.Использование = Истина;
    //  КонецЕсли;
    //КонецЕсли;
    //Параметр = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("парамДолжностьИсполнителя");
    //Если Параметр <> Неопределено Тогда
    //  Если СокрЛП(Параметр.Значение) = "" Тогда
    //      Параметр.Значение = ОтветственныеЛица.ИсполнительДолжность;
    //      Параметр.Использование = Истина;
    //  КонецЕсли;
    //КонецЕсли;
    //Параметр = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("парамРуководитель");
    //Если Параметр <> Неопределено Тогда
    //  Если СокрЛП(Параметр.Значение) = "" Тогда
    //      Параметр.Значение = ОтветственныеЛица.Руководитель;
    //      Параметр.Использование = Истина;
    //  КонецЕсли;
    //КонецЕсли;
    //Параметр = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("парамДолжностьРуководителя");
    //Если Параметр <> Неопределено Тогда
    //  Если СокрЛП(Параметр.Значение) = "" Тогда
    //      Параметр.Значение = ОтветственныеЛица.РуководительДолжность;
    //      Параметр.Использование = Истина;
    //  КонецЕсли;
    //КонецЕсли;
    //Параметр = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("парамГлБухгалтер");
    //Если Параметр <> Неопределено Тогда
    //  Если СокрЛП(Параметр.Значение) = "" Тогда
    //      Параметр.Значение = ОтветственныеЛица.ГлавныйБухгалтер;
    //      Параметр.Использование = Истина;
    //  КонецЕсли;
    //КонецЕсли;
    //Параметр = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("парамДолжностьГлБухгалтера");
    //Если Параметр <> Неопределено Тогда
    //  Если СокрЛП(Параметр.Значение) = "" Тогда
    //      Параметр.Значение = "Главный бухгалтер";
    //      Параметр.Использование = Истина;
    //  КонецЕсли;
    //КонецЕсли;
КонецПроцедуры
 
Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
    //ДокументРезультат = ЭтотОбъект.Результ;
    //УстановитьСтандартныеПараметрыСКД();
    
    МакетШапкиПоследний = "";
    МакетТаблицыПервый = "";
    
    
    
    
    // Очистим табличный документ - результат
    ДокументРезультат.Очистить();
    // Сгенерируем макет компоновки данных при помощи компоновщика макета
    КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
    
    // В качестве схемы компоновки будет выступать схема самого отчета
    // В качестве настроек отчета - текущие настройки отчета
    // Данные расшифровки будем помещать в свойство расширения формы - ДанныеРасшифровки
    МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, КомпоновщикНастроек.Настройки, ДанныеРасшифровки);
    
    // Находим последний макет заголовка (МакетШапкиПоследний)
    // и первый кусок макета таблицы (МакетТаблицыПервый)
    
    
    СписокМакетовТаблицы = Новый СписокЗначений;
    Для Каждого Макет из МакетКомпоновки.Макеты Цикл
        ЭтоМакетШапки = Ложь;
        ЭтоМакетТаблицы = Ложь;
        Для Каждого ПараметрМакета Из Макет.Параметры Цикл
            Если ТипЗнч(ПараметрМакета) = Тип("ПараметрОбластиВыражениеКомпоновкиДанных") Тогда
                Если Найти(ПараметрМакета.Выражение, "&") > 0 Тогда
                    ЭтоМакетШапки = Истина;
                Иначе
                    ЭтоМакетТаблицы = Истина;
                КонецЕсли;
            КонецЕсли;
        КонецЦикла;
        
        
        // хз чего так сделано, если есть группировка с иерархией,  то первый макет в таблице 17 !!!! а не 14. 
        //так что такой алгоритм поиска ПЕРВОГО макета в таблице не канает
        //перепишу
        
        //Если ЭтоМакетШапки Тогда
        //  МакетШапкиПоследний = Макет.Имя;
        //Иначе
        //  Если ЭтоМакетТаблицы Тогда
        //      МакетТаблицыПервый = Макет.Имя;
        //      Прервать;
        //  КонецЕсли;
        //КонецЕсли;
        
        
        
        Если ЭтоМакетШапки Тогда
            МакетШапкиПоследний = Макет.Имя;
        Иначе
            Если ЭтоМакетТаблицы Тогда
                МакетТаблицыПервый = Макет.Имя;
                //Прервать;
                СписокМакетовТаблицы.Добавить(МакетТаблицыПервый);
            КонецЕсли;
        КонецЕсли;
 
        
        
        
    КонецЦикла;
    
    ///////////////////////////////////////////////////////////////////////////
    //Стандартный пошаговый вывод компоновки (с диска ИТС)
    //мои вставки - с коментарием //$$
    
    // Создадим и инициализируем процессор компоновки
    ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
    ПроцессорКомпоновки.Инициализировать(МакетКомпоновки, ,ДанныеРасшифровки);
 
    // Создадим и инициализируем процессор вывода результата
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
    ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
    // Обозначим начало вывода
    ПроцессорВывода.НачатьВывод();
    
    ЗаконченВыводЗаголовков = Ложь;//$$
    НеНачатВыводТабличнойЧастиОтчета = Истина;//$$
    //$$ по ходу вывода компоновки считаем:
    ШиринаТаблицыБезПодвала = 0;//$$ количество колонок в отчете (понадобится для выравнивания заголовка по центру)
    НомерСтрокиКонецШапкиОтчета = 0;//$$ (строка до заголовков таблички отчета)
    НомерСтрокиКонецШапкиТаблицы = 0;//$$ (нижняя строка заголовков таблички отчета)
    
    // Основной цикл вывода отчета
    Пока Истина Цикл
        #Если Клиент тогда
        ОбработкаПрерыванияПользователя();
        #КонецЕсли
        
        // Получим следующий элемент результата компоновки
        ЭлементРезультата = ПроцессорКомпоновки.Следующий();
        Если ЭлементРезультата = Неопределено Тогда
            // Следующий элемент не получен - заканчиваем цикл вывода
            Прервать;
        Иначе
            Если НеНачатВыводТабличнойЧастиОтчета Тогда
                //$$ по ходу вывода находится конец шапки, начало таблицы, ширину таблицу до подвала
                //Если ЭлементРезультата.Макет = МакетТаблицыПервый   Тогда
                
                Если  СписокМакетовТаблицы.НайтиПоЗначению(ЭлементРезультата.Макет) <> Неопределено Тогда
                    НомерСтрокиКонецШапкиТаблицы = ДокументРезультат.ВысотаТаблицы;
                    ЗаконченВыводЗаголовков = Истина;
                КонецЕсли;
                Если ЗаконченВыводЗаголовков И ДокументРезультат.ВысотаТаблицы > НомерСтрокиКонецШапкиТаблицы Тогда
                    НеНачатВыводТабличнойЧастиОтчета = Ложь;
                    ШиринаТаблицыБезПодвала = ДокументРезультат.ШиринаТаблицы;
                КонецЕсли;
                
                // Элемент получен - выведем его при помощи процессора вывода
                ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);
                
                //$$ Весь заголовок объединяется в группу (для сворачивания)
                Если ДокументРезультат.ВысотаТаблицы = 1 И МакетШапкиПоследний <> "" Тогда
                    ДокументРезультат.НачатьГруппуСтрок();
                КонецЕсли;
                Если (ЭлементРезультата.Макет = МакетШапкиПоследний) И МакетШапкиПоследний <> "" Тогда
                    НомерСтрокиКонецШапкиОтчета = ДокументРезультат.ВысотаТаблицы;
                    ДокументРезультат.ЗакончитьГруппуСтрок();
                КонецЕсли;
            Иначе
                // Элемент получен - выведем его при помощи процессора вывода
                ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
    
    // Обозначем завершение вывода
    ПроцессорВывода.ЗакончитьВывод();
    //
    ///////////////////////////////////////////////////////////////////////////
    
    // имеется ширина таблицы (в колонках) считается ширина в символах (но не менее 30 если слишком узко)
    // нужно для выравнивания заголовков по центру, правому краю
    ОбщаяШиринаМакета = 0;
    Для ААА = 1 По ШиринаТаблицыБезПодвала Цикл
        Ячейка = ДокументРезультат.Область("R"+НомерСтрокиКонецШапкиТаблицы+"C"+ААА); 
        ОбщаяШиринаМакета = ОбщаяШиринаМакета + Ячейка.ШиринаКолонки;
    КонецЦикла;
    ОбщаяШиринаМакета = Макс(30, ОбщаяШиринаМакета);
    
    // перебирается построчно заголовок отчета:
    // заполненные строки - выравниваются
    // пустые строки - удаляются
    КоличествоУдаленныхСтрок = 0;
    ААА = НомерСтрокиКонецШапкиОтчета;
    Пока ААА > 0 Цикл
        ОбластьЗаголовок = ДокументРезультат.Область("R"+ААА+"C1");
        ОбластьЗаголовокПравый = ДокументРезультат.Область("R"+ААА+"C2");
        Если СокрЛП(ОбластьЗаголовок.Текст) <> "" Тогда
            ОбластьЗаголовок.ШиринаКолонки = ОбщаяШиринаМакета;
        ИначеЕсли СокрЛП(ОбластьЗаголовокПравый.Текст) <> "" Тогда
            ОбластьЗаголовок.ШиринаКолонки = ОбщаяШиринаМакета - ОбластьЗаголовокПравый.ШиринаКолонки;
        Иначе
            Если ААА <> 1 Тогда
                ОбластьПустаяСтрока = ДокументРезультат.Область("R"+ААА);
                ДокументРезультат.УдалитьОбласть(ОбластьПустаяСтрока, ТипСмещенияТабличногоДокумента.ПоВертикали);
                КоличествоУдаленныхСтрок = КоличествоУдаленныхСтрок + 1;
            КонецЕсли;
        КонецЕсли;
        ААА = ААА - 1;
    КонецЦикла;
    
    // повтор шапки таблицы при печати; фиксация строк; если заполнен параметр в компоновке - фиксация колонок
    ОбластьШапкаТаблицы = ДокументРезультат.Область(НомерСтрокиКонецШапкиОтчета - КоличествоУдаленныхСтрок + 1, ,НомерСтрокиКонецШапкиТаблицы - КоличествоУдаленныхСтрок, );
        ДокументРезультат.ПовторятьПриПечатиСтроки = ОбластьШапкаТаблицы;
    ДокументРезультат.ФиксацияСверху = НомерСтрокиКонецШапкиТаблицы - КоличествоУдаленныхСтрок;
    Параметр = КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("парамФиксКолонки");
    Если Параметр <> Неопределено Тогда
        Если Параметр.Использование И Параметр.Значение > 0 Тогда
            ДокументРезультат.ФиксацияСлева = Параметр.Значение;
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры
 
Если СохраненнаяНастройка = Неопределено Тогда
    СохраненнаяНастройка =  Справочники.СохраненныеНастройки.ПустаяСсылка();
КонецЕсли;
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
22.09.2017, 11:45
Здравствуйте! Я подобрал для вас темы с ответами на вопрос Не выводится результат ПриКомпоновкеРезультата (1С):

СКД не выводится результат - 1С
Добрый день. Проблема с СКД. Есть запрос, в консоле запросов результат выводится то, что нужно. В СКД данные по новым контрагентам не...

Результат выводится в поле но не выводится в span - jQuery
&lt;div class=&quot;hot_predlojenia&quot;&gt; &lt;input type=&quot;checkbox&quot; name=&quot;hot_home_page&quot; id=&quot;hot_home_page&quot; value=&quot;a&quot; onclick=&quot;showMe(this)&quot;&gt; &lt;label...

Не выводится результат - Matlab
Ребят, подскажите в чем проблема, не как не могу разобраться. &gt;&gt; x=0.0 : 0.001 : 1.0; &gt;&gt; y=x+log(x)-0.5; &gt;&gt;...

Не выводится результат - C++
Мне нужно написать программу по определению приналежности точки к определённой области на C++. Я написала код, когда выполняется...

Не выводится результат - PHP
Такая вот ситуация, начал изучать php. Ну и самый первый урок это вывести HELLO WORLD. Вроде бы всё просто, но почему после словосочетания...

не выводится результат - C#
записан код: double q; double s; double q1; double n; string q2; ...

1
Владислаучык
0 / 0 / 3
Регистрация: 21.03.2013
Сообщений: 426
22.09.2017, 14:24  [ТС] #2
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
СтандартнаяОбработка = Ложь;
 
 МакетДопОформление = ЭтотОбъект.ПолучитьМакет("Макет"); 
 
 // Шапка.
 ШапкаОтчета = МакетДопОформление.ПолучитьОбласть("Заголовок"); 
 ДокументРезультат.Вывести(ШапкаОтчета);
 
ЭтотОбъект.КомпоновщикНастроек.ЗагрузитьНастройки(ЭтотОбъект.СхемаКомпоновкиДанных.НастройкиПоУмолчанию);
 
    ЗначениеПараметраПодразделение = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("Подразделение"));
    Если ЗначениеПараметраПодразделение <> Неопределено Тогда
        ЗначениеПараметраПодразделение.Значение = Подразделение;
        ЗначениеПараметраПодразделение.Использование = Истина;
    КонецЕсли;
    
    Параметр = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("НачалоПериода");
    Если Параметр <> Неопределено Тогда
        Параметр.Значение = НачалоДня(ЭтотОбъект.НачалоПериода);
        Параметр.Использование = Истина;
        Сообщить(Параметр.Значение);
    КонецЕсли;
    Параметр = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("КонецПериода");
    Если Параметр <> Неопределено Тогда
        Параметр.Значение = КонецДня(ЭтотОбъект.КонецПериода);
        Сообщить(Параметр.Значение);
        Параметр.Использование = Истина;
    КонецЕсли;
 
 
 //ЭтотОбъект.КомпоновщикНастроек.ЗагрузитьНастройки(НастройкиОтчета);
 
 // СКД.
 КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
 МакетКомпоновки = КомпоновщикМакета.Выполнить(
  ЭтотОбъект.СхемаКомпоновкиДанных,
  ЭтотОбъект.КомпоновщикНастроек.ПолучитьНастройки(),
  ДанныеРасшифровки);
 
 ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
 ПроцессорКомпоновки.Инициализировать(МакетКомпоновки, , ДанныеРасшифровки, Истина);
 
 ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
 ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
 ПроцессорВывода.Вывести(ПроцессорКомпоновки);
 
 // Подвал.
 ПодвалОтчета = МакетДопОформление.ПолучитьОбласть("Подразделение"); 
 ДокументРезультат.Вывести(ПодвалОтчета);
- Чуть по другому попробовал, но ничего
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
22.09.2017, 14:24
Привет! Вот еще темы с ответами:

Не выводится результат! - C#
Добрый вечер Всем! Подскажите пожалуйста &quot;начинающему&quot; что ни так в коде ... Преподаватель поставил простую задачку слепить программку,в...

Не выводится результат - Objective-C
Здравствуйте! Только начал изучать язык(перешел с C++) и столкнулся с проблемой: в консоль не выводится сумма двух чисел ...

Не выводится результат на label - C#
Здравствуйте! Программа расчёта стоимости бензина при прохождении определённого пути. Цену на бензин пользователь указывает сам. В label1...

Не выводится результат на экран - Visual C++
Арифметические команды. Составить программу, при помощи которой можно вычислить значение выражения y = 3x + 9, причем значения ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.