Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.75/4: Рейтинг темы: голосов - 4, средняя оценка - 4.75
Дарья20
0 / 0 / 0
Регистрация: 05.08.2017
Сообщений: 8
1

Подключение защиты на печатную форму

24.09.2017, 21:46. Просмотров 771. Ответов 5
Метки нет (Все метки)

Как мне поключить защиту и только просмотр печатной формы ? помогите пожалуйста

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
&НаКлиенте
Процедура Печать(Команда)
    СформироватьМакет(Объект.Ссылка).Показать();
 
 
 
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция СформироватьМакет(Ссылка)
    
Макет = Документы.ПлатежноеПоручение.ПолучитьМакет("ПечатнаяФорма");
ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
ОбластьДанные = Макет.ПолучитьОбласть("ОбластьДанных");
ОбластьПодпись = Макет.ПолучитьОбласть("Подпись"); 
ТабДок = Новый ТабличныйДокумент;
 
ОбластьШапка.Параметры.Дата = Ссылка.Дата;
ОбластьШапка.Параметры.Номер = Ссылка.Номер;
ОбластьДанные.Параметры.Плательщик = Ссылка.Плательщик;
ОбластьДанные.Параметры.ПлательщикКод = Ссылка.Плательщик.Код;
ОбластьДанные.Параметры.БанкСсылкаКод = Ссылка.Банк.Код;
ОбластьДанные.Параметры.БанкСсылкаДебитСчет = Ссылка.Банк.ДебитСчет;
ОбластьДанные.Параметры.БанкСсылкаКредитСчет = Ссылка.Банк.КредитСчет;
ОбластьДанные.Параметры.НазначениеПлатежаСчетКод = Ссылка.НазначениеПлатежа.СчетКод;
ОбластьДанные.Параметры.Текст = Ссылка.Текст;
ОбластьДанные.Параметры.Сумма = Ссылка.Сумма;
ОбластьДанные.Параметры.СуммаСловами = Ссылка.СуммаСловами;
 
ТабДок.Вывести(ОбластьШапка);
ТабДок.Вывести(ОбластьДанные);
ТабДок.Вывести(ОбластьПодпись);
 
Возврат ТабДок;
КонецФункции
0
Лучшие ответы (1)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
24.09.2017, 21:46
Ответы с готовыми решениями:

Сформировать печатную форму по иждевенцам
Здравствуйте. Изучаю самостоятельно 1С. Создал базу. Пытаюсь сформировать...

Вывод картинки на печатную форму
Всем привет! Я только начинаю программировать на 1С. Помогите с выводом...

Ломбард. Добавление параметра в печатную форму
Здравствуйте. Есть внешняя обработка с анкетой физического лица, которую надо...

Как повернуть печатную форму на 90 градусов
Можно ли макет выводимый на печать повернуть на 90 градусов?...заранее спасибо

Вывод в печатную форму несколько выделенных документов
Доброе время суток Уважаемые профи 1С! Ребят помогите новичку разобраться!...

5
GreenkA
Модератор
Эксперт 1С
2274 / 1679 / 501
Регистрация: 25.06.2009
Сообщений: 6,149
24.09.2017, 22:11 2
Дарья20, в свойствах табличного документа выставить Защита = Истина
0
Дарья20
0 / 0 / 0
Регистрация: 05.08.2017
Сообщений: 8
24.09.2017, 22:24  [ТС] 3
Как сократить это код помогите
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
&НаКлиенте
Процедура Печать(Команда)
    СформироватьМакет(Объект.Ссылка).Показать();
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция СформироватьМакет(Ссылка)
    
Макет = Документы.ПлатежноеПоручение.ПолучитьМакет("ПечатнаяФорма");
//Экземпляр 1
ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
ОбластьДанные = Макет.ПолучитьОбласть("ОбластьДанных");
ОбластьПодпись = Макет.ПолучитьОбласть("Подпись"); 
//Экземпляр 2
ОбластьШапка1 = Макет.ПолучитьОбласть("Шапка1");
ОбластьДанные1 = Макет.ПолучитьОбласть("ОбластьДанных1");
ОбластьПодпись1 = Макет.ПолучитьОбласть("Подпись1"); 
//Экземпляр 3
ОбластьШапка2 = Макет.ПолучитьОбласть("Шапка2");
ОбластьДанные2 = Макет.ПолучитьОбласть("ОбластьДанных2");
ОбластьПодпись2 = Макет.ПолучитьОбласть("Подпись2"); 
 
ТабДок = Новый ТабличныйДокумент;
//Экземпляр 1
ОбластьШапка.Параметры.Дата = Ссылка.Дата;
ОбластьШапка.Параметры.Номер = Ссылка.Номер;
ОбластьДанные.Параметры.Плательщик = Ссылка.Плательщик;
ОбластьДанные.Параметры.ПлательщикКод = Ссылка.Плательщик.Код;
ОбластьДанные.Параметры.БанкСсылкаКод = Ссылка.Банк.Код;
ОбластьДанные.Параметры.БанкСсылкаДебитСчет = Ссылка.Банк.ДебитСчет;
ОбластьДанные.Параметры.БанкСсылкаКредитСчет = Ссылка.Банк.КредитСчет;
ОбластьДанные.Параметры.НазначениеПлатежаСчетКод = Ссылка.НазначениеПлатежа.СчетКод;
ОбластьДанные.Параметры.Текст = Ссылка.Текст;
ОбластьДанные.Параметры.Сумма = Ссылка.Сумма;
ОбластьДанные.Параметры.СуммаСловами = Ссылка.СуммаСловами;
 
//Экземпляр 2
ОбластьШапка1.Параметры.Дата = Ссылка.Дата;
ОбластьШапка1.Параметры.Номер = Ссылка.Номер;
ОбластьДанные1.Параметры.Плательщик = Ссылка.Плательщик;
ОбластьДанные1.Параметры.ПлательщикКод = Ссылка.Плательщик.Код;
ОбластьДанные1.Параметры.БанкСсылкаКод = Ссылка.Банк.Код;
ОбластьДанные1.Параметры.БанкСсылкаДебитСчет = Ссылка.Банк.ДебитСчет;
ОбластьДанные1.Параметры.БанкСсылкаКредитСчет = Ссылка.Банк.КредитСчет;
ОбластьДанные1.Параметры.НазначениеПлатежаСчетКод = Ссылка.НазначениеПлатежа.СчетКод;
ОбластьДанные1.Параметры.Текст = Ссылка.Текст;
ОбластьДанные1.Параметры.Сумма = Ссылка.Сумма;
ОбластьДанные1.Параметры.СуммаСловами = Ссылка.СуммаСловами;
 
//Экземпляр 3
ОбластьШапка2.Параметры.Дата = Ссылка.Дата;
ОбластьШапка2.Параметры.Номер = Ссылка.Номер;
ОбластьДанные2.Параметры.Плательщик = Ссылка.Плательщик;
ОбластьДанные2.Параметры.ПлательщикКод = Ссылка.Плательщик.Код;
ОбластьДанные2.Параметры.БанкСсылкаКод = Ссылка.Банк.Код;
ОбластьДанные2.Параметры.БанкСсылкаДебитСчет = Ссылка.Банк.ДебитСчет;
ОбластьДанные2.Параметры.БанкСсылкаКредитСчет = Ссылка.Банк.КредитСчет;
ОбластьДанные2.Параметры.НазначениеПлатежаСчетКод = Ссылка.НазначениеПлатежа.СчетКод;
ОбластьДанные2.Параметры.Текст = Ссылка.Текст;
ОбластьДанные2.Параметры.Сумма = Ссылка.Сумма;
ОбластьДанные2.Параметры.СуммаСловами = Ссылка.СуммаСловами;
 
//Экземпляр 1
ТабДок.Вывести(ОбластьШапка);
ТабДок.Вывести(ОбластьДанные);
ТабДок.Вывести(ОбластьПодпись);
//Экземпляр 2
ТабДок.Вывести(ОбластьШапка1);
ТабДок.Вывести(ОбластьДанные1);
ТабДок.Вывести(ОбластьПодпись1);
//Экземпляр 3
ТабДок.Вывести(ОбластьШапка2);
ТабДок.Вывести(ОбластьДанные2);
ТабДок.Вывести(ОбластьПодпись2);
 
ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Истина;
ТабДок.ТолькоПросмотр = Истина;
ТабДок.ОтображатьЗаголовки = Ложь;
 
Возврат ТабДок;
КонецФункции
0
GreenkA
Модератор
Эксперт 1С
2274 / 1679 / 501
Регистрация: 25.06.2009
Сообщений: 6,149
24.09.2017, 22:27 4
Дарья20, покажите ваш макет, насколько отличны области шапок(1-3) и данных.

Добавлено через 1 минуту

Не по теме:

кто такой 'дебИт'?:D ни один бух вам это не простит, исправляйте)

0
Дарья20
0 / 0 / 0
Регистрация: 05.08.2017
Сообщений: 8
24.09.2017, 22:31  [ТС] 5
Три Экземпляра, одинаковой формы и одинаковыми данными
0
Миниатюры
Подключение защиты на печатную форму   Подключение защиты на печатную форму  
GreenkA
Модератор
Эксперт 1С
2274 / 1679 / 501
Регистрация: 25.06.2009
Сообщений: 6,149
24.09.2017, 22:43 6
Лучший ответ Сообщение было отмечено Дарья20 как решение

Решение

Дарья20, укажите где-нибудь количество экземпляров и печатайте циклом без лишних областей и их заполнения. Можно даже в параметрах печати руками вбить)
0
24.09.2017, 22:43
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
24.09.2017, 22:43

Обращение к реквизиту формы документа через внешнюю печатную форму.
Здравствуйте Есть внешняя печатная форма и документ "Договор". У документа...

Добавить печатную форму 1С v8
Необходимо Документы - Ведомость в кассу добавить печатную форму 0504403. Зашел...

Выбрать печатную форму
У клиентов свои печатные формы актов, поэтому чтобы не делать кучу печатных...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru