Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Андрей Малютин
0 / 0 / 0
Регистрация: 15.05.2015
Сообщений: 16
1

SMS-информирование. Ошибка: "Тип не определен"

30.09.2017, 21:55. Просмотров 367. Ответов 5
Метки нет (Все метки)

1С выдает следующую ошибку:

"{Документ.Заказ.Форма.ФормаДокумента.Форма(110,21)}: Тип не определен (SMSСообщение)
Сообщение = Новый <<?>>SMSСообщение();".

Как исправить - не знаю.

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
&НаКлиенте
Процедура ОтправитьСМС(Команда)
    Если ЗначениеЗаполнено(Объект.Клиент) Тогда
    Телефон = ПолучитьТелефон(Объект.Клиент);
    Если ЗначениеЗаполнено(Телефон) Тогда
        Сообщение = Новый SMSСообщение();
        Сообщение.Получатели.Добавить(Телефон);
        #Если МобильноеПриложениеКлиент Тогда
        СредстваТелефонии.ПослатьSMS(Сообщение, Истина);
        #КонецЕсли      
    Иначе
        Сообщение = Новый СообщениеПользователю();
        Сообщение.Текст = "Не указан телефон клиента";
        Сообщение.Поле = "Объект.Клиент";
        Сообщение.Сообщить();
    КонецЕсли
    Иначе
        Сообщение = Новый СообщениеПользователю();
        Сообщение.Текст = "Клиент не выбран!";
        Сообщение.Поле = "Объект.Клиент";
        Сообщение.Сообщить();
    КонецЕсли
КонецПроцедуры
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
30.09.2017, 21:55
Ответы с готовыми решениями:

Из обычного приложения в управляемое: ошибка Тип не определен - ДиалогВыбораФайла
Здравствуйте, переделываю конфигурацию на упф, столкнулся с проблемой. Был следующий рабочий...

1С 8.3 Розница 2.1.4.9 "Текущая цена розницы" и "Остаток" в форме элемента "Номенклатура"
Есть ли готовое решение, можно через внешнюю форму нужно контроль &quot;Текущая цена розницы&quot; и...

1С 8.2 Розница - "Текущая цена розницы", "Остаток" в форме элемента "Номенклатура"
Всем добрый день! Нужна помощь. В Форму элемента &quot;Номенклатура&quot; нужно добавить два поля с выводом...

Как программно добавить таблицу значений (тип "ДанныеФормыКоллекция") на форму
Подскажите позжайлуста в чем ошибка?:wall: &amp;НаСервере Процедура ДобавитьТаблицуНаСервере() ...

Тип "Дата" - математические операции и преобразования
Доброго! Подскажите пожалуйста как правильно работать с датами, на следующем примере. К примеру...

5
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,781
01.10.2017, 11:51 2
Андрей Малютин, из СП:
SMSСообщение (SMSMessage)
Свойства:
Вложения (Attachments)
ДатаПолучения (DateReceived)
Отправитель (From)
Получатели (To)
Текст (Text)

Конструкторы:
По умолчанию

Описание:
Содержит SMS-сообщение.

Доступность:
Мобильное приложение(клиент), мобильное приложение(сервер).
1C
1
2
3
4
5
        #Если МобильноеПриложениеКлиент Тогда
        Сообщение = Новый SMSСообщение();
        Сообщение.Получатели.Добавить(Телефон);
        СредстваТелефонии.ПослатьSMS(Сообщение, Истина);
        #КонецЕсли
0
Dethmontt
Модератор
Эксперт 1С
2644 / 2436 / 416
Регистрация: 10.03.2011
Сообщений: 8,701
Записей в блоге: 1
Завершенные тесты: 1
05.10.2017, 12:27 3
1C
1
2
3
4
5
6
 #Если МобильноеПриложениеКлиент Тогда
Сообщение = Новый SMSСообщение();
        Сообщение.Получатели.Добавить(Телефон);
       
        СредстваТелефонии.ПослатьSMS(Сообщение, Истина);
#КонецЕсли
0
GreenkA
05.10.2017, 12:30
  #4

Не по теме:

Dethmontt, это фишка типа: найди три отличия в коде?:)

0
Dethmontt
05.10.2017, 12:41
  #5

Не по теме:

GreenkA, не заметил )))

У меня пробелы круче!!!

0
GreenkA
05.10.2017, 12:45     1C 8.x SMS-информирование. Ошибка: "Тип не определен"
  #6

Не по теме:

Dethmontt, да ты сам круче, я ж не спорю:D:friends:

0
05.10.2017, 12:45
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
05.10.2017, 12:45
Привет! Вот еще темы с ответами:

Ошибка Ошибка при вызове метода контекста (Выполнить) Ожидается выражение "ВЫБРАТЬ"
Выдает ошибку. Была пропущена точка. Исправила. Выдавал другую ошибку теперь опять эту. ...

Работа с запросом и ошибка "Ошибка при вызове метода контекста (Выполнить)"
Подскажите почему вылезает ошибка {Форма.ФормаОтчета.Форма(52)}: Ошибка при вызове метода...

Для заданого 0<=n<=200.Расматриваемого как возраст человека,вывести фразу вида: "Мне 21 год", "Мне 32 года", "мне 12 лет".
МОЙ ВОЗРАСТ. Для заданого 0&lt;=n&lt;=200.Расматриваемого как возраст человека,вывести фразу вида: &quot;Мне...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru