Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
partners008
0 / 0 / 0
Регистрация: 01.02.2018
Сообщений: 2
#1

Двойное сообщение - 1С/1C 8.x

01.02.2018, 20:58. Просмотров 112. Ответов 2
Метки нет (Все метки)

Доброго времени суток всем.

Я только учусь программированию 1с 8.3 УФ, потому прошу быть терпеливыми.

Подскажите почему после этих процедур выдает сообщение с поисковыми позициями номенклатуры и пустую строку?

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
&НаСервере
Функция ПоискНаСервере(Арт, Фирм)
    Выборка = Справочники.Номенклатура.Выбрать();
    Пока Выборка.Следующий() Цикл
        Если Выборка.Артикул = Арт И Выборка.ФирмаПроизводитель = Фирм Тогда
            Сообщить(Выборка.Артикул + " " + Выборка.ФирмаПроизводитель + " " + Выборка.Наименование);
        КонецЕсли;  
    КонецЦикла;
КонецФункции
 
&НаКлиенте
Процедура Поиск(Команда)
    Арт = Объект.ИскомоеЗначение;
    Фирм = Объект.ФирмаПроизводитель;
    Сообщить(ПоискНаСервере(Арт, Фирм));    
КонецПроцедуры
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
01.02.2018, 20:58
Я подобрал для вас темы с готовыми решениями и ответами на вопрос 1C 8.x Двойное сообщение (1С):

1c77 двойное упорядочивание в запросе
Можно ли, если да, то какими средствами обеспечить в запросе упорядочивание...

Двойное произведение
Доброго времени суток! У меня тут вот такое задание есть:...

Двойное условие
Добрый день. Как-то давно мечтал на JS писать условия так: 1)if (variable ==...

Двойное условие в while
Цикл do..while как сделать так чтоб работало двойное условие? пытался записать...

двойное действые
Как сделать так чтоб окно которое выводится на экран не двигалось при кнопке...

Двойное деление
Кто-нибудь может помочь рядовому студенту с двойным делением? Вот данные:...

2
Yulunga
302 / 205 / 62
Регистрация: 22.04.2013
Сообщений: 1,194
Завершенные тесты: 1
01.02.2018, 21:32 #2
по
1C
1
Сообщить(Выборка.Артикул + " " + Выборка.ФирмаПроизводитель + " " + Выборка.Наименование);
выводится то, что ищешь
по
1C
1
Сообщить(ПоискНаСервере(Арт, Фирм));
выводит то, что возвращает функция поискНаСервере. а что она возвращает? правильно, ничего не возвращает. не написано в ней "Возврат чтонибудь;"
поэтому и выводится ( вообще говоря выводится "Неопределено" )
1
partners008
0 / 0 / 0
Регистрация: 01.02.2018
Сообщений: 2
01.02.2018, 21:38  [ТС] #3
Дико извиняюсь все просмотрел, видно очевидное и незаметил.
Спасибо!
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
01.02.2018, 21:38
Привет! Вот еще темы с решениями:

Двойное неравенство
Привет! помогите решить это уравнение, жедательно подробно -1<-x/6<1 ...

Двойное условие if
Всем доброго времени суток. Делаю дипломную, суть программы в ведении учёта ООО...

Двойное Неравенство
Прошу помочь найти ошибку в коде: #include <iostream> using namespace std;...

Двойное условие
как сделать двойное условие в уловии if ?! на пример X<100, но X>50


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru