Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
 
Рейтинг 4.60/5: Рейтинг темы: голосов - 5, средняя оценка - 4.60
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,195
#1

Колонки в макете

07.02.2018, 15:17. Просмотров 898. Ответов 27
Метки нет (Все метки)

Добрый день! Не могу понять как создать колонки с датами. Объясню что надо:
Я выбираю период с 01.02.2018 по 28.02.2018, формирую макет, в макете появилась таблица с 28 колонками, в шапке каждой колонки дата от 01.02.2018 по 28.02.2018.
В макете я в шапке колонка добавил параметр "Дата". Пытался различными способами но не могу найти нормальное объяснение. Используют Присоединить(), но как этим пользоваться не понятно.

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
    ТабДок = ЭлементыФормы.ПолеТабличногоДокумента;
    ТабДок.Очистить();
    Макет=ПолучитьМакет("Макет");
    ОбластьШапка=Макет.ПолучитьОбласть("Шапка");
    Период="за "+ПредставлениеПериода(НачалоДня(НачПериода),КонецДня(КонПериода),);
    ОбластьШапка.Параметры.Период=Период;
    ОбластьШапка.Параметры.Регион=АбонентскийУчасток;
    ТабДок.Вывести(ОбластьШапка);   
 
    ДатаТЗ=НачалоДня(НачПериода);
    Пока ДатаТЗ<=КонПериода Цикл
        ОбластьШапкаДата=Макет.ПолучитьОбласть("ШапкаДата");
        ОбластьШапкаДата.Область().Текст=ДатаТЗ;
        ОбластьШапкаДата.Область().ГоризонтальноеПоложение = ГоризонтальноеПоложение.Центр;
        ДатаТЗ=ДатаТЗ+24*60*60;
        ТабДок.Присоединить(ОбластьШапкаДата);
    КонецЦикла;
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
07.02.2018, 15:17
Ответы с готовыми решениями:

Ошибка Неверное имя колонки При добавлении колонки ТЗ
Народ, подскажите что не правильно, Выдет ошибку.Результат отчета помещаю в...

Расшифровка в макете
Есть отчет, в нем форма и макет. Макет открывается в отдельном окне, в него...

Гиперссылка на ячейку в макете
Можете показать пример как в макете нажимая на ячейку с текстом (имеет...

Ошибка в макете Документа
Здравствуйте друзья! Прошу Вас об очередной помощи. Не могу найти ошибку в...

Группировка строк в макете
Как вывести группировку, нужен именно такой пример:

27
polax
667 / 412 / 133
Регистрация: 16.01.2015
Сообщений: 1,436
26.02.2018, 20:59 #21
Ermak27, а если убрать из первого цикла?
1C
1
2
3
4
5
6
7
8
9
10
11
Для каждого Стр Из РезультатТЗ цикл
        //СтрокаДанных.Параметры.Адрес = Стр.Адрес;
      //  ТабДок.Вывести(СтрокаДанных);
        
        для Каждого Колонка из РезультатТЗ.Колонки цикл
        СтрокаДанныхДата.Параметры.Данные = Стр[Колонка.Имя];
        ТабДок.Присоединить(СтрокаДанныхДата);
        СтрокаДанных.Параметры.Адрес = Стр.Адрес;
        ТабДок.Вывести(СтрокаДанных); 
    КонецЦикла; 
    КонецЦикла;
1
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,195
27.02.2018, 09:26  [ТС] #22
polax, получилось что то не то
0
Миниатюры
Колонки в макете  
polax
667 / 412 / 133
Регистрация: 16.01.2015
Сообщений: 1,436
27.02.2018, 15:46 #23
Ermak27, Точно - не то. Не мучались бы. Ну сделайте на СКД
0
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,195
27.02.2018, 16:26  [ТС] #24
polax, давно не работал с скд, надо вспоминать
0
Dethmontt
Модератор
Эксперт 1С
2616 / 2416 / 407
Регистрация: 10.03.2011
Сообщений: 8,594
Записей в блоге: 1
Завершенные тесты: 1
28.02.2018, 02:18 #25
Ermak27, нужно вывести адрес, потом присоединять к нему значения
и т.д.

Добавлено через 3 минуты
отдельный цикл по сгруппированным адресам и поиск значений Адрес+дата
если нашли присоединяем значение, не нашли присоединяем пустую ячейку
0
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,195
28.02.2018, 08:58  [ТС] #26
Dethmontt, мне не понятно как искать значение Адрес+дата в ТабДок, там же нет колонок, как искать?
0
Dethmontt
Модератор
Эксперт 1С
2616 / 2416 / 407
Регистрация: 10.03.2011
Сообщений: 8,594
Записей в блоге: 1
Завершенные тесты: 1
01.03.2018, 01:16 #27
Цитата Сообщение от Ermak27 Посмотреть сообщение
в ТабДок
не надо искать в ТабДок, искать надо в ТЗ,
а в ТабДок выводить
0
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,195
02.03.2018, 09:55  [ТС] #28
Dethmontt, не понимаю
делаю так но какая та фигня
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
Для каждого Стр Из РезультатТЗ цикл
        СтрокаДанных.Параметры.Адрес = Стр.Адрес;
        ТабДок.Вывести(СтрокаДанных);       
    КонецЦикла; 
    
    Для каждого Стр Из РезультатТЗ цикл
    Для каждого Колонка Из РезультатТЗ.Колонки цикл
        Отбор = Новый Структура();
        Отбор.Вставить("Адрес",Стр.Адрес);
        Отбор.Вставить(Колонка.Заголовок,Колонка.Заголовок);
        Строки = РезультатТЗ.НайтиСтроки(Отбор);
        Если Строки.Количество()>0 Тогда
            
        КонецЕсли;
    КонецЦикла; 
    КонецЦикла;
0
02.03.2018, 09:55
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
02.03.2018, 09:55

Сместился текст в макете
Добрый день, собственно на макете все нормально, но вот при выводе смещается...

Заполнение таблицы в макете
Здравствуйте. В макете печатной формы есть таблица. Данные из таблицы берутся...

Вывести Итог Суммы в макете
Здравствуйте, помогите пожалуйста.1с 8.2Мне нужно чтобы при печати Итог суммы...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
28
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru