Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Ашильда
0 / 0 / 0
Регистрация: 16.06.2017
Сообщений: 10
1

Пересчет цены за все услуги при удалении строки табличной части документа.

08.04.2018, 18:38. Просмотров 269. Ответов 2
Метки нет (Все метки)

Если убрать одну услугу отсюда, то цена остается вместе с предыдущей услугой которую убрали, как можно сделать чтобы сумма тоже менялась при удалении той или иной услуги?
Код суммирования показан ниже

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
&НаКлиенте
Процедура Услуги1ЦенаУслугиПриИзменении(Элемент)
    Объект.ЦенаУслуги = Объект.Услуги1.Итог("СтоимостьУслуги");
КонецПроцедуры
 
&НаКлиенте
Процедура ВидУслугиПриИзменении(Элемент)
    Объект.Наименование = Объект.ВидУслуги  ;
КонецПроцедуры
 
 
&НаКлиенте
Процедура УслугиВидУслугиСтоимостьУслугиПриИзменении(Элемент)
    Объект.ЦенаУслуги = Объект.Услуги1.Итог("СтоимостьУслуги");
КонецПроцедуры
 
&НаКлиенте
Процедура Услуги1ВидУслугиПриИзменении(Элемент)
      СуммаУслуг =0;
         Для  Каждого  СТР ИЗ объект.Услуги1  Цикл
           Сумма = ПолучитьСуммуУслуг(Стр.ВидУслуги);
           СуммаУслуг = СуммаУслуг +Сумма  
           КонецЦикла;  
           Объект.ЦенаУслуги = СуммаУслуг;      
КонецПроцедуры
 
 
&НаСервере
Функция ПолучитьСуммуУслуг(Цслуга)
            Возврат Цслуга.СтоимостьУслуги; 
КонецФункции // ()
 
 
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка) 
     а=0;
КонецПроцедуры
0
Миниатюры
Пересчет цены за все услуги при удалении строки табличной части документа.  
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
08.04.2018, 18:38
Ответы с готовыми решениями:

Значение строки табличной части получить в табличной части другого документа
Есть документ ПриходнаяНакладная (товар приходит от поставщика по его цене), с табличной частью...

Ошибка при расчете суммы текущей строки табличной части в управляемой форме документа
Подскажите что не так ? Почему не срабатывает подсчёт? ...

Заполнение реквизита табличной части документа (строки, из справочника наименования, внутри документа)
Здравствуйте. Волею судеб нужно сваять пару документов в 1с 77. Вроде бы как все шло нормально,...

Заполнение табличной части одного документа из табличной части другого документа
Здравсвуйте. 1С 8.2. Есть документ Приход и документ Расход. Оба документа имеют табличные части -...

Заполнение табличной части одного документа из табличной части этого же документа
Здравсвуйте. 1С 8.2. Есть документ в этом документе 2 табличные части В 1 табличной части...

2
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,104
09.04.2018, 22:18 2
Цитата Сообщение от Ашильда Посмотреть сообщение
Если убрать одну услугу отсюда
Отсюда - это откуда? Сформулируйте вопрос понятней. Пока не разобраться, что вы хотите
0
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,784
10.04.2018, 23:52 3
Ашильда, опишите событие табличной части ПриОкончанииРедактирования() как пересчет цены в шапке документа:
1C
1
2
3
4
&НаКлиенте
Процедура Услуги1ПриОкончанииРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования)
    Объект.ЦенаУслуги = Объект.Услуги1.Итог("СтоимостьУслуги");
КонецПроцедуры
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
10.04.2018, 23:52

Автоматическое заполнение табличной части документа при изменении реквизита этого документа
Здравствуйте. Делаю свою конфу на 1с 8.3.5. Добавил справочник "Сотрудники" и подчиненный ему...

7.7. Скрытые строки в табличной части документа
Вот у меня заказчик что придумал : Для некоторых пользователей закрыть часть строк в ТЧ (целиком...

Цвет строки табличной части документа
Такая ситуация, я пока что новичек в этом деле вот и обращаюсь к спецам...Прошу помощи, мне нужно...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru