Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.75/4: Рейтинг темы: голосов - 4, средняя оценка - 4.75
xxx_73
1 / 4 / 1
Регистрация: 06.01.2014
Сообщений: 357
1

Как связать значение константы с реквизитом на форме

01.05.2018, 09:56. Просмотров 778. Ответов 4
Метки нет (Все метки)

Данные в реквизите не выводятся. Что я не так делаю? На форме элементу назначаю событие "ФермаСоздание"
1C
1
2
3
4
5
6
7
8
9
10
11
12
&НаСервере
Процедура ФермаСозданиеНаСервере()
    Если Объект.Ссылка.Пустая() 
        Тогда    Объект.Ферма=Константы.НазваниеФермы.Получить();
 
    КонецЕсли;
КонецПроцедуры
 
&НаКлиенте
Процедура ФермаСоздание(Элемент, СтандартнаяОбработка)
    ФермаСозданиеНаСервере();
КонецПроцедуры
0
Лучшие ответы (1)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
01.05.2018, 09:56
Ответы с готовыми решениями:

Как связать значение константы с реквизитом документа?
Как связать значение константы с реквизитом документа? Есть константа...

Программно записать значение в поле формы, если оно не связано ни с одним реквизитом
Как программно записать значение в поле формы, если оно не связано ни с одним...

Работа с периодическим реквизитом
Доброе утро! Столкнулась с такой проблемой, ну просто тупик. Можно ли...

Подскажите пожалуйста с реквизитом словаря
В конфигураторе играюсь со Справочниками Нужно настроить реквизит чтоб...

Получение значений формы, не являющихся реквизитом
Здравствуйте! Ситуация: на форме содержится элемент диалога, содержащий...

4
polax
733 / 464 / 149
Регистрация: 16.01.2015
Сообщений: 1,669
01.05.2018, 12:00 2
xxx_73, По коду все верно. Предполагаю, что Объект.Ферма и Константа НазваниеФермы имеют разный тип значения
0
xxx_73
1 / 4 / 1
Регистрация: 06.01.2014
Сообщений: 357
02.05.2018, 15:53  [ТС] 3
Цитата Сообщение от polax Посмотреть сообщение
xxx_73, По коду все верно. Предполагаю, что Объект.Ферма и Константа НазваниеФермы имеют разный тип значения
Ну вот я быстренько создал пустую базу, что бы не коверкать рабочую базу. Набросал и та же ошибка. На всякий случай я выгрузку сделал. Все таки мне очень важно исправить мои пробелы.
0
Миниатюры
Как связать значение константы с реквизитом на форме  
Вложения
Тип файла: rar 1Cv8.rar (33.1 Кб, 1 просмотров)
polax
733 / 464 / 149
Регистрация: 16.01.2015
Сообщений: 1,669
02.05.2018, 16:27 4
Лучший ответ Сообщение было отмечено xxx_73 как решение

Решение

xxx_73, Все более запущено.
Вы не назначаете событие формы. Ваши процедуры просто не начинают работать, они ни откуда не вызываются. Сделайте как на картинках
Код:
1C
1
2
3
4
5
6
7
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Если Объект.Ссылка.Пустая() Тогда
Объект.Название=Константы.НазваниеЛагеря.Получить();
    
КонецЕсли;
КонецПроцедуры
1
Миниатюры
Как связать значение константы с реквизитом на форме   Как связать значение константы с реквизитом на форме  
xxx_73
1 / 4 / 1
Регистрация: 06.01.2014
Сообщений: 357
02.05.2018, 16:44  [ТС] 5
Цитата Сообщение от polax Посмотреть сообщение
xxx_73, Все более запущено.
Вы не назначаете событие формы. Ваши процедуры просто не начинают работать, они ни откуда не вызываются. Сделайте как на картинках
Код:
1C
1
2
3
4
5
6
7
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Если Объект.Ссылка.Пустая() Тогда
Объект.Название=Константы.НазваниеЛагеря.Получить();
    
КонецЕсли;
КонецПроцедуры
Ай..яй яй и то верно, запущено. Событие из формы..а я событие с элемента формы создавал. Спасибо.
0
02.05.2018, 16:44
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
02.05.2018, 16:44

Проверка значений реквизитов с другим реквизитом
Добрый вечер! Написал код на модуле объекта документа, для проверки двух...

Как связать константы с формулами?
Подскажите, пожалуйста, как привязывать разные константы к формулам и формулы...

Как связать Edit-ы на первой форме с Edit-ами на второй форме?
Как связать Editы на первой форме с Editами на второй форме ?


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru