Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/3: Рейтинг темы: голосов - 3, средняя оценка - 4.67
jediAlex
4 / 4 / 4
Регистрация: 12.07.2011
Сообщений: 519
1

Обновление ссылки на документ в реквизите справочника и заполнение реквизитов элемента справочника по новой ссылке

07.05.2018, 14:38. Просмотров 504. Ответов 2
Метки нет (Все метки)

Здравствуйте. В собственной конфигурации есть документ "Объектныйграфик" с реквизитами: ШифрОбъекта - СправочникСсылка.РегистрацияШифров;Договор - СправочникСсылка.договоры и т. д. также есть справочник -ЖурналРегистрацииГрафиков, куда записываются созданные графики. Реквизиты: Номер - число(порядковый номер графика в году - не то же самое, что стандартный номер элемента),год - число; остальные реквизиты схожи с графиком, но есть еще реквизит "График" - ДокументСсылка.ОбъектныйГрафик. В документе Объектныйграфик есть ссылка на соответствующую строку справочника: ФактРегистрации - СправочникСсылка.ЖурналРегистрацииГрафиков. Мне нужно реализовать следующее: в результате записи документа "Объектныйграфик" записать в выбранную в этом графике строку справочника записать параметры графика и в реквизит "график" ссылку на записанный документ. Делал так:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
 НаСервере
Процедура ПослеЗаписиНаСервере(ТекущийОбъект, ПараметрыЗаписи)
    
    Если  рольДоступна("Администратор") И Объект.СтатусГрафика=Перечисления.СтатусГрафика.Активный тогда
        Если ЗначениеЗаполнено(ТекущийОбъект.ФактРегистрацииГрафика) тогда
        РегГрафика=ТекущийОбъект.ФактРегистрацииГрафика.ПолучитьОбъект();
    РегГрафика.График=ТекущийОбъект.Ссылка;
    РегГрафика.НаименованиеРаботы=Объект.ШифрОбъекта.НаименованиеРабот;
//  РегГрафика.Контрагент=Объект.ШифрОбъекта.Контрагент;
    РегГрафика.ПлощадкаПроектирования=Объект.ПлощадкаПроектирования;
    РегГрафика.Договор=Объект.Договор;
    РегГрафика.Статус=Объект.СтатусГрафика;
     РегГрафика.Стадия=Объект.Стадия;
    РегГрафика.ДатаНачалаРабот=Объект.ДатаНачала;
    РегГрафика.ДатаОкончанияРабот=Объект.ДатаОкончания;
    РегГрафика.Примечание=Объект.Примечание;
    РегГрафика.ГИП=Объект.ГИП;
    РегГрафика.РПО=Объект.РуководительПроектногоОфиса;
    РегГрафика.Записать();
    конецесли; 
    КонецЕсли; 
    Если  Не рольДоступна("Администратор") тогда
    Если ЗначениеЗаполнено(ТекущийОбъект.ФактРегистрацииГрафика) тогда
    РегГрафика=ТекущийОбъект.ФактРегистрацииГрафика.ПолучитьОбъект();
    РегГрафика.График=ТекущийОбъект.Ссылка;
    РегГрафика.НаименованиеРаботы=Объект.ШифрОбъекта.НаименованиеРабот;
//  РегГрафика.Контрагент=Объект.ШифрОбъекта.Контрагент;
    РегГрафика.ПлощадкаПроектирования=Объект.ПлощадкаПроектирования;
    РегГрафика.Договор=Объект.Договор;
    РегГрафика.Статус=Объект.СтатусГрафика;
     РегГрафика.Стадия=Объект.Стадия;
    РегГрафика.ДатаНачалаРабот=Объект.ДатаНачала;
    РегГрафика.ДатаОкончанияРабот=Объект.ДатаОкончания;
    РегГрафика.Примечание=Объект.Примечание;
    РегГрафика.ГИП=Объект.ГИП;
    РегГрафика.РПО=Объект.РуководительПроектногоОфиса;
    
    РегГрафика.Записать();
Иначе
    Сообщить("Не указана ссылка на запись журнала регистрации графиков");
 
КонецЕсли;
КонецЕсли;
 
 
КонецПроцедуры
В результате ничего не происходит... данные в записи справочника не обновляются. что не так делаю? помогите пожалуйста.
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
07.05.2018, 14:38
Ответы с готовыми решениями:

Перенос реквизитов справочника в документ
Есть справочник Товары с реквизитами Автор и Журнал. Есть документ Договор с реквизитами Счет и...

Заполнение ТЧ Документа из Реквизитов справочника
нужно заполнить ТЧ документа из Реквизита справочника. &НаКлиенте Процедура...

Перенос реквизитов справочника номенклатуры в документ Поступление ТМЦ
Здравствуйте! Есть справочник "Номенклатура" с реквизитами: Код Наименование, Артикул, Есть...

Заполнение реквизитов справочника Номенклатура программно в 1С
Здравствуйте. Помогите решить задачку. Необходимо заполнить реквизит Брэнд в справочнике...

Установка реквизитов формы элемента справочника (Пл. - 7.7,Бух. - 4.5)
Необходимо программно снимать на форме элемента справочника флажок, как сделать это? Пл. - 7.7,Бух....

2
polax
1082 / 691 / 243
Регистрация: 16.01.2015
Сообщений: 2,665
08.05.2018, 15:39 2
jediAlex,
1C
1
рольДоступна("Администратор")
, такая роль существует? Не путаете с пользователем?
0
jediAlex
4 / 4 / 4
Регистрация: 12.07.2011
Сообщений: 519
10.05.2018, 13:47  [ТС] 3
нет не путаю. Так названа именно роль. Пользователя с таким именем нет.

Добавлено через 9 минут
все получилось, сам разобрался. Проблема была не в коде, а в заполнении реквизитов и соответственно в обработке условия
0
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
10.05.2018, 13:47

Заполнение справочника через документ
Есть справочник Оборудование, в нем есть реквизит Состояние, тип значения - строка. Необходимо,...

Запись элемента справочника из модуля объекта другого справочника
Добрый день. 1С:Предприятие 8.3. Управляемые формы. К внутреннему документу...

Как переносить реквизиты выбранного элемента справочника в документ
Обращаюсь к вам за помощью! Ситуация такая: есть справочник с реквизитами, также есть документ, в...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.