Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.60/5: Рейтинг темы: голосов - 5, средняя оценка - 4.60
яНачинающая
0 / 0 / 0
Регистрация: 19.04.2016
Сообщений: 15
1

Планировщик

19.05.2018, 17:31. Просмотров 1042. Ответов 1
Метки нет (Все метки)

Добрый день! Создала форму Планировщика на основе документа, но элементы планировщика почему то не выходят(. Пожалуйста подскажите, в чем ошибка, уже неделю мучаюсь((


вот текст процедуры :


1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
&НаСервере
    Процедура ЗаполнитьПланировщикНаСервере()
        
        //ИЗМЕРЕНИЯ
        ИзмерениеСотрудник = Планировщик.Измерения.Добавить("Сотрудник");
        
        
        Запрос = Новый Запрос;
        Запрос.Текст = 
        "ВЫБРАТЬ
        |   Сотрудники.Наименование КАК Наименование,
        |   Сотрудники.Ссылка КАК Ссылка,
        |   Сотрудники.Представление КАК Представление
        |ИЗ
        |   Справочник.Сотрудники КАК Сотрудники";
        
        РезультатЗапроса = Запрос.Выполнить();
        
        ВыборкаСотрудников = РезультатЗапроса.Выбрать();
        
        Пока ВыборкаСотрудников.Следующий() Цикл
            
            НовыйСотрудник = ИзмерениеСотрудник.Элементы.Добавить(ВыборкаСотрудников.Ссылка);
            НовыйСотрудник.Текст = ВыборкаСотрудников.Ссылка.Наименование;
                        
        КонецЦикла;
        
        //ЭЛЕМЕНТЫ
        
        ЭлементыПланировщика = Планировщик.Элементы;
        ЭлементыПланировщика.Очистить();
 
        
        Запрос = Новый Запрос;
        Запрос.Текст = 
        "ВЫБРАТЬ
        |   ЗаданиеНаДеньЗадание.Ссылка.Дата КАК Дата,
        |   ЗаданиеНаДеньЗадание.НомерСтроки КАК НомерСтроки,
        |   ЗаданиеНаДеньЗадание.ДатаНачала КАК ДатаНачала,
        |   ЗаданиеНаДеньЗадание.ДатаОкончания КАК ДатаОкончания,
        |   ЗаданиеНаДеньЗадание.Сотрудник КАК Сотрудник,
        |   ЗаданиеНаДеньЗадание.Проект КАК Проект,
        |   ЗаданиеНаДеньЗадание.Задача КАК Задача,
        |   ЗаданиеНаДеньЗадание.Ссылка КАК Ссылка
        |ИЗ
        |   Документ.ЗаданиеНаДень.Задание КАК ЗаданиеНаДеньЗадание";
        
        РезультатЗапроса = Запрос.Выполнить();
        
        Выборка = РезультатЗапроса.Выбрать();
        
        
        Пока Выборка.Следующий() Цикл
            
            // Связка записей с измерениями выполняется через соответствия
            Начало = НачалоДня(Выборка.Дата)+ Секунда(Выборка.ДатаНачала) ;
            Конец = НачалоДня(Выборка.Дата)+Секунда(Выборка.ДатаОкончания);
            
            Соответствия = Новый Соответствие;
            Соответствия.Вставить("Сотрудник",ВыборкаСотрудников.Ссылка);
            
            НовыйЭлемент = Планировщик.Элементы.Добавить(Начало, Конец);
            НовыйЭлемент.ЗначенияИзмерений = Новый ФиксированноеСоответствие(Соответствия);
            НовыйЭлемент.Текст = Выборка.Проект;
                                    
                    
        КонецЦикла;
        
        
        
    КонецПроцедуры
Добавлено через 1 час 36 минут
ура, до меня дошло)))
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
19.05.2018, 17:31
Ответы с готовыми решениями:

Планировщик в AD
Доброго времени суток, уважаемые участники форума. Руководство поставило задачу "бэкапить" рабочие...

Планировщик
Доброго времени суток. Не могу написать программу которая через квант времени сначала выполняла 1...

Планировщик
У нас есть: - Домен - Сервер: w2k3 sp2 В планировщике устанавливаются задачи (bat), которые...

Планировщик C#
Нужно сделать планировщик на C#. То есть такую программу, позволяющую запланировать включение той...

Планировщик заданий
Хочу написать планировщик, но немного запутался. 1) Нужно, чтобы рабочее окно было поделено на...

1
Valhalla
0 / 0 / 0
Регистрация: 15.04.2015
Сообщений: 1
29.01.2019, 23:39 2
А что в итоге было не так?
0
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
29.01.2019, 23:39

Планировщик потоков
Программная реализация простого бесприоритетного планировщика потоков. Исходные данные: -...

Планировщик заданий
ПОМОГИТЕ,ПОЖАЛУЙСТА...создать программу,которая включает службу планировщика задания"schedule" и...

Планировщик заданий
Команда создания задания: schtasks /create /S %computername% /u Alex /p 111 /RU Alex /rp 111 /sc...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.