Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
 
chyoulife
0 / 0 / 0
Регистрация: 05.06.2018
Сообщений: 30
1

Заполнение документов данными из справочника

06.06.2018, 20:46. Просмотров 360. Ответов 21
Метки нет (Все метки)

Здравствуйте! У меня есть документы ЗачислениеВКружки и ОтчислениеИзКружков. Как сделать так, чтобы отчислять можно было только тех, кто зачислен?
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
06.06.2018, 20:46
Ответы с готовыми решениями:

Заполнение документов из справочника
Здравствуйте. есть справочник "Информация" с реквизитом НомерАКБ, есть справочник "Эксплуатация",...

Заполнение документа данными из справочника
Здравствуйте! Столкнулась с проблемой. Есть Справочник "ПроизводственныйДефект" который имеет...

Заполнение табличной части документа данными из справочника
Добрый день! Очень нужна ваша помощь ! Есть справочник Должности (на каждую должность список спец...

Заполнение таблицы документа данными справочника автоматически
Здравствуйте. Делаю простую программу на 1С и столкнулся с проблемой. У меня есть...

Заполнение справочников данными из документов
Здравствуйте! Есть справочник Кружки и документ ЗачислениеВКружки. Необходимо чтобы после...

21
Tklwegsd
Эксперт 1С
762 / 556 / 189
Регистрация: 24.07.2013
Сообщений: 1,916
06.06.2018, 21:53 2
Учет должен быть организован по тем кто зачислен. Например с помощью регистра накопления.
0
chyoulife
0 / 0 / 0
Регистрация: 05.06.2018
Сообщений: 30
06.06.2018, 21:59  [ТС] 3
У меня есть такой регистр, о что дальше делать не понимаю
0
chyoulife
0 / 0 / 0
Регистрация: 05.06.2018
Сообщений: 30
13.06.2018, 19:57  [ТС] 4
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
Процедура КружокПриИзменении(Элемент)
    Если ЭтотОбъект.Кружок<>Неопределено тогда
        если ЭтотОбъект.ЭтоНовый() тогда
        Предупреждение ("Документ не записан!!! Сначала запишите");
        Возврат;
    КонецЕсли;
    
    Режим = РежимДиалогаВопрос.ДаНет;
    Ответ = Вопрос("Табличная часть будет очищена. Продолжить?" , Режим, 0);
    Если Ответ=КодВозвратаДиалога.Да тогда
        Ученики.Очистить();
        
        ЗапросУчеников = Новый Запрос(
        "ВЫБРАТЬ
        |   КружкииСрезПоследних.Ученик
        |ИЗ
        |   РегистрСведений.Кружкии.СрезПоследних(&ВыбДата, Кружок = &ВыбКружок) КАК КружкииСрезПоследних");
        ЗапросУчеников.УстановитьПараметр ("ВыбКружок", ЭтотОбъект.Кружок);
        ЗапросУчеников.УстановитьПараметр("ВыбДата", ЭтотОбъект.Дата);
        Результат = ЗапросУчеников.Выполнить().Выгрузить();
        для сч=0 по Результат.Количество()-1 Цикл
            НоваяСтрока = Ученики.Добавить();
            НоваяСтрока.ФИО = Результат[сч].Ученик;
        КонецЦикла;
    КонецЕсли;
    КонецЕсли;
КонецПроцедуры
0
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,104
13.06.2018, 22:57 5
Не принципиально в данном случае. Но лучше использовать цикл Для Каждого, работает быстрее

Добавлено через 1 минуту
chyoulife, Так что не устраивает? Что не работает?
0
chyoulife
0 / 0 / 0
Регистрация: 05.06.2018
Сообщений: 30
13.06.2018, 23:00  [ТС] 6
все равно весь список учеников открывается((
0
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,104
13.06.2018, 23:00 7
Удалили мое предыдущее сообщение, но там еще было исправление ошибки
1C
1
2
3
4
5
6
ЗапросУчеников = Новый Запрос;
ЗапросУчеников.Текст = 
        "ВЫБРАТЬ
        |   КружкииСрезПоследних.Ученик
        |ИЗ
        |   РегистрСведений.Кружкии.СрезПоследних(&ВыбДата, Кружок = &ВыбКружок) КАК КружкииСрезПоследних";
0
chyoulife
0 / 0 / 0
Регистрация: 05.06.2018
Сообщений: 30
13.06.2018, 23:02  [ТС] 8
Когда в документе Отчисление, мы выбираем кружок, в табличную часть должны выбираться только те ученики, которые уже зачислены в этот кружок
0
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,104
13.06.2018, 23:03 9
chyoulife, Значит не верные движения по регистру Кружки
0
chyoulife
0 / 0 / 0
Регистрация: 05.06.2018
Сообщений: 30
13.06.2018, 23:05  [ТС] 10
Что значит неверные? при проведении документа, записи в регистр добавляются
0
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,104
13.06.2018, 23:08 11
chyoulife, Честно говоря, проще было бы сделать группы в справочнике Кружки (с именем кружка) и перемещать учеников по группам. Тогда и отбор проще. Ну а в данном случае, проверьте в консоле что выдает запрос. Скорей всего у вас как-то не так организованы движения по этому регистру.

Добавлено через 1 минуту
chyoulife, Измерение Кружок, Ресурс Ученик?
0
chyoulife
0 / 0 / 0
Регистрация: 05.06.2018
Сообщений: 30
13.06.2018, 23:15  [ТС] 12
ну так в справочнике Кружки есть группы по названиям кружков

Добавлено через 1 минуту
у меня наоборот, измерение ученик, ресурс кружок

Добавлено через 6 минут
изменила, но всё так же осталось
0
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,104
13.06.2018, 23:17 13
Цитата Сообщение от chyoulife Посмотреть сообщение
у меня наоборот, измерение ученик, ресурс кружок
Не совсем правильно. По-простому: Измерение - какая-то постоянная (кружок не меняется) Ресурс - переменная (ученик, может мигрировать) У вас же все наоборот
0
chyoulife
0 / 0 / 0
Регистрация: 05.06.2018
Сообщений: 30
13.06.2018, 23:19  [ТС] 14
я изменила регистр,но список все равно весь выходит, он теперь говорит, что записи регистра сведений не уникальны
0
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,104
13.06.2018, 23:22 15
chyoulife, Регистр должен быть периодическим и запись движений сопровождаться записью периода

Добавлено через 30 секунд
Ученики разбросаны по группам в соответствии с кружками?
0
chyoulife
0 / 0 / 0
Регистрация: 05.06.2018
Сообщений: 30
13.06.2018, 23:25  [ТС] 16
они должны быть так разбросаны после проведения документа ЗачислениеВКружки, но это у меня еще тоже не работает, у меня вообще все плохоотчисление.rar
0
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,104
13.06.2018, 23:27 17
chyoulife, лучше dt файл. Администрирование - выгрузить инфобазу
0
chyoulife
0 / 0 / 0
Регистрация: 05.06.2018
Сообщений: 30
13.06.2018, 23:32  [ТС] 18
1Cv8.rar
0
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,104
14.06.2018, 00:04 19
chyoulife, Оф. С налету не разобрался (мало опыта с ними). надо время

Добавлено через 4 минуты
chyoulife, Запрос выдает корректные данные

Добавлено через 5 минут
И док отчисление корректно заполняет таб ученики. Все у вас верно
0
chyoulife
0 / 0 / 0
Регистрация: 05.06.2018
Сообщений: 30
14.06.2018, 00:40  [ТС] 20
в таблице ученики открывается список всех учеников, а надо только тех, кто в этом кружке
0
14.06.2018, 00:40
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
14.06.2018, 00:40

Заполнение табличной части документа данными из нескольких документов
Здравствуйте! Столкнулась с такой проблемой. Имеется 2 документа: &quot;Акт&quot; и &quot;Ведомость&quot;. Документ...

Обновление ссылки на документ в реквизите справочника и заполнение реквизитов элемента справочника по новой ссылке
Здравствуйте. В собственной конфигурации есть документ &quot;Объектныйграфик&quot; с реквизитами: ШифрОбъекта...

Автоматическое заполнение полей документа данными из справочника
Помогите пожалуйста с написанием модуля. есть справочник сотрудники с реквизитами: табельный...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
20
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru