Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/6: Рейтинг темы: голосов - 6, средняя оценка - 5.00
6elka1703
64 / 72 / 22
Регистрация: 29.10.2016
Сообщений: 773
Завершенные тесты: 4
1

Автоматическое заполнение поля Сумма в табличной части документа

18.10.2018, 15:45. Просмотров 1214. Ответов 6
Метки нет (Все метки)

Скажите можно ли сделать так чтобы когда заполняю документ Приходная накладная я записываю цену количество товара и сумму, как сделать чтобы сумма сама рассчитывалась и автоматический подставлялась в документ когда я введу цену и количество.
0
Лучшие ответы (1)
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
18.10.2018, 15:45
Ответы с готовыми решениями:

Автоматическое заполнение табличной части документа из табличной части другого
Добрый день. Совсем недавно начал изучать 1С и пока не могу найти решения собственной задачи)...

Автоматическое заполнение табличной части документа при изменении реквизита этого документа
Здравствуйте. Делаю свою конфу на 1с 8.3.5. Добавил справочник "Сотрудники" и подчиненный ему...

Автоматическое заполнение табличной части документа
В документе при выборе реквизита Услуга, должна автоматически заполняться ТЧ - поле Оборудование. ...

Автоматическое заполнение полей табличной части документа
Здравствуйте. У меня есть справочник "Номенклатура", в котором есть реквизит...

Как сделать автоматическое заполнение реквизитов табличной части документа
Приветствую! Не так давно начал знакомиться со средой 1С и столкнулся с проблемой. У меня...

6
GreenkA
Форумчанин
Эксперт 1С
2996 / 1926 / 520
Регистрация: 25.06.2009
Сообщений: 6,806
18.10.2018, 15:58 2
Лучший ответ Сообщение было отмечено 6elka1703 как решение

Решение

6elka1703, опишите события полей Цена и Количество ПриИзменении()-
как расчет суммы по текущей строке табличной части:
1C
1
2
3
4
5
6
7
8
9
10
&НаКлиенте
Процедура ИмяТабличнойЧастиЦенаПриИзменении(Элемент) //такую же процедуру для Количества
 ТекСтрока = Элементы[ИмяТабличнойЧасти].ТекущиеДанные;
 РассчитатьСуммуПоСтроке(ТекСтрока);
КонецПроцедуры
 
&НаКлиенте
Процедура РассчитатьСуммуПоСтроке(ТекСтрока)
 ТекСтрока.Сумма = ТекСтрока.Цена * ТекСтрока.Количество;
КонецПроцедуры
1
6elka1703
64 / 72 / 22
Регистрация: 29.10.2016
Сообщений: 773
Завершенные тесты: 4
18.10.2018, 16:00  [ТС] 3
GreenkA, а можно тогда сделать только для количества, цена же уже будет известна, чтобы не писать одну процедуру дважды для двух полей?
0
GreenkA
Форумчанин
Эксперт 1С
2996 / 1926 / 520
Регистрация: 25.06.2009
Сообщений: 6,806
18.10.2018, 16:03 4
6elka1703, опишите событие ПриИзменении() только для Количества
0
6elka1703
64 / 72 / 22
Регистрация: 29.10.2016
Сообщений: 773
Завершенные тесты: 4
18.10.2018, 16:07  [ТС] 5
GreenkA, Когда пишу в скобках имя табличной части пишет переменная не определена, что не так?
1C
1
2
3
4
5
&НаКлиенте
Процедура СписокНоменклатурыЦенаПриИзменении(Элемент)
     ТекСтрока = Элементы[СписокНоменклатуры].ТекущиеДанные;
 РассчитатьСуммуПоСтроке(ТекСтрока);
КонецПроцедуры
0
GreenkA
Форумчанин
Эксперт 1С
2996 / 1926 / 520
Регистрация: 25.06.2009
Сообщений: 6,806
18.10.2018, 16:09 6
6elka1703, в скобках надо писать в кавычках. Или без кавычек, но через точку:
1C
1
2
Элементы["СписокНоменклатуры"].ТекущиеДанные;
Элементы.СписокНоменклатуры.ТекущиеДанные;
0
6elka1703
64 / 72 / 22
Регистрация: 29.10.2016
Сообщений: 773
Завершенные тесты: 4
18.10.2018, 16:10  [ТС] 7
GreenkA, работает, спасибо
0
18.10.2018, 16:10
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
18.10.2018, 16:10

Программное заполнение табличной части документа из табличной части справочника
Доброго! Ситуация, поставившая меня в тупик. Имеем 1с 8.2 УФ Имеем справочник "Работ" Имеем...

Заполнение табличной части документа
Всем привет. Народ, помогите пожалуйста. Такой вопрос: создал документ, добавил туда табличную...

Заполнение Табличной части документа
Здравствуйте! Заполняю табличную часть документа из справочника Номенклатура. Нужно, чтобы при...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru