Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/3: Рейтинг темы: голосов - 3, средняя оценка - 5.00
Лютик23
1 / 1 / 0
Регистрация: 10.10.2018
Сообщений: 147
1

СКД Вывод данных по флажку

29.10.2018, 09:14. Просмотров 571. Ответов 8
Метки нет (Все метки)

Делаю внешний отчет с СКД. Надо сделать так,чтобы когда флажок алименты истина,то выводить столбец удержания. Как это можно реализовать? Помогите пожалуйста...
Конфигурация 8.3,зуп 3.1
0
Миниатюры
СКД Вывод данных по флажку  
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
29.10.2018, 09:14
Ответы с готовыми решениями:

Вывод отчета на скд
Здравствуйте. Пока сделала следующий запрос (может имеет смысл разбить на 2, не знаю, как...

Вывод отчета на скд
Есть отчет. Внешний вид: http://upload.akusherstvo.ru/image629368.jpg Настройки:...

Вывод квартала в отчете СКД
Здравствуйте. Делаю простой отчет на СКД в собственной конфигурации. Суть отчета - из регистра...

Вывод заголовков ресурсов в СКД
Здравствуйте! Формирую отчет в СКД, использую таблицу,группировки строк - номенклатура,...

Вывод месяца и года в отчете на СКД
Здравствуйте. В собственной конфигурации делаю отчет по месяцам. Вывожу его в таблицу, в названиях...

8
Xomych
838 / 640 / 108
Регистрация: 01.11.2012
Сообщений: 2,353
29.10.2018, 09:40 2
Использовать другой вариант отчета, например.
0
Лютик23
1 / 1 / 0
Регистрация: 10.10.2018
Сообщений: 147
29.10.2018, 10:02  [ТС] 3
Xomych, о,точно,а я что то не подумала. Спасибо)

Добавлено через 9 минут
Xomych, похоже так не получится,макет то у них один,на все варианты
0
Xomych
838 / 640 / 108
Регистрация: 01.11.2012
Сообщений: 2,353
29.10.2018, 11:23 4
Для другого варианта создай свой макет без удержаний
0
29.10.2018, 11:23
Лютик23
1 / 1 / 0
Регистрация: 10.10.2018
Сообщений: 147
29.10.2018, 11:29  [ТС] 5
Xomych, я так понимаю,что надо создать еще один набор данных?
0
Xomych
838 / 640 / 108
Регистрация: 01.11.2012
Сообщений: 2,353
29.10.2018, 11:33 6
Нет, не надо.

Два макета просто и 2 варианта.
Потом по галке подставляй нужный вариант.
Немного допрограммировать придётся

Добавлено через 42 секунды
А вообще, выложи скрин экрана настроек и макета
0
Лютик23
1 / 1 / 0
Регистрация: 10.10.2018
Сообщений: 147
29.10.2018, 12:54  [ТС] 7
Xomych,
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
 
 // Получаем необходимую СКД.
 НеобходимаяСКД = Неопределено;
 Если ЭтотОбъект.Алименты = Истина Тогда
  НеобходимаяСКД = ЭтотОбъект.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
 Иначе
  НеобходимаяСКД = ЭтотОбъект.ПолучитьМакет("Без_удержания");
 КонецЕсли;
 
 // Устанавливаем выбранную СКД как основную.
 ЭтотОбъект.СхемаКомпоновкиДанных = НеобходимаяСКД;
 
 // Загружаем настройки выбранной СКД в компоновщик настроек.
 ИсточникДоступныхНастроек = Новый ИсточникДоступныхНастроекКомпоновкиДанных(НеобходимаяСКД);
 ЭтотОбъект.КомпоновщикНастроек.Инициализировать(ИсточникДоступныхНастроек);
 ЭтотОбъект.КомпоновщикНастроек.ЗагрузитьНастройки(НеобходимаяСКД.НастройкиПоУмолчанию);
 
 // Устанавливаем настройки.
 ПараметрыДанных = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных;
  
КонецПроцедуры
Вот так написала в модуле,но алименты не находит(
0
Миниатюры
СКД Вывод данных по флажку   СКД Вывод данных по флажку   СКД Вывод данных по флажку  

СКД Вывод данных по флажку  
Лютик23
1 / 1 / 0
Регистрация: 10.10.2018
Сообщений: 147
29.10.2018, 16:30  [ТС] 8
Xomych,
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
&НаКлиенте
Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
 
 // Получаем необходимую СКД.
 НеобходимаяСКД = Неопределено;
 форма=ЭтотОбъект.ПолучитьФорму("ФормаОтчета");
//Алим=форма.ЭлементыФормы.Найти("Алименты");
Алим=форма.ЭлементыФормы.Алименты;
Если Алим = Истина Тогда
  НеобходимаяСКД = ЭтотОбъект.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
 Иначе
  НеобходимаяСКД = ЭтотОбъект.ПолучитьМакет("Без_удержания");
 КонецЕсли;
 
 // Устанавливаем выбранную СКД как основную.
 ЭтотОбъект.СхемаКомпоновкиДанных = НеобходимаяСКД;
 
 // Загружаем настройки выбранной СКД в компоновщик настроек.
 ИсточникДоступныхНастроек = Новый ИсточникДоступныхНастроекКомпоновкиДанных(НеобходимаяСКД);
 ЭтотОбъект.КомпоновщикНастроек.Инициализировать(ИсточникДоступныхНастроек);
 ЭтотОбъект.КомпоновщикНастроек.ЗагрузитьНастройки(НеобходимаяСКД.НастройкиПоУмолчанию);
 
 // Устанавливаем настройки.
 ПараметрыДанных = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных;
  
КонецПроцедуры
Сделала,вот так,пока что не ругается. Но теперь пишет,что СКД не выбрана. Хотя я в модуле формы прописала
1C
1
2
3
4
5
6
7
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
       ЭтаФорма.Алименты=Истина;
    //ЭтотОбъект.Алименты=Истина;
    
    
КонецПроцедуры
Добавлено через 3 часа 16 минут
Xomych, все разобралась,спасибо
0
polax
1117 / 723 / 247
Регистрация: 16.01.2015
Сообщений: 2,790
31.10.2018, 01:32 9
Лютик23, Все же есть более простое решение.
1C
1
2
3
4
5
6
Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
   
 ЭтотОбъект.КомпоновщикНастроек.Настройки.Структура[0].Выбор.Элементы[1].Использование = ЭтотОбъект.КомпоновщикНастроек.ПользовательскиеНастройки.Элементы[0].ПравоеЗначение
 //Где  Элементы[1] - ваше поле которое надо скрыть или показать (индекс, ясно, может быть любым, в зависимости от ваших настроек)
//  Элементы[0] - поле отбора, индекс также может быть любым в зависимости от ваших настроек
КонецПроцедуры
Смысл: Получаем значение отбора по нужному полю (у вас Алименты) и в зависимости от его значения устанавливаем использование нужного поля (у вас Удержания)
0
31.10.2018, 01:32
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
31.10.2018, 01:32

Вывод Отчета сформированного в СКД ландшафтом
Как можно сделать, что бы сформированный отчет выводился автоматически ландшафтном?

Отчет через СКД. Вывод итогов
Делают отчёт по таблице путевых листов. Пытаюсь просто вывести все ТС которые выезжали за...

Динамический вывод колонок в отчете СКД
Добрый день. Есть отчет, показывающий доступную номенклатуру к продаже с указанием цены и вида цен....


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.