Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
 
Рейтинг 4.60/5: Рейтинг темы: голосов - 5, средняя оценка - 4.60
jediAlex
4 / 4 / 3
Регистрация: 12.07.2011
Сообщений: 473
1

Отчет СКД: не заполняются значения параметров

12.11.2018, 10:37. Просмотров 981. Ответов 36
Метки нет (Все метки)

Здравствуйте. Делаю отчет на СКД в собственной конфигурации 1С 8.3. суть отчета: выгрузить из регистра за период количество времени, списанное сотрудниками подразделений по дням. Вот запрос:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
ВЫБРАТЬ
    Сотрудники.Наименование КАК ФамилияИмяОтчество,
    Сотрудники.Подразделение.Наименование + ЕСТЬNULL(Сотрудники.МаркерПодразделения.Наименование, "") КАК Подразделение,
    ОтработаноЧасовОстаткиИОбороты.ПериодДень КАК ДатаОтчета,
    ЕСТЬNULL(ОтработаноЧасовОстаткиИОбороты.КоличествоЧасовРасход, 0) КАК ЧасовВОтчете
ИЗ
    Справочник.Сотрудники КАК Сотрудники
        ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ОтработаноЧасов.ОстаткиИОбороты(НАЧАЛОПЕРИОДА(&НачалоПериода, ДЕНЬ), , Авто, , ) КАК ОтработаноЧасовОстаткиИОбороты
        ПО Сотрудники.Ссылка = ОтработаноЧасовОстаткиИОбороты.Сотрудник.Ссылка
ГДЕ
    Сотрудники.Статус = ЗНАЧЕНИЕ(Перечисление.СтатусСотрудника.Работает)
    И Сотрудники.Подразделение В(&МассивПодразделений)
    И ОтработаноЧасовОстаткиИОбороты.Регистратор ССЫЛКА Документ.ЕжедневныйОтчет
 
УПОРЯДОЧИТЬ ПО
    Подразделение
т.е. нужно получить информацию по всем сотрудникам из перечня подразделений и увидеть, по каким из работающих сотрудников есть списания в выбранном периоде и в какой день, а по каким - нет. Захотел присвоить значения параметров программно - чтобы их не набирать каждый раз для формирования отчета, а сразу заполнить при открытии формы. Сделал так в форме отчета:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
&НаСервере
Функция ПодразделенияДляОтчета() Экспорт
МассивПодразделений=Новый массив;
МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000001"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000003"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000004"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000005"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000006"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000007"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000008"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000009"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000010"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000011"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000012"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000013"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000020"));
Возврат МассивПодразделений;    
КонецФункции    
&НаСервере
Процедура ПриОткрытииНаСервере()
    // Вставить содержимое обработчика.
    ПараметрСКД = Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("МассивПодразделений");
   ПараметрСКД.Использование = Истина;
   ПараметрСКД.Значение  = ПодразделенияДляОтчета();
    ПараметрНачалоПериода = Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("НачалоПериода");
   ПараметрНачалоПериода.Использование = Истина;
   Если ДеньНедели(ТекущаяДата()) >1 И ДеньНедели(ТекущаяДата()) <6 тогда 
   ПараметрНачалоПериода.Значение  = Текущаядата()-86400;
иначе 
Если ДеньНедели(ТекущаяДата()) =1 тогда 
   ПараметрНачалоПериода.Значение  = Текущаядата()-3*86400;
КонецЕсли;
КонецЕсли;
 ПараметрОкончаниеПериода = Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("ОкончаниеПериода");
   ПараметрОкончаниеПериода.Использование = Истина;
   Если ДеньНедели(ТекущаяДата()) >1 И ДеньНедели(ТекущаяДата()) <6 тогда 
   ПараметрОкончаниеПериода.Значение  = Текущаядата()-86400;
иначе
Если ДеньНедели(ТекущаяДата()) =1 тогда 
   ПараметрОкончаниеПериода.Значение  = Текущаядата()-3*86400;
КонецЕсли;
КонецЕсли;
КонецПроцедуры
&НаКлиенте
Процедура ПриОткрытии(Отказ)
    ПриОткрытииНаСервере();
КонецПроцедуры
ни один из параметров в режиме предприятия не заполняется... что не так делаю? помогите пожалуйста. Параметры отчета в СКД прилагаю.
0
Миниатюры
Отчет СКД: не заполняются значения параметров  
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
12.11.2018, 10:37
Ответы с готовыми решениями:

Отчет СКД: отображение значений параметров на форме
Добрый день, устанавливаю значения параметров при открытии, но на форме колонки эти пустые,...

1с отчет СКД выбор данных в зависимости от значения логического параметра
Здравствуйте. Платформа 1С: Предприятие 8.3. Столкнулась с такой проблемой. Имеется отчет &quot;Отчет...

Обычные формы, отчет на СКД - вывод параметров на форму
Обычная форма, делаю отчет на СКД. Задаю параметры , на форме размещаю Табличное поле - В его...

Отчет СКД. Вывод нескольких таблиц в отчет из разных запросов.
Привет, коллеги! Возникла необходимость в одном отчете видеть 2 таблички: одну по продажам, другую...

Отчет СКД. Пересчет значения поля табличного документа при изменении другого поля
Народ, есть отчет без СКД, нужно разрешить ввод пользователем 5 графы отчета, и на основе...

36
polax
933 / 610 / 205
Регистрация: 16.01.2015
Сообщений: 2,154
12.11.2018, 10:59 2
jediAlex, Все это надо делать не в модуле формы и ПриОткрытии, а в модуле объекта отчета и в ПриКомпоновкиРезультата
А правильно делать - это в параметрах скд (ваш скрин) Вот там в выражениях и в доступных значениях настроить ваши значения параметров
0
1c-k
339 / 315 / 42
Регистрация: 20.08.2014
Сообщений: 1,238
Записей в блоге: 1
12.11.2018, 11:06 3
Попробуйте параметры устанавливать в модуле объекта в процедуре ПриКомпоновкеРезультата().
0
jediAlex
4 / 4 / 3
Регистрация: 12.07.2011
Сообщений: 473
12.11.2018, 12:04  [ТС] 4
сделал в модуле объекта:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
СтандартнаяОбработка=Ложь;
ПараметрСКД = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("МассивПодразделений");
   ПараметрСКД.Использование = Истина;
   ПараметрСКД.Значение  = ПодразделенияДляОтчета();
    ПараметрНачалоПериода = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("НачалоПериода");
   ПараметрНачалоПериода.Использование = Истина;
   Если ДеньНедели(ТекущаяДата()) >1 И ДеньНедели(ТекущаяДата()) <6 тогда 
   ПараметрНачалоПериода.Значение  = Текущаядата()-86400;
иначе 
Если ДеньНедели(ТекущаяДата()) =1 тогда 
   ПараметрНачалоПериода.Значение  = Текущаядата()-3*86400;
КонецЕсли;
КонецЕсли;
 ПараметрОкончаниеПериода = ЭтотОбъект.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("ОкончаниеПериода");
   ПараметрОкончаниеПериода.Использование = Истина;
   Если ДеньНедели(ТекущаяДата()) >1 И ДеньНедели(ТекущаяДата()) <6 тогда 
   ПараметрОкончаниеПериода.Значение  = Текущаядата()-86400;
иначе
Если ДеньНедели(ТекущаяДата()) =1 тогда 
   ПараметрОкончаниеПериода.Значение  = Текущаядата()-3*86400;
КонецЕсли;
КонецЕсли;
 
КонецПроцедуры
ситуация та же... параметры не заполняются. Что не так опять делаю?
0
12.11.2018, 12:04
Yulunga
393 / 284 / 72
Регистрация: 22.04.2013
Сообщений: 1,778
Записей в блоге: 1
Завершенные тесты: 1
12.11.2018, 12:29 5
а почему стандартная обработка ложь?
просто вы задаёте своих параметров или чего хотите, а уж компоновщик и прочие штуки пусть оно делает так, как ему полагается.
хотя вероятно дело не в этом
0
polax
933 / 610 / 205
Регистрация: 16.01.2015
Сообщений: 2,154
12.11.2018, 16:39 6
jediAlex Устанавливаешь Ложь стандартной обработке, а работаешь только с Компоновщиком. Ну изменил компоновщик, а где макет, где процессор вывода? У тебя ничего не выполняется без этого. И если эти параметры в скд установлены как пользовательские, то устанавливает параметры не в Настройках, а в ПользовательскиеНастройки. Ну и еще раз, как минимум параметры дат можно попробовать выставить на закладке Параметы макета скд

Добавлено через 3 часа 50 минут
Вижу сложности. Вот нашел у себя пример. Мне нужно было перенести в нестандартную обработку пользовательские настройки (параметры и отбор), с просто настройками - по аналогии.
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
 
    СтандартнаяОбработка = Ложь;
    КомпоновщикМакет = Новый КомпоновщикМакетаКомпоновкиДанных;
    ДН = КомпоновщикНастроек.ПользовательскиеНастройки.Элементы[0].Значение.ДатаНачала;
    ДО = КомпоновщикНастроек.ПользовательскиеНастройки.Элементы[0].Значение.ДатаОкончания;
    КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы[2].Значение.ДатаНачала = ДН;
    КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы[2].Значение.ДатаОкончания = ДО;
    Для каждого Эл Из КомпоновщикНастроек.Настройки.Отбор.Элементы  Цикл
        
    Поле = КомпоновщикНастроек.ПользовательскиеНастройки.Элементы.Найти(Эл.ИдентификаторПользовательскойНастройки);
    Эл.Использование =  Поле.Использование;
    Эл.ВидСравнения = Поле.ВидСравнения;
    Эл.ПравоеЗначение = Поле.ПравоеЗначение;
    Эл.ПредставлениеПользовательскойНастройки = Поле.ПредставлениеПользовательскойНастройки;
        
    КонецЦикла; 
    
    Макет = КомпоновщикМакет.Выполнить(СхемаКомпоновкиДанных, ЭтотОбъект.КомпоновщикНастроек.Настройки, ДанныеРасшифровки);
    ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
    ПроцессорКомпоновки.Инициализировать(Макет, , ДанныеРасшифровки);
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
    ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
    ПроцессорВывода.Вывести(ПроцессорКомпоновки);
    ДокументРезультат.ПоказатьУровеньГруппировокСтрок(1); // Сворачиваем группировки второго уровня вложенности
    
КонецПроцедуры
0
jediAlex
4 / 4 / 3
Регистрация: 12.07.2011
Сообщений: 473
13.11.2018, 11:51  [ТС] 7
попробовал сделать по примеру:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
СтандартнаяОбработка = Ложь;
    КомпоновщикМакет = Новый КомпоновщикМакетаКомпоновкиДанных;
     Если ДеньНедели(ТекущаяДата()) >1 И ДеньНедели(ТекущаяДата()) <6 тогда 
   ДН  = Текущаядата()-86400;
иначе 
Если ДеньНедели(ТекущаяДата()) =1 тогда 
   ДН  = Текущаядата()-3*86400;
КонецЕсли;
КонецЕсли;
Если ДеньНедели(ТекущаяДата()) >1 И ДеньНедели(ТекущаяДата()) <6 тогда 
   ДО  = Текущаядата()-86400;
иначе
Если ДеньНедели(ТекущаяДата()) =1 тогда 
   ДО  = Текущаядата()-3*86400;
КонецЕсли;
КонецЕсли;
Подраздел=ПодразделенияДляОтчета();
    //Подраздел=КомпоновщикНастроек.ПользовательскиеНастройки.Элементы[0].Значение.МассивПодразделений;
    КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы[2].Значение.ДатаНачала = ДН;
    КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы[2].Значение.ДатаОкончания = ДО;
    КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы[2].Значение.МассивСотрудников = Подраздел;
    Для каждого Эл Из КомпоновщикНастроек.Настройки.Отбор.Элементы  Цикл     
    Поле = КомпоновщикНастроек.ПользовательскиеНастройки.Элементы.Найти(Эл.ИдентификаторПользовательскойНастройки);
    Эл.Использование =  Поле.Использование;
    Эл.ВидСравнения = Поле.ВидСравнения;
    Эл.ПравоеЗначение = Поле.ПравоеЗначение;
    Эл.ПредставлениеПользовательскойНастройки = Поле.ПредставлениеПользовательскойНастройки;    
    КонецЦикла;     
    Макет = КомпоновщикМакет.Выполнить(СхемаКомпоновкиДанных, ЭтотОбъект.КомпоновщикНастроек.Настройки, ДанныеРасшифровки);
    ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
    ПроцессорКомпоновки.Инициализировать(Макет, , ДанныеРасшифровки);
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
    ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
    ПроцессорВывода.Вывести(ПроцессорКомпоновки);
    ДокументРезультат.ПоказатьУровеньГруппировокСтрок(1); // Сворачиваем группировки второго уровня вложенности
в результате параметры не заполняются все равно... что не так делаю?
0
polax
933 / 610 / 205
Регистрация: 16.01.2015
Сообщений: 2,154
13.11.2018, 12:20 8
jediAlex, Не надо просто копировать мой код. Адаптируйте его к своему. Например Параметры. У меня Меняется ОДИН параметр - Стандартный отчет (на скрине &Параметр) поэтому это ОДНА строка
1C
1
КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы[2]
у вас нет стандартного отчета, у вас ДВЕ строки поэтому уже установка всего в Элементы[2] работать не может
И потом Окончание периода что это?
В общем, установите правильно параметры в макете скд и все получится
0
Миниатюры
Отчет СКД: не заполняются значения параметров  
polax
933 / 610 / 205
Регистрация: 16.01.2015
Сообщений: 2,154
13.11.2018, 12:21 9
Куда и что ставить - пользуйтесь отладчиком и смотрите
0
jediAlex
4 / 4 / 3
Регистрация: 12.07.2011
Сообщений: 473
13.11.2018, 13:39  [ТС] 10
ни разу не делал такой вывод отчета(программно) поэтому не пойму что и как делать в данном случае...

Добавлено через 4 минуты
ОкончаниеПериода - параметр, который задается пользователем и используется для расчета конца периода. Я пробовал без этого обойтись - сразу в условии запроса писал
....
1C
1
ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ОтработаноЧасов.ОстаткиИОбороты(НАЧАЛОПЕРИОДА(&НачалоПериода, ДЕНЬ), КОНЕЦПЕРИОДА(&КонецПериода, ДЕНЬ), Авто, , ) КАК ОтработаноЧасовОстаткиИОбороты
но при этом у меня не попадал в отчет конечный день интервала.
0
polax
933 / 610 / 205
Регистрация: 16.01.2015
Сообщений: 2,154
13.11.2018, 22:05 11
jediAlex,
1C
1
Извини в 13 уехал на работу в 21 приехал, раньше никак
Вот это правильно для моего варианта, неправильно для твоего

1C
1
2
3
4
 //Подраздел=КомпоновщикНастроек.ПользовательскиеНастройки.Элементы[0].Значение.МассивПодразделений;
    КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы[2].Значение.ДатаНачала = ДН;
    КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы[2].Значение.ДатаОкончания = ДО;
    КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы[2].Значение.МассивСотрудников = Подраздел
Замени на
1C
1
2
3
4
 //Подраздел=КомпоновщикНастроек.ПользовательскиеНастройки.Элементы[0].Значение.МассивПодразделений;
    КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы[0].Значение = ДН;
    КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы[3].Значение = ДО;
    КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы[2].Значение = Подраздел
А вообще ставь точку останова и смотри значение КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы, увидишь под каким индексом что стоит
0
jediAlex
4 / 4 / 3
Регистрация: 12.07.2011
Сообщений: 473
14.11.2018, 09:37  [ТС] 12
попробовал, как вы посоветовали. Параметры дат присвоились, а массив подразделений - пустое значение... что не так с этим массивом?

Добавлено через 5 минут
ставил точку останова - при выполнении не останавливается
0
polax
933 / 610 / 205
Регистрация: 16.01.2015
Сообщений: 2,154
14.11.2018, 09:41 13
Цитата Сообщение от jediAlex Посмотреть сообщение
Подраздел=ПодразделенияДляОтчета();
Функция ПодразделенияДляОтчета() что возвращает? Проверяли? Дайте код этой функции

Добавлено через 1 минуту
Где ставили точку останова? Сначала запускаете конфигуратор, из него запускаете программу (отладку). Есть подозрение что сделали наоборот
0
jediAlex
4 / 4 / 3
Регистрация: 12.07.2011
Сообщений: 473
14.11.2018, 09:51  [ТС] 14
вот функция:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
Функция ПодразделенияДляОтчета() Экспорт
МассивПодразделений=Новый массив;
МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000001"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000001"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000003"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000004"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000005"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000006"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000007"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000008"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000009"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000010"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000011"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000012"));
        МассивПодразделений.Добавить(Справочники.Подразделения.НайтиПоКоду("000000013"));
Возврат МассивПодразделений;    
КонецФункции
точку ставлю на строке
1C
1
КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы[2].Значение = Подраздел;
ставил и на строке
1C
1
Подраздел=ПодразделенияДляОтчета();
чтоб посмотреть, что функция дает.. останова не происходит...

Добавлено через 1 минуту
код справочника - в виде строки
0
polax
933 / 610 / 205
Регистрация: 16.01.2015
Сообщений: 2,154
14.11.2018, 09:58 15
jediAlex, Раз параметры даты устанавливаются, значит код работает, отсюда - должна останавливаться по точке останова. Вариант один - не запущена отладка:
Цитата Сообщение от polax Посмотреть сообщение
Сначала запускаете конфигуратор, из него запускаете программу (отладку).
0
jediAlex
4 / 4 / 3
Регистрация: 12.07.2011
Сообщений: 473
14.11.2018, 10:26  [ТС] 16
отладка запущена
0
polax
933 / 610 / 205
Регистрация: 16.01.2015
Сообщений: 2,154
14.11.2018, 10:28 17
jediAlex, выгружайте dt. Так быстрее и проще разобраться
0
jediAlex
4 / 4 / 3
Регистрация: 12.07.2011
Сообщений: 473
14.11.2018, 10:57  [ТС] 18
выгрузил dt 17 МБ не прикрепляется...413 Request Entity Too Large
0
polax
933 / 610 / 205
Регистрация: 16.01.2015
Сообщений: 2,154
14.11.2018, 11:00 19
jediAlex, Его надо загрузить на любой файлообменник и ссылку с файлообменника выложить сюда

Добавлено через 44 секунды
Например сюда
0
jediAlex
4 / 4 / 3
Регистрация: 12.07.2011
Сообщений: 473
14.11.2018, 18:06  [ТС] 20
вот ссылка на ИБ данные правлда там до апреля 2018 г - более новую не мог даже по почте отправить себе с рабочего места из-за массы ограничений. На файлообменники вообще не могу заходить. Юзер -Админ без пароля. См отчет "НаличиОтчетовСотрудников"

Добавлено через 16 секунд
https://my-files.ru/z56the
0
14.11.2018, 18:06
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
14.11.2018, 18:06

Отчет в СКД
Господа, подскажите как в СКД можно решить данную проблему: нужно вывести оганизации в 2...

Отчет СКД
Создала внешний отчет с помощью СКД. Результат вывожу на форму в Поле табличного документа. Ка мне...

Отчет в СКД
Здравствуйте.У меня отчет вида как на рисунке 1,подскажите пожалуйста, как в СКД преобразовать...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
20
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru