Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
ЗахарКомардин
0 / 0 / 0
Регистрация: 01.10.2018
Сообщений: 97
1

Ввод на основании

14.12.2018, 08:51. Просмотров 362. Ответов 8
Метки нет (Все метки)

Что я сделал не так что не устанавливается количество в тч списание товаров?


1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)
    //{{__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.Калькуляция") Тогда
        // Заполнение шапки
        Для Каждого ТекСтрокаЗаказ Из ДанныеЗаполнения.Заказ Цикл
            НоваяСтрока = ВыпускаемаяПродукция.Добавить();
            НоваяСтрока.ЕдИзм = ТекСтрокаЗаказ.ЕдИзм;
            НоваяСтрока.Количество = ТекСтрокаЗаказ.Количество;
            НоваяСтрока.НаименованиеТовара = ТекСтрокаЗаказ.НаименованиеТовара;
            НоваяСтрока.ПолноеНаименованиеТовара = ТекСтрокаЗаказ.ПолноеНаименованиеТовара;
        КонецЦикла;
        Для Каждого ТекСтрокаСписаниеТоваров Из ДанныеЗаполнения.СписаниеТоваров Цикл
            НоваяСтрока = СписаниеТоваров.Добавить();
            НоваяСтрока.ЕдИзм = ТекСтрокаСписаниеТоваров.ЕдИзм;
            НоваяСтрока.Количество = ТекСтрокаСписаниеТоваров.Количество*ТекСтрокаЗаказ.Количество;
            НоваяСтрока.НаименованиеТовара = ТекСтрокаСписаниеТоваров.НаименованиеТовара;
            НоваяСтрока.ПолноеНаименованиеТовара = ТекСтрокаСписаниеТоваров.ПолноеНаименованиеТовара;
        КонецЦикла;
    КонецЕсли;
    //}}__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
КонецПроцедуры
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
14.12.2018, 08:51
Ответы с готовыми решениями:

Ввод на основании
Уважаемые,программисты!Ситуация такая...Имеется документ "ЗаявкаНаПриобритение" в нем имеется...

Ввод бизнеспроцесса на основании
Хочу запускать бизнес процесс из документа, указал настройки для ввода на основании, но сама...

Ввод на основании по документу и справочнику
Всем добрый день! Такая конфигурация есть док Меню нужно чтобы при вводе на основании заполнялся...

Изменить значение в переменной (ввод на основании)
Добрый день! Есть ввод на основании, есть три документа:...

Ввод на основании данных табличного поля
Есть документ "Регистрация вакансии", где по нажатию на кнопку "Подобрать сотрудников" запросом...

8
polax
933 / 610 / 205
Регистрация: 16.01.2015
Сообщений: 2,154
14.12.2018, 09:03 2
ЗахарКомардин, Первый цикл закончился и во втором уже НЕ существует ТекСтрокаЗаказ.Количество
0
ЗахарКомардин
0 / 0 / 0
Регистрация: 01.10.2018
Сообщений: 97
14.12.2018, 12:20  [ТС] 3
а как сделать?

Добавлено через 1 час 38 минут
Есть документ Выпуск ГП в нем есть ТЧ Списание Товаров в поле количество надо вписать выражение Документ.Калькуляция.ТЧ.Заказ.Количество*Документ.Калькуляция.ТЧ.Калькуляция.Количество Как это сделать? Подскажите пожалуйста!
0
polax
933 / 610 / 205
Регистрация: 16.01.2015
Сообщений: 2,154
14.12.2018, 16:50 4
ЗахарКомардин,у дока Калькуляция есть ТЧ Заказ и ТЧ Калькуляция? Номенклатура в обеих ТЧ одинаковая и отличается только количеством?
0
14.12.2018, 16:50
ЗахарКомардин
0 / 0 / 0
Регистрация: 01.10.2018
Сообщений: 97
14.12.2018, 18:28  [ТС] 5
У документа Калькуляция есть ТЧ Заказ и ТЧ Калькуляция. Номенклатура и количество разные
0
Tklwegsd
Эксперт 1С
773 / 565 / 191
Регистрация: 24.07.2013
Сообщений: 1,929
14.12.2018, 18:35 6
Цитата Сообщение от ЗахарКомардин Посмотреть сообщение
Документ.Калькуляция.ТЧ.Заказ.Количество*Документ.Калькуляция.ТЧ.Калькуляция.Количество
Так а что на что умножать? Несвязанные вещи ведь (по смыслу).
0
polax
933 / 610 / 205
Регистрация: 16.01.2015
Сообщений: 2,154
14.12.2018, 20:58 7
ЗахарКомардин, Присоединяюсь к вопросу Tklwegsd

Не по теме:

Сегодня суматошный день, никак не сесть за комп

0
ЗахарКомардин
0 / 0 / 0
Регистрация: 01.10.2018
Сообщений: 97
15.12.2018, 09:40  [ТС] 8
Заказ Количество это будет количество выпускаемой продукции. Калькуляция Количество это количество товара затраченное на выпуск одной продукции.

Добавлено через 2 часа 11 минут
понял свою ошибку Калькуляция.Количество стояло ссылка на Справочник.Номенклатура.Количество

Добавлено через 4 минуты
а можно ли ввод на основании сделать из документа и справочника одновременно чтобы было так: НоваяСтрока.Количество = ТекСтрокаСправочникСсылка.Номенклатура.Количество*ТекСтрокаЗаказ.Количество;
0
polax
933 / 610 / 205
Регистрация: 16.01.2015
Сообщений: 2,154
15.12.2018, 11:17 9
ЗахарКомардин, Ну так это классические ЗаказНаПроизводство - ваш Заказ, Спецификация - ваша Калькуляция и, по всей видимости, что-то похожее на док Производство - ваше СписаниеТоваров (если он еще фиксирует выпуск продукции - 100% док Производство).
Тогда вы немного не так подошли к задаче. Расчет материала должен быть не в доке Списание а в доке Заказ. Делаем в Заказе Шкаф подтягивается на второй ТЧ калькуляция - ДСП 4 м, увеличиваем количество шкафов - 2, меняется калькуляция ДСП 8 м. А в док Списание просто берем одну таблицу со спецификацией.
Посмотрите как сделано в УНФ или УПП
0
15.12.2018, 11:17
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
15.12.2018, 11:17

Можно ли в 1с Предприятие создать ввод на основании используя два документа?
Можно ли в 1с Предприятие создать ввод на основании используя два документа?

Как сделать ввод на основании через форму (при нажатии галочки одобрено)?
как сделать ввод на основании через форму? т.е. при нажатии галочки одобрено?

Ввод на основании
Здравствуйте! Версия 1 Предприятие 8.1 (Учебная версия) Есть документ Оформление заказа. У него...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru