Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Galina_71
0 / 0 / 0
Регистрация: 30.04.2016
Сообщений: 10
1

Как из одного документа перенести значение из табличной части в реквизит другого документа?

14.12.2018, 15:33. Просмотров 482. Ответов 9
Метки нет (Все метки)

Только начинаю осваивать 1С, учебная задача.
Есть два документа "Индивидуальный заказ" и "Конкретное изделие в заказе" (см вложения). На каждую строку в табличной части документа "Индивидуальный заказ" должен оформляться документ "Конкретное изделие в заказе". При этом номер заказа, код изделия, наименование изделия и размер должны копироваться.
Думала сделать с помощью ввода на основании, но не знаю, как перенести конкретное поле табличной части в реквизит другого документа. Подскажите, в каком направлении копать и как это можно реализовать.
0
Миниатюры
Как из одного документа перенести значение из табличной части в реквизит другого документа?   Как из одного документа перенести значение из табличной части в реквизит другого документа?  
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
14.12.2018, 15:33
Ответы с готовыми решениями:

Как получить значение реквизита одного справочника и перенести их в реквизит табличной части другого
Добрый день, очень сильно нужна помощь.... Есть справочник "ВидыУслуг", реквизит "Тариф" ...

Из одного документа получить данные табличной части другого документа
Добрый день. Сразу оговорюсь 1С только начал изучать, поэтому просьба помидорами не закидывать. ...

Значение строки табличной части получить в табличной части другого документа
Есть документ ПриходнаяНакладная (товар приходит от поставщика по его цене), с табличной частью...

Заполнение табличной части одного документа на основании другого.
Мне необходимо чтобы в Документе :ЗаказНаПроизводство в Табличной части: Товар отражались данные...

Заполнение табличной части одного документа данными из ТЧ другого
Здравствуйте. Есть 2 документа: 1) "Выдача книги" с табличной частью "Список" с реквизитами...

9
Tklwegsd
Эксперт 1С
767 / 560 / 190
Регистрация: 24.07.2013
Сообщений: 1,918
14.12.2018, 18:26 2
Galina_71, Почитайте форум. Тут примерно каждое третье сообщение с Вашим вопросом.

Цитата Сообщение от Galina_71 Посмотреть сообщение
документ "Конкретное изделие в заказе"
Кажеться, что это должен быть все-таки справочник.
0
Galina_71
0 / 0 / 0
Регистрация: 30.04.2016
Сообщений: 10
14.12.2018, 19:15  [ТС] 3
Нет, это именно документ. Нужно что-то типа на какой строке таблицы стоишь, такой документ "конкретное изделие" и создаешь (по количеству позиций в заказе).
0
Yulunga
372 / 266 / 69
Регистрация: 22.04.2013
Сообщений: 1,706
Записей в блоге: 1
Завершенные тесты: 1
15.12.2018, 00:05 4
для каждого Стр из Заказы Цикл
1) создать документ Док
2) Док.нужныйреквизит1 = Стр.известныйреквизит1
3) Док.нужныйреквизит2 = Стр.известныйреквизит2
...
конец цыклу
0
Galina_71
0 / 0 / 0
Регистрация: 30.04.2016
Сообщений: 10
15.12.2018, 20:40  [ТС] 5
При таком коде создается документ только на последнюю строчку таблицы.
В строке начала цикла если убрать Данные заполнения, выдает ошибку Переменная "заказ" не определена. Это название табличной части в документе "Индивидуальный заказ". Что не так?
 Комментарий модератора 
Ознакомьтесь с правилами форума и выкладывайте код текстом, а не картинками.
0
Миниатюры
Как из одного документа перенести значение из табличной части в реквизит другого документа?  
Galina_71
0 / 0 / 0
Регистрация: 30.04.2016
Сообщений: 10
15.12.2018, 21:15  [ТС] 6
При таком коде создается документ только на последнюю строчку таблицы.
В строке начала цикла если убрать Данные заполнения, выдает ошибку Переменная "заказ" не определена. Это название табличной части в документе "Индивидуальный заказ". Все это пишу в модуле объекта Конкретное изделие. Что не так?
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)
    //{{__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ИндивидуальныйЗаказ") Тогда
        // Заполнение шапки
        Для каждого Стр из ДанныеЗаполнения.Заказ цикл
            НовыйДокумент = Документы.КонкретноеИзделиеВЗаказе.СоздатьДокумент();
            КодЗаказа = Номер;
            КодИзделияВЗаказе = Стр.КодИзделия;
            НаименованиеИзделия = Стр.НаименованиеИзделия;
        КонецЦикла;
    КонецЕсли;
    //}}__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
КонецПроцедуры
0
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,105
15.12.2018, 22:10 7
Galina_71,
1C
1
НовыйДокумент.Записать()
Добавлено через 8 минут
точнее так:
1C
1
2
3
4
5
6
7
8
 Для каждого Стр из ДанныеЗаполнения.Заказ цикл
            НовыйДокумент = Документы.КонкретноеИзделиеВЗаказе.СоздатьДокумент();
            НовыйДокумент.КодЗаказа = Стр.Номер;
            НовыйДокумент.КодИзделияВЗаказе = Стр.КодИзделия;
            НовыйДокумент.НаименованиеИзделия = Стр.НаименованиеИзделия;
            НовыйДокумент.Записать();
        КонецЦикла;
    КонецЕсли;
0
Galina_71
0 / 0 / 0
Регистрация: 30.04.2016
Сообщений: 10
16.12.2018, 17:10  [ТС] 8
При таком коде значения реквизитов не копируются совсем.
0
Galina_71
0 / 0 / 0
Регистрация: 30.04.2016
Сообщений: 10
16.12.2018, 17:45  [ТС] 9
Точнее документы создаются. При нажатии кнопки Создать на основании открывается документ, но реквизиты в нем пустые (см вложения 1,2, красным выделены реквизиты, которые должны быть скопированы). При этом в списке документов документы уже созданные лежат.
0
Миниатюры
Как из одного документа перенести значение из табличной части в реквизит другого документа?   Как из одного документа перенести значение из табличной части в реквизит другого документа?   Как из одного документа перенести значение из табличной части в реквизит другого документа?  

polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,105
16.12.2018, 22:34 10
Galina_71,Проверяйте типы значений. например, Код как правило строка, а у вас на втором скрине число. Думаю и другие типы косячат
0
16.12.2018, 22:34
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
16.12.2018, 22:34

Как вывести поле из строки табличной части справочника в реквизит документа?
Есть справочник ФизЛица с таблчной частью образование и документ Учет с реквизитом-образование (не...

Автоматическое заполнение табличной части документа из табличной части другого
Добрый день. Совсем недавно начал изучать 1С и пока не могу найти решения собственной задачи)...

Вывод на печать табличной части одного документа
Ребята, выручайте. Понимаю, что ошибка пустяковая, но я ее не вижу((((((((((((((( Выводит на...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
10
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru