Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.75/4: Рейтинг темы: голосов - 4, средняя оценка - 4.75
Faksi
0 / 0 / 0
Регистрация: 30.10.2014
Сообщений: 6
1

Программа для вычисления

23.01.2019, 19:11. Просмотров 789. Ответов 1

Доброго времени суток!
Помогите составить программу:

Задание. Используя процедуру нахождения факториала, составить программу для вычисления:
C = N!/M!(N-M)! при условии что N>M.

Я сделал на паскале такую программу, но нужно теперь в 1с, а с его синтаксисом и средой разработки не знаком. Задачка не трудная, выручите студента.
0
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
23.01.2019, 19:11
Ответы с готовыми решениями:

Отчеты2 - ячейка для вычисления ср. арифметического
Здраствуйте... Мне хотелось бы спросить, как сделать так, чтобы в отчете итогом выводилось среднее...

Написать программу в 1С для вычисления суммы и среднего арифметического
Помогите, пожалуйста. Надо написать программу, вычисляемую сумму и среднее арифметическое...

Есть ли программа для учета рыбной продукции?
Есть 1с:рыбопереработка, но для малого предприятия в 30-50 человек 155 тысяч больно круто..тем...

Программа для вычисления F с описанием и вызовом процедуры вычисления
исправить ошибки в программе t=(P^2+L^2)^2 Program lab9; {F = (A^2 + B^2)^2 + (C^2 +...

Программа для вычисления С=n!/k!(n-k)
программа для вычисления С=n!/k!(n-k) с использованием сначала процедуры , а потом функции ...

1
Tklwegsd
Эксперт 1С
743 / 543 / 183
Регистрация: 24.07.2013
Сообщений: 1,894
23.01.2019, 23:58 2
Лучший ответ Сообщение было отмечено Faksi как решение

Решение

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
    Функция Факториал(Знач N) Экспорт
        
        Факториал = 1;
        Для Индекс = 1 По N Цикл
            Факториал = Факториал * Индекс;
        КонецЦикла;
        
        Возврат Факториал;
        
    КонецФункции
    
    Функция ЧислоСочетаний(Знач N, Знач M) Экспорт
        
        Возврат Факториал(N) / (Факториал(M) * Факториал(N - M));
        
    КонецФункции
1
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
23.01.2019, 23:58

Программа для вычисления
Помогите, кто-нибудь: как написать программу С++ для вычисления представленного ниже задания.

Программа для вычисления
Написать программу для вычисления

программа для вычисления
Составьте в Excel список условных 20-ти своих одноклассников, предложите форму записи и введите дни...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru