Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Типовые и стандартные решения
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.68/38: Рейтинг темы: голосов - 38, средняя оценка - 4.68
Gibsonius
4 / 4 / 1
Регистрация: 26.09.2012
Сообщений: 27
#1

Внешняя печатная форма ТОРГ-12 для БП3.0

30.01.2014, 12:41. Просмотров 6886. Ответов 13

Всем привет!
Есть у кого-нибудь Внешняя печатная форма ТОРГ-12 БП 3.0
Или подсказать какие-нибудь толковые ссылки
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
30.01.2014, 12:41
Ответы с готовыми решениями:

Внешняя печатная форма управляемого приложения ТОРГ-12 для УТ 11.3
Здравствуйте. Пытаюсь сделать ВПФ ТОРГ-12 для УТ 11.3. Вроде все вынесла,что к...

Внешняя печатная форма управляемого приложения ТОРГ-12 в УТ
Здравствуйте, может кто нибудь создать внешнюю печатную форму управляемого...

УТ 11. Реализация Товаров. ТОРГ-12. Внешняя печатная форма + таблица значений
собственно все достаточно просто. УТ 11. Реализация Товаров. ТОРГ-12. ...

Внешняя печатная форма для УТ11
Доброго времени суток. создаю внешнюю печ.форму для УТ 11 (печать товарного...

Внешняя печатная форма для документа СчетНаОплатуПокупателю
Добрый день! Версия платформы: 8.3.4.437 "Управление торговлей", редакция...

13
wladimir_ui
Шизофреник
358 / 361 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
30.01.2014, 12:49 #2
сделай сам:

ОбщийМодуль ПечатьТорговыхДокументов
Функция ПечатьТОРГ12
+
ОбщийМакет.ПФ_MXL_ТОРГ12
0
Dethmontt
Модератор
Эксперт 1С
2609 / 2410 / 402
Регистрация: 10.03.2011
Сообщений: 8,555
Записей в блоге: 1
Завершенные тесты: 1
30.01.2014, 13:00 #3
http://www.1c-pro.ru/topic26882.html/page__view__findpost__p__114677

Добавлено через 37 секунд
Принцип один и тот же...
0
Gibsonius
4 / 4 / 1
Регистрация: 26.09.2012
Сообщений: 27
30.01.2014, 13:00  [ТС] #4
Почитаемс
0
Gibsonius
4 / 4 / 1
Регистрация: 26.09.2012
Сообщений: 27
20.02.2014, 11:34  [ТС] #5
Столкнулся с такой проблемой, ВПФ в платформе подключается и открывается, но макет открывается из конфигурации, а не мой отредактированный. Я так понял, что в процедура Печать ссылается на макет из конфигурации, но как сделать, чтобы мой макет выводился в ВПФ?

Вот код:

Кликните здесь для просмотра всего текста
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
416
417
418
419
420
421
422
423
424
425
426
427
428
429
430
431
432
433
434
435
436
437
438
439
440
441
442
443
444
445
446
447
448
449
450
451
452
453
454
455
456
457
458
459
460
461
462
463
464
465
466
467
468
469
470
471
472
473
474
475
476
477
478
479
480
481
482
483
484
485
486
487
488
489
490
491
492
493
494
495
496
497
498
499
500
501
502
503
504
505
506
507
508
509
510
511
512
513
514
515
516
517
518
519
520
521
522
523
524
525
526
527
528
529
530
531
532
533
534
535
536
537
538
539
540
541
542
543
544
545
546
547
548
549
550
551
552
553
554
555
556
557
558
559
560
561
562
563
564
565
566
567
568
569
570
571
572
573
574
575
576
577
578
579
580
581
582
583
584
585
586
587
588
589
590
591
592
593
594
595
596
597
598
599
600
601
602
603
604
605
606
607
608
609
610
611
612
613
614
615
616
617
618
619
620
621
622
623
624
625
626
627
628
629
630
631
632
633
634
635
636
637
638
639
640
641
642
643
644
645
646
647
648
649
650
651
652
653
654
655
656
657
658
659
660
661
662
663
664
665
666
667
668
669
670
671
672
673
674
675
676
677
678
679
680
681
682
683
684
685
686
687
688
689
690
691
692
693
694
695
696
697
698
699
700
701
702
703
704
705
706
707
708
709
710
711
712
713
714
715
716
717
718
719
720
721
722
723
724
725
726
727
728
729
730
731
732
733
734
735
736
737
738
739
740
741
742
743
744
745
746
747
748
749
750
751
752
753
754
755
756
757
758
759
760
761
762
763
764
765
766
767
768
769
770
771
772
773
774
775
776
777
778
779
780
781
782
783
784
785
786
787
788
789
790
791
792
793
794
795
796
797
798
799
800
801
802
803
804
805
806
807
808
809
810
811
812
813
814
815
816
817
818
819
820
821
822
823
824
825
826
827
828
829
830
831
832
833
834
835
836
837
838
839
840
841
842
843
844
845
846
847
848
849
850
851
852
853
854
855
856
857
858
859
860
861
862
863
864
865
866
867
868
869
870
871
872
873
874
875
876
877
878
879
880
881
882
883
884
885
886
887
888
889
890
891
892
893
894
895
896
897
898
899
900
901
902
903
904
905
906
907
908
909
910
911
912
913
914
915
916
917
918
919
920
921
922
923
924
925
926
927
928
929
930
931
932
933
934
935
936
937
938
939
940
941
942
943
944
945
946
947
948
949
950
951
952
953
954
955
956
957
958
959
960
961
962
963
964
965
966
967
968
969
970
971
972
973
974
975
976
977
978
979
980
981
982
983
984
985
986
Функция СведенияОВнешнейОбработке() Экспорт
    
  ПараметрыРегистрации = Новый Структура;
  МассивНазначений = Новый Массив;
  
  МассивНазначений.Добавить("Документ.РеализацияТоваровУслуг");
  
  ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма");
  ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
  ПараметрыРегистрации.Вставить("Наименование","ТОРГ12_Внешняя");
  ПараметрыРегистрации.Вставить("Версия", "1.0");
  ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина);
  ПараметрыРегистрации.Вставить("Информация", "Дополнительная печатная форма 'ТОРГ12_Внешняя' к документу реализация товаров и услуг");
  ПараметрыРегистрации.Вставить("ВерсияБСП", "1.2.1.4");
  ТаблицаКоманд = ПолучитьТаблицуКоманд();
  ДобавитьКоманду(ТаблицаКоманд,
          "ВПФ ТОРГ12",
          "ТОРГ12_Внешняя",
          "ВызовСерверногоМетода",
          Истина,
          "ПечатьMXL");
  ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
  
  Возврат ПараметрыРегистрации;
  
КонецФункции
 
Функция ПолучитьТаблицуКоманд()
    
  Команды = Новый ТаблицаЗначений;
  Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
  Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
  
  Возврат Команды;
  
КонецФункции
 
Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
    
  НоваяКоманда = ТаблицаКоманд.Добавить();
  НоваяКоманда.Представление = Представление;
  НоваяКоманда.Идентификатор = Идентификатор;
  НоваяКоманда.Использование = Использование;
  НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
  НоваяКоманда.Модификатор = Модификатор;
  
КонецПроцедуры
 
Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
    
    ПараметрыВывода.ДоступнаПечатьПоКомплектно = Истина;
    
    Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ТОРГ12_Внешняя") Тогда
        ВключатьУслуги = Истина;
        ТаблицаСведенийТОРГ12 = ПолучитьТаблицуСведенийТОРГ12(МассивОбъектов, ВключатьУслуги);
        ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_РеализацияТоваровУслуг_ТОРГ12";
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "ТОРГ12_Внешняя", "ТОРГ12_Внешняя", 
            ПечатьТорговыхДокументов.ПечатьТОРГ12(ТаблицаСведенийТОРГ12, ОбъектыПечати, ИмяПараметровПечати),,"ОбщийМакет.ПФ_MXL_ТОРГ12");
    КонецЕсли;
        
    Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ТОРГ12_Внешняя") Тогда
        ВключатьУслуги = Ложь;
        ТаблицаСведенийТОРГ12 = ПолучитьТаблицуСведенийТОРГ12(МассивОбъектов, ВключатьУслуги);
        ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_РеализацияТоваровУслуг_ТОРГ12";
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "ТОРГ12_Внешняя", "ТОРГ12_Внешняя",
            ПечатьТорговыхДокументов.ПечатьТОРГ12(ТаблицаСведенийТОРГ12, ОбъектыПечати, ИмяПараметровПечати),,"ОбщийМакет.ПФ_MXL_ТОРГ12");
    КонецЕсли;
 
 
        
КонецПроцедуры
 
Функция ПечатьДокумента(МассивОбъектов, ОбъектыПечати)
 
    УстановитьПривилегированныйРежим(Истина);
    
    ТабличныйДокумент = Новый ТабличныйДокумент;
    ТабличныйДокумент.АвтоМасштаб           = Истина;
    ТабличныйДокумент.ОриентацияСтраницы    = ОриентацияСтраницы.Портрет;
    ТабличныйДокумент.ИмяПараметровПечати   = "ПАРАМЕТРЫ_ПЕЧАТИ_РеализацияТоваровУслуг_Накладная";
    
    ДополнительнаяКолонкаПечатныхФормДокументов = Константы.ДополнительнаяКолонкаПечатныхФормДокументов.Получить();
    Если НЕ ЗначениеЗаполнено(ДополнительнаяКолонкаПечатныхФормДокументов) Тогда
        ДополнительнаяКолонкаПечатныхФормДокументов = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.НеВыводить;
    КонецЕсли;
    ВыводитьКоды = ДополнительнаяКолонкаПечатныхФормДокументов <> Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.НеВыводить;
    
    Запрос = Новый Запрос();
    Запрос.УстановитьПараметр("МассивОбъектов", МассивОбъектов);
    Запрос.УстановитьПараметр("ДополнительнаяКолонкаПечатныхФормДокументов", ДополнительнаяКолонкаПечатныхФормДокументов);
    Запрос.Текст = 
    "ВЫБРАТЬ
    |   ДокументРеализацияТоваровУслуг.Ссылка КАК Ссылка,
    |   ДокументРеализацияТоваровУслуг.Номер КАК Номер,
    |   ДокументРеализацияТоваровУслуг.Дата КАК Дата,
    |   ДокументРеализацияТоваровУслуг.ДоговорКонтрагента КАК ДоговорКонтрагента,
    |   ДокументРеализацияТоваровУслуг.Контрагент КАК Получатель,
    |   ДокументРеализацияТоваровУслуг.Организация КАК Организация,
    |   ДокументРеализацияТоваровУслуг.ПодразделениеОрганизации КАК ПодразделениеОрганизации,
    |   ДокументРеализацияТоваровУслуг.Организация КАК Поставщик,
    |   ДокументРеализацияТоваровУслуг.Ссылка.Склад КАК Склад,
    |   ДокументРеализацияТоваровУслуг.СуммаДокумента КАК СуммаДокумента,
    |   ДокументРеализацияТоваровУслуг.ВалютаДокумента КАК ВалютаДокумента,
    |   ДокументРеализацияТоваровУслуг.СуммаВключаетНДС КАК СуммаВключаетНДС,
    |   РеализацияТоваровУслуг.Номенклатура КАК Номенклатура,
    |   РеализацияТоваровУслуг.ЕдиницаИзмерения КАК ЕдиницаИзмерения,
    |   РеализацияТоваровУслуг.Цена КАК Цена,
    |   РеализацияТоваровУслуг.СтавкаНДС КАК СтавкаНДС,
    |   РеализацияТоваровУслуг.СтранаПроисхождения КАК СтранаПроисхождения,
    |   РеализацияТоваровУслуг.НомерГТД КАК НомерГТД,
    |   СУММА(РеализацияТоваровУслуг.Количество) КАК Количество,
    |   СУММА(РеализацияТоваровУслуг.КоличествоМест) КАК КоличествоМест,
    |   СУММА(РеализацияТоваровУслуг.Сумма) КАК Сумма,
    |   СУММА(РеализацияТоваровУслуг.СуммаНДС) КАК СуммаНДС,
    |   МИНИМУМ(РеализацияТоваровУслуг.НомерСтроки) КАК НомерСтроки
    |ПОМЕСТИТЬ ВТ_ВложенныйЗапросПоТоварам
    |ИЗ
    |   Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслуг
    |   ПРАВОЕ СОЕДИНЕНИЕ Документ.РеализацияТоваровУслуг КАК ДокументРеализацияТоваровУслуг
    |   ПО РеализацияТоваровУслуг.Ссылка = ДокументРеализацияТоваровУслуг.Ссылка
    |ГДЕ
    |   ДокументРеализацияТоваровУслуг.Ссылка В(&МассивОбъектов)
    |
    |СГРУППИРОВАТЬ ПО
    |   РеализацияТоваровУслуг.Номенклатура,
    |   РеализацияТоваровУслуг.ЕдиницаИзмерения,
    |   РеализацияТоваровУслуг.Цена,
    |   РеализацияТоваровУслуг.СтавкаНДС,
    |   РеализацияТоваровУслуг.СтранаПроисхождения,
    |   РеализацияТоваровУслуг.НомерГТД,
    |   ДокументРеализацияТоваровУслуг.Ссылка,
    |   ДокументРеализацияТоваровУслуг.Номер,
    |   ДокументРеализацияТоваровУслуг.Дата,
    |   ДокументРеализацияТоваровУслуг.ДоговорКонтрагента,
    |   ДокументРеализацияТоваровУслуг.Контрагент,
    |   ДокументРеализацияТоваровУслуг.Организация,
    |   ДокументРеализацияТоваровУслуг.Склад,
    |   ДокументРеализацияТоваровУслуг.ПодразделениеОрганизации,
    |   ДокументРеализацияТоваровУслуг.СуммаДокумента,
    |   ДокументРеализацияТоваровУслуг.ВалютаДокумента,
    |   ДокументРеализацияТоваровУслуг.СуммаВключаетНДС,
    |   ДокументРеализацияТоваровУслуг.Организация
    |;
    |
    |////////////////////////////////////////////////////////////////////////////////
    |ВЫБРАТЬ
    |   ВложенныйЗапросПоТоварам.Ссылка КАК Ссылка,
    |   ВложенныйЗапросПоТоварам.Номер КАК Номер,
    |   ВложенныйЗапросПоТоварам.Дата КАК Дата,
    |   ВложенныйЗапросПоТоварам.ДоговорКонтрагента КАК ДоговорКонтрагента,
    |   ВложенныйЗапросПоТоварам.Получатель КАК Получатель,
    |   ВложенныйЗапросПоТоварам.Организация КАК Организация,
    |   ВложенныйЗапросПоТоварам.ПодразделениеОрганизации КАК ПодразделениеОрганизации,
    |   ВложенныйЗапросПоТоварам.Организация КАК Поставщик,
    |   ВложенныйЗапросПоТоварам.Ссылка.Склад КАК Склад,
    |   ВложенныйЗапросПоТоварам.СуммаДокумента КАК СуммаДокумента,
    |   ВложенныйЗапросПоТоварам.ВалютаДокумента КАК ВалютаДокумента,
    |   ВложенныйЗапросПоТоварам.СуммаВключаетНДС КАК СуммаВключаетНДС,
    |   ВложенныйЗапросПоТоварам.Номенклатура,
    |   ВложенныйЗапросПоТоварам.Номенклатура.НаименованиеПолное КАК Товар,
    |   ВЫБОР
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул)
    |           ТОГДА ВложенныйЗапросПоТоварам.Номенклатура.Артикул
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Код)
    |           ТОГДА ВложенныйЗапросПоТоварам.Номенклатура.Код
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.НеВыводить)
    |           ТОГДА """"
    |   КОНЕЦ КАК Артикул,
    |   ВложенныйЗапросПоТоварам.Количество,
    |   ВложенныйЗапросПоТоварам.КоличествоМест,
    |   ВложенныйЗапросПоТоварам.ЕдиницаИзмерения КАК ЕдиницаИзмерения,
    |   ВложенныйЗапросПоТоварам.Номенклатура.ЕдиницаИзмерения КАК ЕдиницаХранения,
    |   ВложенныйЗапросПоТоварам.Цена,
    |   ВложенныйЗапросПоТоварам.Сумма,
    |   ВложенныйЗапросПоТоварам.СуммаНДС,
    |   ВложенныйЗапросПоТоварам.СтранаПроисхождения КАК СтранаПроисхождения,
    |   ВложенныйЗапросПоТоварам.НомерГТД КАК НомерГТД,
    |   ВложенныйЗапросПоТоварам.НомерСтроки,
    |   1 КАК ID
    |ИЗ
    |   ВТ_ВложенныйЗапросПоТоварам КАК ВложенныйЗапросПоТоварам
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    |   РеализацияТоваровУслуг.Ссылка,
    |   РеализацияТоваровУслуг.Ссылка.Номер,
    |   РеализацияТоваровУслуг.Ссылка.Дата,
    |   РеализацияТоваровУслуг.Ссылка.ДоговорКонтрагента,
    |   РеализацияТоваровУслуг.Ссылка.Контрагент,
    |   РеализацияТоваровУслуг.Ссылка.Организация,
    |   РеализацияТоваровУслуг.Ссылка.ПодразделениеОрганизации,
    |   РеализацияТоваровУслуг.Ссылка.Организация,
    |   РеализацияТоваровУслуг.Ссылка.Склад,
    |   РеализацияТоваровУслуг.Ссылка.СуммаДокумента,
    |   РеализацияТоваровУслуг.Ссылка.ВалютаДокумента,
    |   РеализацияТоваровУслуг.Ссылка.СуммаВключаетНДС,
    |   РеализацияТоваровУслуг.Номенклатура,
    |   РеализацияТоваровУслуг.Номенклатура.НаименованиеПолное,
    |   ВЫБОР
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул)
    |           ТОГДА РеализацияТоваровУслуг.Номенклатура.Артикул
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Код)
    |           ТОГДА РеализацияТоваровУслуг.Номенклатура.Код
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.НеВыводить)
    |           ТОГДА """"
    |   КОНЕЦ,
    |   РеализацияТоваровУслуг.Количество,
    |   NULL,
    |   NULL,
    |   NULL,
    |   РеализацияТоваровУслуг.Цена,
    |   РеализацияТоваровУслуг.Сумма,
    |   0,
    |   NULL,
    |   NULL,
    |   РеализацияТоваровУслуг.НомерСтроки,
    |   2
    |ИЗ
    |   Документ.РеализацияТоваровУслуг.ВозвратнаяТара КАК РеализацияТоваровУслуг
    |ГДЕ
    |   РеализацияТоваровУслуг.Ссылка В(&МассивОбъектов)
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    |   РеализацияТоваровУслуг.Ссылка,
    |   РеализацияТоваровУслуг.Ссылка.Номер,
    |   РеализацияТоваровУслуг.Ссылка.Дата,
    |   РеализацияТоваровУслуг.Ссылка.ДоговорКонтрагента,
    |   РеализацияТоваровУслуг.Ссылка.Контрагент,
    |   РеализацияТоваровУслуг.Ссылка.Организация,
    |   РеализацияТоваровУслуг.Ссылка.ПодразделениеОрганизации,
    |   РеализацияТоваровУслуг.Ссылка.Организация,
    |   РеализацияТоваровУслуг.Ссылка.Склад,
    |   РеализацияТоваровУслуг.Ссылка.СуммаДокумента,
    |   РеализацияТоваровУслуг.Ссылка.ВалютаДокумента,
    |   РеализацияТоваровУслуг.Ссылка.СуммаВключаетНДС,
    |   ВЫБОР
    |       КОГДА (НЕ РеализацияТоваровУслуг.Содержание ПОДОБНО """")
    |           ТОГДА РеализацияТоваровУслуг.Содержание
    |       КОГДА (НЕ РеализацияТоваровУслуг.Номенклатура.НаименованиеПолное ПОДОБНО """")
    |           ТОГДА РеализацияТоваровУслуг.Номенклатура.НаименованиеПолное
    |       ИНАЧЕ РеализацияТоваровУслуг.Номенклатура.Наименование
    |   КОНЕЦ,
    |   ВЫБОР
    |       КОГДА (НЕ РеализацияТоваровУслуг.Содержание ПОДОБНО """")
    |           ТОГДА РеализацияТоваровУслуг.Содержание
    |       КОГДА (НЕ РеализацияТоваровУслуг.Номенклатура.НаименованиеПолное ПОДОБНО """")
    |           ТОГДА РеализацияТоваровУслуг.Номенклатура.НаименованиеПолное
    |       ИНАЧЕ РеализацияТоваровУслуг.Номенклатура.Наименование
    |   КОНЕЦ,
    |   ВЫБОР
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул)
    |           ТОГДА РеализацияТоваровУслуг.Номенклатура.Артикул
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Код)
    |           ТОГДА РеализацияТоваровУслуг.Номенклатура.Код
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.НеВыводить)
    |           ТОГДА """"
    |   КОНЕЦ,
    |   РеализацияТоваровУслуг.Количество,
    |   NULL,
    |   NULL,
    |   РеализацияТоваровУслуг.Номенклатура.ЕдиницаИзмерения,
    |   РеализацияТоваровУслуг.Цена,
    |   РеализацияТоваровУслуг.Сумма,
    |   РеализацияТоваровУслуг.СуммаНДС,
    |   NULL,
    |   NULL,
    |   РеализацияТоваровУслуг.НомерСтроки,
    |   3
    |ИЗ
    |   Документ.РеализацияТоваровУслуг.Услуги КАК РеализацияТоваровУслуг
    |ГДЕ
    |   РеализацияТоваровУслуг.Ссылка В(&МассивОбъектов)
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    |   РеализацияТоваровУслуг.Ссылка,
    |   РеализацияТоваровУслуг.Ссылка.Номер,
    |   РеализацияТоваровУслуг.Ссылка.Дата,
    |   РеализацияТоваровУслуг.Ссылка.ДоговорКонтрагента,
    |   РеализацияТоваровУслуг.Ссылка.Контрагент,
    |   РеализацияТоваровУслуг.Ссылка.Организация,
    |   РеализацияТоваровУслуг.Ссылка.ПодразделениеОрганизации,
    |   РеализацияТоваровУслуг.Ссылка.Организация,
    |   РеализацияТоваровУслуг.Ссылка.Склад,
    |   РеализацияТоваровУслуг.Ссылка.СуммаДокумента,
    |   РеализацияТоваровУслуг.Ссылка.ВалютаДокумента,
    |   РеализацияТоваровУслуг.Ссылка.СуммаВключаетНДС,
    |   ВЫБОР
    |       КОГДА (НЕ РеализацияТоваровУслуг.Содержание ПОДОБНО """")
    |           ТОГДА РеализацияТоваровУслуг.Содержание
    |       КОГДА (НЕ РеализацияТоваровУслуг.Номенклатура.НаименованиеПолное ПОДОБНО """")
    |           ТОГДА РеализацияТоваровУслуг.Номенклатура.НаименованиеПолное
    |       ИНАЧЕ РеализацияТоваровУслуг.Номенклатура.Наименование
    |   КОНЕЦ,
    |   ВЫБОР
    |       КОГДА (НЕ РеализацияТоваровУслуг.Содержание ПОДОБНО """")
    |           ТОГДА РеализацияТоваровУслуг.Содержание
    |       КОГДА (НЕ РеализацияТоваровУслуг.Номенклатура.НаименованиеПолное ПОДОБНО """")
    |           ТОГДА РеализацияТоваровУслуг.Номенклатура.НаименованиеПолное
    |       ИНАЧЕ РеализацияТоваровУслуг.Номенклатура.Наименование
    |   КОНЕЦ,
    |   ВЫБОР
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул)
    |           ТОГДА РеализацияТоваровУслуг.Номенклатура.Артикул
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Код)
    |           ТОГДА РеализацияТоваровУслуг.Номенклатура.Код
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.НеВыводить)
    |           ТОГДА """"
    |   КОНЕЦ,
    |   РеализацияТоваровУслуг.Количество,
    |   NULL,
    |   NULL,
    |   РеализацияТоваровУслуг.Номенклатура.ЕдиницаИзмерения,
    |   РеализацияТоваровУслуг.Цена,
    |   РеализацияТоваровУслуг.Сумма,
    |   РеализацияТоваровУслуг.СуммаНДС,
    |   NULL,
    |   NULL,
    |   РеализацияТоваровУслуг.НомерСтроки,
    |   4
    |ИЗ
    |   Документ.РеализацияТоваровУслуг.АгентскиеУслуги КАК РеализацияТоваровУслуг
    |ГДЕ
    |   РеализацияТоваровУслуг.Ссылка В(&МассивОбъектов)
    |
    |УПОРЯДОЧИТЬ ПО
    |   Дата,
    |   Ссылка,
    |   ID,
    |   ВложенныйЗапросПоТоварам.НомерСтроки";
    
    Шапка = Запрос.Выполнить().Выбрать();
    
    ПервыйДокумент = Истина;
    
    Пока Шапка.СледующийПоЗначениюПоля("Ссылка") Цикл
        
        Макет = УправлениеПечатью.ПолучитьМакет("ТОРГ12_Внешняя");
 
        Если НЕ ПервыйДокумент Тогда
            ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
        КонецЕсли;
        
        ПервыйДокумент = Ложь;
        // Запомним номер строки, с которой начали выводить текущий документ.
        НомерСтрокиНачало = ТабличныйДокумент.ВысотаТаблицы + 1;
        
        // Выводим шапку накладной
 
        ОбластьМакета = Макет.ПолучитьОбласть("Заголовок");
        ОбластьМакета.Параметры.ТекстЗаголовка = ОбщегоНазначенияБПВызовСервера.СформироватьЗаголовокДокумента(Шапка.Ссылка, "Расходная накладная");
        ТабличныйДокумент.Вывести(ОбластьМакета);
 
        ОбластьМакета = Макет.ПолучитьОбласть("Поставщик");
        СведенияОбОрганизации   = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Организация, Шапка.Дата);
        ПредставлениеПоставщика = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОбОрганизации, "НаименованиеДляПечатныхФорм,");
        ОбластьМакета.Параметры.ПредставлениеПоставщика = ПредставлениеПоставщика;
        ОбластьМакета.Параметры.Поставщик               = Шапка.Поставщик;
        ТабличныйДокумент.Вывести(ОбластьМакета);
 
        ОбластьМакета = Макет.ПолучитьОбласть("Покупатель");
        СведенияОКонтрагенте    = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Получатель, Шапка.Дата);
        ПредставлениеПолучателя = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОКонтрагенте, "НаименованиеДляПечатныхФорм,");
        ОбластьМакета.Параметры.ПредставлениеПолучателя = ПредставлениеПолучателя;
        ОбластьМакета.Параметры.Получатель = Шапка.Получатель;
        ТабличныйДокумент.Вывести(ОбластьМакета);
 
        ЕстьСкидки = Ложь;
 
        ОбластьНомера = Макет.ПолучитьОбласть("ШапкаТаблицы|НомерСтроки");
        ОбластьКодов  = Макет.ПолучитьОбласть("ШапкаТаблицы|КолонкаКодов");
        ОбластьДанных = Макет.ПолучитьОбласть("ШапкаТаблицы|Данные");
        ОбластьСуммы  = Макет.ПолучитьОбласть("ШапкаТаблицы|Сумма");
 
        ТабличныйДокумент.Вывести(ОбластьНомера);
        Если ВыводитьКоды Тогда
            Если ДополнительнаяКолонкаПечатныхФормДокументов = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул Тогда
                ОбластьКодов.Параметры.ИмяКолонкиКодов = "Артикул";
            ИначеЕсли ДополнительнаяКолонкаПечатныхФормДокументов = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Код Тогда
                ОбластьКодов.Параметры.ИмяКолонкиКодов = "Код";
            КонецЕсли;
            ТабличныйДокумент.Присоединить(ОбластьКодов);
        КонецЕсли;
        ТабличныйДокумент.Присоединить(ОбластьДанных);
        ТабличныйДокумент.Присоединить(ОбластьСуммы);
 
        ОбластьКолонкаТовар = Макет.Область("Товар");
 
        Если НЕ ВыводитьКоды Тогда
            ОбластьКолонкаТовар.ШиринаКолонки = ОбластьКолонкаТовар.ШиринаКолонки + 
                                                Макет.Область("КолонкаКодов").ШиринаКолонки;
        КонецЕсли;
        
        Если НЕ ЕстьСкидки Тогда
            ОбластьКолонкаТовар.ШиринаКолонки = ОбластьКолонкаТовар.ШиринаКолонки + 
                                                Макет.Область("СуммаБезСкидки").ШиринаКолонки +
                                                Макет.Область("СуммаСкидки").ШиринаКолонки;
        КонецЕсли;
 
        ОбластьНомера = Макет.ПолучитьОбласть("Строка|НомерСтроки");
        ОбластьКодов  = Макет.ПолучитьОбласть("Строка|КолонкаКодов");
        ОбластьДанных = Макет.ПолучитьОбласть("Строка|Данные");
        ОбластьСуммы  = Макет.ПолучитьОбласть("Строка|Сумма");
 
        Сумма    = 0;
        СуммаНДС = 0;
        ВсегоСкидок    = 0;
        ВсегоБезСкидок = 0;
        КоличествоСтрок = 0;
 
        НомерСтроки = 0;
 
        Пока Шапка.Следующий() Цикл 
            
            Если Шапка.Номенклатура = Null Тогда 
                Продолжить;
            КонецЕсли;
            
            НомерСтроки = НомерСтроки + 1;
 
            ОбластьНомера.Параметры.НомерСтроки = НомерСтроки;
            ТабличныйДокумент.Вывести(ОбластьНомера);
 
            Если ВыводитьКоды Тогда
                ОбластьКодов.Параметры.Заполнить(Шапка);
                ТабличныйДокумент.Присоединить(ОбластьКодов);
            КонецЕсли;
            
            ОбластьДанных.Параметры.Заполнить(Шапка);
            ОбластьДанных.Параметры.Товар = СокрЛП(Шапка.Товар);
            ТабличныйДокумент.Присоединить(ОбластьДанных);
 
            Скидка = 0;
            
            ОбластьСуммы.Параметры.Заполнить(Шапка);
            ТабличныйДокумент.Присоединить(ОбластьСуммы);
            Сумма          = Сумма       + ?(ЗначениеЗаполнено(Шапка.Сумма), Шапка.Сумма, 0);
            СуммаНДС       = СуммаНДС    + ?(ЗначениеЗаполнено(Шапка.СуммаНДС), Шапка.СуммаНДС, 0);
            ВсегоСкидок    = ВсегоСкидок + Скидка;
            ВсегоБезСкидок = Сумма       + ВсегоСкидок;
            
            КоличествоСтрок = КоличествоСтрок + 1;
 
        КонецЦикла;
 
        // Вывести Итого
        ОбластьНомера = Макет.ПолучитьОбласть("Итого|НомерСтроки");
        ОбластьКодов  = Макет.ПолучитьОбласть("Итого|КолонкаКодов");
        ОбластьДанных = Макет.ПолучитьОбласть("Итого|Данные");
        ОбластьСуммы  = Макет.ПолучитьОбласть("Итого|Сумма");
 
        ТабличныйДокумент.Вывести(ОбластьНомера);
        Если ВыводитьКоды Тогда
            ТабличныйДокумент.Присоединить(ОбластьКодов);
        КонецЕсли;
        ТабличныйДокумент.Присоединить(ОбластьДанных);
        ОбластьСуммы.Параметры.Всего = ОбщегоНазначенияБПВызовСервера.ФорматСумм(Сумма);
        ТабличныйДокумент.Присоединить(ОбластьСуммы);
        
        // Вывести ИтогоНДС
        ОбластьНомера = Макет.ПолучитьОбласть("ИтогоНДС|НомерСтроки");
        ОбластьКодов  = Макет.ПолучитьОбласть("ИтогоНДС|КолонкаКодов");
        ОбластьДанных = Макет.ПолучитьОбласть("ИтогоНДС|Данные");
        ОбластьСуммы  = Макет.ПолучитьОбласть("ИтогоНДС|Сумма");
        
        ТабличныйДокумент.Вывести(ОбластьНомера);
        Если ВыводитьКоды Тогда
            ТабличныйДокумент.Присоединить(ОбластьКодов);
        КонецЕсли;
        
        Если СуммаНДС <> 0 Тогда
            ОбластьСуммы.Параметры.ВсегоНДС  = ОбщегоНазначенияБПВызовСервера.ФорматСумм(СуммаНДС);
            ОбластьДанных.Параметры.НДС      = ?(Шапка.СуммаВключаетНДС, "В том числе НДС", " Сумма НДС");
        Иначе
            ОбластьСуммы.Параметры.ВсегоНДС  = "-";
            ОбластьДанных.Параметры.НДС      = "Без налога (НДС)";
        КонецЕсли;
        
        ТабличныйДокумент.Присоединить(ОбластьДанных);
        ТабличныйДокумент.Присоединить(ОбластьСуммы);
                
        // Вывести Сумму прописью
        ОбластьМакета = Макет.ПолучитьОбласть("СуммаПрописью");
        СуммаКПрописи = Сумма + ?(Шапка.СуммаВключаетНДС, 0, СуммаНДС);
        ОбластьМакета.Параметры.ИтоговаяСтрока ="Всего наименований " + КоличествоСтрок
            + ", на сумму " + ОбщегоНазначенияБПВызовСервера.ФорматСумм(СуммаКПрописи, Шапка.ВалютаДокумента);
        ОбластьМакета.Параметры.СуммаПрописью = ОбщегоНазначенияБПВызовСервера.СформироватьСуммуПрописью(СуммаКПрописи, Шапка.ВалютаДокумента);
        ТабличныйДокумент.Вывести(ОбластьМакета);
 
        // Вывести подписи
        ОбластьМакета = Макет.ПолучитьОбласть("Подписи");
        ОбластьМакета.Параметры.Заполнить(Шапка);
        
        Если Шапка.Склад <> Справочники.Склады.ПустаяСсылка() Тогда 
            МОЛ = ОтветственныеЛицаБП.ОтветственноеЛицоНаСкладе(Шапка.Склад, Шапка.Дата);
            ДанныеФизЛица = ОбщегоНазначенияБПВызовСервера.ДанныеФизЛица(Шапка.Организация, МОЛ, Шапка.Дата);
            Представление = ?(ЗначениеЗаполнено(ДанныеФизЛица.Должность), Строка(ДанныеФизЛица.Должность) + " ", "");
            Представление = Представление + ?(ЗначениеЗаполнено(ДанныеФизЛица.Представление), Строка(ДанныеФизЛица.Представление), "");
            ОбластьМакета.Параметры.ОтветственныйПредставление = Представление;
        КонецЕсли;
 
        ТабличныйДокумент.Вывести(ОбластьМакета);
 
        
        // В табличном документе зададим имя области, в которую был 
        // выведен объект. Нужно для возможности печати покомплектно.
        УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабличныйДокумент, 
            НомерСтрокиНачало, ОбъектыПечати, Шапка.Ссылка);
 
    КонецЦикла;
 
    Возврат ТабличныйДокумент;
 
КонецФункции
 
Функция ПодготовитьТаблицуДокументаДляПечати(ВыборкаСтрок, ТаблицаПоТоварам, ПечататьТовары, ПечататьУслуги)
 
    ТаблицаПоТоварам.Очистить();
 
    ВалютаРегламентированногоУчета   = ОбщегоНазначенияБПВызовСервераПовтИсп.ПолучитьВалютуРегламентированногоУчета();
    МассивРаспределения = Новый Массив;
 
    СуммаВзаиморасчетов     = 0;
    СуммаВзаиморасчетовНДС  = 0;
    ПерваяСтрокаДокумента   = Истина;
    СуммаВключаетНДС        = Неопределено;
    РасчетыВУсловныхЕдиницах= Неопределено;
    ДатаДокумента           = Неопределено;
 
    Пока ВыборкаСтрок.Следующий() Цикл
        
        СтрокаТаблицы = ТаблицаПоТоварам.Добавить();
        ЗаполнитьЗначенияСвойств(СтрокаТаблицы, ВыборкаСтрок);
        
        Если ПерваяСтрокаДокумента Тогда
 
            СуммаВключаетНДС            = ВыборкаСтрок.СуммаВключаетНДС;
            РасчетыВУсловныхЕдиницах    = ВыборкаСтрок.РасчетыВУсловныхЕдиницах;
            ДатаДокумента               = ВыборкаСтрок.ДатаДокумента;
            
            НуженПересчетВРубли = Ложь;
            
            Если ВыборкаСтрок.Проведен 
                И (ВыборкаСтрок.РасчетыВУсловныхЕдиницах
                ИЛИ (ВыборкаСтрок.ВалютаДокумента <> ВалютаРегламентированногоУчета И ВыборкаСтрок.ДатаДокумента >= '20090101000000')) Тогда
                НуженПересчетВРубли = Истина;
            КонецЕсли;
            
            ПерваяСтрокаДокумента = Ложь;
            
        КонецЕсли;
        
        Если НуженПересчетВРубли Тогда
            
            Если  СтрокаТаблицы.ВсегоРуб = 0 Тогда
                
                СтрокаТаблицы.Сумма = СтрокаТаблицы.Сумма;
                СтрокаТаблицы.СуммаНДС = СтрокаТаблицы.СуммаНДС;
                
            Иначе
                
                СтрокаТаблицы.Сумма = СтрокаТаблицы.ВсегоРуб - ?(СуммаВключаетНДС, 0, СтрокаТаблицы.НДСРуб);
                СтрокаТаблицы.СуммаНДС = СтрокаТаблицы.НДСРуб;
                
            КонецЕсли;  
            
            СтрокаТаблицы.СуммаБезНДС = СтрокаТаблицы.Сумма - СтрокаТаблицы.СуммаНДС;
            
            СтрокаТаблицы.Цена = ?(СтрокаТаблицы.Количество = 0, 0, Окр(СтрокаТаблицы.Сумма/СтрокаТаблицы.Количество,2));
            
        КонецЕсли;  
                
        
    КонецЦикла;
    
    Если НЕ ПечататьТовары ИЛИ НЕ ПечататьУслуги Тогда
        // Исключим строки из табличный частей, которые не удовлетворяют условиям печати. При выборке запросом их необходимо получать, 
        // чтобы распределять сумма взаиморасчетов в рублях на все строки документа.
        Инд = ТаблицаПоТоварам.Количество() - 1;
        Пока Инд >= 0 Цикл
            СтрокаТовар = ТаблицаПоТоварам[Инд];
            
            Если СтрокаТовар.ID = 1 ИЛИ СтрокаТовар.ID = 2 Тогда // Товары или ВозвратнаяТара
                Если НЕ ПечататьТовары Тогда
                    ТаблицаПоТоварам.Удалить(Инд);
                КонецЕсли;          
            ИначеЕсли СтрокаТовар.ID = 3 ИЛИ СтрокаТовар.ID = 4 Тогда // Услуги или АгентскиеУслуги
                Если НЕ ПечататьУслуги Тогда
                    ТаблицаПоТоварам.Удалить(Инд);
                КонецЕсли;
            КонецЕсли;
            
            Инд = Инд - 1;
        КонецЦикла;
    КонецЕсли;
 
    Возврат ТаблицаПоТоварам;
 
КонецФункции
 
Функция ПолучитьТекстЗапросаДляФормированияТаблицыСведенийТОРГ12()
    
    ТекстЗапроса = 
    "ВЫБРАТЬ
    |   РегистрСведенийРублевыеСуммыДокументовВВалюте.Регистратор КАК Регистратор,
    |   РегистрСведенийРублевыеСуммыДокументовВВалюте.НомерСтрокиДокумента КАК НомерСтрокиДокумента,
    |   РегистрСведенийРублевыеСуммыДокументовВВалюте.ТабличнаяЧастьДокумента КАК ТабличнаяЧастьДокумента,
    |   РегистрСведенийРублевыеСуммыДокументовВВалюте.Всего,
    |   РегистрСведенийРублевыеСуммыДокументовВВалюте.НДС,
    |   РегистрСведенийРублевыеСуммыДокументовВВалюте.НалоговаяБазаНДС
    |ПОМЕСТИТЬ РегистрСведенийРублевыеСуммыДокументовВВалюте
    |ИЗ
    |   РегистрСведений.РублевыеСуммыДокументовВВалюте КАК РегистрСведенийРублевыеСуммыДокументовВВалюте
    |ГДЕ
    |   РегистрСведенийРублевыеСуммыДокументовВВалюте.Регистратор В(&МассивДокументов)
    |
    |ИНДЕКСИРОВАТЬ ПО
    |   Регистратор,
    |   НомерСтрокиДокумента,
    |   ТабличнаяЧастьДокумента
    |;
    |
    |////////////////////////////////////////////////////////////////////////////////
    |ВЫБРАТЬ
    |   РеализацияТоваровУслуг.Ссылка КАК Ссылка,
    |   РеализацияТоваровУслуг.СуммаВключаетНДС КАК СуммаВключаетНДС,
    |   РеализацияТоваровУслуг.Дата КАК ДатаДокумента
    |ПОМЕСТИТЬ ДокументыДляПечати
    |ИЗ
    |   Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
    |ГДЕ
    |   РеализацияТоваровУслуг.Ссылка В(&МассивДокументов)
    |
    |ИНДЕКСИРОВАТЬ ПО
    |   Ссылка
    |;
    |
    |////////////////////////////////////////////////////////////////////////////////
    |ВЫБРАТЬ
    |   РеализацияТоваровУслуг.Ссылка КАК Документ,
    |   РеализацияТоваровУслуг.Дата КАК ДатаДляПолученияСведений,
    |   ДанныеПервичныхДокументов.Номер КАК НомерДокумента,
    |   ДанныеПервичныхДокументов.Дата КАК ДатаДокумента,
    |   РеализацияТоваровУслуг.Дата КАК ДатаПодписанияДокумента,
    |   РеализацияТоваровУслуг.Организация КАК Организация,
    |   РеализацияТоваровУслуг.ПодразделениеОрганизации КАК Подразделение,
    |   РеализацияТоваровУслуг.Организация КАК Поставщик,
    |   РеализацияТоваровУслуг.Контрагент КАК Покупатель,
    |   ВЫБОР
    |       КОГДА РеализацияТоваровУслуг.Грузополучатель = ЗНАЧЕНИЕ(Справочник.Контрагенты.ПустаяСсылка)
    |           ТОГДА РеализацияТоваровУслуг.Контрагент
    |       ИНАЧЕ РеализацияТоваровУслуг.Грузополучатель
    |   КОНЕЦ КАК Грузополучатель,
    |   ВЫБОР
    |       КОГДА РеализацияТоваровУслуг.Грузоотправитель = ЗНАЧЕНИЕ(Справочник.Контрагенты.ПустаяСсылка)
    |           ТОГДА РеализацияТоваровУслуг.Организация
    |       ИНАЧЕ РеализацияТоваровУслуг.Грузоотправитель
    |   КОНЕЦ КАК Грузоотправитель,
    |   РеализацияТоваровУслуг.БанковскийСчетОрганизации КАК БанковскийСчетПродавца,
    |   РеализацияТоваровУслуг.АдресДоставки КАК АдресДоставки,
    |   РеализацияТоваровУслуг.ДоговорКонтрагента КАК Договор,
    |   РеализацияТоваровУслуг.ДоговорКонтрагента.Представление КАК Основание,
    |   РеализацияТоваровУслуг.ДоговорКонтрагента.Номер КАК ОснованиеНомер,
    |   РеализацияТоваровУслуг.ДоговорКонтрагента.Дата КАК ОснованиеДата,
    |   РеализацияТоваровУслуг.ВалютаДокумента КАК ВалютаДокумента,
    |   РеализацияТоваровУслуг.КурсВзаиморасчетов КАК Курс,
    |   РеализацияТоваровУслуг.КратностьВзаиморасчетов КАК Кратность,
    |   РеализацияТоваровУслуг.Руководитель,
    |   РеализацияТоваровУслуг.ГлавныйБухгалтер,
    |   РеализацияТоваровУслуг.ОтпускПроизвел КАК Кладовщик,
    |   РеализацияТоваровУслуг.ЗаРуководителяПоПриказу,
    |   РеализацияТоваровУслуг.ЗаГлавногоБухгалтераПоПриказу,
    |   РеализацияТоваровУслуг.ДоверенностьНомер КАК ДоверенностьНомер,
    |   РеализацияТоваровУслуг.ДоверенностьДата КАК ДоверенностьДата,
    |   РеализацияТоваровУслуг.ДоверенностьВыдана КАК ДоверенностьВыдана,
    |   РеализацияТоваровУслуг.ДоверенностьЧерезКого КАК ДоверенностьЧерезКого
    |ИЗ
    |   Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
    |       ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ДанныеПервичныхДокументов КАК ДанныеПервичныхДокументов
    |       ПО РеализацияТоваровУслуг.Организация = ДанныеПервичныхДокументов.Организация
    |           И РеализацияТоваровУслуг.Ссылка = ДанныеПервичныхДокументов.Документ
    |ГДЕ
    |   РеализацияТоваровУслуг.Ссылка В
    |           (ВЫБРАТЬ
    |               ДокументыДляПечати.Ссылка
    |           ИЗ
    |               ДокументыДляПечати КАК ДокументыДляПечати)
    |
    |УПОРЯДОЧИТЬ ПО
    |   ДатаДокумента,
    |   Документ
    |;
    |
    |////////////////////////////////////////////////////////////////////////////////
    |ВЫБРАТЬ
    |   РеализацияТоваровУслуг.Ссылка КАК Документ,
    |   ДокументыДляПечати.ДатаДокумента КАК ДатаДокумента,
    |   ЗНАЧЕНИЕ(Перечисление.ТабличныеЧастиДокументов.Товары) КАК ТабличнаяЧасть,
    |   1 КАК ПорядокТабличнойЧасти,
    |   РеализацияТоваровУслуг.НомерСтроки КАК НомерСтроки,
    |   РеализацияТоваровУслуг.Номенклатура КАК Товар,
    |   РеализацияТоваровУслуг.Номенклатура.НаименованиеПолное КАК ТоварНаименование,
    |   ВЫБОР
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул)
    |           ТОГДА РеализацияТоваровУслуг.Номенклатура.Артикул
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Код)
    |           ТОГДА РеализацияТоваровУслуг.Номенклатура.Код
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.НеВыводить)
    |           ТОГДА """"
    |   КОНЕЦ КАК ТоварКод,
    |   РеализацияТоваровУслуг.Количество,
    |   РеализацияТоваровУслуг.КоличествоМест,
    |   ЕСТЬNULL(РеализацияТоваровУслуг.Номенклатура.ЕдиницаИзмерения, ЗНАЧЕНИЕ(Справочник.КлассификаторЕдиницИзмерения.ПустаяСсылка)) КАК ЕдиницаИзмерения,
    |   ЕСТЬNULL(РеализацияТоваровУслуг.Номенклатура.ЕдиницаИзмерения.Код, """") КАК ЕдиницаИзмеренияКод,
    |   ЕСТЬNULL(РеализацияТоваровУслуг.Номенклатура.ЕдиницаИзмерения.Наименование, """") КАК ЕдиницаИзмеренияНаименование,
    |   РеализацияТоваровУслуг.ЕдиницаИзмерения КАК ВидУпаковки,
    |   РеализацияТоваровУслуг.Коэффициент КАК КоличествоВОдномМесте,
    |   РеализацияТоваровУслуг.Цена КАК Цена,
    |   ВЫБОР
    |       КОГДА ДокументыДляПечати.СуммаВключаетНДС
    |           ТОГДА РеализацияТоваровУслуг.Сумма - РеализацияТоваровУслуг.СуммаНДС
    |       ИНАЧЕ РеализацияТоваровУслуг.Сумма
    |   КОНЕЦ КАК СуммаБезНДС,
    |   РеализацияТоваровУслуг.СуммаНДС КАК СуммаНДС,
    |   РеализацияТоваровУслуг.СтавкаНДС,
    |   ЕСТЬNULL(РегистрСведенийРублевыеСуммыДокументовВВалюте.Всего, 0) КАК ВсегоВРублях,
    |   ЕСТЬNULL(РегистрСведенийРублевыеСуммыДокументовВВалюте.НДС, 0) КАК НДСВРублях,
    |   ВЫБОР
    |       КОГДА РегистрСведенийРублевыеСуммыДокументовВВалюте.Регистратор ЕСТЬ NULL 
    |           ТОГДА ЛОЖЬ
    |       ИНАЧЕ ИСТИНА
    |   КОНЕЦ КАК СуществуютЗаписиРублевыхСумм
    |ИЗ
    |   ДокументыДляПечати КАК ДокументыДляПечати
    |       ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслуг
    |       ПО ДокументыДляПечати.Ссылка = РеализацияТоваровУслуг.Ссылка
    |       ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведенийРублевыеСуммыДокументовВВалюте КАК РегистрСведенийРублевыеСуммыДокументовВВалюте
    |       ПО (РеализацияТоваровУслуг.Ссылка = РегистрСведенийРублевыеСуммыДокументовВВалюте.Регистратор)
    |           И (РеализацияТоваровУслуг.НомерСтроки = РегистрСведенийРублевыеСуммыДокументовВВалюте.НомерСтрокиДокумента)
    |           И (РегистрСведенийРублевыеСуммыДокументовВВалюте.ТабличнаяЧастьДокумента = ЗНАЧЕНИЕ(Перечисление.ТабличныеЧастиДокументов.Товары))
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    |   РеализацияТоваровУслуг.Ссылка,
    |   ДокументыДляПечати.ДатаДокумента,
    |   ЗНАЧЕНИЕ(Перечисление.ТабличныеЧастиДокументов.ВозвратнаяТара),
    |   2,
    |   РеализацияТоваровУслуг.НомерСтроки,
    |   РеализацияТоваровУслуг.Номенклатура,
    |   РеализацияТоваровУслуг.Номенклатура.НаименованиеПолное,
    |   ВЫБОР
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул)
    |           ТОГДА РеализацияТоваровУслуг.Номенклатура.Артикул
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Код)
    |           ТОГДА РеализацияТоваровУслуг.Номенклатура.Код
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.НеВыводить)
    |           ТОГДА """"
    |   КОНЕЦ,
    |   РеализацияТоваровУслуг.Количество,
    |   0,
    |   NULL,
    |   NULL,
    |   NULL,
    |   NULL,
    |   0,
    |   РеализацияТоваровУслуг.Цена,
    |   РеализацияТоваровУслуг.Сумма,
    |   0,
    |   NULL,
    |   ЕСТЬNULL(РегистрСведенийРублевыеСуммыДокументовВВалюте.Всего, 0),
    |   ЕСТЬNULL(РегистрСведенийРублевыеСуммыДокументовВВалюте.НДС, 0),
    |   ВЫБОР
    |       КОГДА РегистрСведенийРублевыеСуммыДокументовВВалюте.Регистратор ЕСТЬ NULL 
    |           ТОГДА ЛОЖЬ
    |       ИНАЧЕ ИСТИНА
    |   КОНЕЦ
    |ИЗ
    |   ДокументыДляПечати КАК ДокументыДляПечати
    |       ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.РеализацияТоваровУслуг.ВозвратнаяТара КАК РеализацияТоваровУслуг
    |       ПО ДокументыДляПечати.Ссылка = РеализацияТоваровУслуг.Ссылка
    |       ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведенийРублевыеСуммыДокументовВВалюте КАК РегистрСведенийРублевыеСуммыДокументовВВалюте
    |       ПО (РеализацияТоваровУслуг.Ссылка = РегистрСведенийРублевыеСуммыДокументовВВалюте.Регистратор)
    |           И (РеализацияТоваровУслуг.НомерСтроки = РегистрСведенийРублевыеСуммыДокументовВВалюте.НомерСтрокиДокумента)
    |           И (РегистрСведенийРублевыеСуммыДокументовВВалюте.ТабличнаяЧастьДокумента = ЗНАЧЕНИЕ(Перечисление.ТабличныеЧастиДокументов.ВозвратнаяТара))
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    |   РеализацияТоваровУслуг.Ссылка,
    |   ДокументыДляПечати.ДатаДокумента,
    |   ЗНАЧЕНИЕ(Перечисление.ТабличныеЧастиДокументов.Услуги),
    |   3,
    |   РеализацияТоваровУслуг.НомерСтроки,
    |   РеализацияТоваровУслуг.Номенклатура,
    |   ВЫБОР
    |       КОГДА НЕ РеализацияТоваровУслуг.Содержание ПОДОБНО """"
    |           ТОГДА РеализацияТоваровУслуг.Содержание
    |       КОГДА НЕ РеализацияТоваровУслуг.Номенклатура.НаименованиеПолное ПОДОБНО """"
    |           ТОГДА РеализацияТоваровУслуг.Номенклатура.НаименованиеПолное
    |       ИНАЧЕ РеализацияТоваровУслуг.Номенклатура.Наименование
    |   КОНЕЦ,
    |   ВЫБОР
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул)
    |           ТОГДА РеализацияТоваровУслуг.Номенклатура.Артикул
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Код)
    |           ТОГДА РеализацияТоваровУслуг.Номенклатура.Код
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.НеВыводить)
    |           ТОГДА """"
    |   КОНЕЦ,
    |   РеализацияТоваровУслуг.Количество,
    |   0,
    |   ЕСТЬNULL(РеализацияТоваровУслуг.Номенклатура.ЕдиницаИзмерения, ЗНАЧЕНИЕ(Справочник.КлассификаторЕдиницИзмерения.ПустаяСсылка)),
    |   ЕСТЬNULL(РеализацияТоваровУслуг.Номенклатура.ЕдиницаИзмерения.Код, """"),
    |   ЕСТЬNULL(РеализацияТоваровУслуг.Номенклатура.ЕдиницаИзмерения.Наименование, """"),
    |   NULL,
    |   0,
    |   РеализацияТоваровУслуг.Цена,
    |   ВЫБОР
    |       КОГДА ДокументыДляПечати.СуммаВключаетНДС
    |           ТОГДА РеализацияТоваровУслуг.Сумма - РеализацияТоваровУслуг.СуммаНДС
    |       ИНАЧЕ РеализацияТоваровУслуг.Сумма
    |   КОНЕЦ,
    |   РеализацияТоваровУслуг.СуммаНДС,
    |   РеализацияТоваровУслуг.СтавкаНДС,
    |   ЕСТЬNULL(РегистрСведенийРублевыеСуммыДокументовВВалюте.Всего, 0),
    |   ЕСТЬNULL(РегистрСведенийРублевыеСуммыДокументовВВалюте.НДС, 0),
    |   ВЫБОР
    |       КОГДА РегистрСведенийРублевыеСуммыДокументовВВалюте.Регистратор ЕСТЬ NULL 
    |           ТОГДА ЛОЖЬ
    |       ИНАЧЕ ИСТИНА
    |   КОНЕЦ
    |ИЗ
    |   ДокументыДляПечати КАК ДокументыДляПечати
    |       ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.РеализацияТоваровУслуг.Услуги КАК РеализацияТоваровУслуг
    |       ПО ДокументыДляПечати.Ссылка = РеализацияТоваровУслуг.Ссылка
    |       ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведенийРублевыеСуммыДокументовВВалюте КАК РегистрСведенийРублевыеСуммыДокументовВВалюте
    |       ПО (РеализацияТоваровУслуг.Ссылка = РегистрСведенийРублевыеСуммыДокументовВВалюте.Регистратор)
    |           И (РеализацияТоваровУслуг.НомерСтроки = РегистрСведенийРублевыеСуммыДокументовВВалюте.НомерСтрокиДокумента)
    |           И (РегистрСведенийРублевыеСуммыДокументовВВалюте.ТабличнаяЧастьДокумента = ЗНАЧЕНИЕ(Перечисление.ТабличныеЧастиДокументов.Услуги))
    |ГДЕ
    |   &ВключатьУслуги = ИСТИНА
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    |   РеализацияТоваровУслуг.Ссылка,
    |   ДокументыДляПечати.ДатаДокумента,
    |   ЗНАЧЕНИЕ(Перечисление.ТабличныеЧастиДокументов.АгентскиеУслуги),
    |   4,
    |   РеализацияТоваровУслуг.НомерСтроки,
    |   РеализацияТоваровУслуг.Номенклатура,
    |   ВЫБОР
    |       КОГДА НЕ РеализацияТоваровУслуг.Содержание ПОДОБНО """"
    |           ТОГДА РеализацияТоваровУслуг.Содержание
    |       КОГДА НЕ РеализацияТоваровУслуг.Номенклатура.НаименованиеПолное ПОДОБНО """"
    |           ТОГДА РеализацияТоваровУслуг.Номенклатура.НаименованиеПолное
    |       ИНАЧЕ РеализацияТоваровУслуг.Номенклатура.Наименование
    |   КОНЕЦ,
    |   ВЫБОР
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул)
    |           ТОГДА РеализацияТоваровУслуг.Номенклатура.Артикул
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Код)
    |           ТОГДА РеализацияТоваровУслуг.Номенклатура.Код
    |       КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.НеВыводить)
    |           ТОГДА """"
    |   КОНЕЦ,
    |   РеализацияТоваровУслуг.Количество,
    |   0,
    |   ЕСТЬNULL(РеализацияТоваровУслуг.Номенклатура.ЕдиницаИзмерения, ЗНАЧЕНИЕ(Справочник.КлассификаторЕдиницИзмерения.ПустаяСсылка)),
    |   ЕСТЬNULL(РеализацияТоваровУслуг.Номенклатура.ЕдиницаИзмерения.Код, """"),
    |   ЕСТЬNULL(РеализацияТоваровУслуг.Номенклатура.ЕдиницаИзмерения.Наименование, """"),
    |   NULL,
    |   0,
    |   РеализацияТоваровУслуг.Цена,
    |   ВЫБОР
    |       КОГДА ДокументыДляПечати.СуммаВключаетНДС
    |           ТОГДА РеализацияТоваровУслуг.Сумма - РеализацияТоваровУслуг.СуммаНДС
    |       ИНАЧЕ РеализацияТоваровУслуг.Сумма
    |   КОНЕЦ,
    |   РеализацияТоваровУслуг.СуммаНДС,
    |   РеализацияТоваровУслуг.СтавкаНДС,
    |   ЕСТЬNULL(РегистрСведенийРублевыеСуммыДокументовВВалюте.Всего, 0),
    |   ЕСТЬNULL(РегистрСведенийРублевыеСуммыДокументовВВалюте.НДС, 0),
    |   ВЫБОР
    |       КОГДА РегистрСведенийРублевыеСуммыДокументовВВалюте.Регистратор ЕСТЬ NULL 
    |           ТОГДА ЛОЖЬ
    |       ИНАЧЕ ИСТИНА
    |   КОНЕЦ
    |ИЗ
    |   ДокументыДляПечати КАК ДокументыДляПечати
    |       ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.РеализацияТоваровУслуг.АгентскиеУслуги КАК РеализацияТоваровУслуг
    |       ПО ДокументыДляПечати.Ссылка = РеализацияТоваровУслуг.Ссылка
    |       ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведенийРублевыеСуммыДокументовВВалюте КАК РегистрСведенийРублевыеСуммыДокументовВВалюте
    |       ПО (РеализацияТоваровУслуг.Ссылка = РегистрСведенийРублевыеСуммыДокументовВВалюте.Регистратор)
    |           И (РеализацияТоваровУслуг.НомерСтроки = РегистрСведенийРублевыеСуммыДокументовВВалюте.НомерСтрокиДокумента)
    |           И (РегистрСведенийРублевыеСуммыДокументовВВалюте.ТабличнаяЧастьДокумента = ЗНАЧЕНИЕ(Перечисление.ТабличныеЧастиДокументов.АгентскиеУслуги))
    |ГДЕ
    |   &ВключатьУслуги = ИСТИНА
    |
    |УПОРЯДОЧИТЬ ПО
    |   ДатаДокумента,
    |   Документ,
    |   ПорядокТабличнойЧасти,
    |   НомерСтроки";
    
    Возврат ТекстЗапроса;
    
КонецФункции
 
Функция ПолучитьТаблицуСведенийТОРГ12(Знач МассивДокументов, Знач ВключатьУслуги) Экспорт
    
    ТаблицаСведений = ПечатьТорговыхДокументов.ПолучитьОписаниеТОРГ12();
    
    Запрос = Новый Запрос();
    Запрос.УстановитьПараметр("МассивДокументов",   МассивДокументов);
    Запрос.УстановитьПараметр("ВключатьУслуги",     ВключатьУслуги);
    Запрос.УстановитьПараметр("ДополнительнаяКолонкаПечатныхФормДокументов", Константы.ДополнительнаяКолонкаПечатныхФормДокументов.Получить());
    
    Запрос.Текст = ПолучитьТекстЗапросаДляФормированияТаблицыСведенийТОРГ12();
        
    РезультатыЗапроса = Запрос.ВыполнитьПакет();
    
    ВалютаРегУчета = ОбщегоНазначенияБПВызовСервераПовтИсп.ПолучитьВалютуРегламентированногоУчета();
    РеквизитыВалютыРегУчета = ОбщегоНазначения.ЗначенияРеквизитовОбъекта(ВалютаРегУчета, "Код, Наименование");
    
    Выборка = РезультатыЗапроса[2].Выбрать();
    СтрокиДокументов = РезультатыЗапроса[3].Выгрузить();
    СтрокиДокументов.Индексы.Добавить("Документ");
    
    Пока Выборка.Следующий() Цикл
        
        СведенияОДокументе = ТаблицаСведений.Добавить();
        ЗаполнитьЗначенияСвойств(СведенияОДокументе, Выборка);
        
        СведенияОДокументе.Валюта             = ВалютаРегУчета;
        СведенияОДокументе.ВалютаКод          = РеквизитыВалютыРегУчета.Код;
        СведенияОДокументе.ВалютаНаименование = РеквизитыВалютыРегУчета.Наименование;
        
        ТаблицаДокумента = ПечатьТорговыхДокументов.ПолучитьОписаниеТаблицыТОРГ12();
        
        Отбор = Новый Структура("Документ", Выборка.Документ);
        СтрокиДокумента = СтрокиДокументов.НайтиСтроки(Отбор);
        
        НуженПересчетВРубли = Ложь;
        Если Выборка.ВалютаДокумента <> ВалютаРегУчета Тогда
            НуженПересчетВРубли = Истина;
        КонецЕсли;
        
        Для Каждого Строка Из СтрокиДокумента Цикл
            
            СтрокаТаблицыДокумента = ТаблицаДокумента.Добавить();
            ЗаполнитьЗначенияСвойств(СтрокаТаблицыДокумента, Строка);
            
            Если НуженПересчетВРубли Тогда
                Если Строка.СуществуютЗаписиРублевыхСумм Тогда
                    СтрокаТаблицыДокумента.СуммаНДС     = Строка.НДСВРублях;
                    СтрокаТаблицыДокумента.СуммаБезНДС  = Строка.ВсегоВРублях - Строка.НДСВРублях;
                Иначе
                    Кратность = ?(Выборка.Кратность     = 0, 1, Выборка.Кратность);
                    СтрокаТаблицыДокумента.СуммаНДС     = Строка.СуммаНДС * Выборка.Курс / Кратность;;
                    СтрокаТаблицыДокумента.СуммаБезНДС  = (Строка.СуммаБезНДС + Строка.СуммаНДС) * Выборка.Курс / Кратность - СтрокаТаблицыДокумента.СуммаНДС;
                КонецЕсли;
            КонецЕсли;
            СтрокаТаблицыДокумента.СуммаСНДС = СтрокаТаблицыДокумента.СуммаБезНДС + СтрокаТаблицыДокумента.СуммаНДС;
            СтрокаТаблицыДокумента.Цена      = ?(СтрокаТаблицыДокумента.Количество = 0, СтрокаТаблицыДокумента.СуммаБезНДС, 
                                                        СтрокаТаблицыДокумента.СуммаБезНДС / СтрокаТаблицыДокумента.Количество);
        КонецЦикла;
        
        СведенияОДокументе.ТаблицаДокумента = ТаблицаДокумента;
        
        ПорядокЗаполнения = Новый Структура("ЗаполнятьРуководителя, ЗаполнятьГлавногоБухгалтера, ЗаполнятьКладовщика");
        ПечатьТорговыхДокументов.ЗаполнитьДанныеОтветственныхЛиц(СведенияОДокументе, ПорядокЗаполнения);
    
    КонецЦикла;
    
    Возврат ТаблицаСведений;
    
КонецФункции
0
wladimir_ui
Шизофреник
358 / 361 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
20.02.2014, 12:56 #6
Макет = УправлениеПечатью.ПолучитьМакет("ТОРГ12_Внешняя");
поменяй на
Макет = ПолучитьМакет("ИмяТвоегоМакетаВоВнешнейОбработке");
0
Gibsonius
4 / 4 / 1
Регистрация: 26.09.2012
Сообщений: 27
20.02.2014, 13:52  [ТС] #7
Цитата Сообщение от wladimir_ui Посмотреть сообщение
Макет = УправлениеПечатью.ПолучитьМакет("ТОРГ12_Внешняя");
поменяй на
Макет = ПолучитьМакет("ИмяТвоегоМакетаВоВнешнейОбработке");
Без изменений осталось ((
0
Вложения
Тип файла: rar МАГЛин.rar (22.1 Кб, 257 просмотров)
wladimir_ui
Шизофреник
358 / 361 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
20.02.2014, 15:15 #8
1C
1
2
3
Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
    ПечатьДокумента(МассивОбъектов, ОбъектыПечати)
КонецПроцедуры
Вот так заработает содержимое процедуры "ПечатьДокумента". Но код из "ПечатьДокумента" - не взлетит, он собирает какой то левый макет, а вовсе не тот, что у тебя в обработке
0
Desc84
0 / 0 / 0
Регистрация: 03.03.2014
Сообщений: 24
03.03.2014, 12:46 #9
Ребят, я новичок еще в 1с, вот что то по пробовал сделать внешнюю Форму , подскажите что не так с ней?
0
wladimir_ui
Шизофреник
358 / 361 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
03.03.2014, 13:14 #10
все не так, не взлетит даже в БП2.0.
Вы просто скопировали макет и код функции.

Добавлено через 2 минуты
если для 2.0 вояешь:
в ВПФ в модуле должна быть - Функция Печать() экспорт
а в реквизитах -СсылкаНаОбъект с типом ДокументСсылка.ХХХХХХХХ

Добавлено через 3 минуты
в Функция Печать() запихивай свой код и дорабатывай напильником с учетом того, что при подключении/использовании в реквизите СсылкаНаОбъект - будет сидеть ссылка на тот док, с которого будешь юзать свою ВПФ

Добавлено через 4 минуты
если БП3.0 - скопируй хотя бы вложение ТС МАГЛин.rar - и допиливай его
0
Desc84
0 / 0 / 0
Регистрация: 03.03.2014
Сообщений: 24
03.03.2014, 14:51 #11
Что то на корулесил... а может у вас есть ссылка с мануалом как это сделать
0
Вложения
Тип файла: 7z ТОРГ12Внешняя.7z (121.4 Кб, 136 просмотров)
Desc84
0 / 0 / 0
Регистрация: 03.03.2014
Сообщений: 24
03.03.2014, 14:52 #12
Делаю для БП 3.0 . А у вас нету случаем ссылки на мануал как сотворить обработку? что то до ковырял гляньте, если не сложно
0
wladimir_ui
Шизофреник
358 / 361 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
03.03.2014, 20:31 #13
глянул то, что первый раз выложено было (и скоропостижно удалено) - комментарии и рекомендации в предыдущем моем посте.


Цитата Сообщение от Desc84 Посмотреть сообщение
что то до ковырял гляньте, если не сложно
вы издеваетесь?
даже если вам нагуглить и дать мануал, что это изменит?
"что то до ковырял гляньте" будет до последней точки с запятой от вас сыпаться.
Для "Ребят, я новичок еще в 1с" начинать надо вовсе не с ВПФ.
Либо беритесь за литературку, с ноля, и, возможно, будет толк. Либо вернитесь обратно к "согласен - далее - далее - не устанавливать яндексбар - готово".
0
boooring
0 / 0 / 1
Регистрация: 02.10.2014
Сообщений: 3
12.11.2014, 13:30 #14
Здравствуйте, извините за оффтопик, но мне нужна ваша помощь по одной задачи на С++. вы на другом ресурсе опубликовывали ее решение, но у меня компилятор ругается на ваш код. Задача Анализ ситуации на шахматном поле.
http://forum.codenet.ru/q73599/%D0%9...BE%D0%BB%D0%B5.

Добавлено через 51 минуту
Gibsonius, Здравствуйте, извините за оффтопик, но мне нужна ваша помощь по одной задачи на С++. вы на другом ресурсе опубликовывали ее решение, но у меня компилятор ругается на ваш код. Задача Анализ ситуации на шахматном поле.
http://forum.codenet.ru/q73599/%D0%9...BE%D0%BB%D0%B5.
0
12.11.2014, 13:30
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
12.11.2014, 13:30

БП 3.0 Внешняя печатная форма для выгрузки ворд
Мне нужно из док. ПоступлениеТоваровУслуг сделать ВПФ договора в ворд. В модуле...

Внешняя печатная форма
Добрый вечер, люди добрые подскажите пожалуйста в чем проблема. Создаю внешнюю...

Внешняя печатная форма
Добрый вечер взялся по работе сделать ВПФ СчетНаОплатуПокупателю с печатью и...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
14
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru