Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Типовые и стандартные решения
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.79/68: Рейтинг темы: голосов - 68, средняя оценка - 4.79
Gokusa
Заблокирован
1

Раскрасить строки табличной части обычное приложение

08.04.2014, 16:05. Просмотров 12638. Ответов 13
Метки нет (Все метки)

Всем привет,
задача раскрасить некоторые строки табличной части.
как это можно сделать в обычном приложении.
1C
1
ЭлементыФормы.ИмяТабчасти.текущаястрока
а дальше не понятно как установить именно для этой строки какие-то настройки оформления.

Добавлено через 6 минут
натолкнулся на Оформлениестроки, но в описании написано что оно вступает в силу только после выполнения обработчиков присоздании и при заполнении.
а мне нужно в НекоейПроцедуре связать записи из некоторых уже отображенных списков, отображенные в таблиичных полях и связанные записи отметить допустим цветом.
т.е. перезаписывать или пересоздавать ранее отображенные списки не планируется.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
08.04.2014, 16:05
Ответы с готовыми решениями:

Запрос. Условие: строка из первой табличной части равна любой строке из другой табличной части
Есть документ "РаспределениеМатериаловНаВыпуск". У этого документа имеется "Форма документа". На...

Выделение строки табличной части
Что нужно сделать, что бы при клике мышкой по строке табличной части документа вся строка...

Скрыть некоторые строки табличной части
Возможно ли каким нибудь образом отображать только некоторые строки ТабЧасти, а не все? Или это...

Цвет строки табличной части документа
Такая ситуация, я пока что новичек в этом деле вот и обращаюсь к спецам...Прошу помощи, мне нужно...

7.7. Скрытые строки в табличной части документа
Вот у меня заказчик что придумал : Для некоторых пользователей закрыть часть строк в ТЧ (целиком...

13
wladimir_ui
Шизофреник
358 / 361 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
08.04.2014, 16:56 2
как то так: событие "приВыводеСтроки"...

Добавлено через 7 минут
угу, тчн
1C
1
2
3
Процедура ИмяСпрПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    // Вставить содержимое обработчика.
КонецПроцедуры
у тч толстого есть событие - сотвори его и вояй чего хош
0
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
08.04.2014, 17:06 3
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
Процедура ЗаявкиКлиентаПриПолученииДанных(Элемент, ОформленияСтрок)
Для каждого ОформлениеСтроки из ОформленияСтрок Цикл
//ф=РаботаСДиалогами.ПолучитьТекстСчетаФактуры(УчетНДС.НайтиПодчиненныйСчетФактуру(ОформлениеСтроки.ДанныеСтроки.Ссылка,"СчетФактураВыданный"));
//ОформлениеСтроки.Ячейки.СчетФактура.УстановитьТекст(?(ф="Ввести счет-фактуру","",ф));
//ЦветПогрузка=Новый Цвет(204, 255, 204 );
//ЦветФона=Новый Цвет(255, 255, 255 );
//Ф=?(ЯЗСК.ДаПогрузка(ОформлениеСтроки.ДанныеСтроки.Ссылка),204,255);
//ОформлениеСтроки.ЦветФона=Новый Цвет(р,г,б);
    Если ОформлениеСтроки.ДанныеСтроки.Ссылка.Оплачено Тогда
    //ЦветФона=Новый Цвет(100,255,100);
    ЦветФона=Новый Цвет(176,196,222);
    Иначе
    ЦветФона=Новый Цвет(255, 255, 255 );
    КонецЕсли;
ОформлениеСтроки.ЦветФона=ЦветФона;
//кр= 255, 100,100
//зел= 100, 255, 100
//жел= 255, 255, 100
//255, 204, 153
КонецЦикла;
КонецПроцедуры
Добавлено через 19 секунд
под рукой оказалась
0
Gokusa
Заблокирован
08.04.2014, 17:14  [ТС] 4
не совсем понимаю.
какое событие может отработать чтение данных из табличного поля?
0
08.04.2014, 17:14
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
08.04.2014, 17:15 5
событие ПриПолученииДанных ткни
1
wladimir_ui
Шизофреник
358 / 361 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
08.04.2014, 17:24 6
ткни в лупу понравившегося события: либо как Дюк предложил: при получении данных раскрашивать, либо при выводе строки(как я) - все зависит от объема данных таблицы - выбирать тебе
0
Миниатюры
Раскрасить строки табличной части обычное приложение  
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
08.04.2014, 17:44 7
Цитата Сообщение от wladimir_ui Посмотреть сообщение
все зависит от объема данных таблицы
я как ни тестил (правда чисто визуально и по вызовам, без системного хронометража), не нашёл разницы: то, что довыводится, то и обрабатывается. Преимущество в вызове: один раз, но в цикле, либо сколько строк, столько вызовов. По времени не уловить разницы.
0
Gokusa
Заблокирован
08.04.2014, 18:07  [ТС] 8
не работает.
работает как условное заполнение и при первоначальном и при непервоначальном заполнениях.
мне нужно чтобы при первоначальной записи строки были чистые одинаковые.
а после выполнения некоторого действия по кнопке например, часть из них раскрасилась или изменилась как-то иначе.
т.е. первая загрузка данных не должна никак обрабатываться.
а вот их обработка должна.
////////////
или я опять туплю?

Добавлено через 2 минуты
Дюк, вы предложили мне условное оформление,типа если поле из таблицы заполнено то меняет или не меняем.
а я хочу так:
выделяю пять строк из ТЧ, выделяю 3 строки из другой ТЗ.
нажимаю кнопку на форме и
5 строк из первой ТЧ и 3 строки из втрой поменяли цвет,
причем их данные не изменились.
0
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
08.04.2014, 18:22 9
либо меняется реквизит дока, либо отметку можно записать в регистр сведений. С реквизитом - надо записывать док. С РС - при удалении дока чистить. У меня на довольно крупном предприятии список реализаций раскрашен в четыре цвета, по кнопочкам пишется в регистр цвет, при получении данных читается. Ничего так, сносно пашет.
0
Gokusa
Заблокирован
08.04.2014, 18:47  [ТС] 10
p/s/ мужики, чета цены по 1с вообще копеечные по москве.
программисты чейта не ценят свой труд вообще.
такое ощущение что они не в этом мире живут, сраные менеджеры на кайенах ездят , а программеры на лисапедах,роликах и метре
пиздоси бля.
обыдно
з.ы. я когда говорю что можно напилить, наштробить, нагипсокартонить на 30 000 руб в день никто в офисе не верит

Добавлено через 11 минут
з.ы. можно даже шлангов продать на 150 000 руб. чистой маржи в день.
при подготовке сделки 1 день, а программеры все "наборызаписей, рекурсия, релятивистская теория, заменил подшипники в каретке"
0
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
08.04.2014, 20:42 11
эка прорвало! Есть же разделы для таких порывов. Мне 150 крублей предлагали, а я не согласился. Не об этом речь по жизни вообще. Деньги делать - а их нельзя заработать, можно только сделать - жутко неинтересно. Ты сам как он есть - самая интересная вещь в жизни.
0
Dethmontt
Модератор
Эксперт 1С
2672 / 2455 / 425
Регистрация: 10.03.2011
Сообщений: 8,799
Записей в блоге: 1
Завершенные тесты: 1
09.04.2014, 23:51 12
ПриПолученииДанных или ПриВыводеСтроки

Только в этих процедурах можно красить строки
0
Gokusa
Заблокирован
18.04.2014, 17:47  [ТС] 13
Цитата Сообщение от duk337 Посмотреть сообщение
Есть же разделы для таких порывов.
че за разделы такие, подскажите мне - малограммногму
0
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
18.04.2014, 18:04 14
Цитата Сообщение от Gokusa Посмотреть сообщение
че за разделы такие
http://www.cyberforum.ru/holywars/ к примеру

Добавлено через 2 минуты
http://www.cyberforum.ru/dump/ короче, в основном тут копья трещат
0
18.04.2014, 18:04
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
18.04.2014, 18:04

Заполнение табличной части одного документа из табличной части этого же документа
Здравсвуйте. 1С 8.2. Есть документ в этом документе 2 табличные части В 1 табличной части...

Заполнение табличной части одного документа из табличной части другого документа
Здравсвуйте. 1С 8.2. Есть документ Приход и документ Расход. Оба документа имеют табличные части -...

Программно очистить строки табличной части документа ПереносДанных (ЗУП 2.5)
Добрый день.Возникла необходимость программно почистить данный документ. Суть в следующем: были...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
14
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru