Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Типовые и стандартные решения
Войти
Регистрация
Восстановить пароль
 
Roman2408
4 / 4 / 1
Регистрация: 04.04.2013
Сообщений: 111
1

БП 3.0. Очистка выпадающего списка поля табличной части документа

15.11.2016, 18:31. Просмотров 296. Ответов 0
Метки нет (Все метки)

Всем привет! БП 3.0, платформа 8.3. Такая проблема: В табличной части документа есть колонки "Поставщик"(тип СправочникСсылка.Контрагенты) и "Партия"(тип СправочникСсылка.ДоговорыКонтрагента). Нужно очищать Партию при изменении Поставщика. Это я сделал, НО! Когда начинаешь выбирать Партию, то в выпадающем списке вылезают старые договоры, использованные ранее для других контрагентов. И их можно выбрать. Когда нажимаю "Показать все", то форма выбора договоров открывается как положено, с отбором по текущему контрагенту. Но вот этот список напрягает. Подскажите, как сделать так, чтобы он автоматом очищался?
В процедуре "ЗаполнитьСписокВыбора" список задается пустой, но в реале все равно вылезают последние использованные значения.
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
&НаКлиенте
Процедура ТоварыПоставщикПриИзменении(Элемент)
    ОчисткаДоговора = ПодготовитьОчисткуПартии();
    ЗаполнитьЗначенияСвойств(ТекущийЭлемент.ТекущиеДанные, ОчисткаДоговора);
КонецПроцедуры
    
&НаСервере
Функция ПодготовитьОчисткуПартии()
    ОчистимПартию = Новый Структура("Партия",Справочники.ДоговорыКонтрагентов.ПустаяСсылка());
    Возврат ОчистимПартию
КонецФункции
 
 
 
&НаКлиенте
Процедура ТоварыПартияАвтоПодбор(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, Ожидание, СтандартнаяОбработка)
    КонтрагентБезДоговоров=Ложь;
    СтандартнаяОбработка = Ложь;
    РаботаСДоговорамиКонтрагентовБПКлиент.ЗаполнитьСписокВыбора(Элемент, Текст, КонтрагентБезДоговоров, СтандартнаяОбработка);
КонецПроцедуры

это процедура из общего модуля:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
Процедура ЗаполнитьСписокВыбора(ЭлементФормыСписка, Текст, КонтрагентБезДоговоров, СтандартнаяОбработка) Экспорт
    
    СписокВыбора = ЭлементФормыСписка.СписокВыбора;
    
    Если СписокВыбора.Количество()> 0 Тогда
        СписокВыбора.Очистить();
    КонецЕсли;
    
    Если ПустаяСтрока(Текст) И КонтрагентБезДоговоров Тогда
        
        СписокВыбора.Добавить("БезДоговора", "Без договора");
        СписокВыбора.Добавить("НовыйДоговор", "Создать договор ...");
        
    КонецЕсли;
    
КонецПроцедуры
0
Миниатюры
БП 3.0. Очистка выпадающего списка поля табличной части документа  
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
15.11.2016, 18:31
Ответы с готовыми решениями:

Заполнение Табличной Части документа из Табличной Части другого документа
Здравсвуйте. 1С 8.2 Есть два документа ТоварнаяНакладная.Накладная с...

Автозаполнения поля в табличной части документа
Ребят, уже который день ломаю голову над одной из проблем по конфигурированию в...

Заполнение табличной части одного документа из табличной части другого документа
Здравсвуйте. 1С 8.2. Есть документ Приход и документ Расход. Оба документа...

Заполнение табличной части одного документа из табличной части этого же документа
Здравсвуйте. 1С 8.2. Есть документ в этом документе 2 табличные части В 1...

Поиск в табличной части документа из формы списка
Версия 8.1. В 1С я только начинаю, путевой литературы мало, так-что вопрос...

0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
15.11.2016, 18:31

Обход табличной части документа
Вопрос не новый, но все-таки я много бродил оп Интернет и не нашел рабочий...

Флажёк в табличной части документа
Всем здравствуйте. Пытаюсь в табличной части документа поставить поле с флажком...

Обратиться к табличной части документа. УТ 11.1
Мне необходимо построить отчет по РН Выручка и себестоимостьПродаж. Из...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
1
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru