Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Типовые и стандартные решения
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/6: Рейтинг темы: голосов - 6, средняя оценка - 4.67
Tatiana21
0 / 0 / 0
Регистрация: 01.11.2015
Сообщений: 121
1

Создание записи в непериодическом регистре сведений при записи элемента справочника

03.04.2017, 10:17. Просмотров 1247. Ответов 2

Всем привет!
Платформа 1С:Предприятие 8.3, конфигурация редактированная типовая, режим неуправляемый.
Имеется справочник Контрагенты с табличной частью ПунктыВыгрузки: КонечныйГрузополучатель, МестоВыгрузки, Регион, Город, УлицаИДом, КонтактноеЛицоВыгрузки, ТелефонВыгрузки. Необходимо при записи (или перед записью) элемента справочника создать новую запись в регистре сведений ПунктыДоставкиКонтрагента (непериодический, независимый): измерения - Контрагент, ресурсы - КонечныйГрузополучатель, МестоВыгрузки, Регион, Город, УлицаИДом, КонтактноеЛицоВыгрузки, ТелефонВыгрузки. В результате выполнения следующего кода записывается только последняя строка табличной части:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
&НаСервере
Процедура ПередЗаписью(Отказ)
    
    Для Каждого Строка Из ЭтотОбъект.ПунктыВыгрузки Цикл 
        Контрагент = ЭтотОбъект.Наименование;
        КонечныйГрузополучатель = Строка.КонечныйГрузополучатель;
        Страна = Строка.МестоВыгрузки;
        Регион = Строка.Регион;
        Город = Строка.Город;
        УлицаИДом = Строка.УлицаИДом;
        КонтактноеЛицоВыгрузки = Строка.КонтактноеЛицоВыгрузки;
        ТелефонВыгрузки = Строка.ТелефонВыгрузки;
        ОбновитьПунктыДоставки(ЭтотОбъект, Контрагент, КонечныйГрузополучатель, Страна, Регион, Город, УлицаИДом, КонтактноеЛицоВыгрузки, ТелефонВыгрузки);
    КонецЦикла;
    
КонецПроцедуры
 
&НаСервере
Процедура ОбновитьПунктыДоставки(ЭтотОбъект, Контрагент, КонечныйГрузополучатель, Страна, Регион, Город, УлицаИДом, КонтактноеЛицоВыгрузки, ТелефонВыгрузки)
    
    Запись = РегистрыСведений.ПунктыДоставкиКонтрагента.СоздатьМенеджерЗаписи();
        Запись.Контрагент = Контрагент;
        Запись.КонечныйГрузополучатель = КонечныйГрузополучатель;
    Запись.Страна = Страна;
    Запись.Регион = Регион;
    Запись.Город = Город; 
    Запись.УлицаИДом = УлицаИДом;
    Запись.КонтактноеЛицоВыгрузки = КонтактноеЛицоВыгрузки;
    Запись.ТелефонВыгрузки = ТелефонВыгрузки;
        Запись.Записать();
    
КонецПроцедуры
Код написан в модуле объекта справочника Контрагенты. Может кто подскажет, что не так? Заранее спасибо)
0
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
03.04.2017, 10:17
Ответы с готовыми решениями:

Не выбран элемент при записи реквизита справочника из обработки проведения документа
Требуется из обработки проведения документа внести изменения в справочник, Процедура...

Одинаковые записи в регистре
Всем добрый день! Собственно, вопрос в теме :) Есть непериодический независимый регистр сведений...

Откуда берутся записи в регистре ЗначенияПоказателейОтчетности
УНФ 1.6.13 Врут показатели оплаты налогов по страховым взносам за себя ИП на ЕНВД. Началось с...

1С8. Не добавляются записи в регистр сведений.
В переменной Городская храню предопределённый элемент справочника Подразделения. В справочнике...

Недоступность записи периодической константы при запрете записи истории
Необходимо заблокировать редактирование истории значения для константы, но при этом разрешить...

2
GreenkA
Форумчанин
Эксперт 1С
2996 / 1926 / 520
Регистрация: 25.06.2009
Сообщений: 6,802
03.04.2017, 10:31 2
Лучший ответ Сообщение было отмечено GreenkA как решение

Решение

Tatiana21, а вы не думали, что мало измерений создали в регистре сведений? Только Контрагент.
С учетом того, что регистр сведений непериодический для каждого Контрагента будет храниться только один набор заданных ресурсов, в другом случае все будет перезаписываться и снова - для каждого Контрагента только один набор ресурсов.
1
Tatiana21
0 / 0 / 0
Регистрация: 01.11.2015
Сообщений: 121
03.04.2017, 10:49  [ТС] 3
Кстати да)) добавила в измерение Конечный грузополучатель и нормально записывает. Большое спасибо!
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
03.04.2017, 10:49

Удаление записи из справочника
привет всем. помогите пж. есть справочник (СОТРУДНИКИ) - со всеми необходимыми полями. мне...

Удалнеие записи из справочника
требуется удалить записи из справочника НоменклатурныеГруппы. Выборка =...

Записи регистра сведений стали не уникальными: ЗамерыВремени
1С:УТАП 11.2.3.300 Перехожу с 1С:УТАП 11.2.3.300 на 11.3.3.196 обновлением. При обновлении...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru