Форум программистов, компьютерный форум, киберфорум
Наши страницы

1С: Типовые и стандартные решения

Войти
Регистрация
Восстановить пароль
 
barracuda1991
1 / 1 / 1
Регистрация: 30.07.2015
Сообщений: 91
Завершенные тесты: 1
#1

Не работает выгрузка файлов на клиенте (веб-браузер) - 1С/1C 8.x

13.12.2017, 16:10. Просмотров 115. Ответов 1
Метки нет (Все метки)

Нетиповая самописная конфигурация, 1С:Предприятие 8.3 (8.3.7.1917)
Добрый день. При попытке выгрузить фото в 1С, запущенной в веб-браузере, при попытке установить расширение 1С отображается ошибка Google Chrome (ошибка сети) - фото во вложении.
В самой конфигурации написан следующий код:

1C
1
2
3
4
5
6
7
8
9
10
11
&НаКлиенте
Процедура ВыгрузитьФото(Команда)
    Если Элементы.ГруппаСтраницы.ТекущаяСтраница <> Элементы.СтраницаАнкеты Тогда
        Возврат;
    КонецЕсли;
#Если Не МобильноеПриложениеКлиент И ВебКлиент Тогда
    НачатьПодключениеРасширенияРаботыСФайлами(Новый ОписаниеОповещения("ПослеПодключения", ЭтотОбъект));
#Иначе
    ВыгрузитьФотоНаКлиенте();
#КонецЕсли
КонецПроцедуры
1C
1
2
3
4
5
6
7
8
9
10
11
&НаКлиенте
Процедура ВыгрузитьФотоНаКлиенте()
#Если Не МобильноеПриложениеКлиент Тогда    
    МассивФайлов = ВыгрузитьФотоНаСервере();
    Если МассивФайлов.Количество() > 0 Тогда
        ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.ВыборКаталога);
        ДиалогОткрытияФайла.Заголовок = "Выберите папку";
        НачатьПолучениеФайлов(Новый ОписаниеОповещения("ПослеПолучения", ЭтаФорма), МассивФайлов, ДиалогОткрытияФайла);
    КонецЕсли;
#КонецЕсли
КонецПроцедуры
Помогите пожалуйста, разобраться, в чем может быть причина.
0
Миниатюры
Не работает выгрузка файлов на клиенте (веб-браузер)   Не работает выгрузка файлов на клиенте (веб-браузер)   Не работает выгрузка файлов на клиенте (веб-браузер)  

Не работает выгрузка файлов на клиенте (веб-браузер)   Не работает выгрузка файлов на клиенте (веб-браузер)  
Изображения
 
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
13.12.2017, 16:10
Здравствуйте! Я подобрал для вас темы с ответами на вопрос 1C 8.x Не работает выгрузка файлов на клиенте (веб-браузер) (1С):

1C 8.x (тонкий) Поле табличного документа недоступно для редактирования в веб-клиенте - 1С
Добрый день! Конфигурация 1С:Бухгалтерия 3.0 Возникла такая проблема. Есть обработка, на форме которой размещено поле табличного...

Выгрузка данных в dbf файл: обработка выборки запроса на сервере, запись файла - на клиенте. - 1С
Добрый день. Пишу процедуру выгрузки данных в dbf файл. Запрос выполняется НаСервере, а остальной код должен выполняться НаКлиенте....

Загрузка из Blob на сервере Excel файла и выгрузка его в память с целью вывода на клиенте для просмотра - Delphi БД
Здравствуйте, есть следующая функция //Загрузка файла из таблицы BLOBS function GetBLOBSFile(id : Integer; FilePath : String = '')...

Форма на веб и в клиенте - Lotus
Есть две формы, одна для отображения документа в броузере, другая -- в клиенте. Имеют один и тот же алиас, первой сказано быть скрытой от...

Веб-браузер, парсинг в общем работа с веб-страничками! - C++ Builder
Здраствуйте! Вот тут решил попрактиковаться в работе с WebBrowser.. Постановка задачи: Открыл я свой браузер открыл страницу:...

1С Web Вставить скриншот в 1С в веб-клиенте - 1С
Добрый день. На данный момент для тонкого клиента используется следующая процедура для вставки скриншота из буфера обмена: #Если не...

1
_ЕГОР_
28 / 28 / 5
Регистрация: 26.02.2010
Сообщений: 202
14.12.2017, 07:30 #2
А просто без 1с пробовали установить расширение?
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
14.12.2017, 07:30
Привет! Вот еще темы с ответами:

1С Web Модальные окна в веб-клиенте - 1С
Доброе утро! Столкнулись с проблемой с модальными окнами в веб клиенте. В конфигурации они разрешены, в настройках хрома тоже, но все равно...

Встроенный в PSPad editor браузер выдаёт ошибку: Веб-сайт отклонил запрос на отображение веб-страницы - PHP
навеяло отсюда http://www.cyberforum.ru/php-beginners/thread726600.html#post4937346 Ребят, а в чём у меня может быть косяк, при выводе...

Отображение файлов сервера, на клиенте - C# WCF
Потребовалось написать клиент-серверную программу. Подумал, раз уж такие дела, возьму ка я WCF и разберусь. За полдня разобрался. Сделал...

Распределение разных типов файлов по разным ListBox в FTP-клиенте - Visual Basic .NET
Доброго времени суток! Это код FTP клиента Imports System.Net Imports System.IO Public Class Form1 Private Sub...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.