Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Типовые и стандартные решения
Войти
Регистрация
Восстановить пароль
 
monikamo
0 / 0 / 0
Регистрация: 05.01.2019
Сообщений: 7
1

Модуль формы документа

17.01.2019, 13:30. Просмотров 246. Ответов 0
Метки нет (Все метки)

У меня есть справочник "Дисконтные карты" (владелец справочника Справочник.Контрагенты, т.к. для каждого покупателя заводится дисконтная карта) с реквизитом "Основная скидка"- тип СправочникСсылка.Скидки, справочник Скидки имеет три предопределенных элемента: "Обычная карта10" "Серебряная карта20" и "Золотая карта30". Мне нужно, чтобы в документ "ВыдачаТоваров" при выборе контрагента и принадлежащей ему дисконтной карты в табличную часть "Товары" автоматически подставлялся процент скидки по карте. Помогите пожалуйста разобраться

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
&НаСервере
Функция ПолучитьЗначениеРеквизитаНаСервере(ТекОбъект)
    Возврат ТекОбъект.ОсновнаяСкидка;
КонецФункции
 
&НаКлиенте
Процедура ДисконтнаяКартаПриИзменении(Элемент)
    ТекСтрока = Элементы.Товары.ТекущиеДанные;
    ТекСтрока.Скидка = ПолучитьЗначениеРеквизитаНаСервере(ТекСтрока.Скидка);
    ТоварыСкидкаПриИзменении(Элемент);
КонецПроцедуры
 
&НаСервере
Функция ПолучитьСуммуСкидки(Скидка)
    Если Скидка=Справочники.Скидки.ОбычнаяКарта10 Тогда
        Возврат 10;
    ИначеЕсли Скидка=Справочники.Скидки.СеребрянаяКарта20 Тогда
        Возврат 20;
    ИначеЕсли Скидка=Справочники.Скидки.ЗолотаяКарта30 Тогда
        Возврат 30;
    Иначе
        Возврат 0;
    КонецЕсли;
КонецФункции
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
17.01.2019, 13:30
Ответы с готовыми решениями:

Печатные формы: вывод табличного документа без формы.
Всем добрый день!:) Простите за глупый вопрос, но с печатными формами мало имела дел. Мне нужно...

Модуль формы и общий модуль
Приложен скриншот. Строка "Сумма" должна реагировать на изменения "Количество" и "Цена". Но...

Вывод формы документа
Здравствуйте, не могли бы вы помочь, у меня есть документ в который мы вносим оценки. У меня вопрос...

Элементы документа из другой формы
8.2 Управляемое приложение Управление небольшой фирмой в общем нужно из просто отдельной формы...

Разбиение формы документа на группы
Здравствуйте, хотел бы узнать как разбить документ, как изображено на прикреплённом файле

0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
17.01.2019, 13:30

Вывод надписи из формы документа на печать
Добрый день! Программа УТ 11.3 На форму документа формируется запросом и выводится текст (он...

Автозаполнение полей формы документа при открытии
Здравствуйте. Помогите разобраться, как открыть новый документ с заполоненным полем отбора по...

Как добавить реквизит на макет для печатной формы документа
Есть документ, использовала конструктор печати, и вынесла все необходимые реквизиты. Но в процессе...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
1
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru