Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Типовые и стандартные решения
Войти
Регистрация
Восстановить пароль
 
никмейн
1 / 1 / 1
Регистрация: 24.10.2016
Сообщений: 355
1

Макеты в 1с 8.3

22.08.2019, 22:09. Просмотров 434. Ответов 6
Метки нет (Все метки)

Надо создать условие при котором если указывается организация ИП, то в макете в области заголовке указывается один текст, если указывается организация ООО, а другой в этом же макете указывается уже другой текст. Как написать условия
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
22.08.2019, 22:09
Ответы с готовыми решениями:

макеты в 1с
можно ли в макет вставить поле выбора? я поискала, вроде не нашла ничего подобного

Макеты
У меня есть печатная форма кредитного документа..мне надо чтобы одна область "ПОДВАЛ" выводилась...

Макеты 1С
Всем доброе утро! Такой вопрос - нужно создать макет. Точнее, сам макет есть, теперь его нужно...

Макеты печатных форм
Добрый день!Не могли бы Вы посоветовать как мне лучше поступить? В программе Управление Торговлей...

Общие макеты Word, Редактирование
Добрый вечер, извиняюсь за занудство, но повесили на меня 1с без знания и нормального обучения. ...

6
Yulunga
445 / 316 / 80
Регистрация: 22.04.2013
Сообщений: 2,025
Записей в блоге: 1
Завершенные тесты: 1
23.08.2019, 06:35 2
1C
1
2
3
если объект.организация.методорганизации = "ИП" тогда параметры.заголовок = "один текст"
иначе если объект.организация.методорганизации = "ООО" тогда параметры.заголовок = "уже другой текст"
иначе параметры.заголовок = "ой"
0
_ЕГОР_
Тест
Эксперт 1С
378 / 160 / 55
Регистрация: 26.02.2010
Сообщений: 1,205
23.08.2019, 07:39 3
краткий курс операторов сравнения в языке 1с...
0
Xomych
814 / 621 / 102
Регистрация: 01.11.2012
Сообщений: 2,264
23.08.2019, 16:14 4
Или просто сделать две области, если надо красиво текст заделать, и выводить разные по условию юрлица.
0
QwertyZ
97 / 84 / 30
Регистрация: 07.05.2016
Сообщений: 328
24.08.2019, 09:20 5
никмейн,
надеюсь конфа самописная, а не типовая?
в типовых на УФ там все это есть и велосипед не нужен

Добавлено через 11 минут
+ в печатной форме счета на оплату
0
никмейн
1 / 1 / 1
Регистрация: 24.10.2016
Сообщений: 355
24.08.2019, 20:13  [ТС] 6
Цитата Сообщение от QwertyZ Посмотреть сообщение
надеюсь конфа самописная, а не типовая?
да, самописная
0
никмейн
1 / 1 / 1
Регистрация: 24.10.2016
Сообщений: 355
27.08.2019, 10:40  [ТС] 7
Цитата Сообщение от Xomych Посмотреть сообщение
выводить разные по условию юрлица.
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
&НаСервере 
Функция СформироватьДоговорПрицеп() 
ТабличныйДокумент = Новый ТабличныйДокумент; 
ОтчетОбъект = РеквизитФормыВЗначение("Объект"); 
МакетОбработки = ОтчетОбъект.ПолучитьМакет("Прицеп"); 
//МакетОбработки = ПолучитьМакетНаСервере(); 
////заполняем шапку 
ОбластьШапка = МакетОбработки.ПолучитьОбласть("Шапка"); 
ОбластьШапка.Параметры.ТекДата = Формат(ЭтотОбъект.ТекДата, "ДЛФ=ДД"); 
Если ЗначениеЗаполнено(объект.Договор) Тогда 
ОбластьШапка.Параметры.Ном = Число(Прав(Объект.Договор.Код,3)); 
КонецЕсли; 
ТабличныйДокумент.Вывести(ОбластьШапка); 
 
Если ТипЗнч(Объект.Покупатель) = Тип("СправочникСсылка.ФизическиеЛица") Тогда 
ОбластьТело = МакетОбработки.ПолучитьОбласть("Тело"); 
ОбластьТело.Параметры.ПродавецФИО = Объект.Продавец; 
//ОбластьТело.Параметры.ФИОДиректора = СклонениеПредставленийОбъектов.ПросклонятьФИО(Объект.Продавец.Руководитель,2,,); 
ОбластьТело.Параметры.ОГРН = Объект.Продавец.ОГРН; 
ОбластьТело.Параметры.ПокупательФИО = Объект.Покупатель; 
ОбластьТело.Параметры.ПокупательАдрес = Объект.Покупатель.А_Адрес; 
ОбластьТело.Параметры.ПокупательСерия = Объект.Покупатель.А_СерияПаспорта; 
ОбластьТело.Параметры.ПокупательНомер = Объект.Покупатель.А_НомерПаспорта; 
ОбластьТело.Параметры.ПокупательВыданДата = Формат(Объект.Покупатель.А_ДатаВыдачи,"ДЛФ=Д"); 
ОбластьТело.Параметры.ПокупательВыданКем = Объект.Покупатель.А_КемВыдан; 
ТабличныйДокумент.Вывести(ОбластьТело); 
Иначе 
ОбластьТело = МакетОбработки.ПолучитьОбласть("ТелоЮр"); 
ОбластьТело.Параметры.ПродавецФИО = Объект.Продавец; 
//ОбластьТело.Параметры.ФИОДиректора = СклонениеПредставленийОбъектов.ПросклонятьФИО(Объект.Продавец.Руководитель,2,,); 
ОбластьТело.Параметры.ОГРН = Объект.Продавец.ОГРН; 
ОбластьТело.Параметры.ПокупательФИО = Объект.Покупатель; 
ОбластьТело.Параметры.ИННПокупателя = Объект.Покупатель.ИНН; 
ОбластьТело.Параметры.КПППокупателя = Объект.Покупатель.КПП; 
ОбластьТело.Параметры.ПокупательАдрес = ДернутьАдрес(Объект.Покупатель); 
ТабличныйДокумент.Вывести(ОбластьТело); 
КонецЕсли; 
 
ОбластьТело1 = МакетОбработки.ПолучитьОбласть("Тело1"); 
ОбластьТело1.Параметры.Марка = Объект.Автомобиль.А_Марка; 
ОбластьТело1.Параметры.Модель = Объект.Автомобиль.А_Модель; 
ОбластьТело1.Параметры.ВИН = Объект.Автомобиль.А_VIN; 
ОбластьТело1.Параметры.ГодВыпуска = Объект.Автомобиль.А_ГодВыпуска; 
ОбластьТело1.Параметры.МаркаНомерДвигателя = Объект.Автомобиль.А_МаркаНомерДвигателя; 
ОбластьТело1.Параметры.Кузов = Объект.Автомобиль.А_Кузов; 
ОбластьТело1.Параметры.Шасси = Объект.Автомобиль.А_Шасси; 
ОбластьТело1.Параметры.Цвет = Объект.Автомобиль.А_Цвет; 
ОбластьТело1.Параметры.НомерПТС = Объект.Автомобиль.А_НомерПТС; 
ОбластьТело1.Параметры.ДатаПТС = Формат(Объект.Автомобиль.А_ДатаПТС,"ДЛФ=Д"); 
ОбластьТело1.Параметры.КемВыданПТС = Объект.Автомобиль.А_КемВыданПТС; 
ОбластьТело1.Параметры.Сумма = СуммаПродажи; 
мСуммаПрописью = ЧислоПрописью(СуммаПродажи, "Л=ru_RU;ДП=Истина", "целая, целых, целых, ж, сотая, сотой, сотых, ж, 2"); 
иСуммаПрописью = СтрЗаменить(мСуммаПрописью,"целых","руб"); 
рСуммаПрописью = СтрЗаменить(иСуммаПрописью,"сотых","коп"); 
ОбластьТело1.Параметры.СуммаПрописью = рСуммаПрописью; 
ТабличныйДокумент.Вывести(ОбластьТело1); 
 
ОбластьПодписиПродавец = МакетОбработки.ПолучитьОбласть("ПодписиПродавец"); 
ОбластьПодписиПродавец.Параметры.ПродавецФИО = Объект.Продавец; 
ОбластьПодписиПродавец.Параметры.ИННПродавца = "ИНН: "+Объект.Продавец.ИНН; 
ОбластьПодписиПродавец.Параметры.КПППродавца = "КПП: "+Объект.Продавец.КПП; 
ОбластьПодписиПродавец.Параметры.АдресПродавца = ДернутьАдрес(Объект.Продавец); 
ОбластьПодписиПродавец.Параметры.ФиоДиректора = Объект.Продавец.Руководитель; 
ТабличныйДокумент.Вывести(ОбластьПодписиПродавец); 
 
Если ТипЗнч(Объект.Покупатель) = Тип("СправочникСсылка.ФизическиеЛица") Тогда 
ОбластьПодписиФизПокупатель = МакетОбработки.ПолучитьОбласть("ПодписиФизПокупатель");
ОбластьПодписиФизПокупатель.Параметры.ПокупательФио = Объект.Покупатель;
 
ОбластьПодписиФизПокупатель.Параметры.ПаспортПокупатель = "серия: "+Объект.Покупатель.А_СерияПаспорта+" номер: "+Объект.Покупатель.А_НомерПаспорта; 
ОбластьПодписиФизПокупатель.Параметры.КемВыданУПокупателя = Объект.Покупатель.А_КемВыдан; 
ОбластьПодписиФизПокупатель.Параметры.АдресПокупателя = Объект.Покупатель.А_Адрес; 
ТабличныйДокумент.Вывести(ОбластьПодписиФизПокупатель); 
Иначе 
ОбластьПодписиЮрПокупатель = МакетОбработки.ПолучитьОбласть("ПодписиЮрПокупатель"); 
ОбластьПодписиЮрПокупатель.Параметры.ПокупательФИО = Объект.Покупатель; 
ОбластьПодписиЮрПокупатель.Параметры.ИННПокупателя = "ИНН: "+Объект.Покупатель.ИНН; 
ОбластьПодписиЮрПокупатель.Параметры.КПППокупателя = "КПП: "+Объект.Покупатель.КПП; 
ОбластьПодписиЮрПокупатель.Параметры.АдресПокупателя = ДернутьАдрес(Объект.Покупатель); 
ОбластьПодписиЮрПокупатель.Параметры.ФиоДиректораПокупателя = Объект.Покупатель.Руководитель; 
ТабличныйДокумент.Вывести(ОбластьПодписиЮрПокупатель); 
КонецЕсли; 
 
ОбластьАкт = МакетОбработки.ПолучитьОбласть("АктШапка"); 
ОбластьАкт.Параметры.ТекДата = Формат(ТекДата,"ДЛФ=Д"); 
Если ЗначениеЗаполнено(Объект.Договор) Тогда 
ОбластьАкт.Параметры.Ном = Число(Прав(Объект.Договор.Код,3)); 
КонецЕсли; 
ТабличныйДокумент.Вывести(ОбластьАкт); 
 
Если ТипЗнч(Объект.Покупатель) = Тип("СправочникСсылка.ФизическиеЛица") Тогда 
ОбластьАктФиз = МакетОбработки.ПолучитьОбласть("АктФиз"); 
ОбластьАктФиз.Параметры.ПродавецФИО = Объект.Продавец; 
//ОбластьАктФиз.Параметры.ФИОДиректора = СклонениеПредставленийОбъектов.ПросклонятьФИО(Объект.Продавец.Руководитель,2,,); 
ОбластьАктФиз.Параметры.ОГРН = Объект.Продавец.ОГРН; 
ОбластьАктФиз.Параметры.ПокупательФИО = Объект.Покупатель; 
Попытка 
ОбластьАктФиз.Параметры.ПокупательГодРождения = Формат(Объект.Покупатель.ДатаРождения,"ДЛФ=Д"); 
Исключение 
ОбластьАктФиз.Параметры.ПокупательГодРождения = ""; 
КонецПопытки; 
ОбластьАктФиз.Параметры.ПокупательАдрес = Объект.Покупатель.А_Адрес; 
ОбластьАктФиз.Параметры.ПокупательСерияНомер = "" + Объект.Покупатель.А_СерияПаспорта + " " + Объект.Покупатель.А_НомерПаспорта; 
ОбластьАктФиз.Параметры.ПокупательГодВыдачи = Формат(Объект.Покупатель.А_ДатаВыдачи,"ДЛФ=Д"); 
ТабличныйДокумент.Вывести(ОбластьАктФиз); 
Иначе 
ОбластьАктЮр = МакетОбработки.ПолучитьОбласть("АктЮр"); 
ОбластьАктЮр.Параметры.ПродавецФИО = Объект.Продавец; 
//ОбластьАктЮр.Параметры.ФИОДиректора = СклонениеПредставленийОбъектов.ПросклонятьФИО(Объект.Продавец.Руководитель,2,,); 
ОбластьАктЮр.Параметры.ОГРН = Объект.Продавец.ОГРН; 
ОбластьАктЮр.Параметры.ПокупательФио = Объект.Покупатель; 
ОбластьАктЮр.Параметры.ИННПокупателя = Объект.Покупатель.ИНН; 
ОбластьАктЮр.Параметры.КПППокупателя = Объект.Покупатель.КПП; 
ОбластьАктЮр.Параметры.ПокупательАдрес = ДернутьАдрес(Объект.Покупатель); 
ТабличныйДокумент.Вывести(ОбластьАктЮр); 
КонецЕсли; 
 
ОбластьАкт = МакетОбработки.ПолучитьОбласть("Акт"); 
ОбластьАкт.Параметры.МаркаМодельТипТС = ""+ Объект.Автомобиль.А_Марка +" " + Объект.Автомобиль.А_Модель; 
ОбластьАкт.Параметры.ГодТС = Объект.Автомобиль.А_ГодВыпуска; 
ОбластьАкт.Параметры.VIN = Объект.Автомобиль.А_VIN; 
ОбластьАкт.Параметры.ДвигательМодельНомер = Объект.Автомобиль.А_МаркаНомерДвигателя; 
ОбластьАкт.Параметры.КузовНомер = Объект.Автомобиль.А_Кузов; 
ОбластьАкт.Параметры.ШассиНомер = Объект.Автомобиль.А_Шасси; 
ОбластьАкт.Параметры.Цвет = Объект.Автомобиль.А_Цвет; 
ОбластьАкт.Параметры.ПаспортТС = Объект.Автомобиль.А_НомерПТС; 
ТабличныйДокумент.Вывести(ОбластьАкт); 
 
ТабличныйДокумент.АвтоМасштаб = Истина; 
Возврат ТабличныйДокумент;
0
27.08.2019, 10:40
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
27.08.2019, 10:40

Добавить доп. макеты в ФормуДокумента окно печать
Может быть это и не будет сложно для вашего уровня. Мне нужно добавить еще по одному каждого...

Групповая Печать - Как Получить Макеты Для Печати
Приветствую всех! Пишу обработку групповой печати документов (см.рис.) для самообучения....

Нужны макеты
Народ здравствуйте мне нужны psd макеты для верстки только не из паблика а например с ваших работ я...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru