Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/4: Рейтинг темы: голосов - 4, средняя оценка - 5.00
Riogi Shiki
0 / 0 / 0
Регистрация: 11.11.2013
Сообщений: 5
1
1C 8.x

Подскажите в чем ошибка

11.11.2013, 01:08. Просмотров 687. Ответов 5
Метки нет (Все метки)

добрый вечер форумчане. работаю в 8.2 конфигурация самопальная необходима ваша помощь в 2х частях кода.
выкладываю код всей процедуры:
1-я ошибка расположена после Результат = Запрос.Выполнить(); и до Если СокрЛП(НайденныйКонтрагент.РасчетныеСчета[0].ВидУслуги) = "Домофоны" Тогда в этой части должно создаваться 4 строки имеющие разные виды документа и разные виды услуг но по факту получается что образуется 2е строки и выдает ошибку описанную кодом
1C
1
2
3
4
5
6
Исключение
                    глПредупреждение("Критическая ОШИБКА","У контрагента """+НайденныйКонтрагент+""" не заполнены реквизиты банка.","Заполнить рсчетные счета у контрагента """+СокрЛП(НайденныйКонтрагент)+"""");
                КонецПопытки;
            Иначе
                глПредупреждение("Критическая ОШИБКА!","Не нашел контрагента по его наименованию в справочнике контрагентов.","Собщить программисту!");
            КонецЕсли;
в чем проблема не могу понять по логике вроде бы все правильно написано

2-я ошибка начинается на части Если СокрЛП(НайденныйКонтрагент.Наименование) = "Энергосбыт" Тогда
в ней вместо 2х строк выводится 3 одна из строк является суммарным количеством всех платежей


1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
ЭлементыФормы.ЗакрываемыеДокументы.ТолькоПросмотр = Ложь;
    ЭлементыФормы.ЗакрываемыеДокументы.Колонки.ВходитВЗакрытие.Видимость = Истина;
    ЭлементыФормы.НиОдного.Доступность = Истина;
    ЭлементыФормы.Все.Доступность = Истина;
    ЭлементыФормы.Выборочно.Доступность = Истина;
    Выделение = 0;
    // Вставим проверку на созданные платежные поручения, 
    //если они были созданы то тогда спросим их удалить
    //при отказе никаких изменений не произойдет!
    
    
    
    ТекстФормы.Очистить();
    ЗакрываемыеДокументы.Очистить();
    //Если глТекущийРабочийЧек.ВошедшиеДокументы.Количество() > 0 Тогда
    //  глПредупреждение("ВНИМАНИЕ!",
    //  "Перед тем как вывести отчет о закрытии на печать необходимо закрыть текущий рабочий чек.",
    //  "Закройте чек и повторите попытку!");
    //  Отказ = Истина;
    //Иначе
    
    // Проверим, если были закрытия сегодня, тогда создадим второе закрытие
    //во второе закрытие включим все что не вошло в прошлом номере за сегодня
    // 1 по счету закрытие всегда создается без ЖСК, второе только по жск
    Запрос_ = Новый Запрос;
    Запрос_.Текст = "ВЫБРАТЬ
    |   ОтгрузкаИнформации.Дата КАК Дата,
    |   ОтгрузкаИнформации.Номер КАК Номер
    |ИЗ
    |   Документ.ОтгрузкаИнформации КАК ОтгрузкаИнформации
    |ГДЕ
    |   ОтгрузкаИнформации.Дата МЕЖДУ &ДатаНач И &ДатаКон
    |   И  ОтгрузкаИнформации.Проведен = ИСТИНА";
    Запрос_.УстановитьПараметр("ДатаНач",НачалоДня(ТекущаяДата()));
    Запрос_.УстановитьПараметр("ДатаКон",КонецДня(ТекущаяДата()));
    Результат_ = Запрос_.Выполнить().Выбрать();
    ПорядковыйНомерЗаДень = 1;
    Если Результат_.Количество() = 0 Тогда
        ПорядковыйНомерЗаДень = 1;
    ИначеЕсли Результат_.Количество() = 1 Тогда
        // Спросить создать второе или пересоздать первое
        Режим = РежимДиалогаВопрос.ДаНет;
        Ответ = Вопрос("Переформировать закрытие по основным (Да) 
                       |  или сформировать закрытие по ЖСК (Нет)?", Режим, 0);
        Если Ответ = КодВозвратаДиалога.Да Тогда
            ПорядковыйНомерЗаДень = 1;
        Иначе
            ПорядковыйНомерЗаДень = 2;
        КонецЕсли;
    Иначе
        Если ВвестиЧисло(ПорядковыйНомерЗаДень, "Какое закрытие хотите пересоздать Основные (1) или ЖСК (2)?", 1, 0) Тогда
            Если ПорядковыйНомерЗаДень = 1 ИЛИ ПорядковыйНомерЗаДень = 2 Тогда
                
            Иначе  
                глПредупреждение("Предупреждение","Отменено создание закрытия","Отчет закрыт.");
                Закрыть();
            КонецЕсли;
        КонецЕсли;     
    КонецЕсли;
    Если ПорядковыйНомерЗаДень = 2 Тогда
        //ПериодС = НачалоДня(ТекущаяДата()-604800)
    КонецЕсли;
        
        // Сформируем отчет и заполним основную форму для просмотра
        Запрос = Новый Запрос;
        Запрос.Текст = "ВЫБРАТЬ
        |   Платежи.ВидПлатежа,
        |   Платежи.ПолныйВидПлатежа КАК ПолныйВидПлатежа,
        |   Платежи.Период, 
        |   Платежи.ВидДокумента,
        |   СУММА(Платежи.Количество) КАК Количество,
        |   СУММА(Платежи.Сумма) КАК Сумма
        |ИЗ
        |   РегистрНакопления.Платежи КАК Платежи
        |ГДЕ
        |   Платежи.Период МЕЖДУ &ДатаНач И &ДатаКон";
        Если ПорядковыйНомерЗаДень = 1 Тогда
            Запрос.Текст = Запрос.Текст + "
                                           |    И Платежи.ВидПлатежа <> ""ЖСК""";
                                           //|  И Платежи.ВидПлатежа <> ""ГОРОНО""";
        ИначеЕсли ПорядковыйНомерЗаДень = 2 Тогда
            Запрос.Текст = Запрос.Текст + "
                                           |    И Платежи.ВидПлатежа В (""ЖСК"")";  //,""ГОРОНО""
        КонецЕсли;
        Запрос.Текст = Запрос.Текст + "
        |
        |СГРУППИРОВАТЬ ПО
        |   Платежи.ПолныйВидПлатежа,
        |   Платежи.Период,
        |   Платежи.ВидПлатежа, 
        |   Платежи.ВидДокумента
        |
        |УПОРЯДОЧИТЬ ПО
        |   ПолныйВидПлатежа
        |ИТОГИ
        |   СУММА(Количество),
        |   СУММА(Сумма)
        |ПО
        |   ОБЩИЕ,
        |   ПолныйВидПлатежа, ВидДокумента";
        Запрос.УстановитьПараметр("ДатаНач",НачалоДня(ПериодС));
        Запрос.УстановитьПараметр("ДатаКон",КонецДня(ПериодПо));
        //Запрос.УстановитьПараметр("ВидТелефон","Телефон");
        //Запрос.УстановитьПараметр("ВидТелевидение","Телевидение");
        
        Результат = Запрос.Выполнить();
        // Получим и запомним итоги
        ВыборкаИтог = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Общие");
        ВыборкаИтог.Следующий();
        СпрКонтрагентов = Справочники.Контрагенты;
        ВыборкаВидПлатежа = ВыборкаИтог.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"ПолныйВидПлатежа");
        Пока ВыборкаВидПлатежа.Следующий() Цикл
            Стр = ЗакрываемыеДокументы.Добавить();
            Стр.ВидПлатежа = ВыборкаВидПлатежа.ПолныйВидПлатежа;
            НайденныйКонтрагент = СпрКонтрагентов.НайтиПоНаименованию(СтрЗаменить(ВыборкаВидПлатежа.ПолныйВидПлатежа,"ВДС",""));
            Стр.Количество = ВыборкаВидПлатежа.Количество;
            Стр.Сумма = ВыборкаВидПлатежа.Сумма;
            Если НЕ НайденныйКонтрагент.Пустая() Тогда
                Стр.Организация = НайденныйКонтрагент;
                Стр.ПроцентУдержания = НайденныйКонтрагент.Процент;
                Попытка
                    Если Найти(ВыборкаВидПлатежа.ПолныйВидПлатежа,"ВДС") > 0 Тогда
                        Если ВыборкаПоВиду.ВидДокумента = 4 Тогда
                        Стр.Банк = НайденныйКонтрагент.РасчетныеСчета[1].Банк;
                        Стр.КоличествоПлатежекДляПечати = НайденныйКонтрагент.РасчетныеСчета[1].КоличествоПлатежекДляПечати;
                        Стр.КореспондентскийСчет = НайденныйКонтрагент.РасчетныеСчета[1].КореспондентскийСчет;
                        Стр.Куб = НайденныйКонтрагент.РасчетныеСчета[1].Куб;
                        Стр.ОснованиеДляСчета = НайденныйКонтрагент.РасчетныеСчета[1].ОснованиеДляСчета;
                        Стр.РасчетныйСчет = НайденныйКонтрагент.РасчетныеСчета[1].РасчетныйСчет;
                        Стр.ФискальныйКод = НайденныйКонтрагент.РасчетныеСчета[1].ФискальныйКод;
                        Стр.СуммаУдержания = Окр(Окр(Стр.Сумма/100,2)*Стр.ПроцентУдержания,2);
                        Стр.КПеречислению = Стр.Сумма - Стр.СуммаУдержания;
                        Иначе
                        Стр.Банк = НайденныйКонтрагент.РасчетныеСчета[0].Банк;
                        Стр.КоличествоПлатежекДляПечати = НайденныйКонтрагент.РасчетныеСчета[0].КоличествоПлатежекДляПечати;
                        Стр.КореспондентскийСчет = НайденныйКонтрагент.РасчетныеСчета[0].КореспондентскийСчет;
                        Стр.Куб = НайденныйКонтрагент.РасчетныеСчета[0].Куб;
                        Стр.ОснованиеДляСчета = НайденныйКонтрагент.РасчетныеСчета[0].ОснованиеДляСчета;
                        Стр.РасчетныйСчет = НайденныйКонтрагент.РасчетныеСчета[0].РасчетныйСчет;
                        Стр.ФискальныйКод = НайденныйКонтрагент.РасчетныеСчета[0].ФискальныйКод;
                        КонецЕсли;
                    ИначеЕсли ВыборкаПоВиду.ВидДокумента = 4 Тогда
                        Стр.Банк = НайденныйКонтрагент.РасчетныеСчета[1].Банк;
                        Стр.КоличествоПлатежекДляПечати = НайденныйКонтрагент.РасчетныеСчета[1].КоличествоПлатежекДляПечати;
                        Стр.КореспондентскийСчет = НайденныйКонтрагент.РасчетныеСчета[1].КореспондентскийСчет;
                        Стр.Куб = НайденныйКонтрагент.РасчетныеСчета[1].Куб;
                        Стр.ОснованиеДляСчета = НайденныйКонтрагент.РасчетныеСчета[1].ОснованиеДляСчета;
                        Стр.РасчетныйСчет = НайденныйКонтрагент.РасчетныеСчета[1].РасчетныйСчет;
                        Стр.ФискальныйКод = НайденныйКонтрагент.РасчетныеСчета[1].ФискальныйКод;
                        Стр.СуммаУдержания = Окр(Окр(Стр.Сумма/100,2)*Стр.ПроцентУдержания,2);
                        Стр.КПеречислению = Стр.Сумма - Стр.СуммаУдержания;
                        Иначе
                        Стр.Банк = НайденныйКонтрагент.РасчетныеСчета[0].Банк;
                        Стр.КоличествоПлатежекДляПечати = НайденныйКонтрагент.РасчетныеСчета[0].КоличествоПлатежекДляПечати;
                        Стр.КореспондентскийСчет = НайденныйКонтрагент.РасчетныеСчета[0].КореспондентскийСчет;
                        Стр.Куб = НайденныйКонтрагент.РасчетныеСчета[0].Куб;
                        Стр.ОснованиеДляСчета = НайденныйКонтрагент.РасчетныеСчета[0].ОснованиеДляСчета;
                        Стр.РасчетныйСчет = НайденныйКонтрагент.РасчетныеСчета[0].РасчетныйСчет;
                        Стр.ФискальныйКод = НайденныйКонтрагент.РасчетныеСчета[0].ФискальныйКод;
                    
                        // Если ВидУслуги = Домофоны тогда посчитаем процент из самих документов не учитывая
                        //процент справочника удержания иначе расхождение в копейки будет постоянным
                        Если СокрЛП(НайденныйКонтрагент.РасчетныеСчета[0].ВидУслуги) = "Домофоны" Тогда
                            Запрос = Новый Запрос;
                            Запрос.Текст = "ВЫБРАТЬ
                                           |    Домофоны.Дата,
                                           |    Домофоны.Проведен,
                                           |    Домофоны.НомерЧека,
                                           |    СУММА(Домофоны.Комиссия) КАК Комиссия,
                                           |    СУММА(Домофоны.СуммаКОплате) КАК СуммаКОплате,
                                           |    СУММА(Домофоны.СуммаПлатежа) КАК СуммаПлатежа
                                           |ИЗ
                                           |    Документ.Домофоны КАК Домофоны
                                           |ГДЕ
                                           |    Домофоны.Дата МЕЖДУ &ДатаНачала И &ДатаКонца
                                           |    И Домофоны.Проведен = Истина
                                           |
                                           |СГРУППИРОВАТЬ ПО
                                           |    Домофоны.Дата,
                                           |    Домофоны.Проведен,
                                           |    Домофоны.НомерЧека
                                           |ИТОГИ 
                                           |ПО
                                           |    Общие";
                            Запрос.УстановитьПараметр("ДатаНачала", НачалоДня(ПериодС));
                            Запрос.УстановитьПараметр("ДатаКонца", КонецДня(ПериодПо));
                            Результат = Запрос.Выполнить();
                            ВыборкаИтог = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Общие");
                            ВыборкаИтог.Следующий();
                            Стр.СуммаУдержания = ВыборкаИтог.Комиссия;
                        Иначе
                            Стр.СуммаУдержания = ?(СокрЛП(НайденныйКонтрагент.РасчетныеСчета[0].ВидУслуги) = "ЖСК", Окр(Окр(Стр.Сумма/(100+Стр.ПроцентУдержания),2)*Стр.ПроцентУдержания,2), Окр(Окр(Стр.Сумма/100,2)*Стр.ПроцентУдержания,2));
                        КонецЕсли;
                        Стр.КПеречислению = Стр.Сумма - Стр.СуммаУдержания;
                    КонецЕсли;
                Исключение
                    глПредупреждение("Критическая ОШИБКА","У контрагента """+НайденныйКонтрагент+""" не заполнены реквизиты банка.","Заполнить рсчетные счета у контрагента """+СокрЛП(НайденныйКонтрагент)+"""");
                КонецПопытки;
            Иначе
                глПредупреждение("Критическая ОШИБКА!","Не нашел контрагента по его наименованию в справочнике контрагентов.","Собщить программисту!");
            КонецЕсли;
            
            
                        Если СокрЛП(НайденныйКонтрагент.Наименование) = "Энергосбыт" Тогда
                //добавим 2 строки платежей
                ВыборкаПоВиду = ВыборкаВидПлатежа.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"ВидДокумента");
                Пока ВыборкаПоВиду.Следующий() Цикл
                    Стр = ЗакрываемыеДокументы.Добавить();
                    Стр.ВидПлатежа = ВыборкаВидПлатежа.ПолныйВидПлатежа;
                    //НайденныйКонтрагент = СпрКонтрагентов.НайтиПоНаименованию(СтрЗаменить(ВыборкаВидПлатежа.ПолныйВидПлатежа,"ЖСК",""));
                    Стр.Количество = ВыборкаПоВиду.Количество;
                    Стр.КодПлатежа = ВыборкаПоВиду.ВидДокумента;
                    Стр.Сумма = ВыборкаПоВиду.Сумма;
                    Если НЕ НайденныйКонтрагент.Пустая() Тогда
                        Стр.Организация = НайденныйКонтрагент;
                        ////Если СокрЛП(НайденныйКонтрагент.Наименование) = "Энергосбыт" Тогда
                        Если ВыборкаПоВиду.ВидДокумента = 1 ИЛИ ВыборкаПоВиду.ВидДокумента = 2 
                            Тогда
                            Стр.ПроцентУдержания = НайденныйКонтрагент.РасчетныеСчета[0].ПроцентУдержаиня;
                            Стр.Банк = НайденныйКонтрагент.РасчетныеСчета[0].Банк;
                            Стр.КоличествоПлатежекДляПечати = НайденныйКонтрагент.РасчетныеСчета[0].КоличествоПлатежекДляПечати;
                            Стр.КореспондентскийСчет = НайденныйКонтрагент.РасчетныеСчета[0].КореспондентскийСчет;
                            Стр.Куб = НайденныйКонтрагент.РасчетныеСчета[0].Куб;
                            Стр.ОснованиеДляСчета = НайденныйКонтрагент.РасчетныеСчета[0].ОснованиеДляСчета;
                            Стр.РасчетныйСчет = НайденныйКонтрагент.РасчетныеСчета[0].РасчетныйСчет;
                            Стр.ФискальныйКод = НайденныйКонтрагент.РасчетныеСчета[0].ФискальныйКод;
                            Стр.СуммаУдержания = Окр(Окр(Стр.Сумма/100,2)*Стр.ПроцентУдержания,2);
                            Стр.КПеречислению = Стр.Сумма - Стр.СуммаУдержания;
                            Стр.СуммаУдержания = ?(СокрЛП(НайденныйКонтрагент.РасчетныеСчета[0].ВидУслуги) = "Энергосбыт", Окр(Окр(Стр.Сумма/(100+Стр.ПроцентУдержания),2)*Стр.ПроцентУдержания,2), 
 
Окр(Окр(Стр.Сумма/100,2)*Стр.ПроцентУдержания,2));
                        Иначе
                        Если ВыборкаПоВиду.ВидДокумента = 3 Тогда
                            Стр.ПроцентУдержания = НайденныйКонтрагент.РасчетныеСчета[1].ПроцентУдержаиня;
                            Стр.Банк = НайденныйКонтрагент.РасчетныеСчета[1].Банк;
                            Стр.КоличествоПлатежекДляПечати = НайденныйКонтрагент.РасчетныеСчета[1].КоличествоПлатежекДляПечати;
                            Стр.КореспондентскийСчет = НайденныйКонтрагент.РасчетныеСчета[1].КореспондентскийСчет;
                            Стр.Куб = НайденныйКонтрагент.РасчетныеСчета[1].Куб;
                            Стр.ОснованиеДляСчета = НайденныйКонтрагент.РасчетныеСчета[1].ОснованиеДляСчета;
                            Стр.РасчетныйСчет = НайденныйКонтрагент.РасчетныеСчета[1].РасчетныйСчет;
                            Стр.ФискальныйКод = НайденныйКонтрагент.РасчетныеСчета[1].ФискальныйКод;
                            Стр.СуммаУдержания = Окр(Окр(Стр.Сумма/100,2)*Стр.ПроцентУдержания,2);
                            Стр.КПеречислению = Стр.Сумма - Стр.СуммаУдержания;
                            Стр.СуммаУдержания = ?(СокрЛП(НайденныйКонтрагент.РасчетныеСчета[0].ВидУслуги) = "Энергосбыт", Окр(Окр(Стр.Сумма/(100+Стр.ПроцентУдержания),2)*Стр.ПроцентУдержания,2), 
 
Окр(Окр(Стр.Сумма/100,2)*Стр.ПроцентУдержания,2));
                        КонецЕсли;
                    КонецЕсли;
                КонецЦикла;   
                
                
            КонецЕсли;
            КонецЦикла;
    //// При изменении каких либо настроек удалять файлы
    
КонецПроцедуры
очень прошу помочь я с 1с не так давно работаю поэтому еще многого не знаю.
людей пишуших коменты типа ты нуб и т.д. прошу просто проигнорить тему
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
11.11.2013, 01:08
Ответы с готовыми решениями:

В чем ошибка компилляции?
Я программированием 1С не владею, поэтому использовал рекомендации из статьи &quot;Загрузка данных в 1С...

Подскажите в чем ошибка..
Доброго времени суток, подскажите где ошибка, уже мозги кипят....sos procedure...

Подскажите в чем ошибка?
Дано задание: Построить график функции f(x) и приблизительно определить один из корней уравнения....

Подскажите в чем ошибка
В этом коде переменная Str2 инициализируется null. Подскажите почему. (Код взят из учебника,...

Подскажите, в чем ошибка?
Добрый день! есть такой метод процедуры: internal void AddToBd(Button button, TextBox tab_number,...

5
Xomych
838 / 640 / 108
Регистрация: 01.11.2012
Сообщений: 2,356
11.11.2013, 10:50 2
НайденныйКонтрагент.РасчетныеСчета[0].ВидУслуги
Вы уверены что ВидУслуги это Строка?

Ну а 3-я строка это ваши ИТОГИ по запросу. Какой запрос, такой и результат

ПО
| ОБЩИЕ,
| ПолныйВидПлатежа, ВидДокумента
ВОт у вас тут третья строка это итог по ВидДокумента.
0
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
11.11.2013, 10:52 3
Для отладки "Попытка...Исключение...КонецПопытки" заремарьте временно. Это случай, когда лень прогера имеет минусовой вектор. Под попыткой уйма подводных камней по возможным пустым ссылкам.
0
Riogi Shiki
0 / 0 / 0
Регистрация: 11.11.2013
Сообщений: 5
11.11.2013, 20:20  [ТС] 4
Xomych: Вы уверены что ВидУслуги это Строка?
да уверен это строка с длиной 20 символов.
Xomych: ВОт у вас тут третья строка это итог по ВидДокумента.
если я правильно понял этой строкой "ВыборкаПоВиду = ВыборкаВидПлатежа.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"ВидДокумента");" я обошел группировку по ВидуДокумента

Добавлено через 1 минуту
duk337 спасибо за подсказку буду пробовать
0
Riogi Shiki
0 / 0 / 0
Регистрация: 11.11.2013
Сообщений: 5
14.11.2013, 03:20  [ТС] 5
кто еще может предложить умные мысли как обойти эту группировку или отключить ее а то уже все облазил ничего не нашел
0
OrkVasya
о_____О
Эксперт 1С
221 / 221 / 36
Регистрация: 19.11.2010
Сообщений: 1,061
Завершенные тесты: 1
14.11.2013, 08:57 6
А можете пояснить, как именно лазили?

Поддерживаю вариант duk337, закомментите на фиг все "Попытка" и все все, что между "Исключение" и "КонецПопытки", в таком варианте должно все громко упасть на ошибке, но вам будет понятно где смотреть и что анализировать.

З.Ы. Что с ходу резануло глаз:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
    ПорядковыйНомерЗаДень = 1;
    Если Результат_.Количество() = 0 Тогда
        ПорядковыйНомерЗаДень = 1;
    ИначеЕсли Результат_.Количество() = 1 Тогда
        // Спросить создать второе или пересоздать первое
        Режим = РежимДиалогаВопрос.ДаНет;
        Ответ = Вопрос("Переформировать закрытие по основным (Да) 
                       |  или сформировать закрытие по ЖСК (Нет)?", Режим, 0);
        Если Ответ = КодВозвратаДиалога.Да Тогда
            ПорядковыйНомерЗаДень = 1;
        Иначе
            ПорядковыйНомерЗаДень = 2;
        КонецЕсли;
Как-то в бедную переменную возможно несколько раз одно и то же записать...
Я бы переделал так:

1C
1
2
3
4
5
6
7
8
9
 ПорядковыйНомерЗаДень = 1;
   Если Результат_.Количество() = 1 Тогда
        // Спросить создать второе или пересоздать первое
        Режим = РежимДиалогаВопрос.ДаНет;
        Ответ = Вопрос("Переформировать закрытие по основным (Да) 
                       |  или сформировать закрытие по ЖСК (Нет)?", Режим, 0);
        Если Ответ = КодВозвратаДиалога.Нет Тогда
            ПорядковыйНомерЗаДень = 2;
        КонецЕсли;
Просто чуть меньше кода.

2. Не смотря на то, что это закомменчено
Цитата Сообщение от Riogi Shiki Посмотреть сообщение
//ПериодС = НачалоДня(ТекущаяДата()-604800)
Готовыми циферами писать таки дурной тон. Я понял, что это неделя только с помощью метода призыва калькулятора.

Лучше писать не "604800", а хотя бы "7 * 24 * 60 * 60". Платформа это осилит, а тот кто будет разбираться в коде, не поимеет желание что-нить сделать с афтором (по крайней мере при взгляде на этот оператор )
0
14.11.2013, 08:57
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
14.11.2013, 08:57

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Подскажите в чем ошибка
&lt;button...

подскажите в чем ошибка
// KURSOVA.cpp : main project file. #include &quot;stdafx.h&quot; #include &lt;iostream&gt; #include &lt;conio.h&gt;...

Подскажите, в чем ошибка?
Здравствуйте, у меня возникла проблема... Я нашел исходный код инжектора длл файлов. На Delphi 7 он...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.