Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.83/6: Рейтинг темы: голосов - 6, средняя оценка - 4.83
Shalhoekx
0 / 0 / 0
Регистрация: 25.02.2013
Сообщений: 6
1

Создать на основании Бухгалтерия 8.2

15.11.2013, 11:23. Просмотров 1035. Ответов 1
Метки нет (Все метки)

Добрый день!
Мне требуется написать обработку для документов "Реализация товаров и услуг" при условии, что в поле комментарий есть надпись "Создан автоматически", создать на основании этого документа "Корректировку реализации", а на её основе создать "Корректировочный счет фактура". В самой конфигурации есть такая возможность, но где это реализуется в коде найти не могу (усложняет немного, что при создании Корректировки реализации, еще необходимо выбрать из списка "Корректировка по соглашению сторон"). Читал про конструктор создания документов на основании, там написано, что создается процедура в модуле (что-то вроде "ОбработкаОснования", щас уже не помню как точно пишется), но найти её ни в Реализации товаров, ни в Корректировке реализации не смог. Можно и самому конечно создавать документ и заполнять реквизиты, а следом на его основании создавать еще документ, но боюсь что что-то упущу. Может кто знает где найти процедуру создания документа на основании, чтоб либо выдернуть код, либо както её вызывать из обработки?

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
Процедура КнопкаВыполнитьНажатие(Кнопка)
Если ВыбДата = Дата(1,1,1) Тогда
        Предупреждение("Не выбрана дата начала периода!", 15, "Обработка договоров");
        Возврат;
КонецЕсли;      
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |   РеализацияТоваровУслуг.Ссылка, РеализацияТоваровУслуг.Комментарий
        |ИЗ
        |   Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
        |ГДЕ
        |   ПОДСТРОКА (РеализацияТоваровУслуг.Комментарий, 1, 20) = &Автомат
        |   И РеализацияТоваровУслуг.Проведен = &ИСТИНА
        |   И  РеализацияТоваровУслуг.Дата >= &Дата";
 
    Запрос.УстановитьПараметр("ИСТИНА", ИСТИНА);
    Запрос.УстановитьПараметр("Автомат", "Создан автоматически");
    Запрос.УстановитьПараметр("Дата"                , НачалоДня(ВыбДата) - 1);
    РезультатЗапроса = Запрос.Выполнить();
 
    Выборка = РезультатЗапроса.Выбрать();
Колво = 0;
    Пока Выборка.Следующий() Цикл
        Колво = Колво +1;
        Реализация = Выборка.Ссылка.ПолучитьОбъект();
        Сообщить(Реализация.Комментарий);
    КонецЦикла;
Сообщить(Колво);
КонецПроцедуры
З.Ы: щас сделал отбор еще и по дате, чтоб при тесте все доки не гонять (а то 32,5к документов)
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
15.11.2013, 11:23
Ответы с готовыми решениями:

Создать на основании
Создаю на основании документ. потом еще один и еще и еще много могу создать на основании одного...

Создать документ на основании справочника
Здравствуйте! Делаю базу столовой и мне нужно создать документ "Варка", в котором при указании...

8.2 Бухгалтерия Предприятия создать пользователя для работы только с Одним документом ?
Добрый день, Вопрос такой - есть стандартная база (8.2 Бухгалтерия Предприятия - толстый клиент)....

Бухгалтерия 8.3 Не удается создать внешнюю печатную форму
Помогите пожалуйста найти ошибку. Пытаюсь сделать внешнюю печатную форму Счета на оплату Ошибка...

Программно создать документ на основании другого документа
Здравствуйте. Есть документ "Образец заполнения". Есть внешняя обработка, в которой пользователь...

1
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
15.11.2013, 11:50 2
МодульОбъекта.ОбработкаЗаполнения(Основание)
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
15.11.2013, 11:50

Можно ли в 1с Предприятие создать ввод на основании используя два документа?
Можно ли в 1с Предприятие создать ввод на основании используя два документа?

Создать новую таблицу на основании другой
Прошу помощи. из таблицы необходимо сделать так, чтобы отображались в таблице нужные данные по...

Создать таблицу на основании другой таблицы
Добрый день. Есть таблица Excel, где 200 колонок и 5000 строк. Нужно создать на основании этой...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru