Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
 
Рейтинг: Рейтинг темы: голосов - 18, средняя оценка - 4.61
Ermak27
4 / 4 / 1
Регистрация: 16.01.2013
Сообщений: 1,195
#1

Загрузить DBF в TXT - 1С/1C 8.x

26.11.2013, 12:19. Просмотров 2662. Ответов 48
Метки нет (Все метки)

Подскажите пожалуйста примером как можно с помощью 1С с DBF загрузить в TXT
http://www.cyberforum.ru/1c/thread606203.html
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
26.11.2013, 12:19
Я подобрал для вас темы с готовыми решениями и ответами на вопрос 1C 8.x Загрузить DBF в TXT (1С):

Как файл Dbf загрузить в программу 1c ?
Вообщем я хочу загрузить dbf файл в 1C.. захожу в конфигуратор..нажимаю...

кодировка Dbf
1) Как в 1с8 при создании объекта XBase указать нужную кодировку текста, чтобы...

проблема с Dbf
Есть алгоритм выгрузки заявок в dbf. далее эти заявки попадают к поставщику и...

Dbf айлы
Наверно вопрос очень простой... Пытаюсь понять для чего мне могут пригодиться...

Кодировка .dbf
При загрузке данных из .dbf в 1С, некоторые записи записуются краказябрами....

48
OrkVasya
о_____О
Эксперт 1С
219 / 219 / 36
Регистрация: 19.11.2010
Сообщений: 1,061
Завершенные тесты: 1
28.11.2013, 15:30 #41
А у вас других вариантов нет, кроме как понять, как пользоваться отладчиком. Если уж программируете, вы с ним вместе проведете не один десяток прекрасных часов.
У Радченко есть в книге по 8.2 инфа по этому вопросу, в инете море информации.
0
Ermak27
4 / 4 / 1
Регистрация: 16.01.2013
Сообщений: 1,195
29.11.2013, 11:50  [ТС] #42
Не понимаю как сделать, я делаю вот так но не работает

1C
1
2
3
4
5
6
7
САЛ = ФайлДБФ.ПолучитьЗначениеПоля("SALDO");
САЛФ = Формат(САЛ, "ЧРД='.'");
Если САЛФ = "0" Тогда
ПР = "0";
Иначе
КонецЕсли;
Сообщить (ПР);
Мне нужно если значение колонки САЛ = 0 чтобы выводила 0.00 , почему то не выводит, а если значение равно 4,10 то выводил 4.10, все нормально. Подскажите как мне исправить
0
OrkVasya
о_____О
Эксперт 1С
219 / 219 / 36
Регистрация: 19.11.2010
Сообщений: 1,061
Завершенные тесты: 1
29.11.2013, 13:06 #43
1C
1
2
3
Если Сал = "0" Тогда
Сал = "0.00";
КонецЕсли;
Но вам надо работать со строкой.
1
Ermak27
4 / 4 / 1
Регистрация: 16.01.2013
Сообщений: 1,195
29.11.2013, 13:35  [ТС] #44
Делаю так все равно не выводит значение = 0

1C
1
2
3
4
5
6
7
8
САЛ = ФайлДБФ.ПолучитьЗначениеПоля("SALDO");
        САЛФ = Формат(САЛ, "ЧРД='.'");
    Если САЛ = "0" Тогда
            ПР1 = "0.00";
        Иначе
            ПР1 = САЛФ; 
        КонецЕсли;
Сообщить (ПР1);
0
OrkVasya
о_____О
Эксперт 1С
219 / 219 / 36
Регистрация: 19.11.2010
Сообщений: 1,061
Завершенные тесты: 1
29.11.2013, 13:42 #45
У меня, как обычно, все работает...
1
Вложения
Тип файла: 7z ВнешняяОбработка1.7z (2.8 Кб, 3 просмотров)
Ermak27
4 / 4 / 1
Регистрация: 16.01.2013
Сообщений: 1,195
29.11.2013, 15:29  [ТС] #46
OrkVasya, ты какой то бред мне скинул в обработке
0
OrkVasya
о_____О
Эксперт 1С
219 / 219 / 36
Регистрация: 19.11.2010
Сообщений: 1,061
Завершенные тесты: 1
29.11.2013, 16:01 #47
Вы писали, что "Мне нужно если значение колонки САЛ = 0 чтобы выводила 0.00 , почему то не выводит".
В моем бреде написано, что если в строкой переменной содержится "0.00", то оно вполне нормально распечатывается.
В данном случае могу только порекомендовать определиться с тем, что вам конкретно нужно, дабы не получать в ответ всякий бред. И читать побольше литературы по программированию в 1С, если уж влезли в код.
Успеха.
0
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
29.11.2013, 16:36 #48
Ermak27, а знаете ли Вы, что в отладчике можно посмотреть тип и значение любой переменной в момент выполнения любой строки кода? Если увидеть их своими глазами, то и спрашивать не придётся.
Загрузите конфигуратор, откройте модуль, кликните слева напротив нужной строки. Появится красное яблочко. Запустите Предприятие и там свою обработку. Когда программа дойдёт до яблочка, она остановится и покажет конфигуратор. Вверху кнопочки для информации, а так же меню.Отладка. Кроме того подсказка при наведении указателя на переменную покажет её значение. 0 или "0" или "0.00" или Неопределено...
0
Dethmontt
Модератор
Эксперт 1С
2577 / 2384 / 391
Регистрация: 10.03.2011
Сообщений: 8,426
Записей в блоге: 1
Завершенные тесты: 1
30.11.2013, 01:42 #49
Цитата Сообщение от Ermak27 Посмотреть сообщение
OrkVasya, ты какой то бред мне скинул в обработке
Ermak27 это не уважительно с твоей стороны!!! Человек помочь тебе хотел!!!
0
30.11.2013, 01:42
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
30.11.2013, 01:42
Привет! Вот еще темы с решениями:

1с 7.7 Dbf Over 2000+ Mb )
Здравствуйте, в общем ситуация печальная. 1С 7.7 Бухгалтерия с порядочным...

Конвертирование Db в Dbf
Есть db-таблицы определенной структуры. Их необходимо загружать в 1С....

1c 8.2 Выгруз в DBF
Help!!! Есть код: // Обработчик выгрузки в DBF-файл // Процедура...

Загрузка из *.dbf в 1с
Здравствуйте... случилась беда.. нужно загружать данные из dbf файла в 1с,...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
49
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru