Форум программистов, компьютерный форум, киберфорум
Наши страницы

Войти
Регистрация
Восстановить пароль
 
SirClipz
2 / 2 / 0
Регистрация: 29.08.2013
Сообщений: 113
#1

Загрузка ТЧ упр. формы - 1С/1C 8.x (тонкий)

27.11.2013, 21:25. Просмотров 942. Ответов 10
Метки нет (Все метки)

Подскажите пожалуйста, не знаю как заполнить ТЧ документа...
Переписал обработку для загрузки из Excell данных, получаю прочитанный файлик в табличное поле, выбираю необходимые колонки, клацаю "Загрузить", но тут вопрос, не получается обратиться к тч моего документа из данной обработки... Вопрос указан в коде ниже! Помогите пожалуйста!
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
&НаСервере
Процедура Загрузить(Отказ)
    
    Если Объект.СписокЗагрузки.Количество() = 0 Тогда
        Возврат;
    КонецЕсли;
    
    //РеквизитФормыВЗначение("Объект").ПроверитьДублиСтрок(Отказ);
    //
    //Если Отказ Тогда
    //  Возврат;
    //КонецЕсли;
    
    Если ВидОперации = "Цены" Тогда
        Менеджер = Справочники.Номенклатура;
    ИначеЕсли ВидОперации = "Остатки" Тогда
        ДокументВводОстатков = Документы.ВводНачальныхОстатков.СоздатьДокумент();
        ДокументВводОстатков.РазделУчета = "Запасы";
        ДокументВводОстатков.Организация = Справочники.Организации.ОсновнаяОрганизация;
        ДокументВводОстатков.Дата = ?(ЗначениеЗаполнено(Дата), Дата, ТекущаяДата());
        ДокументВводОстатков.Комментарий = "# Документ введен обработкой загрузки данных из электронной таблицы.";
        Менеджер = Справочники.Номенклатура;
    ИначеЕсли ВидОперации = "Номенклатура" Тогда
        Менеджер = Справочники.Номенклатура;
    ИначеЕсли ВидОперации = "Контрагенты" Тогда
        Менеджер = Справочники.Контрагенты;
    ИначеЕсли ВидОперации = "РегНомера" Тогда
        Менеджер = Документы.итсЗагрузкаРегистраИТС;
        
    КонецЕсли;
    
    Для каждого СтрокаЗагрузки Из Объект.СписокЗагрузки Цикл
    
        Если НЕ СтрокаЗагрузки.ФлагЗагрузки Тогда
            Продолжить;
        КонецЕсли;
        
        Если СтрокаЗагрузки.Ссылка.Пустая() Тогда
            ОбъектДляЗаписи = Менеджер.СоздатьЭлемент();
        Иначе
            ОбъектДляЗаписи = СтрокаЗагрузки.Ссылка.ПолучитьОбъект();
        КонецЕсли;
        
        Если ВидОперации = "Контрагенты" Тогда
            
            ЗаполнитьЗначенияСвойств(ОбъектДляЗаписи, СтрокаЗагрузки);
            ОбъектДляЗаписи.НаименованиеПолное = ОбъектДляЗаписи.НаименованиеПолное;
            ОбъектДляЗаписи.ЮрФизЛицо = Перечисления.ЮрФизЛицо.ЮрЛицо;
            ОбъектДляЗаписи.СчетУчетаРасчетовСПокупателем = ПланыСчетов.Управленческий.РасчетыСПокупателями;
            ОбъектДляЗаписи.СчетУчетаАвансовПокупателя = ПланыСчетов.Управленческий.РасчетыПоАвансамПолученным;
            ОбъектДляЗаписи.СчетУчетаРасчетовСПоставщиком = ПланыСчетов.Управленческий.РасчетыСПоставщиками;
            ОбъектДляЗаписи.СчетУчетаАвансовПоставщику = ПланыСчетов.Управленческий.РасчетыПоАвансамВыданным;
            ОбъектДляЗаписи.ВестиРасчетыПоДоговорам = Истина;
            ОбъектДляЗаписи.ВестиРасчетыПоДокументам = Истина;
            ОбъектДляЗаписи.ВестиРасчетыПоЗаказам = Истина;
            ОбъектДляЗаписи.ВестиУчетОплатыПоСчетам = Истина;
            ОбъектДляЗаписи.Записать();
            
        //ИначеЕсли ВидОперации = "РегНомера" Тогда 
            //СтрокаТЧ = Объект.Приход.Добавить();
            //ЗаполнитьЗначенияСвойств (ОбъектДляЗаписи, СтрокаЗагрузки);
            //ОбъектДляЗаписи.РегНомера = СтрокаТЧ.СерийныйНомер;
            //ОбъектДляЗаписи.Записать(); ВОТ тут вопрос... знаю что неправильно написано,
                        //                                           не знаю как тут быть, подскажите!!!!
                        //                                           Выложил все, чтобы посмотрели всю процедуру,
                        //                                           тут несколько видов операций, интересует только "РегНомера".
                        //                                           Если нужна будет обработка, я сброшу... В ТЧ документа нужен 1                         //столбец только - РегНомер
            
        ИначеЕсли ВидОперации = "Номенклатура" Тогда
            
            ЗаполнитьЗначенияСвойств(ОбъектДляЗаписи, СтрокаЗагрузки);
            ОбъектДляЗаписи.НаименованиеПолное = СтрокаЗагрузки.Наименование;
            ОбъектДляЗаписи.ЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.шт;
            ОбъектДляЗаписи.НоменклатурнаяГруппа = Справочники.НоменклатурныеГруппы.ОсновнаяГруппа;
            ОбъектДляЗаписи.СчетУчетаЗапасов = ПланыСчетов.Управленческий.СырьеИМатериалы;
            ОбъектДляЗаписи.СчетУчетаЗатрат = ПланыСчетов.Управленческий.НезавершенноеПроизводство;
            ОбъектДляЗаписи.СпособПополнения = Перечисления.СпособыПополненияЗапасов.Закупка;
            ОбъектДляЗаписи.МетодОценки = Перечисления.МетодОценкиЗапасов.ПоСредней;
            ОбъектДляЗаписи.НаправлениеДеятельности = Справочники.НаправленияДеятельности.ОсновноеНаправление;
            ОбъектДляЗаписи.ТипНоменклатуры = Перечисления.ТипыНоменклатуры.Запас;
            ОбъектДляЗаписи.СтранаПроисхождения = СтранаПроисхождения;
            
            СтавкаНДС = НайтиСтавкуНДС(СтрокаЗагрузки.НДС);
            Если СтавкаНДС <>Неопределено Тогда
                ОбъектДляЗаписи.СтавкаНДС = СтавкаНДС;
            Иначе
                ОбъектДляЗаписи.СтавкаНДС = ?(ЗначениеЗаполнено(ОбъектДляЗаписи.СтавкаНДС), ОбъектДляЗаписи.СтавкаНДС, Справочники.Организации.ОсновнаяОрганизация.СтавкаНДСПоУмолчанию);
            КонецЕсли;
            
            ОбъектДляЗаписи.Записать();
            
            Если ЗначениеЗаполнено(СтрокаЗагрузки.ШтрихКод) Тогда
                НаборЗаписейШтрихКодыНоменклатуры = РегистрыСведений.ШтрихкодыНоменклатуры.СоздатьНаборЗаписей();
                НаборЗаписейШтрихКодыНоменклатуры.Отбор.ШтрихКод.Установить(СтрокаЗагрузки.ШтрихКод);
                НоваяСтрока = НаборЗаписейШтрихКодыНоменклатуры.Добавить();
                НоваяСтрока.Номенклатура = ОбъектДляЗаписи.Ссылка;
                НоваяСтрока.ШтрихКод = СтрокаЗагрузки.ШтрихКод;
                НаборЗаписейШтрихКодыНоменклатуры.Записать(Истина);
            КонецЕсли;
            
        ИначеЕсли ВидОперации = "Цены" Тогда
            
            Если НЕ ЗначениеЗаполнено(ОбъектДляЗаписи.Ссылка) Тогда
                
                ЗаполнитьЗначенияСвойств(ОбъектДляЗаписи, СтрокаЗагрузки);
                ОбъектДляЗаписи.НаименованиеПолное = СтрокаЗагрузки.Наименование;
                ОбъектДляЗаписи.ЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.шт;
                ОбъектДляЗаписи.НоменклатурнаяГруппа = Справочники.НоменклатурныеГруппы.ОсновнаяГруппа;
                ОбъектДляЗаписи.СчетУчетаЗапасов = ПланыСчетов.Управленческий.СырьеИМатериалы;
                ОбъектДляЗаписи.СчетУчетаЗатрат = ПланыСчетов.Управленческий.НезавершенноеПроизводство;
                ОбъектДляЗаписи.СпособПополнения = Перечисления.СпособыПополненияЗапасов.Закупка;
                ОбъектДляЗаписи.МетодОценки = Перечисления.МетодОценкиЗапасов.ПоСредней;
                ОбъектДляЗаписи.НаправлениеДеятельности = Справочники.НаправленияДеятельности.ОсновноеНаправление;
                ОбъектДляЗаписи.ТипНоменклатуры = Перечисления.ТипыНоменклатуры.Запас;
                ОбъектДляЗаписи.СтранаПроисхождения = СтранаПроисхождения;
                
                СтавкаНДС = НайтиСтавкуНДС(СтрокаЗагрузки.НДС);
                Если СтавкаНДС <>Неопределено Тогда
                    ОбъектДляЗаписи.СтавкаНДС = СтавкаНДС;
                Иначе
                    ОбъектДляЗаписи.СтавкаНДС = ?(ЗначениеЗаполнено(ОбъектДляЗаписи.СтавкаНДС), ОбъектДляЗаписи.СтавкаНДС, Справочники.Организации.ОсновнаяОрганизация.СтавкаНДСПоУмолчанию);
                КонецЕсли;
                
                ОбъектДляЗаписи.Записать();
                
            КонецЕсли;
            
            НаборЗаписейЦеныНоменклатуры = РегистрыСведений.ЦеныНоменклатуры.СоздатьНаборЗаписей();
            НаборЗаписейЦеныНоменклатуры.Отбор.Период.Установить(?(ЗначениеЗаполнено(Дата), Дата, ТекущаяДата()));
            НаборЗаписейЦеныНоменклатуры.Отбор.ВидЦен.Установить(?(ЗначениеЗаполнено(ВидЦен), ВидЦен, Справочники.ВидыЦен.Оптовая));
            НаборЗаписейЦеныНоменклатуры.Отбор.Номенклатура.Установить(ОбъектДляЗаписи.Ссылка);
            НаборЗаписейЦеныНоменклатуры.Отбор.Характеристика.Установить(Справочники.ХарактеристикиНоменклатуры.ПустаяСсылка());
            НоваяСтрока = НаборЗаписейЦеныНоменклатуры.Добавить();
            НоваяСтрока.Номенклатура = ОбъектДляЗаписи.Ссылка;
            НоваяСтрока.ВидЦен = ?(ЗначениеЗаполнено(ВидЦен), ВидЦен, Справочники.ВидыЦен.Оптовая);
            НоваяСтрока.Актуальность = Истина;
            НоваяСтрока.Период = ?(ЗначениеЗаполнено(Дата), Дата, ТекущаяДата());
            НоваяСтрока.Цена = СтрокаЗагрузки.Цена;
            НоваяСтрока.ЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.шт;
            НаборЗаписейЦеныНоменклатуры.Записать(Истина);
 
        ИначеЕсли ВидОперации = "Остатки" Тогда
            
            Если НЕ ЗначениеЗаполнено(ОбъектДляЗаписи.Ссылка) Тогда
                
                ЗаполнитьЗначенияСвойств(ОбъектДляЗаписи, СтрокаЗагрузки);
                ОбъектДляЗаписи.НаименованиеПолное = СтрокаЗагрузки.Наименование;
                ОбъектДляЗаписи.ЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.шт;
                ОбъектДляЗаписи.НоменклатурнаяГруппа = Справочники.НоменклатурныеГруппы.ОсновнаяГруппа;
                ОбъектДляЗаписи.СчетУчетаЗапасов = ПланыСчетов.Управленческий.СырьеИМатериалы;
                ОбъектДляЗаписи.СчетУчетаЗатрат = ПланыСчетов.Управленческий.НезавершенноеПроизводство;
                ОбъектДляЗаписи.СпособПополнения = Перечисления.СпособыПополненияЗапасов.Закупка;
                ОбъектДляЗаписи.МетодОценки = Перечисления.МетодОценкиЗапасов.ПоСредней;
                ОбъектДляЗаписи.НаправлениеДеятельности = Справочники.НаправленияДеятельности.ОсновноеНаправление;
                ОбъектДляЗаписи.ТипНоменклатуры = Перечисления.ТипыНоменклатуры.Запас;
                ОбъектДляЗаписи.СтранаПроисхождения = СтранаПроисхождения;
                
                СтавкаНДС = НайтиСтавкуНДС(СтрокаЗагрузки.НДС);
                Если СтавкаНДС <>Неопределено Тогда
                    ОбъектДляЗаписи.СтавкаНДС = СтавкаНДС;
                Иначе
                    ОбъектДляЗаписи.СтавкаНДС = ?(ЗначениеЗаполнено(ОбъектДляЗаписи.СтавкаНДС), ОбъектДляЗаписи.СтавкаНДС, Справочники.Организации.ОсновнаяОрганизация.СтавкаНДСПоУмолчанию);
                КонецЕсли;
                
                ОбъектДляЗаписи.Записать();
                
            КонецЕсли;
            
            Если ЗначениеЗаполнено(СтрокаЗагрузки.НомерГТД) Тогда
                НоваяСтрока = ДокументВводОстатков.ЗапасыВРазрезеГТД.Добавить();
                НоваяСтрока.Номенклатура = ОбъектДляЗаписи.Ссылка;
                НоваяСтрока.Количество = СтрокаЗагрузки.Количество;
                НоваяСтрока.ЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.шт;
                СтранаПроисхождения = ОбъектДляЗаписи.Ссылка.СтранаПроисхождения;
                Если СтранаПроисхождения.Пустая() Тогда
                    Отказ = Истина;
                    Сообщить("Для позиции "+СокрЛП(НоваяСтрока.Номенклатура)+" не заполнена страна происхождения!");
                КонецЕсли;
                НоваяСтрока.СтранаПроисхождения = ОбъектДляЗаписи.Ссылка.СтранаПроисхождения;
                НоваяСтрока.НомерГТД = НайтиСоздатьНомерГТД(СтрокаЗагрузки.НомерГТД);
            КонецЕсли;
            
            НоваяСтрока = ДокументВводОстатков.Запасы.Добавить();
            НоваяСтрока.Номенклатура = ОбъектДляЗаписи.Ссылка;
            НоваяСтрока.Количество = СтрокаЗагрузки.Количество;
            НоваяСтрока.Цена = СтрокаЗагрузки.Цена;
            НоваяСтрока.Сумма = НоваяСтрока.Количество * НоваяСтрока.Цена;
            НоваяСтрока.ЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.шт;
            НоваяСтрока.СтруктурнаяЕдиница = ?(ЗначениеЗаполнено(Склад), Склад, Справочники.СтруктурныеЕдиницы.ОсновнойСклад);
            
        КонецЕсли;
        
    КонецЦикла;
    
    Если Отказ Тогда
        Сообщить("Во время загрузки произошли ошибки. Данные не будут загружены.");
        Возврат;
    КонецЕсли;
    
    Если ВидОперации = "Остатки" Тогда
        ДокументВводОстатков.Записать(РежимЗаписиДокумента.Проведение);
    КонецЕсли;
    
    
КонецПроцедуры
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
27.11.2013, 21:25
Здравствуйте! Я подобрал для вас темы с ответами на вопрос 1C 8.x (тонкий) Загрузка ТЧ упр. формы (1С):

1C 8.x 8.3 Упр.формы: Зачем ОЛЕ в макете ? - 1С
Можно создать макет из активдокумент (Ворд, Эксел и т.п.). Но использовать его в упр.формах нельзя - спрашивается зачем такая возможность...

1C 8.x 8.3 Упр.Прил.: Сохранить реквизит формы типа СписокЗначений ? - 1С
Тут такая вещь возникла - у формы реквизит с типом СписокЗначений (не у объекта) стоят галочки Автосохранение настроек... у формы и галочка...

1C 8.x Фильтр в упр. - 1С
У меня есть документ &quot;Договор&quot;. В табличной части есть поле &quot;Вид работ&quot; и &quot;Исполнитель&quot;, которые выбираются из списка (справочников). ...

1C 8.x 8.3 Упр.прил - Конвертация из 7.7 - 1С
Конфигурация на 7.7 имеет свою структуру на 8.3 пишется сейчас и имеет свою. Вопрос как можно перенести данные из старой в новую, чтобы...

1C 8.x Упр.форма, Элементы.ТабПоле - 1С
Почему не получается? 1С 8.2 Банальная задача подсчёта суммы не получается. Процедура ТоварыКоличествоПриИзменении(Элемент) ...

1C 8.x Настройка рабочего стола (упр) - 1С
Можно как то на рабочем столе отобразить диаграмму? Знаю что можно вставить форму документа, но это не очень подходит.

10
Fenomen
898 / 875 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
27.11.2013, 21:53 #2
Так где у Вас указано, нет ошибки.
Ошибка скорее всего здесь:
Цитата Сообщение от SirClipz Посмотреть сообщение
ОбъектДляЗаписи = Менеджер.СоздатьЭлемент();
У объект ДокументМенеджер нет метода СоздатьЭлемент.
0
SirClipz
2 / 2 / 0
Регистрация: 29.08.2013
Сообщений: 113
27.11.2013, 22:16  [ТС] #3
А как мне тогда быть?? У меня есть ощущение что не воспринимает обработка мою тч документа...Может у Вас пример кода есть?Я бы по аналогии переделал...А то я уже все что мог перебрал А запас знаний у меня невелик

Добавлено через 11 минут
у меня выдает такую ошибку:
"{Обработка._ЗагрузкаИзТаблицы.Форма.Форма.Форма(471)}: Значение не является значением объектного типа (Пустая)
Если СтрокаЗагрузки.Ссылка.Пустая() Тогда"
0
Fenomen
898 / 875 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
28.11.2013, 09:32 #4
Цитата Сообщение от SirClipz Посмотреть сообщение
у меня выдает такую ошибку:
"{Обработка._ЗагрузкаИзТаблицы.Форма.Форма.Форма(471)}: Значение не является значением объектного типа (Пустая)
Если СтрокаЗагрузки.Ссылка.Пустая() Тогда"
Посмотрите в отладчике какой тип имеет СтрокаЗагрузки.Ссылка?
0
SirClipz
2 / 2 / 0
Регистрация: 29.08.2013
Сообщений: 113
28.11.2013, 14:42  [ТС] #5
Строковый... у меня в обработке все строки и в тч пишу в строку...

Добавлено через 5 минут
Ладно, этот вопрос я обошел, но возник другой...
Как мне обратиться к ТЧ моего документа? сейчас выдает это:
"{Обработка._ЗагрузкаИзТаблицы.Форма.Форма.Форма(496)}: Поле объекта не обнаружено (Приход)
СтрокаТЧ = Объект.Приход.Добавить();"
0
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
28.11.2013, 22:16 #6
"Объект" - это что в момент выполнения команды?
0
SirClipz
2 / 2 / 0
Регистрация: 29.08.2013
Сообщений: 113
28.11.2013, 22:57  [ТС] #7
Я исправил ситуацию, но блин, одна ошибка за другой...
Подскажите что с циклом сделать, пожалуйста!

1C
1
2
3
4
5
6
7
8
9
10
11
12
Если ВидОперации = "РегНомера" Тогда 
            ОбъектДляЗаписи = Документы.итсЗагрузкаРегистраИТС.СоздатьДокумент();
            ОбъектДляЗаписи.Дата = ?(ЗначениеЗаполнено(Дата), Дата, ТекущаяДата());
            ЗаполнитьЗначенияСвойств (ОбъектДляЗаписи, СтрокаЗагрузки);
            Р=Объект.СписокЗагрузки.Количество();
            Для  Н=0 По Р
            Цикл 
            чл=ОбъектДляЗаписи.Приход.Добавить();
            чл.СерийныйНомер = СтрокаЗагрузки.РегНомер;
            
            КонецЦикла;
            ОбъектДляЗаписи.Записать();
Он выгружает данные, но он создает каждый раз новый документ и добавляет по порядку по 1 записи в каждый созданный документ...
Я совсем запутался с циклом этим...
Как мне записать все
1C
1
чл.СерийныйНомер = СтрокаЗагрузки.РегНомер
в одной таб части одного документа?

не по теме: *начинаю потихоньку злиться и на 1сину и на себя*

Добавлено через 1 минуту
СписокЗагрузки - это таб часть в обработке моей... (если что)
0
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
28.11.2013, 23:15 #8
Не пойму.
Должно быть как:
1. Создали новый объект по виду операции.
2. Запустили цикл по ТЧ список загрузки и заполнили, например, ТЧ нового объекта.
Похоже, у Вас не один цикл.
0
SirClipz
2 / 2 / 0
Регистрация: 29.08.2013
Сообщений: 113
28.11.2013, 23:25  [ТС] #9
ах точно...
1C
1
Для каждого СтрокаЗагрузки Из Объект.СписокЗагрузки Цикл
Это как раз над моим кодом...

Добавлено через 1 минуту
не заметил из-за большого количества комментариев между....
получается что у меня так записано:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
Для каждого СтрокаЗагрузки Из Объект.СписокЗагрузки Цикл
      Если ВидОперации = "РегНомера" Тогда 
            ОбъектДляЗаписи = Документы.итсЗагрузкаРегистраИТС.СоздатьДокумент();
            ОбъектДляЗаписи.Дата = ?(ЗначениеЗаполнено(Дата), Дата, ТекущаяДата());
            ЗаполнитьЗначенияСвойств (ОбъектДляЗаписи, СтрокаЗагрузки);
            Р=Объект.СписокЗагрузки.Количество();
            Для  Н=0 По Р
            Цикл 
            чл=ОбъектДляЗаписи.Приход.Добавить();
            чл.СерийныйНомер = СтрокаЗагрузки.РегНомер;
            
            КонецЦикла;
            ОбъектДляЗаписи.Записать();
Добавлено через 1 минуту
Может мне просто удалить цикл первый?
В принципе важно, чтобы именно мой ВидОперации отработал..

Добавлено через 2 минуты
Проверил, удалять нельзя, уйма ошибок вылезает... надо как-то иначе выкручиваться
0
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
28.11.2013, 23:38 #10
Я ж напейсал: создай объект до цикла (Документы.итсЗагрузкаРегистраИТС.СоздатьДокумент()). Я так понимаю, что это путаница из-за того, что надо заполнять либо справочник, либо тч. И в случае спр. создавать элемент, а в случае тч добавлять строку в тч уже созданного
1
SirClipz
2 / 2 / 0
Регистрация: 29.08.2013
Сообщений: 113
28.11.2013, 23:42  [ТС] #11
Решил проблему таким способом!
duk, спасибо Вам большое!

1C
1
2
3
4
5
6
7
8
9
10
11
Если ВидОперации = "РегНомера" Тогда 
            ОбъектДляЗаписи = Документы.итсЗагрузкаРегистраИТС.СоздатьДокумент();
            ОбъектДляЗаписи.Дата = ?(ЗначениеЗаполнено(Дата), Дата, ТекущаяДата());
            Для каждого СтрокаЗагрузки Из Объект.СписокЗагрузки Цикл
            ЗаполнитьЗначенияСвойств (ОбъектДляЗаписи, СтрокаЗагрузки);
            чл=ОбъектДляЗаписи.Приход.Добавить();
            чл.СерийныйНомер = СтрокаЗагрузки.РегНомер;
            
            КонецЦикла;
            ОбъектДляЗаписи.Записать();
            КонецЕсли;
0
28.11.2013, 23:42
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
28.11.2013, 23:42
Привет! Вот еще темы с ответами:

1C 8.x 8.3 Упр.прил.: Дерево из Запроса ? - 1С
Есть справочник с группами и элементами - нужно получить дерево с видом: Группа Элемент Группа2 Элемент2 и...

1C 8.x 8.3 Упр.прил.: ДеревоЗначений и .НайтиСтроки - 1С
Ситуация такая, нужно вывести на экран дерево с отбором строк. Делаю это путем полного &quot;переформирования&quot; дерева, но вот когда использую...

От Новичка: Поле ввода в упр.форме ? - 1С
Есть в упр.форме поле ввода и назначен обработчик &quot;по завершении ввода&quot; (как то так называется) в модуле формы. Когда введена строка в это...

1C 8.x Упр. приложение. Простой отчет по справочнику - 1С
Помогите пожалуйста! Покажите отчет по справочнику Контрагенты. Должен выбираться номер бригады и выдаваться соответствующий список...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
11
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.