Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.58/12: Рейтинг темы: голосов - 12, средняя оценка - 4.58
Василёчек
0 / 0 / 0
Регистрация: 27.11.2013
Сообщений: 12
1

Открытие формы документа по ответу

04.12.2013, 12:24. Просмотров 2211. Ответов 8
Метки нет (Все метки)

Доброго времени. Столкнулся с такой задачей : необходимо открыть некий документ если на вопрос в другом документе будет выполнено некое условие и выбран ответ "Да".

пример условия:
1C
1
2
3
4
5
6
7
8
9
10
11
&НаКлиенте
Процедура ПослеЗаписи1(ПараметрыЗаписи)ТекДанные = Элементы.Товары.ТекущиеДанные;
    Если ТекДанные.Сумма > 1000 Тогда
    Ответ = Вопрос("Желаете оформить доставку?", РежимДиалогаВопрос.ДаНет, 30);
        Если Ответ = КодВозвратаДиалога.Да Тогда
            
            
            
        КонецЕсли; 
    КонецЕсли; 
КонецПроцедуры
И где стоит прописывать открытие формы?
Заранее благодарен!
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
04.12.2013, 12:24
Ответы с готовыми решениями:

Как изменить текст надписи формы документа при записи документа
Здравствуйте уважаемые, у меня простой вопрос - как мне при записи документа...

Проведение документа из модуля формы документа
Столкнулся с такой проблемой. Нужно провести документ из формы документа....

Открытие документа кнопкой
Добрый день! Прежде заказ-наряды можно было запустить нажав F11. Я давно еще...

Закрытие формы документа из внешней печатной формы
Нужно после печати документа, закрыть его форму. Управляемое приложение. Никак...

Заполнение формы документа
Такая вот проблема. В форме документа (табличная часть) вводятся два счета -...

8
OrkVasya
о_____О
Эксперт 1С
219 / 219 / 36
Регистрация: 19.11.2010
Сообщений: 1,061
Завершенные тесты: 1
04.12.2013, 13:10 2
"Некий документ" - это новый документ или существующий?
1
Василёчек
0 / 0 / 0
Регистрация: 27.11.2013
Сообщений: 12
04.12.2013, 13:22  [ТС] 3
Это существующий документ.
1C
1
2
3
4
5
Функция ОткрытьФормДок ()  
    Форма = Документы.ЗаявкаНаТранспорт.ПолучитьФорму("ФормаДокумента");
    Форма.Открыть();
    Возврат Форма;
КонецФункции
после этого пишет при отладке такое:

{Документ.Расход.Форма.ФормаДокумента1.Форма(47)}: Ошибка при вызове метода контекста (ОткрытьФормДок)
ФормаОткр = ОткрытьФормДок();
по причине:
Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.
по причине:
Ошибка преобразования данных XDTO:
Запись значения свойства 'ret':
форма: Элемент
имя: {http://v8.1c.ru/8.2/managed-application/modules}ret
по причине:
Ошибка отображения типов:
Отсутствует отображение для типа 'УправляемаяФорма'


ФормаОткр = ОткрытьФормДок(); это выполняется если выбран ответ - ДА
0
OrkVasya
о_____О
Эксперт 1С
219 / 219 / 36
Регистрация: 19.11.2010
Сообщений: 1,061
Завершенные тесты: 1
04.12.2013, 13:26 4
А зачем вы ее возвращаете, если она у вас открылась?
0
Василёчек
0 / 0 / 0
Регистрация: 27.11.2013
Сообщений: 12
04.12.2013, 13:34  [ТС] 5
Передача открытия формы на сервер, а потом обратно в клиент)
Я недавно только начал изучать, и экзамен будет по управляемым формам, а мы их поверхностно проходили.
Эта задача примерно такая, какая будет на экзамене, вот приходится самому разбираться.
0
Fenomen
898 / 875 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
04.12.2013, 13:42 6
Василёчек, открывайте на клиенте так:
1C
1
2
Форма = ПолучитьФорму("Документ.ЗаявкаНаТранспорт.ФормаОбъекта");
Форма.Открыть();
0
Василёчек
0 / 0 / 0
Регистрация: 27.11.2013
Сообщений: 12
04.12.2013, 14:05  [ТС] 7
Вот что получилось:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
&НаКлиенте
Процедура ПослеЗаписи1(ПараметрыЗаписи)
    ТекДанные = Элементы.Товары.ТекущиеДанные;
    Если ТекДанные.Сумма > 1000 Тогда
    Ответ = Вопрос("Желаете оформить доставку?", РежимДиалогаВопрос.ДаНет, 30);
        Если Ответ = КодВозвратаДиалога.Да Тогда
            Форма = ПолучитьФорму("Документ.ЗаявкаНаТранспорт.ФормаОбъекта");
            Форма.Открыть();
            
            
        КонецЕсли; 
    КонецЕсли; 
КонецПроцедуры
("Документ.ЗаявкаНаТранспорт.ФормаОбъекта") пробовал подставлять разное. ответ одинаковый

{Документ.Расход.Форма.ФормаДокумента1.Форма(47)}: Ошибка при вызове метода контекста (ПолучитьФорму)
Форма = ПолучитьФорму("Документы.ЗаявкаНаТранспорт.ФормаОбъекта");
по причине:
Неизвестное имя формы. Имя: "Документы.ЗаявкаНаТранспорт.ФормаОбъекта" и с др данными также
0
Fenomen
898 / 875 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
04.12.2013, 15:22 8
ФормаОбъекта - замените, на ваше имя формы.
1
Василёчек
0 / 0 / 0
Регистрация: 27.11.2013
Сообщений: 12
04.12.2013, 22:57  [ТС] 9
Спасибо всем) разобрался, оказалось просто:
1C
1
2
3
Если Ответ = КодВозвратаДиалога.Да Тогда
            ОткрытьФорму("Документ.ЗаявкаНаТранспорт.Форма.ФормаДокумента")
        КонецЕсли;
0
04.12.2013, 22:57
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
04.12.2013, 22:57

Реквизит формы документа
Как правильно получить значение реквизита проект из ТЧ-РасшифровкаПлатежа?...

Редактирование формы документа
Добрый день! Сразу говорю что я не программист поэтому обращаюсь к вам за...

Права на поля формы документа
Подскажите пожалуйста как в 1С можно настроить права на отдельные поля. Т.е...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru