Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.58/24: Рейтинг темы: голосов - 24, средняя оценка - 4.58
MishkaCN
1 / 1 / 0
Регистрация: 10.10.2013
Сообщений: 30
#1

Иерархический справочник с колонкой флажка в форме (множественный выбор)

05.12.2013, 00:52. Просмотров 4310. Ответов 17
Метки нет (Все метки)

Доброго времени, помогите решить задачу,

Нужно вывести список номенклатуры так так выводится в документе, но есть одно НО, необходимо добавить еще одну колонку с галочками, и возможность выбрать нужные группы и товары.

Список такой как на скрине, вот туда нужно вставить колонку с галочками и реализовать это нужно в управляемой форме, чтобы потом с этим выбраным списком можно было работать.
0
Миниатюры
Иерархический справочник с колонкой флажка в форме (множественный выбор)  
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
05.12.2013, 00:52
Ответы с готовыми решениями:

Иерархический справочник
Доброе. Раньше писал только в 7, а тут пришлось перейти на 8.2. Пока главный...

Множественный выбор
Подскажите как реализовать множественный выбор или как правильно сделать.Нужно...

Множественный выбор
При нажатии на кнопку происходит вызов процедуры, которая формирует новый...

Множественный выбор в Таблицу значений
Доброго времени суток УТ 10.3 (Обычное приложение, 8.1) Вопрос такой: Есть...

Древовидный справочник.Выбор группы.
Привет всем. У меня возникла проблемма такого характера: Есть древовидный...

17
OrkVasya
о_____О
Эксперт 1С
219 / 219 / 36
Регистрация: 19.11.2010
Сообщений: 1,061
Завершенные тесты: 1
05.12.2013, 01:45 #2
Постановка задачи поражает.
"вывести список номенклатуры" - куда?
"так выводится в документе" - в каком?
"добавить еще одну колонку с галочками" - как два пальца, только они делать нифига не будут, потому что вы партизанен.
"Список такой как на скрине" - прям со скрина и брать?
"потом с этим выбраным списком можно было работать" - как?

Если вкратце - опишите, что нужно сделать, а не как вы видите решение?
0
MishkaCN
1 / 1 / 0
Регистрация: 10.10.2013
Сообщений: 30
05.12.2013, 02:05  [ТС] #3
Цитата Сообщение от OrkVasya Посмотреть сообщение
Постановка задачи поражает.
"вывести список номенклатуры" - куда?
"так выводится в документе" - в каком?
"добавить еще одну колонку с галочками" - как два пальца, только они делать нифига не будут, потому что вы партизанен.
"Список такой как на скрине" - прям со скрина и брать?
"потом с этим выбраным списком можно было работать" - как?

Если вкратце - опишите, что нужно сделать, а не как вы видите решение?
Вы правы только больше запутал тем что хотел объяснить. Вообщем задача в том, чтобы из списка номенклатуры "Справочники.Номенклатура" отметить галлочками нужные нам группы или товары, а потом выгрузить все поступления товаров из документа "ПоступленияТоваровИУслуг" по списку выбраной номенклатуры в файл xml как то так)
0
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
05.12.2013, 10:28 #4
Галочками, говоришь... Проще в ТЧ обработки набрать список трививльным способом. А потом уже там, гды выбраны группы, декомпозировать их запросом В ИЕРАРХИИ. Построчно.
0
OrkVasya
о_____О
Эксперт 1С
219 / 219 / 36
Регистрация: 19.11.2010
Сообщений: 1,061
Завершенные тесты: 1
05.12.2013, 11:23 #5
Цитата Сообщение от MishkaCN Посмотреть сообщение
отметить галлочками нужные нам группы или товары, а потом выгрузить все поступления товаров из документа "ПоступленияТоваровИУслуг" по списку выбраной номенклатуры
Аще не ясно, а зачем тогда "галочки" и выбор групп, если номенклатуру выбирается все равно из документа? Что мешает сразу из документа и тянуть?
Или подразумевается искать все документы, в которых есть искомая номенклатура? А зачем, в таком случае, поступления которые уже давно не актуальны, но там есть искомый товар?
0
MishkaCN
1 / 1 / 0
Регистрация: 10.10.2013
Сообщений: 30
05.12.2013, 11:30  [ТС] #6
Цитата Сообщение от OrkVasya Посмотреть сообщение
Аще не ясно, а зачем тогда "галочки" и выбор групп, если номенклатуру выбирается все равно из документа? Что мешает сразу из документа и тянуть?
Или подразумевается искать все документы, в которых есть искомая номенклатура? А зачем, в таком случае, поступления которые уже давно не актуальны, но там есть искомый товар?
Нужно выгрузить в xml все поступления товаров выбранных нами в номенклатуре.

Это будет делать внешняя обработка.
0
OrkVasya
о_____О
Эксперт 1С
219 / 219 / 36
Регистрация: 19.11.2010
Сообщений: 1,061
Завершенные тесты: 1
05.12.2013, 11:37 #7
В таком случае, присоединяюсь к варианту duk337.
0
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
05.12.2013, 12:12 #8
Цитата Сообщение от OrkVasya Посмотреть сообщение
Аще не ясно, а зачем тогда "галочки"
забыли про галочки
0
MishkaCN
1 / 1 / 0
Регистрация: 10.10.2013
Сообщений: 30
05.12.2013, 12:31  [ТС] #9
Вот что есть. На форме только ТабличноеПоле.

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
Процедура ПриОткрытии()
    
ТаблицаЗначений = Новый ТаблицаЗначений;
ТаблицаЗначений.Колонки.Добавить("Выгрузить",Новый ОписаниеТипов("Булево"),,4);
ТаблицаЗначений.Колонки.Добавить("Наименование");
        
 Запрос = Новый Запрос;
 Запрос.Текст = "ВЫБРАТЬ
 |  Номенклатура.Наименование,
 |  Номенклатура.НоменклатурнаяГруппа
 |ИЗ
 |  Справочник.Номенклатура КАК Номенклатура
 |СГРУППИРОВАТЬ ПО
 |  Номенклатура.НоменклатурнаяГруппа,
 |  Номенклатура.Наименование
 |АВТОУПОРЯДОЧИВАНИЕ";
 
Выборка= Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    
    Пока Выборка.Следующий() Цикл
            Стр=ТаблицаЗначений.Добавить();
            Стр.Выгрузить = Истина;
            Стр.Наименование = Выборка.Наименование;
    КонецЦикла;
    
ЭлементыФормы.ТабличноеПоле1.Значение = ТаблицаЗначений;
ЭлементыФормы.ТабличноеПоле1.СоздатьКолонки();
    
ЭлементыФормы.ТабличноеПоле1.Колонки.Выгрузить.УстановитьЭлементУправления(Тип("Флажок"));
ЭлементыФормы.ТабличноеПоле1.Колонки.Выгрузить.РежимРедактирования=РежимРедактированияКолонки.Непосредственно;
ЭлементыФормы.ТабличноеПоле1.Колонки.Выгрузить.Ширина=3;
КонецПроцедуры
Результат такой как на скрине, а хотелось бы выводить это иерархически все...
0
Миниатюры
Иерархический справочник с колонкой флажка в форме (множественный выбор)  
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
05.12.2013, 12:53 #10
В обработке ТЧ с полем Номенклатура. Штатно добавляются строки и выбирается Ном. При "Выполнить" Цикл по строкам. Где ЭтоГруппа - запрос В ИЕРАРХИИ - и добрасывать в результ. таблицу. Если элемент просто добавлять.
0
MishkaCN
1 / 1 / 0
Регистрация: 10.10.2013
Сообщений: 30
05.12.2013, 13:02  [ТС] #11
Цитата Сообщение от duk337 Посмотреть сообщение
В обработке ТЧ с полем Номенклатура. Штатно добавляются строки и выбирается Ном. При "Выполнить" Цикл по строкам. Где ЭтоГруппа - запрос В ИЕРАРХИИ - и добрасывать в результ. таблицу. Если элемент просто добавлять.
Как то все сложно Непонятно) попробую расшифровать)
0
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
05.12.2013, 13:47 #12
а что непонятно? Спрашивай
0
MishkaCN
1 / 1 / 0
Регистрация: 10.10.2013
Сообщений: 30
05.12.2013, 13:50  [ТС] #13
Где ЭтоГруппа - запрос В ИЕРАРХИИ - и добрасывать в результ. таблицу.
Как реализовать это...

P.S.

Вы уж простите мою тупость, мой опыт в программировании 1С составляет 2 недели...


Вот то что сейчас есть

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
Процедура ПриОткрытии()
    
ТаблицаЗначений = Новый ТаблицаЗначений;
ТаблицаЗначений.Колонки.Добавить("Выгрузить",Новый ОписаниеТипов("Булево"),,4);
ТаблицаЗначений.Колонки.Добавить("Наименование");
 
  Запрос = Новый Запрос;
  Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ РАЗЛИЧНЫЕ
  | Номенклатура.ЭтоГруппа,
  | Номенклатура.Наименование,
  | Номенклатура.НоменклатурнаяГруппа
  |ИЗ
  | Справочник.Номенклатура КАК Номенклатура
  |СГРУППИРОВАТЬ ПО
  | Номенклатура.НоменклатурнаяГруппа,
  | Номенклатура.ЭтоГруппа,
  | Номенклатура.Наименование
  |АВТОУПОРЯДОЧИВАНИЕ";
  
    Выборка= Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    Пока Выборка.Следующий() Цикл
        Если Выборка.ЭтоГруппа = Истина Тогда
            
        Иначе
            Стр=ТаблицаЗначений.Добавить();
            Стр.Выгрузить = Истина;
            Стр.Наименование = Выборка.Наименование;
        КонецЕсли
    КонецЦикла;
    
ЭлементыФормы.ТабличноеПоле1.Значение = ТаблицаЗначений;
ЭлементыФормы.ТабличноеПоле1.СоздатьКолонки();
    
ЭлементыФормы.ТабличноеПоле1.Колонки.Выгрузить.УстановитьЭлементУправления(Тип("Флажок"));
ЭлементыФормы.ТабличноеПоле1.Колонки.Выгрузить.РежимРедактирования=РежимРедактированияКолонки.Непосредственно;
ЭлементыФормы.ТабличноеПоле1.Колонки.Выгрузить.Ширина=3;
КонецПроцедуры
0
BVladimir2
14 / 14 / 0
Регистрация: 26.02.2013
Сообщений: 341
05.12.2013, 13:57 #14
Добавлю, что что-то подобное делал путем вывода сформированного запросом ДереваЗначений на упр.форму. В дереве уже была колонка с булево, а на форме, соответственно, это колонка выводилась как галочка (не помню как элем. формы называется). Галочка ставилась или снималась по активации ячейки. Все красиво работает, но писать, помню, надо было много...
0
MishkaCN
1 / 1 / 0
Регистрация: 10.10.2013
Сообщений: 30
05.12.2013, 14:03  [ТС] #15
Цитата Сообщение от BVladimir2 Посмотреть сообщение
Добавлю, что что-то подобное делал путем вывода сформированного запросом ДереваЗначений на упр.форму. В дереве уже была колонка с булево, а на форме, соответственно, это колонка выводилась как галочка (не помню как элем. формы называется). Галочка ставилась или снималась по активации ячейки. Все красиво работает, но писать, помню, надо было много...
Я тоже делаю это на управляемой форме... и чувствую что задачка не из простых... но делать надо...
0
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
05.12.2013, 14:27 #16
На форме кнопка Выполнить и Таб.поле с источником ТабличнаяЧасть.Номенклатура. Она пустая (или из сохранённых данных), далее Она пополняется штатными средствами: добавить строку, выбрать номенклатурину или группу. По кнопке обрабатывается как сказано выше. Вместо результирующей ТЗ, может, лучше завести таб.часть (ТЗ только на сервере, а тут мало ли чего при отладке)
0
Dethmontt
Модератор
Эксперт 1С
2608 / 2409 / 401
Регистрация: 10.03.2011
Сообщений: 8,551
Записей в блоге: 1
Завершенные тесты: 1
05.12.2013, 14:29 #17
Цитата Сообщение от duk337 Посмотреть сообщение
(ТЗ только на сервере, а тут мало ли чего при отладке)
ТЗ может быть на клиенте как таблица формы помещенной в реквизит формы с типом Таблица значений
1
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
05.12.2013, 14:37 #18
тут придётся вторую таблицу создавать, которой нет на форме.
0
05.12.2013, 14:37
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
05.12.2013, 14:37

Доступность и не доступность флажка на форме
На форме установлен флажок. При определенных условиях необходимо, что бы он,...

Выбор нескольких значений из справочника и суммирование их и запись в другой справочник
Здравствуйте. Делаю задание создание конфигурации "Ресторан" в 1С:Предприятие...

Иерархический справочник перенос элементов из группы в другую группу
Здравствуйте. Пытаюсь создать собственную конфигурацию на 1с Предприятие...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
18
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru