Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.88/16: Рейтинг темы: голосов - 16, средняя оценка - 4.88
mauar
0 / 0 / 0
Регистрация: 18.05.2008
Сообщений: 22
1

1С 8.2 Подружить процедуры &НаКлиенте &НаСервере

29.10.2010, 23:51. Просмотров 3052. Ответов 1
Метки нет (Все метки)

Когда пытаюсь получить форму списка и сделать отбор по ней из другой формы или другого модуля
1С ругается Интерактивные операции недоступны
То же самое ругается и на администратора у него все роли включениы включая и интерактивные Интерактивное открытие внешних отчетов и обработок!

Получаю форму так
ФормаСписка=Документы.Договор.ПолучитьФормуСписка();

В чем тут у 8.2 подвох?

В принципе если её получать в процедуре с параматром &На клиенте то работает
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
&НаКлиенте
Процедура ОтобратьДоговоры(Режим) Экспорт     
     
  Договор=Документы.амбДоговорБухгалтерский;
  ФормаСписка=Договор.ПолучитьФормуСписка(ФормаСписка);
 
  Список=ФормаСписка.Список.Отбор.Элементы.Очистить();
  Если НЕ Режим = Неопределено Тогда
        ЭлементОтбора = Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));       
        ЭлементОтбора.ЛевоеЗначение  = Новый ПолеКомпоновкиДанных("Состояние");       
        ЭлементОтбора.ВидСравнения   = ВидСравненияКомпоновкиДанных.Равно;
        ЭлементОтбора.Использование  = Истина;
        ЭлементОтбора.ПравоеЗначение = Перечисления.амбСостояниеДоговоровПоБО[Режим];
  КонецЕсли;
КонецПроцедуры
Но... Есть ещё одна процедура у которой параметр &НаСервере

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
Процедура НайтиИсполнителя() Экспорт
 
  // По исполнителю
Запрос = Новый Запрос;      Запрос.Текст =             "ВЫБРАТЬ   
      |      ИсполнительРегистр.Пользователь,   
      |      ИсполнительРегистр.Исполнитель,         
      |      ИсполнительРегистр.Доступ 
      |ИЗ         
      |      РегистрСведений.ИсполнительРегистр КАК ИсполнительРегистр   
      |ГДЕ         
      |      ИсполнительРегистр.Пользователь = &Пользователь";
Запрос.УстановитьПараметр("Пользователь", ПараметрыСеанса.ТекущийПользователь);
Результат = Запрос.Выполнить();
ВыборкаДетальныеЗаписи = Результат.Выбрать();
Если ВыборкаДетальныеЗаписи.Следующий() тогда   
 
ОтобратьДоговоры(ВыборкаДетальныеЗаписи.Пользователь);  // тут мы делаем отбор  
                                                    //по найденному значению "Пользователь" из запроса
 
 Иначе         
      //сообщить("Записи нету!!!");
 
  КонецЕсли;
      КонецПроцедуры
Так вот собственно если вставить первую процедуру отбора у которой параметры &НаКлиенте в последнюю процедуру запроса с параметрами &НаСервере и сделать отбор по запросу
ОтобратьДоговоры(ВыборкаДетальныеЗаписи.Пользователь);

То 1С 8.2 будет очень сильно ругаться на запись что процедура такая не найдена.
ОтобратьДоговоры(ВыборкаДетальныеЗаписи.Пользователь);

Как можно подружить эти процедуры чтобы они сработали?
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
29.10.2010, 23:51
Ответы с готовыми решениями:

Директивы препроцессора 1С: &НаКлиенте, &НаСервере
Всем добрый день! Архиглупый вопрос.:) Но сколько работаю с 1С не могу понять... Что значит...

КД 2.1, загрузка данных в БП 3.0 НаСервере НаКлиенте
Добрый день, вопрос следующий, при загрузке данных в БП 3.0 (3.0.60.50) нужно чтобы открывалось...

Не работает отладка &наСервере
Добрый день Подскажите почему может не работать отладка ? работает только &НаКлиенте а на всех...

Синтаксическая ошибка "И" между &ДатаНачала и &ДатаКонца
Добрый день! Собственно, текст ошибки в названии темы. У меня частенько встречается такая...

query='SELECT * FROM resume WHERE ' & ''' & RecSet('place')& ''' & '=' & '''& s_loc &''' & - что не так?
упростил для краткости запрос. в чем ошибка? RecSet - это коннекшн. query='SELECT * FROM resume...

1
Konctantin
946 / 749 / 171
Регистрация: 12.04.2009
Сообщений: 1,700
30.10.2010, 12:22 2
потому что серверные процедуры не видят клиентские.

Посмотрите в хелпе какие встроенные процедуры доступны НаКлиенте а какие НаСервере.
Я сам пока изучаю 1С 8.2 и по этому готового решения пока не скажу.
0
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
30.10.2010, 12:22

error '80020009' Îøèáêà. /lalala/profile.asp, line 28
При простейшем и сто раз работавшем скрипте, вылетает ошибка! след. содержания error...

Помогите найти драйвера для pci\ven_8086&DEV_266E&SUBSYS_A002145&REV_05\3&13C0B0C5&0&F2
pci\ven_8086&DEV_266E&SUBSYS_A002145&REV_05\3&13C0B0C5&0&F2 Мультимедиа аудиоконтроллер ...

Мультимедиа контролер PCI\VEN_14F1&DEV_8800&SUBSYS_EA3D14F1&REV_05\4&25700A26&0&3020
Помогите пожалуйста найти драйвер на мультимедиа видеоконтролер ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.