Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.62/68: Рейтинг темы: голосов - 68, средняя оценка - 4.62
Wytdomthyr
0 / 0 / 0
Регистрация: 03.06.2009
Сообщений: 116
1

Преобразование типов из строки в С.Номенклатура

06.06.2009, 20:22. Просмотров 12319. Ответов 6
Метки нет (Все метки)

Наверника найдутся те кто обгадят тему мол нубо тема. с такими вопросами да к бабушки бы... Ну надеюсь найдутся те кто помогут, зарание спасибо,
Собственно суть проблемы:
Тащу данные из экселя а именно заказ из магазин в 3 колонки Номер Товар Кол-во. Всё просто в общем то.
Делаю в отдельной обработке, имеется соответственно таблица в 3 колонки, аналогичная.
Если Товар Тип Строка то всё ровно.. но меня это не устраивает нужно чтобы в дальнейшем у меня было Тип С.Номенклатура.
Данные из обработки попадают в док-т ЗаказМагазина и там вот уже надо чтобы всё ровненько было с С.Номенклатура и т.д.

1С 8.1
УТ 10.3
П.С. Поиском пользовался.
П.С.С не надо камней, я и так знаю что я не гуру.
П.С.С.С. =) спасибо.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
06.06.2009, 20:22
Ответы с готовыми решениями:

Про преобразование типов
Как можно в объект типа Справочник. ХХХ записать информацию из Константа.ххх

Преобразование типов при считывании из Excel
Здравствуйте. Необходимо считать данные из экселевского файла в 1С 7.7. При этом эксель на компе не...

Преобразование типов: строки в double
//Дана строка, состоящая из букв, цифр, запятых, точек, знаков ”+” и ”-”. //Вывести подстроку,...

Строковые потоки. Преобразование типов (как сделать чтобы из строки число полностью преобразовывалось в double без потери чисел)
Всем привет я перевожу string в double следующим образом double fromString(const std::string& s)...

Преобразование типов
Здраствуйте , хочу заполнять таблицу в Sql ,и передавать ей данные вводимые с клавиатуры , в...

6
kortomovmox
0 / 0 / 0
Регистрация: 15.06.2008
Сообщений: 278
06.06.2009, 20:34 2
Если у тебя Товар - это код товара в 1С Тогда так:

Спр=СоздатьОбъект("Справочник.Номенклатура");
Если Спр.НайтиПоКоду(СокрЛП(Товар),0)=1 Тогда
ТоварВОбработке=Спр.ТекущийЭлемент();
КонецЕсли;

Если у тебя Товар - это Текстовое название, тогда так:

Спр=СоздатьОбъект("Справочник.Номенклатура");
Если Спр.НайтиПоНаименованию(СокрЛП(Товар),0)=1 Тогда
ТоварВОбработке=Спр.ТекущийЭлемент();
КонецЕсли;

Примерно так
0
Wytdomthyr
0 / 0 / 0
Регистрация: 03.06.2009
Сообщений: 116
06.06.2009, 20:47 3
У меня Товар это текст

И если я правильно понял то что относительно текстового названия:
Создаст новую номенклатуру если нету такой и потом присвоет уже товару в обработке номенклатуру из справочника?

Вот процедура добавления именно уже в документ ЗаказИзМагазина

Код
Процедура СозданиеДокЗаказИзМагазина ()
ДокЗакИзМагазина = Документы.ЗаказИзМагазина.СоздатьДокумент();
ДокЗакИзМагазина.Дата = ТекущаяДата();
ДокЗакИзМагазина.Магазин = Магазин;
ДокЗакИзМагазина.Продавец = Продавец;

Для каждого СтрокаДанныхМагазина из ДанныеМагазина цикл
ЗаполнитьЗначенияСвойств(ДокЗакИзМагазина.ПереченьТовара.Добавить(), СтрокаДанныхМагазина);
ДокЗакИзМагазина.Записать();
КонецЦикла;

Форма = ДокЗакИзМагазина.ПолучитьФорму();
Форма.Открыть();

КонецПроцедуры
сюда я как понимаю никак надо до это все исправлять
например когда формируем таблицу обработки.
0
umkmowm181538
0 / 0 / 0
Регистрация: 24.12.2008
Сообщений: 1,399
06.06.2009, 21:02 4
Т.е. поиск будет осуществляться по наименованию? Решили ли вы проблему синхронизации? Т.е. не будет ли у вас такого, чтов файле "Огурцы соленые", а в базе "Огурцы соленые под водку" которые реально одно и то же?
А вопрос я не совсем понял)
0
Wytdomthyr
0 / 0 / 0
Регистрация: 03.06.2009
Сообщений: 116
06.06.2009, 21:11 5
=)
Под водку это хорошо... Но сначала так сказать самалеты...
Нет раз синхронизации с огурцами и молоком не будет точно(тобиш проблем с этим нет)
Есть эксель файл там список Номер Това Кол-во
Номер - число просто от 1 - N
Товар это просто текст причем текст именно определнный. в Екселе всё жестко там ошибок не может быть из списка выбирается товар. тоесть в 1ски он точно есть.
Кол-во Число (собственно сколько товара)
Проблема в том что мне в конечном итоге надо чтобы товар уютно сел с типом С.Номенклатура, дабы пойти дальше по документам.
Вот в чем стоит суть проблемы.
0
umkmowm181538
0 / 0 / 0
Регистрация: 24.12.2008
Сообщений: 1,399
06.06.2009, 21:22 6
Так вот...
Проблема у вас не в том что "надо", а в том что "не садится", или в том, что "не знаете, как сделать..."... Это к вопросу формулировки...
Нужно примерно вот это:
[codebox]СпрТовар = Справочники.Номенклатура.НайтиПоНаименованию(НаименованиеИзФайла);
Если СпрТовар = Неопределено Тогда
СпрТовар = Справочники.Номенклатура.СоздатьЭлемент();
СпрТовар.Наименование = НаименованиеИзФайла;
СпрТовар.Записать();
КонецЕсли;
[/codebox]
0
Wytdomthyr
0 / 0 / 0
Регистрация: 03.06.2009
Сообщений: 116
06.06.2009, 21:33 7
Спасибо мужики за помошь. как появится возможность втыкнуть плюс поставлю обоим. помогли оба.
огромное спасибо!
Сделал по своему исходя из первого вариант получилось вот что
Спр= Справочники.Номенклатура;
С4 = Спр.НайтиПоНаименованию(Колонка2);
С2 = С4.Наименование;

Но подумав чтобы забивать новые данные неплохом бы иметь и вариант от unknown181538 (спасибо) и сделал и его вариант тоже... теперь всё тип топ.. веточку не закрываю может еще какой вопрос возникнит.. огромное спасибо...
0
06.06.2009, 21:33
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
06.06.2009, 21:33

Преобразование типов
Здравствуйте! Подскажите как преобразовать тип данных: World в double вот код DLL которую я пишу: ...

преобразование типов
помогите у меня программа выдает ошибки преобразования типов подскажите как должно быть чтоб все...

Преобразование типов
В принципе, Basic сам преобразовывает некоторые типы. Например, результат: Dim B as Boolean, C...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru