Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.75/91: Рейтинг темы: голосов - 91, средняя оценка - 4.75
Mykky556
0 / 0 / 0
Регистрация: 11.01.2009
Сообщений: 2
1

помогите новичку

14.01.2009, 15:24. Просмотров 16419. Ответов 4
Метки нет (Все метки)

1с Производство 7.7

Надо сделать заполнение документа методом подбора, написал следующий код.
// ********************
//
Процедура ОбработкаПроведения()

//Здесь следует написать алгоритм проведения документа

КонецПроцедуры


Процедура Подбор()

ОткрытьПодбор("Номенклатура","ФормаСписка");

КонецПроцедуры

Процедура ОбработкаПодбора(Выб)

ЗапросКоличестваВПодборе(Выб);
УстанЦеныПрих();
Выч_суммы_накл();
АктивизироватьСтроку();

КонецПроцедуры



Процедура ЗапросКоличестваВПодборе(Выб)

Если Выб.ПометкаУдаления()=1 Тогда

Предупреждение("Нельзя выбирать помеченные на удаление товары!");
Возврат;

КонецЕсли;

Кол=1;
Если ВвестиЧисло(Кол, "Введите количество",10,2)=1 Тогда
НоваяСтрока();
Товар=Выб;
Количество=Кол;

КонецЕсли;


КонецПроцедуры

Процедура УстанЦеныПрих()

Цена=Товары.Себестоимость.Получить(ДатаДок);
СтавкаНДС=Товары.СтавкаНДС.Получить(ДатаДок);
КонецПроцедуры

Процедура Выч_суммы_накл()
Сумма=Цена*Количество;
НДС=Сумма/(СтавкаНДС+100)*СтавкаНДС;
КонецПроцедуры


Потом в форме доку мента поставил кнопку Подбор с сылкой на процедуру Подбор(). Но при нажатии кнопки или например попытки пометить накладную на удаление, пишет


ОткрытьПодбор<<?>>("Номенклатура","ФормаСписка");
{Документ.ПрихНакл.Модуль Документа(5)}: Процедура не обнаружена (ОткрытьПодбор)
ЗапросКоличестваВПодборе<<?>>(Выб);
{Документ.ПрихНакл.Модуль Документа(11)}: Процедура не обнаружена (ЗапросКоличестваВПодборе)
УстанЦеныПрих<<?>>();
{Документ.ПрихНакл.Модуль Документа(12)}: Процедура не обнаружена (УстанЦеныПрих)
Выч_суммы_накл<<?>>();
{Документ.ПрихНакл.Модуль Документа(13)}: Процедура не обнаружена (Выч_суммы_накл)
АктивизироватьСтроку<<?>>();
{Документ.ПрихНакл.Модуль Документа(14)}: Процедура не обнаружена (АктивизироватьСтроку)

что я не прально написал?
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
14.01.2009, 15:24
Ответы с готовыми решениями:

Помогите новичку
Добрый день всем! При попытке создать новый документ или отчет, не хочет записывать конфигурацию -...

Помогите новичку!
1. Где в 1с бухгалтерия выставляются ставки по налогам? 2. Что делать если в 1с бухгалтерия не...

Помогите новичку
Всем привет!! я только проштудировал два самоучителя =) нехотелось бы на етом останавливаться взял...

Помогите новичку
Встал вопрос об автоматизации заполнения ТТН. Так как я столкнулся с программированием 1с впервые и...

Помогите новичку!
Я в 1С не шурупаю, и стараюсь туда не лазить, но сталкнулся с такой проблемкой! Мне нужно создать...

4
kyr
0 / 0 / 0
Регистрация: 04.12.2005
Сообщений: 1,588
14.01.2009, 15:40 2
Цитата Сообщение от Mikki556
Процедура Подбор()

ОткрытьПодбор("Номенклатура","ФормаСписка");

КонецПроцедуры
Тут ты вызываешь процедуру ОткрытьПодбор в которую передаешь 2 парамера. Существования такой процедуры в твоем коде я что-то не обнаружил. То же самое кассается и АктивизироватьСтроку. Если это предопределенные функции - почитай к ним описание
0
Mykky556
0 / 0 / 0
Регистрация: 11.01.2009
Сообщений: 2
14.01.2009, 16:28 3
уже разобрался надо было писать вот так


Код
Процедура Подбор()

ОткрытьПодбор("Справочник.Номенклатура","ФормаСписка");

КонецПроцедуры


Процедура ЗапросКоличестваВПодборе(Выб)

Если Выб.ПометкаУдаления()=1 Тогда

Предупреждение("Нельзя выбирать помеченные на удаление товары!");
Возврат;

КонецЕсли;

Кол=1;
Если ВвестиЧисло(Кол, "Введите количество",10,2)=1 Тогда
НоваяСтрока();
Товар=Выб;
Количество=Кол;

КонецЕсли;

КонецПроцедуры

Процедура УстанЦеныПрих()

Цена=Товары.Себестоимость.Получить(ДатаДок);
СтавкаНДС=Товары.СтавкаНДС.Получить(ДатаДок);
КонецПроцедуры

Процедура Выч_суммы_накл()
Сумма=Цена*Количество;
НДС=Сумма/(СтавкаНДС+100)*СтавкаНДС;
КонецПроцедуры

Процедура ОбработкаПодбора(Выб)

ЗапросКоличестваВПодборе(Выб);
УстанЦеныПрих();
Выч_суммы_накл();
АктивизироватьСтроку();

КонецПроцедуры
0
Kyry4
0 / 0 / 0
Регистрация: 16.01.2009
Сообщений: 1
20.01.2009, 11:17 4
Вследствии почти нулевых знаний программирования 1С, не могу понять вот это... обьясните если можете:
При выводе на печать посредствам внешней печатной формы выдает ошибку
_______________________________________________________________________
err Общество <<?>>с ограниченной ответственностью
Переменная не определена (с)
_______________________________________________________________________
0
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
20.01.2009, 12:30 5
Видимо где-то в печатной форме есть текст "Общество с ограниченной ответственностью" и при этом тип ячейки: Выражение
Видимо надо поменять ее тип на Текст
0
20.01.2009, 12:30
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
20.01.2009, 12:30

Помогите новичку!
1С 7.7 Конфигурация &quot;Бухгалтерский учет, редакция 4.5&quot; 7.70.504 В документе &quot;Отгрузка товаров,...

Помогите новичку!
Надо создать обработку, выводящую в визуальную таблицу значений структуру папок и файлов диска C с...

Помогите новичку
Есть справочник, в котором созданы несколько групп, глубина каждой группы 5 уровней. Нужно создать...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru