Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.71/69: Рейтинг темы: голосов - 69, средняя оценка - 4.71
ssvytusyk
0 / 0 / 0
Регистрация: 06.07.2007
Сообщений: 21
1

оч срочно помогите пожалуйста закрытие формы

26.09.2007, 10:45. Просмотров 12386. Ответов 3
Метки нет (Все метки)

мне необходимо сделать следующее при открытие документа закрыть имеющуюся обработку и автоматически открыть другую
Форма.Закрыть выполняется только в работе данного документа или обработке
а мне необходимо из документа закрыть форму((((((((
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
26.09.2007, 10:45
Ответы с готовыми решениями:

Помогите с тестовой задачкой! Очень срочно! Пожалуйста!
Пожалуйста, помогите с простой задачкой. Я понимаю, что она не слишком сложная,...

Закрытие формы документа из внешней печатной формы
Нужно после печати документа, закрыть его форму. Управляемое приложение. Никак...

Помогите, пожалуйста
Здравствуйте. Вот у меня есть часть кода Документ.ИнвентаризацияТМЦ: Код...

Помогите Пожалуйста
Доброго времени суток. У меня такая проблема , поставил 1с 7.7 торговля + склад...

Помогите Разобраться, Пожалуйста (1с V8)
Файл 1.xml был выгружен через обработку MD82Exp.epf(стандартная обработка для...

3
Dr.Uyd
0 / 0 / 0
Регистрация: 04.11.2006
Сообщений: 12
26.09.2007, 11:21 2
"Топорный", но рабочий вариант:
1. В глобальнике заводим две переменные:
Перем глКонтекст Экспорт;
Перем глФормаОткрыта Экспорт;

2. В обработке, которую закрываем из вне добавляем:
Процедура ПриОткрытии()
глФормаОткрыта = 1;
глКонтекст = глВзятьКонтекст(Контекст);
КонецПроцедуры // ПриОткрытии

3. Для того что бы её закрыть:
Процедура Сформировать()
Если глФормаОткрыта = 1 Тогда
глКонтекст.Форма.Закрыть();
глФормаОткрыта = 0;
КонецЕсли;
КонецПроцедуры

И всё...
0
ssvytusyk
0 / 0 / 0
Регистрация: 06.07.2007
Сообщений: 21
26.09.2007, 11:44 3
а процедура сформировать в документе делается????
0
Dr.Uyd
0 / 0 / 0
Регистрация: 04.11.2006
Сообщений: 12
26.09.2007, 13:33 4
Код из процедуры закрывает форму и её содержимое вставляем туда, откуда закрываем форму... т.е. в документ, обработку и т.д. в подходящую процедуру...
P.S. выше был пример...
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
26.09.2007, 13:33

ПОМОГИТЕ ПОЖАЛУЙСТА с 1cv8
Народ первый раз с 1с столкнулся ещё и с 8 версией.В общем создана база данных...

Помогите пожалуйста новичку.
Есть документ "Отчёт о расходе материалов" и в нём есть таблица Расшифровка, в...

Помогите Разобраться, Пожалуйста!
Начало проверки отчета по xsd-схеме: : Element content is invalid according to...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru