Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.97/156: Рейтинг темы: голосов - 156, средняя оценка - 4.97
yspomot
0 / 0 / 0
Регистрация: 19.09.2007
Сообщений: 3
1

Обработка в 1С 7.7

23.09.2007, 09:17. Просмотров 28120. Ответов 5
Метки нет (Все метки)

Нужно сделать обработку, помогите
Задача:
У документов реализации в строках которых есть товары с кодом (код товара 10,19 товар с подчеркиванием АМ10,18) в поле коминент надо установить определенное значение.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
23.09.2007, 09:17
Ответы с готовыми решениями:

Обработка события Click, вставка html после генерации и обработка этого кода
Подскажите пожалуйста как заставить работать эту часть кода 18 строка ...

Обработка одномерных массивов и Обработка двухмерных массивов.
Всем привет, У меня большие проблемы... нужно сделать 2 лабораторные работы по информатике, но я...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
vytfyt
0 / 0 / 0
Регистрация: 28.03.2004
Сообщений: 1,913
23.09.2007, 09:23 2
Что не получается? Сделайте милость, сформулируйте вопрос...
0
yspomot
0 / 0 / 0
Регистрация: 19.09.2007
Сообщений: 3
23.09.2007, 09:28 3
Как вообще это написать, я в 1С не силен, подскажите как эту обрабоку написать, задача написанна...помогите чем можете
0
ModusPomyms
0 / 0 / 0
Регистрация: 10.09.2007
Сообщений: 5
23.09.2007, 12:05 4
Давайте сначала уточним, что же Вам все-таки нужно.

Как я понял из Вашей формулировки задания, нужно написать обработку. Сразу возникает вопрос:
1) Какая у Вас конфигурация? (Бухгалтерия, Торговля и склад, Зарплата и кадры, Комплексная, ...);

Далее, обработка должна работать с документами. И тут уже второй вопрос:
2) Документы какого типа? (Расходная накладная, Розничная накладная, Реализация из розницы, ...);

Из фразы "У документов реализации в строках которых есть товары с кодом" делаем логический вывод, что не у всех товаров заполнено поле "Код товара" и обработка должна проверять все строки (а точнее товары в строках) каждого документа на предмет заполнения данного реквизита. И в случае нахождения хотя бы одного товара с кодом, заполнять в документе "поле коминент", "определенным значением".
0
yspomot
0 / 0 / 0
Регистрация: 19.09.2007
Сообщений: 3
23.09.2007, 13:13 5
Конфигурация Торговля и склад, вы правильно меня поняли из моей фразы, совершенно верно, извините за сыр бор что я написал. Подскажите мне что за обработку мне нужно написать, если можно напишите её здесь.
0
ModusPomyms
0 / 0 / 0
Регистрация: 10.09.2007
Сообщений: 5
23.09.2007, 13:58 6
Что-то такое (! В скобках <> нужно подставлять Ваши значения) :


Код
Док = СоздатьОбъект("Документ.<ТипДокумента>");
Док.ВыбратьДокументы(Дата1,Дата2); //Дата1 и Дата2 - реквизиты формы обработки - дата начала и конца периода обработки

// перебираем документы
Пока Док.ПолучитьДокумент()=1 Цикл
ТекДок=Док.ТекущийДокумент();
// перебираем строки
ТекДок.ВыбратьСтроки();
Пока ТекДок.ПолучитьСтроку()=1 Цикл
// проверяем наличие кода товара
Если СокрЛП(ТекДок.<Реквизит товара>.<Реквизит кода>) != "" Тогда
ТекДок.Коминент=<Определенное значение>; //записываем значение в документ
ТекДок.Записать();
Прервать; // останавливаем цикл перебора строк документа и переходим к следующему, но ТОЛЬКО в том случае ,если реквизит Коминент принадлежит шапке документа. Если же этот реквизит принадлежит таблице, то команду "Прервать" не нужно писать.
КонецЕсли;
КонецЦикла;
КонецЦикла;
0
23.09.2007, 13:58
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru