Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.60/68: Рейтинг темы: голосов - 68, средняя оценка - 4.60
wotdym39
0 / 0 / 0
Регистрация: 06.11.2012
Сообщений: 6
1

Ошибка: Много Параметров

10.11.2012, 13:45. Просмотров 12356. Ответов 14
Метки нет (Все метки)

Здравствуйте вопрос от чайника не могу разобраться с подчиненными справочниками то ест с назначением владельца пишет ошибку:"Слишком много параметров передано при вызове функции/процедуры объекта"
Процедура ОбработкаПроведения()
СпрЗак=СоздатьОбъект("Справочник.Заказы");
Спр=СоздатьОбъект("Справочник.ЗаказыТовар");
Если СпрЗак.НайтиПоКоду(НомерДок,)=1 тогда
Спр.ИспользоватьВладельца(Спрзак.ТекушийЭлемент(),);
КонецЕсли;

ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
Если Спр.НайтиПоРеквизиту("Товар",Товар,)=0 тогда
Спр.Новый();
Спр.Товар=товар;
Спр.Записать();
КонецЕсли;
КонецЦикла;


// ********************


//Здесь следует написать алгоритм проведения документа

КонецПроцедуры
при запеси создается справочник заказы
Вчем моя ошибка??
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
10.11.2012, 13:45
Ответы с готовыми решениями:

Ошибка: Не хватает фактических параметров
Доброго времени суток. прошу помощи с кодом. внешняя печатная форма Доверенность для бухг...

Ошибка Недостаточно фактических параметров (Бух Автономного Учреждения)
После обновления конфигурации базы данных на версию 2.0.38.6 или выше при сохранении информации в...

ЗУП 2.5. Слишком много фактических параметров
Делаю ВПФ с доп. соглашением к ТД. Ругается вот на это Данные.Вставить ("ДокументРаботника",...

Ошибка установки параметров динамического списка
Здравствуйте. В собственной конфигурации есть обработка с реквизитом формы "АктивныеЗадания" -...

Ошибка параметров функции ДАТАВРЕМЯ в запросе
Не понимаю почему не работает функция ДАТАВРЕМЯ в запросе, ошибку параметров пишет Передаю так:...

14
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
10.11.2012, 13:59 2
Сообщение "Слишком много параметров передано при вызове функции/процедуры объекта" должно указывать на конкретную строку кода
Навскидку ошибок не видно
0
wotdym39
0 / 0 / 0
Регистрация: 06.11.2012
Сообщений: 6
10.11.2012, 14:26 3
Цитата Сообщение от vbs
Сообщение "Слишком много параметров передано при вызове функции/процедуры объекта" должно указывать на конкретную строку кода
Навскидку ошибок не видно
Ссылка на Использовать Владельца я тоже не вижу ошибок могу написать суть замысла есть документ шапка и таблица, все дание из шапки записываются в один справочник а из тоблицы в другой справочник который подченен первому, и он выдает тукую ошибку может быть из-за того что у справочника владельца код соответствует номеру документа????
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
10.11.2012, 15:47 4
Попробуй так :

Код ( (Unknown Language)):
Если СпрЗак.НайтиПоКоду(НомерДок,)=1 тогда
Вл = Спрзак.ТекушийЭлемент();
Спр.ИспользоватьВладельца(Вл);
КонецЕсли
0
10.11.2012, 15:47
wotdym39
0 / 0 / 0
Регистрация: 06.11.2012
Сообщений: 6
10.11.2012, 16:28 5
Цитата Сообщение от vbs
Попробуй так :

Код ( (Unknown Language)):
Если СпрЗак.НайтиПоКоду(НомерДок,)=1 тогда
Вл = Спрзак.ТекушийЭлемент();
Спр.ИспользоватьВладельца(Вл);
КонецЕсли
будет ругаться также но на строчку Вл=Спр.ТекущийЭлемент();
пробовал через переменную такая же ошибка
0
umkmowm181538
0 / 0 / 0
Регистрация: 24.12.2008
Сообщений: 1,399
10.11.2012, 20:01 6
Да черт же побери! Уберите слова "Нужна помощь" из названия темы!

Добавлено:


Цитата Сообщение от waldem39
Если СпрЗак.НайтиПоКоду(НомерДок,)=1 тогда
Попробуйте убрать запятую.
0
wotdym39
0 / 0 / 0
Регистрация: 06.11.2012
Сообщений: 6
10.11.2012, 20:41 7
Пробовал не что не меняется может можно какую нибудь другую идею реализовать чтоб при выборе документа в таблице значений появлялась табличная часть то есть в списке выделяя документ видно было табличную часть ну что то вроде того, хотел через журнал не получилось, да и походу через справочник тоже облом
0
umkmowm181538
0 / 0 / 0
Регистрация: 24.12.2008
Сообщений: 1,399
11.11.2012, 19:40 8
Что-то я вам не верю. Да и вообще, у вас каша в голове. И тему перименуйте.
0
wotdym39
0 / 0 / 0
Регистрация: 06.11.2012
Сообщений: 6
11.11.2012, 21:35 9
могу скинуть базу и сам проверишь
0
Дийнеки
0 / 0 / 0
Регистрация: 15.11.2009
Сообщений: 947
11.11.2012, 22:31 10
Ошибка синтаксическая. Значит в самом сообщении есть номер ошибочной строки.
А если кликнуть по красным буковкам "err", то и 1С переведет на эту строку.


Добавлено: А еще при пустых параметрах можно в большинстве случаев убрать запятую. Например:
Спр.ИспользоватьВладельца(Спрзак.ТекушийЭлемент() ,);


Злополучное название темы переименовал. Ну бывают глухие и слепые.
0
umkmowm181538
0 / 0 / 0
Регистрация: 24.12.2008
Сообщений: 1,399
12.11.2012, 05:04 11
"будет ругаться также но на строчку Вл=Спр.ТекущийЭлемент();пробовал через переменную такая же ошибка"
Т.е. в этой строке слишком много параметров? Изменения сохранил, отладчик закрывал?
0
tuskyJokyr
0 / 0 / 0
Регистрация: 18.11.2012
Сообщений: 3
21.11.2012, 15:23 12
Цитата Сообщение от unknown181538
"будет ругаться также но на строчку Вл=Спр.ТекущийЭлемент();пробовал через переменную такая же ошибка"
Т.е. в этой строке слишком много параметров? Изменения сохранил, отладчик закрывал?


Помогите решить задачку по 1С с олимпиады по программированию 2007 года... )))

Условия и конфигурацию скину на почту...)))
0
umkmowm181538
0 / 0 / 0
Регистрация: 24.12.2008
Сообщений: 1,399
22.11.2012, 00:25 13
"Помогите решить задачку по 1С с олимпиады по программированию 2007 года... )))Условия и конфигурацию скину на почту...)))"
Ну вы и хамло. В двух темах написали!
0
Дийнеки
0 / 0 / 0
Регистрация: 15.11.2009
Сообщений: 947
22.11.2012, 01:58 14
Минус. Только он реакции не увидит, т.к. в тему больше и не заглянет.
0
tuskyJokyr
0 / 0 / 0
Регистрация: 18.11.2012
Сообщений: 3
22.11.2012, 14:02 15
Что за паника ?????

Тяжело помочь что ли ????
0
22.11.2012, 14:02
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
22.11.2012, 14:02

Аппаратные ключи. Их много. Как привязать к дистрибутивам, которых тоже много
Начну с вводных данных: имеется: 1) гора дисков 1С 7.7 торговля+склад (предположительно не...

Ошибка компиляции: Описание: Слишком много параметров; параметр a55 превышает допустимый предел, установленный для парам
Прошу помочь непрограммисту, предложите простое решение. Отладчик пишет: Описание: Слишком много...

Много параметров в функцие IIF
Всем доброго времени суток! Есть такой вопрос существует запрос на базе которого формируется...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
15
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru