Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.76/83: Рейтинг темы: голосов - 83, средняя оценка - 4.76
ytyrmyty
0 / 0 / 0
Регистрация: 09.05.2007
Сообщений: 1
1

Сохранение настроек отчета

13.05.2007, 00:26. Просмотров 15016. Ответов 1
Метки нет (Все метки)

Необходимо добавить в отчет(нетиповой), созданный с помощью построителя, сохранение набора настроек(как в стандартных отчетах). В данный момент сохраняется только один(последний вариант настроек)

В данный момент текст модуля, отвечающий за сохранение настроек выглядит так:

Процедура ПриЗакрытии()

СохранитьЗначение("НастройкаВнешниеОтчетыВнешнийОтчет1Отчет_60b07b44-7fcb-41cf-88dc-e2c0d556680b", ПостроительОтчетаОтчет.ПолучитьНастройки());

КонецПроцедуры

Процедура ДействияФормыОтчетНастройка(Кнопка)
Форма = ВнешнийОтчетОбъект.ПолучитьФорму("ОтчетНастройка");
Форма.ПостроительОтчета = ПостроительОтчетаОтчет;
Настройка = ПостроительОтчетаОтчет.ПолучитьНастройки();
Если Форма.ОткрытьМодально() = Истина Тогда
ОтчетВывести();
Иначе
ПостроительОтчетаОтчет.УстановитьНастройки(Настройка);
КонецЕсли;

КонецПроцедуры

Процедура ОтчетИнициализация()
..................................
Настройка = ВосстановитьЗначение("НастройкаВнешниеОтчетыВнешнийОтчет1Отчет_60b07b44-7fcb-41cf-88dc-e2c0d556680b");
Если Настройка <> Неопределено Тогда
ПостроительОтчетаОтчет.УстановитьНастройки(Настройка);
КонецЕсли;
КонецПроцедуры
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
13.05.2007, 00:26
Ответы с готовыми решениями:

Сохранение настроек
Подскажите, пожалуйста! В обработке 1 форма.но 2 вкладки (страницы). Причем данные со второй идут...

Сохранение отчета
из базы выгружаются доки в ексель Скажи как сделать что бы в новый ексель сохраняла неашу таблицу...

Сохранение Отчета В Файл Html
Подскажите, вот в 1С можно сохранить отчет используя Файл -&gt; Сохранить копию... а как это можно...

Сохранение сформированного отчета в базе
Всем привет! У меня такой вопрос: есть некая внешняя обработка, которая выводит в табличный...

1C 8.1 Редактирование отчета созданного с помощью универсального отчета
Создал отчет с помощью универсального отчета, все работает, не получается сделать его &quot;красивым&quot;...

1
kOsho
0 / 0 / 0
Регистрация: 09.03.2007
Сообщений: 19
17.05.2007, 14:36 2
Странно, я думал на всех формочках наверху треугольнички со стрелочками есть, для сохранения настроек.
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
17.05.2007, 14:36

Передать данные из настроек отчета в поле ввода формы отчета
Всем привет! Подскажите, пожалуйста, вот есть: Внешний отчет, реквизит ДатаНачало с типом Дата...

Кнопки Настройки и Конструктор Настроек у отчета в СКД
Друзья, подскажите, как убрать кнопки &quot;Настройки&quot; и &quot;Конструктор Настроек&quot; у отчета, сделанного в...

Сохранение настроек динамического списка (несколько)
Задача такая: Есть настройки окна формы по отборам ( Вид заказа, Состояние и т.д.). Нужно сохранить...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru