Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.71/91: Рейтинг темы: голосов - 91, средняя оценка - 4.71
SoshoR
0 / 0 / 0
Регистрация: 13.04.2007
Сообщений: 4
1

Помогите новичку!

16.04.2007, 20:55. Просмотров 16343. Ответов 6
Метки нет (Все метки)

Надо создать обработку, выводящую в визуальную таблицу значений структуру папок и файлов диска C с колонками:
должно отображаться наименование папок и файлов, размер файлов, дата последней модификации...

Ну саму таблицу сделал ничего сложного в этом нет...
А как сделать чтоб папки и файлы диска С появлялись, что не как не могу догодаться...

Подскажите как это сделать...
заранее благодарю за помощь!!!

есть вот это, но не работает... что и как поменять что заработало, если можно поподробнее...

Функция ПрочитатьКаталог(ИмяКаталога)
Перем ТекКат;
ФС.УстТекКаталог(ИмяКаталога);
ФС.НайтиПервыйФайл();
флВозврат=0;
Пока ФлВозврат=0 Цикл
ТекИмяФайла = ФС.НайтиСледующийФайл();
ТекКат = фС.ТекКаталог();
ФС.АтрибутыФайла(ТекИмяФайла,<РазмерФайла>,<АтрибутыФайла>,<ВремяСоздания>,
<ВремяПоследнегоДоступа>,<ВремяПоследнейЗаписи>,<РасширенноеИмяФайла>)
Если Каталог=1 Тогда
ТЗ.НоваяСтрока()
ТЗ.ИмяФайла = ТекИмяФайла;
ПрочитатьКаталог(ТекИмяФайла);
Иначе
ТЗ.НоваяСтрока()
ТЗ.ИмяФайла = ТекИмяФайла;
КонецЕсли;
КонецЦикла;
КонецФункции
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
16.04.2007, 20:55
Ответы с готовыми решениями:

Помогите новичку
Добрый день всем! При попытке создать новый документ или отчет, не хочет записывать конфигурацию -...

Помогите новичку!
1. Где в 1с бухгалтерия выставляются ставки по налогам? 2. Что делать если в 1с бухгалтерия не...

Помогите новичку
Всем привет!! я только проштудировал два самоучителя =) нехотелось бы на етом останавливаться взял...

помогите новичку
1с Производство 7.7 Надо сделать заполнение документа методом подбора, написал следующий код....

Помогите новичку!
1С 7.7 Конфигурация &quot;Бухгалтерский учет, редакция 4.5&quot; 7.70.504 В документе &quot;Отгрузка товаров,...

6
tsh
0 / 0 / 0
Регистрация: 10.07.2017
Сообщений: 350
17.04.2007, 11:29 2
Для: SashaR

Гуглите обработку "Сусанин". Как раз ваш случай.
0
SoshoR
0 / 0 / 0
Регистрация: 13.04.2007
Сообщений: 4
17.04.2007, 16:05 3
Для: LSH благодарю, сейчас посмотрю...


а можно ссылку...
0
tsh
0 / 0 / 0
Регистрация: 10.07.2017
Сообщений: 350
17.04.2007, 22:07 4
Сусанин (zip)
0
SoshoR
0 / 0 / 0
Регистрация: 13.04.2007
Сообщений: 4
17.04.2007, 23:58 5
благодарю...

не работает...
0
tsh
0 / 0 / 0
Регистрация: 10.07.2017
Сообщений: 350
18.04.2007, 01:23 6
Для: SashaR

ЧТо не работает? Ссылка живая, перед постом сам проверил (открывать левой кнопкой). Обработка которая лежит по ней тоже работает.
0
SoshoR
0 / 0 / 0
Регистрация: 13.04.2007
Сообщений: 4
18.04.2007, 12:27 7
все благодарю... вчера с инетом что - то было...
0
18.04.2007, 12:27
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
18.04.2007, 12:27

Помогите новичку
Есть справочник, в котором созданы несколько групп, глубина каждой группы 5 уровней. Нужно создать...

помогите новичку
Всем привет! недавно заинтересовался платформой 1С предприятие 8.0 помогите пожалуйста где можно...

Помогите новичку
Встал вопрос об автоматизации заполнения ТТН. Так как я столкнулся с программированием 1с впервые и...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru