Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.92/89: Рейтинг темы: голосов - 89, средняя оценка - 4.92
tyotyk
0 / 0 / 0
Регистрация: 12.03.2007
Сообщений: 6
1

Помогите! Активизция поля в модуле формы

15.03.2007, 18:05. Просмотров 15984. Ответов 5
Метки нет (Все метки)

При переходе в другое поле выполняется процедура, в конце процедуры пишу "Активизировать("Такое-то Поле")", в ответ получаю: "В данной формуле не может быть выполнена данная процедура-функция". Прошу подсказать, как перейти программным методом в нужное поле формы, при условии, что процедура находится в то же модуле формы...please...
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
15.03.2007, 18:05
Ответы с готовыми решениями:

Помогите найти ошибки в модуле отчета
//******************************************* Процедура Сформировать() БИ =...

Не создается макет в модуле формы
почему макет в модуле формы не создается? Выдает отчет об ошибке

Ошибка в модуле печатной формы
Подскажите пожалуйста вот модуль Процедура РасчётЦены(ТабДок, Ссылка) Экспорт...

как найти данные о реквизите табличной части в модуле формы?
у меня есть реквизит тч с названием, например, итог, но он не заполнен. есть...

Что нужно дописать в модуле что бы параметры из формы (расчёт цены ) отображались в форме кс2
Здравствуйте подскажите пожалуйста Вот печатная форма

5
tsh
0 / 0 / 0
Регистрация: 10.07.2017
Сообщений: 350
15.03.2007, 22:58 2
Есть такое. Непонятно зачем сделанное ограничение. Процедуру Активизировать() можно вызывать только из предопределенных процедур.

ВОт пример как можно обойти:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
Перем Закр;
 
Процедура ПриЗакрытии()
Если Закр=0 тогда
Активизировать("Какой_То_Реквизит");
СтатусВозврата(0);
КонецЕсли;
Закр=1;
КонецПроцедуры
 
Процедура ПриИзмененииКакого_ТоРеквизита() //вешаем на реквизит
Закр=0;
Форма.Закрыть(0);
КонецПроцедуры
 
Закр=1;
0
jj_moyt
0 / 0 / 0
Регистрация: 25.02.2007
Сообщений: 88
19.03.2007, 09:01 3
а зачем Форма.Закрыть(0); ?
Изменение реквизита не должно приводить к закрытию формы ведь...
0
tsh
0 / 0 / 0
Регистрация: 10.07.2017
Сообщений: 350
19.03.2007, 13:01 4
<!--QuoteBegin-jj_mail+20:03:2007, 08:48 -->
<span class="vbquote">(jj_mail @ 20:03:2007, 08:48 )</span><!--QuoteEBegin-->а зачем Форма.Закрыть(0); ?
Изменение реквизита не должно приводить к закрытию формы ведь...
[snapback]59544" rel="nofollow" target="_blank[/snapback]?[/quote]

Я же написал, что функция может вызываться только из предопределенных процедур.
Заметь, что в функции ПриЗакрытии() стоит СтатусВозврата(0);
0
jj_moyt
0 / 0 / 0
Регистрация: 25.02.2007
Сообщений: 88
19.03.2007, 17:27 5
Да, сорь, не подумал, о том, что ПриЗакрытии() нужно как-то инициировать...
0
tyotyk
0 / 0 / 0
Регистрация: 12.03.2007
Сообщений: 6
19.03.2007, 23:56 6
Благодарю за помощь.

Тема раскрыта полностью...
0
19.03.2007, 23:56
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
19.03.2007, 23:56

Права на поля формы документа
Подскажите пожалуйста как в 1С можно настроить права на отдельные поля. Т.е...

Событие изменения содержимого поля ввода управляемой формы
Никто случайно не знает каким событием поймать изменение содержимого поля ввода...

Помогите передать контекст формы
Дело обстоит так: Есть справочник Объекты, в котором при нажатии на кнопку...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru